KB3171021 - SQL Server 2014 서비스 팩 2 릴리스 정보

적용 대상
SQL Server 2014 Service Pack 2

이 문서에는 Microsoft SQL Server 2014 SP2(서비스 팩 2)를 설치하기 전에 읽어야 할 중요한 정보가 포함되어 있습니다. 이 문서에서는 서비스 팩을 구하는 방법, 서비스 팩에 포함된 수정 사항 목록, 현재 설치된 버전에 따라 올바른 다운로드를 선택하는 방법 및 제품에 대한 저작권 귀속 목록을 설명합니다.

참고 이 문서는 이 서비스 팩과 관련된 모든 설명서를 찾을 수 있는 단일 정보 소스 역할을 합니다. 여기에는 이전에 릴리스 정보 및 Readme.txt 파일에서 찾은 모든 정보가 포함됩니다.

추가 정보

SQL Server 2014 SP2를 다운로드하는 방법

SQL Server 2014 SP2는 SQL Server 2014 SP2 다운로드 페이지에서 다운로드할 수 있습니다. 여기에서 SQL Server 2014 SP2 기능 팩을 다운로드할 수 있습니다.

참고 서비스 팩을 설치한 후 SQL Server 서비스 버전은 12.0.5000.0으로 반영되어야 합니다.

SQL Server 2014 SP2에 포함된 수정 사항 목록

Microsoft SQL Server 2014 서비스 팩은 누적 업데이트입니다. SQL Server 2014 SP2는 SQL Server 2014의 모든 버전 및 서비스 수준을 SQL Server 2014 SP2로 업그레이드합니다. 이 문서에 나열된 수정 사항 외에도 SQL Server 2014 SP2에는 SQL Server 2014 SP1 CU1에서 SQL Server 2014 SP1 CU7까지 포함된 핫픽스가 포함되어 있습니다.

SQL Server 2014에서 사용할 수 있는 누적 업데이트에 대한 자세한 내용은 SQL Server 2014 빌드 버전을 참조하세요.

노트

  • 여기에 설명되어 있지 않은 추가 수정 사항도 서비스 팩에 포함될 수 있습니다.
  • 이 목록은 더 많은 문서가 공개되면 업데이트됩니다.

SQL Server 2014 SP2에서 해결된 버그에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하세요.

VSTS 버그 번호 기술 자료 문서 번호 설명
5694597 3173766 픽스: DBCC CHECKDB또는 CHECKTABLE이 SQL Server 2014에서 데이터 손상 및 어설션 실패에 대해 가양성을 반환함
6935655 3177838 DBCC CLONEDATABASE(Transact-SQL)는 SQL Server 2014 서비스 팩 2에 도입되었습니다
7810838 3173767 SQL Server 2014 SP2에서 파티션 수가 많은 데이터베이스의 성능을 향상시킵니다
7579503 3173157 SQL Server 2014 SP2에서 변경 내용 추적 사이드 테이블을 수동으로 정리하기 위한 저장 프로시저를 추가합니다.
3913004 3172998 해결 방법: SQL Server 2014에서 sys.dm_db_uncontained_entities DMV를 사용할 때 심각한 오류가 발생합니다.
6988068 3173156 업데이트가 SQL Server 2014에서 AlwaysOn 확장 이벤트 및 성능 카운터를 추가함
2197153 3172997 SQL Server 2014 SP2에서 실행 계획 XML에 메모리 허용 경고를 추가하는 업데이트
4297600 3170123 SQL Server 2014의 트랜잭션 복제에 포함된 문서에 대한 DROP TABLE DDL을 지원합니다.
6723609 3170116 해결 방법: 최적화된 중첩 루프 조인을 실행하는 데 필요한 메모리 부여가 SQL Server 2014의 실행 계획 XML에 반영되지 않음
6170324 3170115 사용하도록 설정된 추적 플래그에 대한 정보가 SQL Server 2014 SP2의 실행 계획 XML에 추가됨
5990425 3170114 SQL Server 2014에서 DMF sys.dm_db_incremental_stats_properties 추가하기 위한 업데이트
6685025, 3512277 3170113 SQL Server 2014 SP2에서 실행 계획 XML 및 확장 이벤트에서 연산자별 쿼리 실행 통계를 노출하도록 업데이트
6170317 3170112 SQL Server 2014의 실행 계획 XML에서 단일 쿼리에 대해 활성화된 최대 메모리를 노출하도록 업데이트
6852946 3170044 해결: SQL Server 2014에서 이벤트 출력module_end 구문 분석할 때 잘못된 이름 문자 오류 발생
6927342 3170043 SQL Server 2014 SP1에서 쿼리에 복잡한 조건자에 조인 반대가 포함된 경우 성능 저하
6727876 3170042 DMV sys.dm_db_index_operational_stats가 SQL Server 2014에서 잘못된 range_scan_count 값을 반환함
6936784 3170022 업데이트를 사용하면 SQL Server 2014에서 프로세스에 대한 모든 사용자 모드 가상 주소 공간을 사용할 수 있습니다
6945027 3170020 SQL Server 2014 SP2의 SQL Server 오류 로그에 tempdb 구성에 대한 정보 메시지가 추가됨
6944985 3170019 SQL Server 2014 오류 로그의 보안 정책에 SQL Server 시작 계정에 대한 정보를 추가하도록 SQL Server 업데이트
7638613 3170015 DMV sys.dm_os_memory_nodes가 SQL Server 2014의 DAC 노드에 대한 pages_kb 값에 대해 0이 아닌 값을 반환합니다.
6651348 3156304 SQL Server 2012 및 2014의 SQL Server AlwaysOn 임대 시간 제한 지원 가능성 향상
7003572 3154421 해결 방법: SQL Server 2012 또는 2014에서 AlwaysOn 복제본(replica)를 다시 시작한 후 파일 스트림 디렉터리가 표시되지 않음
6715815 3136780 SQL Server 2014 SP2의 BCP 유틸리티 및 BULK INSERT Transact-SQL 명령에 대한 UTF-8 인코딩 지원
6589061, 6589062, 6589063,
6589064
3112363 SQL Server 2012 및 2014의 SQL Server AlwaysOn 임대 시간 제한 지원 가능성 향상
6588983 3112362 해결 방법: 복제본(replica)이 SQL Server의 가용성 그룹에 표시되지 않는 경우 해당 복제본에 대한 정보를 수신하지 못함
6588982 3112361 해결 방법: alwayson_ddl_executed 확장 이벤트에 SQL Server 2012 또는 2014의 오류 번호가 포함되어 있지 않습니다.
6588981 3107401 SQL Server 2012에서는 새 쿼리 메모리 허용 옵션(min_grant_percent 및 max_grant_percent)을 사용할 수 있습니다.
6589060 3107400 SQL Server 2012 및 2014의 실행 계획 XML 스키마에서 tempdb 유출 진단 개선
6588999 3107399 SQL Server 2012 및 2014의 공간 성능 향상
6588995 3107398 SQL Server 2012 및 2014에서 DMV를 사용할 때 메모리 허용량 진단 개선
6589011 3107397 SQL Server 2012 및 2014에서 잔여 조건자 푸시다운을 포함하는 쿼리 실행 계획에 대한 진단 개선
6589007 3107172 SQL Server 2012 및 2014에서 확장 이벤트를 사용하여 tempdb 유출 진단 개선
6589587 3065060 FIX: SSMS에서 차등 백업을 복원할 때 "LSN 체인의 중단으로 인해 복원 계획을 만들 수 없음" 오류
1046313 2925865 FIPS 사용 Windows에서 SSIS 패키지를 실행할 때 오류 발생

추가 해결 방법

다음 문제에 대한 해결 방법은 SQL Server 2014 SP2에도 포함되어 있습니다.

VSTS 버그 번호 설명
6650726 CDC가 더 이상 사용하도록 설정되지 않은 경우에도 테이블의 열 이름을 바꿀 수 없습니다.
6810365 msdistribution_history에서 20598 오류에 대한 행의 테이블 이름과 PK 값을 인쇄합니다.
6810368 자세한 정보 로깅 없이 querytimeout 오류를 일으킨 Cmd 인쇄
6821167 프로시저 "sys.sp_flush_commit_table_on_demand"에 대해 "change_tracking_hardened_cleanup_version" 및 "safe_cleanup_version"을 쉽게 인쇄할 수 있는 방법을 제공합니다.
6925734 2012/2014의 인덱스 다시 빌드는 sys.dm_db_index_usage_stats에서 해당 사용 통계를 제거합니다(2008 R2에서 회귀).
6943695 로그 판독기 대상 테이블이 빈 문자열일 때 어설션 및 덤프
3988550 일괄 정렬/최적화된 중첩 루프 연산자의 존재로 인해 극단적인 메모리 부여가 발생함 - 서버 안정성 & 성능 문제 발생
3781287 UNIT64로 정의된 Query_hash XEvent query_hash와 일치하지 않으며 varbinary로 정의된 sys.dm_exec_query_stats의 query_hash
7168415 사용자에게 ALTER TRACE 권한이 없습니다. 병합 복제의 필터가 있는 테이블에서 DELETE 명령을 실행할 수 없습니다.
7343398 필드 이름이 너무 길 때 비즈니스 규칙 실행 오류
6167933 클라이언트 연결에 사용되는 TLS/SSL 프로토콜을 찾는 방법을 제공합니다.
6588970 양식을 사용하는 네덜란드어 FTS가 예상대로 작동하지 않습니다.
6588974 msxmlsql.dll에 대한 로드 논리가 잘못된 "Authenticode 서명을 확인하지 못했습니다." 메시지가 나타남
2128386 SqlCmd는 포함된 주석과 중괄호의 조합을 사용하여 오류 없이 종료됩니다 ( 2 투표 )
2288369 비클러스터형 인덱스를 만들면 DBCC CheckDB With Extended_Logical_Checks에서 손상 오류가 발생함
5052858 BCP에서 처리되지 않는 DATE의 YYYY/MM/DD 형식(레거시 Datetime과 달리)
5783955 열을 text에서 varchar(max)로 변경한 후에는 NULL 값이 무시됩니다.
6589326 EKM DEK가 지문이 최대 크기보다 작은 키를 초기화하지 못함
6616118 파티션을 제거한 후 증분 통계를 업데이트할 때 액세스 위반 CPartitionFn::CPartitionFn
6589000 set statistics io on'이 정렬의 작업 테이블 통계를 표시하지 않음

다운로드 및 설치할 올바른 파일 선택

SQL Server 2014 SP2 다운로드 페이지에는 SQL Server 2014 SP2를 설치하기 위한 시스템 요구 사항과 기본 설치 지침이 포함되어 있습니다. 설치된 2014 SP2 구성 요소를 SQL Server 2014 서비스 업데이트로 업그레이드하는 방법에 대한 추가 설명서는 SQL Server 2014 서비스 업데이트 설치를 참조하세요.

다음 표를 사용하여 현재 설치된 버전을 기준으로 다운로드할 파일의 위치와 이름을 확인합니다. 다운로드 페이지는 시스템 요구 사항과 기본 설치 지침을 제공합니다.

현재 설치한 버전 수행할 작업 파일 다운로드 및 설치
모든 버전의 SQL Server 2014 32비트 버전 32비트 버전의 SQL Server 2014 SP2로 업그레이드 여기에서 SQLServer2014SP2-KB3171021-x86-ENU.exe
32비트 버전의 SQL Server 2014 RTM 또는 SP1 Express 32비트 버전의 SQL Server 2014 Express SP2로 업그레이드 여기에서 SQLServer2014SP2-KB3171021-x86-ENU.exe
SQL Server 2014용 클라이언트 및 관리 도구 전용 32비트 버전(SQL Server 2014 Management Studio 포함) 클라이언트 및 관리 기능을 32비트 버전의 SQL Server 2014 SP2로 업그레이드 여기에서 SQLManagementStudio_x86_ENU.exe
32비트 버전의 SQL Server 2014 Management Studio Express 32비트 버전의 SQL Server 2014 SP2 Management Studio Express로 업그레이드 여기에서 SQLManagementStudio_x86_ENU.exe
모든 버전의 32비트 버전 SQL Server 2014 및 32비트 버전의 클라이언트 및 관리 도구 도구(SQL Server 2014 RTM Management Studio 포함) 모든 제품을 32비트 버전의 SQL Server 2014 SP2로 업그레이드 여기에서 SQLServer2014SP2-KB3171021-x86-ENU.exe
Microsoft SQL Server 2014 RTM 기능 팩 또는 Microsoft SQL Server 2014 SP1 기능 팩에서 하나 이상의 도구의 32비트 버전 도구를 32비트 버전의 Microsoft SQL Server 2014 SP2 기능 팩으로 업그레이드합니다 Microsoft SQL Server 2014 SP2 기능 팩에서 하나 이상의 파일
SQL Server 2014 Management Studio의 32비트 설치 없음 SP2를 포함한 32비트 SQL Server 2014 Management Studio 설치 여기에서 SQLManagementStudio_x86_ENU.exe
32비트 버전의 SQL Server 2014 Express가 없습니다. SP2를 포함한 32비트 SQL Server 2014 Express 설치 여기에서 SQLEXPR32_x86_ENU.exe
모든 버전의 SQL Server 2014 64비트 버전 64비트 버전의 SQL Server 2014 SP2로 업그레이드 여기에서 SQLServer2014SP2-KB3171021-x64-ENU.exe
64비트 버전의 SQL Server 2014 RTM 또는 SP1 Express 64비트 버전의 SQL Server 2014 SP2로 업그레이드 여기에서 SQLServer2014SP2-KB3171021-x64-ENU.exe
SQL Server 2014용 클라이언트 및 관리 도구 전용 64비트 버전(SQL Server 2014 Management Studio 포함) 클라이언트 및 관리 도구를 64비트 버전의 SQL Server 2014 SP2로 업그레이드 여기에서 SQLManagementStudio_x64_ENU.exe
64비트 버전의 SQL Server 2014 Management Studio Express 64비트 버전의 SQL Server 2014 SP2 Management Studio Express로 업그레이드 여기에서 SQLManagementStudio_x64_ENU.exe
모든 버전의 64비트 버전 SQL Server 2014 및 64비트 버전의 클라이언트 및 관리 도구(SQL Server 2014 RTM Management Studio 포함) 모든 제품을 64비트 버전의 SQL Server 2014 SP2로 업그레이드 여기에서 SQLServer2014SP2-KB3171021-x64-ENU.exe
Microsoft SQL Server 2014 RTM 기능 팩 또는 Microsoft SQL Server 2014 SP1 기능 팩에서 하나 이상의 도구의 64비트 버전 도구를 64비트 버전의 Microsoft SQL Server 2014 SP2 기능 팩으로 업그레이드합니다 Microsoft SQL Server 2014 SP2 기능 팩에서 하나 이상의 파일
64비트에 SQL Server 2014 Management Studio 설치 없음 SP2를 포함한 64비트 SQL Server 2014 Management Studio 설치 여기에서 SQLManagementStudio_x64_ENU.exe
64비트 버전의 SQL Server 2014 Express가 없습니다. SP2를 포함한 64비트 SQL Server 2014 Express 설치 여기에서 SQLEXPR_x64_ENU.exe

            
SQL Server 설치를 SQL Server 2014 SP2로 업그레이드하는 방법에 대한 자세한 내용은 지원되는 버전 및 버전 업그레이드를 참조하세요.

  • 이 제품에는 Xerox Secure Hash Function에서 파생된 소프트웨어가 포함되어 있습니다.

  • 이 제품에는 zlib 범용 압축 라이브러리의 소프트웨어가 포함되어 있습니다.

  • 이 소프트웨어의 일부는 부분적으로 RSA Data Security, Inc.의 작업을 기반으로 합니다. Microsoft는 이 제품에 RSA Data Security, Inc. 소프트웨어를 포함했으므로 Microsoft는 해당 소프트웨어와 함께 제공되는 아래 텍스트를 포함해야 합니다.

    • Copyright 1990, RSA Data Security, Inc. All rights reserved.
    • 이 소프트웨어를 복사 및 사용할 수 있는 라이선스는 이 소프트웨어 또는 이 기능을 언급하거나 참조하는 모든 자료에서 "RSA Data Security, Inc., MD5 Message-Digest 알고리즘"으로 식별되는 경우 부여됩니다. 또한 파생 저작물을 언급하거나 참조하는 모든 자료에서 해당 저작물이 "RSA Data Security, Inc., MD5 Message-Digest 알고리즘에서 파생"으로 식별되는 경우 파생 저작물을 만들고 사용할 수 있는 라이선스가 부여됩니다.
    • RSA Data Security, Inc.는 본 소프트웨어의 상품성 또는 특정 목적에 대한 본 소프트웨어의 적합성과 관련하여 어떠한 진술도 하지 않습니다. 이 문서는 어떠한 종류의 명시적 또는 묵시적 보증 없이 "있는 그대로" 제공됩니다.

    이러한 통지는 이 설명서나 소프트웨어의 모든 부분에 보관되어야 합니다.

  • Reporting Services 매핑 기능은 미국 인구조사국(http://www.census.gov/)에서 제공하는 TIGER/Line 셰이프파일의 데이터를 사용합니다. TIGER/선 쉐이프파일은 Census MAF/TIGER 데이터베이스에서 선택한 지리 및 지도 제작 정보를 추출한 것입니다. TIGER/Line 셰이프파일은 미국 인구조사국에서 무료로 사용할 수 있습니다. TIGER/Line 셰이프파일에 대한 자세한 내용은 http://www.census.gov/geo/www/tiger 로 이동하세요. TIGER/선 셰이프파일의 경계 정보는 통계 데이터 수집 및 집계 목적으로만 사용됩니다. 통계 목적으로 묘사하고 지정하는 것은 관할권, 소유권 또는 자격에 대한 결정을 구성하지 않으며 법적 토지 설명을 반영하지 않습니다. Census TIGER 및 TIGER/Line은 미국 인구조사국의 등록 상표입니다.

Copyright 2012 Microsoft. All rights reserved.

참조 자료

현재 SQL Server 버전 및 에디션을 확인하는 방법에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하세요.

321185
  SQL Server 버전 및 에디션을 확인하는 방법
 이 문서에서 설명하는 타사 제품은 Microsoft와 무관한 별개의 공급업체에서 제조한 것입니다. Microsoft는 이들 제품의 성능이나 안정성에 관하여 명시적이든 묵시적이든 어떠한 보증도 하지 않습니다.