소개
이 문서에서는 Microsoft SQL Server 2012 SP1(서비스 팩 1)에서 해결된 버그를 나열합니다.
노트
여기에 설명되어 있지 않은 추가 수정 사항도 서비스 팩에 포함될 수 있습니다.
이 목록은 더 많은 문서가 공개되면 업데이트됩니다.
필수 SQL Server 2012 SP1 핫픽스
SQL Server 2012 SP1을 설치한 후 Windows Installer가 반복적으로 시작되는 문제가 발생할 수 있습니다. 이 문제는 다음 Microsoft 기술 자료 문서를 통해 확인할 수 있습니다. 이 문서에는 문제를 해결하는 다운로드 가능한 핫픽스에 대한 링크가 포함되어 있습니다.
참고 SQL Server 2012 SP1을 설치한 후에는 반드시 이 핫픽스를 설치해야 합니다.
2793634 Windows 2012 SP1을 설치한 후 Windows Installer SQL Server 반복적으로 시작됨 이 문제에 대한 자세한 내용은 다음 MSDN 웹 사이트를 참조하십시오.
SQL Server 2012용 서비스 팩 1을 적용한 후 알려진 문제가 발생할 수 있습니다. 내부 세부 정보.....
SQL Server 2012 서비스 팩을 구하는 방법에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하세요.
2755533 SQL Server 2012용 최신 서비스 팩을 구하는 방법
추가 정보
이 문서에 나열된 수정 사항 외에도 SQL Server 2012 SP1에는 Microsoft SQL Server 2012 CU1(누적 업데이트 1) 및 Microsoft SQL Server 2012 CU2(누적 업데이트 2)가 포함되어 있습니다. 따라서 SQL Server 2012 SP1에는 SQL Server 2012 CU1 및 SQL Server 2012 CU2에 포함된 핫픽스가 포함되어 있습니다.
SQL Server 2012에 사용할 수 있는 누적 업데이트 패키지에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
2692828 SQL Server 2012가 출시된 후 출시된 2012 SQL Server 빌드
이 서비스 팩에서 해결된 문제
SQL Server 2012 SP1에서 해결된 버그에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하세요.
| VSTS 버그 번호 | 기술 자료 문서 번호 | 설명 |
|---|---|---|
| 977015 | 2746012 | 해결 방법: 가용성 그룹의 데이터베이스에 SQL Server 2012의 FileTable이 포함된 경우 가용성 그룹 장애 조치(failover)에 시간이 오래 걸림 |
| 838761 | 2645920 | FIX: 새 가용성 그룹 마법사 생성 스크립트가 SQL Server 2012에서 보조 데이터베이스를 가용성 그룹에 조인하는 단계를 건너뜁니다. |
| 871327 | 2699720 | 해결 방법: SQL Server 2012에서 여러 SSIS 패키지를 실행할 때 교착 상태 상태 발생 |
| 917018 | 2705571 | 해결 방법: SQL Server 2012용 누적 업데이트 1을 설치한 후 데이터 품질 프로젝트를 삭제하려고 하면 SQL Server Data Quality Client가 fr입니다. |
| 898170 | 2712972 | SQL Server 2012 DQS 64비트 .xls Excel 파일로 내보내기가 오류와 함께 실패함 |
| 968815 | 2727221 | 해결 방법: 기존 instance가 포함된 Server Core 운영 체제에 SQL Server 2012 cluster instance를 설치할 수 없습니다. |
| 1012760 | 2774422 | 해결 방법: Microsoft Office 2013이 설치된 컴퓨터에는 Excel용 MDS(Master Data Services) 추가 기능을 설치할 수 없습니다. |
| 1021897 | 2774426 | 해결 방법: 변경 내용 추적 그룹의 특성이 다시 설정되고 SQL Server 2012 MDS(Master Data Services)에서 변경되지 않은 것으로 플래그가 지정됩니다. |
| 925157 | 2774432 | 해결: SQL Server 2012용 누적 업데이트 패키지를 설치한 후 MDS를 사용하여 웹 응용 프로그램을 만들 때 "클라이언트 버전이 데이터베이스 버전과 호환되지 않습니다" 오류가 발생합니다. |
| 954940 | 2774434 | FIX: SQL Server 2012 instance와 다른 경로에 Data Quality Services를 설치하면 "'dqs_certificate.cer' 파일에 쓸 수 없습니다" 오류 발생 |
| 966140 | 2774437 | 수정: Data Quality Services가 Standard 버전의 SQL Server 2012에 예기치 않게 설치될 수 있음 |
| 884792 | 2774439 | SQL Server 2012의 DQS(Data Quality Services) 설치 출력 로그를 개선하는 업데이트 사용 가능 |
| 886202 | 2774442 | 해결: SQL Server 2012에서 MDS(Master Data Services)를 사용하여 계층을 탐색할 때 계층 구조가 사전순으로 정렬되지 않음 |
| 965239 | 2723814 | SQL Server 2012에서 주 복제본과 보조 복제본 간의 동기화 속도가 느린 경우 |
| 892506 | 2930239 | FIX: SQL Server 2008 R2 또는 SQL Server 2012에서 일치하지 않는 ON 절을 사용하여 외부에서 DMV를 조인할 때 SQL Server 발생 비양보 스케줄러 오류 발생 |
다음 문제에 대한 해결 방법은 SQL Server 2012 SP1에도 포함되어 있습니다.
| VSTS 버그 번호 | 설명 |
|---|---|
| 825067 | SQL Server DQS(Data Quality Services)의 "검색" 프로세스에서 "샘플 레코드 보기"를 사용할 수 없습니다. |
| 825141 | 로그 심각도 데이터 그리드의 세로 스크롤이 DQS에서 누락되었습니다. |
| 842186 | DQS에서 현재 또는 이전 도메인의 이전 규칙에 새 절이 잘못 추가되었습니다. |
| 852637 | 빈 "이름" 열은 DQS에서 NULL로 게시되지 않습니다. |
| 859290 | 복합 도메인의 하위 도메인에 특정 서식이 있는 경우 해당 하위 도메인의 서식이 지정되지 않습니다. |
| 874949 | 업데이트 권한이 있는 그룹에 있는 읽기 전용 사용자는 업데이트 작업을 수행할 수 있습니다. |
| 878653 | Internet Explorer의 InPrivate 브라우징 모드에서 MDS(Master Data Services)의 엔터티에 액세스하려고 할 때 "IsolatedStorageException" 예외가 발생합니다. |
| 879875 | 날짜/시간 열은 SQL Server 2012의 원격 날짜 서비스로 업데이트되는 20개 행마다 증가하지 않습니다. |
| 880547 | 히브리어 문자열에서 값을 검색할 때 결과가 표시되지 않습니다. |
| 881023 | DQS의 데이터 품질 프로젝트에 로그인하려고 하면 처리되지 않은 예외가 발생합니다. |
| 882088 | DQS에서 Excel 파일로 내보내려고 할 때 "파일 다운로드에 실패했습니다. 내보내기 대상 파일이 아직 존재하지 않는지 검사합니다." 오류가 발생합니다. |
| 882306 | DQS에 새로 추가된 용어 기반 관계의 변경 내용을 승인할 때 "지정된 키가 사전에 없습니다" 오류가 발생합니다. |
| 891191 | SQL Server 2012의 순환 참조로 인해 명시적 계층 구조가 손상되었습니다. |
| 891468 | 구성 관리자를 시작할 때 "이 서버에 Windows PowerShell이 설치되어 있지 않습니다." 오류가 발생합니다. |
| 896478 | 데이터베이스 master 키의 암호에 "&" 문자를 지정하면 DQS 서버를 설치하기 위해 DQSInstaller.exe 파일을 실행하면 설치 작업이 실패합니다. |
| 902725 | 이름에 악센트 부호가 있는 Windows 사용자가 Data Quality Client를 사용하여 Data Quality 프로젝트를 열려고 하면 "구성 이름을 저장하지 못했습니다." 오류가 발생합니다. |
| 905104 | 업데이트된 기술 자료는 DQS에서 이미 열려 있는 정리 프로젝트에서 사용할 수 없습니다. |
| 907179 | Data Quality Client를 사용하려고 하면 잘못된 오류 메시지가 표시됩니다. 참고 이 설명에서 "displayeds"라는 단어는 "displayed"라는 단어의 철자가 틀린 것입니다. |
| 916173 | [mdm]을 실행할 때 정렬 순서가 손상됩니다. [udpAttributeSave] SQL Server 2012의 기존 특성에 대한 저장 프로시저입니다. |
| 932693 | "사용자 '<도메인>\<사용자>'이(가) 로그인하지 못했습니다. 명시적으로 지정된 데이터베이스 'DQS_MAIN'를 열지 못했습니다. [클라이언트: <로컬 컴퓨터>]" 오류가 DQS가 설치되어 있지 않은 경우 MDS(Master Data Services)에 오류가 발생합니다. |
| 935253 | MDS(Master Data Services)의 특성 이름에 "&"가 포함된 경우 비즈니스 규칙을 게시할 수 없습니다. |
| 935653 | RPC(원격 프로시저 호출)를 사용하여 잘못된 오프셋과 함께 하위 문자열 함수를 실행할 때 액세스 위반이 발생합니다. |
| 949931 | MDS(Master Data Services) 웹 UI에서 "DateTime" 형식의 특성에 대해 "변경되었습니다" 비즈니스 규칙을 만드는 경우 "날짜 접미사 인수가 필요합니다." 오류가 발생합니다. |
| 954328 | SQL Server 2012에서 DQS 데이터 정리를 실행하려고 할 때 "마지막 수정 프로세스 중에 예기치 않은 오류가 발생했습니다." 오류가 발생합니다. |
| 956115 | Microsoft Excel 또는 MDS(Master Data Services) 웹 UI용 MDS(Master Data Services) 추가 기능을 사용할 때 DQS 위반 오류 메시지를 이해하기 어렵습니다. |
| 956194 | MDS(Master Data Services) 데이터베이스에서 일시 삭제된 구성원을 영구 삭제할 수 없습니다. |
| 956431 | 일치 정책을 만든 다음 DQS에서 데이터 일치 프로젝트를 실행할 때 잘못된 팝업 메시지가 나타납니다. |
| 962881 | Excel용 MDS(Master Data Services) 추가 기능을 사용할 때 예외를 처리하는 대신 .NET Framework 4.5 기반 응용 프로그램이 중지됩니다. |
| 966134 | SQL Server 통합 서비스(SSIS) DQS 정리 구성 요소 이름의 길이가 32자를 초과하면 "문자열 또는 이진 데이터가 잘립니다." 오류가 발생합니다. |
| 972072 | SQL Server Data Tools(SSDT) 프로젝트의 "SQL46010: SPARSE 근처의 잘못된 구문" 오류입니다. |
| 973194 | TSqlParser.ParseSubQueryExpressionWithOptionalCTE() 메서드는 SSDT 프로젝트에서 CTE(공통 테이블 식)와 괄호 쌍을 포함하는 SELECT문에 대해 NULL을 반환합니다. |
| 978657 | 규칙에 "연결된 값과 같음" 또는 "고유해야 함" 작업이 포함되어 있고 선택한 특성 이름이 128자를 초과하는 경우 비즈니스 규칙을 게시할 수 없습니다. |
| 979356 | 메시지 515, 수준 16, 상태 2, 프로시저 udp_test_Leaf, 줄 335 '코드' 열, 'MDS.mdm.tblStgErrorDetail' 테이블에 NULL 값을 삽입할 수 없습니다. 열에 NULL이 허용되지 않습니다. tblStgErrorDetail 테이블의 코드를 허용하는 열에 NULL 값을 삽입하면 "삽입 실패" 오류가 발생합니다. |
| 1017627 | 관계 준비 테이블의 BatchTag 열에는 인덱스가 없습니다. 일괄 처리 준비 테이블에 많은 레코드가 있는 경우 준비 프로세스의 성능이 느려집니다. SQL Server 2012 SP1은 BatchTag 열에 인덱스를 추가합니다. |
| 1022009 | 이제 SQL Server 2012 SP1에서는 문자열 값을 숫자 값으로 변환할 수 있습니다. |
다음 SQL Server 배포 플랫폼 문제에 대한 해결 방법은 SQL Server 2012 SP1에도 포함되어 있습니다.
| VSTS 버그 번호 | 설명 |
|---|---|
| 861978 | 오류가 발생하고 업그레이드할 SQL Server Reporting Services instance 찾을 수 없습니다. |
| 887180 | 서비스가 삭제용으로 표시되어 있을 때 설치 프로그램(노드 제거 또는 제거)은 서비스를 삭제하지 않습니다. |
| 895610 | 64비트 버전의 Windows에 SQL Server 지원을 설치하면 SQL Server 2012 Express 구성 요소의 32비트 버전이 업데이트되지 않습니다. |
| 934788 | SQL Server 서비스 팩에서는 지역화된 공유 기능을 제거할 수 없습니다. |
| 936548 | 해결 방법: SQL Server 2012 SP1 Express 버전 슬립스트림 패키지에서 UpdateDescription 특성 값이 비어 있습니다. |
| 1025500 | SQL Server 2012 SP1을 설치한 후 기능 선택 페이지에서 공유 기능이 검색되지 않습니다. |
| 918421 | "설치 패키지 'sqlls.msi'의 유효한 복사본을 사용하여 다시 설치해 보세요." SQL Server 2012를 복구하려고 할 때 오류가 발생합니다. |
| 923970 | VSTA_DTLP30.msi 파일을 설치하려고 할 때 "경로를 찾을 수 없음" 오류와 함께 설치가 실패합니다. |
| 931703 | 다른 Windows Installer 작업이 진행 중이므로 SQL Server 2012 SP1을 설치할 수 없습니다. |
| 967159 | "액세스 위반" 오류와 함께 설치 프로세스가 임의로 실패합니다. |
| 1030137 | Microsoft .NET Framework 3.5를 설치하지 않은 경우 Windows 8에서 SQL Server 2012 SP1을 제거할 수 없습니다. |
| 959184 | SQL Server 2012의 두 번째 instance 설치할 때 Microsoft .NET Framework에서 처리되지 않은 예외가 발생합니다. |
| 887176 | 이전에 SQL Server 설치에 실패하면 SQL Server 서비스 팩 또는 누적 업데이트가 정상적으로 설치되지 않습니다. |
| 880222 | 클러스터 리소스를 온라인 상태로 전환하기 위한 재시도 논리에 대한 지원을 추가합니다. |
| 863805 | 요약 로그에 IAcceptSqlServerLicenseTerms 항목이 없고 Settings.xml 파일에 잘못된 항목이 있으면 Microsoft 소프트웨어 사용 조건을 거부했음을 나타냅니다. |
| 853528 | 명령줄의 /QS 매개 변수는 SQL Server 2012를 설치할 때 구성 파일에서 /QUITESIMPLE ="False"를 덮어쓰지 않습니다. |
| 972251 | 클러스터 네트워크 구성 페이지에서 IP/서브넷 옵션을 사용할 수 없으며 다음 단계로 이동할 수 없습니다. |
| 748122 | rsSharePoint.msi를 실행할 때 히브리어와 아랍어의 경우 설치 UI가 왼쪽에서 오른쪽으로 표시됩니다. |
| 810794 | 돌아가서 SQL Server의 새 instance를 선택하는 경우 ADDNODE 마법사의 Cluster Network Configuration 페이지에 선택한 instance의 IP 주소가 표시되지 않습니다. |
| 824972 | SQL Server 설치 센터의 탐색 창이 너무 넓습니다. |
| 964995 | .NET Framework 3.5가 설치되어 있지 않고 컴퓨터가 인터넷에 액세스할 수 없는 경우 경고하는 규칙을 추가합니다. |
| 880779 | 업데이트를 업데이트하거나 제거할 수 없는 경우 다음 단계를 설명하는 요약은 설치 프로세스에 제공되지 않습니다. |
| 969810 | 클러스터된 인스턴스의 수동 노드에서 Windows Server Update Services 또는 Microsoft 업데이트를 통해 SQL Server 업데이트를 설치할 수 없습니다. |
| 880225 | SQM(Service Quality Monitoring) 및 Watson의 메소드를 추가하여 설치 프로그램이 ERROR_PATH_NOT_FOUND 코드로 인해 MSI를 설치할 수 없는 이유를 이해하는 데 도움을 줍니다. |
| 880233 | 설정 유효성 검증이 SQM 및 Watson에서 장애를 유발하는 올바른 설정을 보고하지 않습니다. |
| 897566 | 해결 방법: SQM이 SQL Server 2012 서비스 팩 CTP에서 해제되어 있습니다. |
| 880228 | 해결 방법: SQM 및 Watson에서 UserGroup.Exists() 보고 방법을 수정합니다. |
| 830970 | Active Directory 서버가 다운될 때 계정 유효성 검사 설정 방법이 예외를 발생시킵니다. |
| 926981 | "공급자로부터 클러스터 코드를 호출하지 못했습니다. 예외 메시지: 일반 오류입니다. SQL Server 2008 R2 SP1에서 SQL Server 2012로 업그레이드할 때 상태 코드: 997" 오류 메시지가 표시됩니다. |
| 828466 | 클러스터된 환경에서 SQL Server를 설치하려고 하면 "잘못된 SKU 지원" 메시지가 표시됩니다. |
| 973499 | 해결 방법: SQL Server 다중 서브넷 클러스터링에서 IP 주소를 만들면 영구 상태가 1로 설정됩니다. |
| 858717 | Windows 8 기반 클러스터에서는 Microsoft SQL Server 2008 또는 SQL Server 2008 R2에서 SQL Server 2012로 업그레이드할 수 없습니다. |
| 878531 | 여러 탑재 지점에 종속된 SQL Server 2012는 제거할 수 없습니다. |
| 861377 | 새 기능을 동시에 추가하는 경우 SQL Server 슬립스트림 패키지를 사용하여 현재 기능을 서비스 팩 1로 업데이트할 수 없습니다. |
| 846622 | 설치 마법사는 제품 업데이트를 검색할 때 멈춥니다. |
| 817937 | FIX: MDS(Master Data Services) 기능은 SQL Server 2012 SP1을 제거하려고 할 때 기능 트리에 표시됩니다. |
| 954667 | 수정: 손상된 설치 관리자 파일을 사용하여 SQL Server 클라이언트 도구 또는 SQL Server Full-Text 검색 기능을 업데이트하려고 하면 해당 기능에 올바른 오류 메시지가 표시되지 않습니다. |
| 819093 | instance 컴포넌트가 다른 서비스 팩 레벨에 있는 경우 공유 컴포넌트에 대한 보안 업데이트를 설치할 때 기능을 선택할 수 없습니다. |
| 907647 | 픽스: 서비스 팩 수준을 숫자로 보고하도록 SQM을 업데이트합니다. |
| 887062 | 해결 방법: SQL Server 서비스 팩은 특정 기능이 지역화된 언어를 사용하여 설치될 경우에도 이러한 기능에 영어를 적용합니다. |
| 1018645 | SQL Server 2012 instance을 제거하려고 하면 "종료 코드:-2068578302" 오류 메시지가 나타납니다. |
| 829208 | SQL Server 업그레이드가 실패한 후 보고 서비스가 잘못된 상태에 있습니다. |
참조 자료
현재 SQL Server 버전 및 에디션을 확인하는 방법에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
321185 SQL Server 및 해당 구성 요소의 버전 및 에디션을 확인하는 방법