Als u formules in berekende kolommen in lijsten gebruikt, kunt u bestaande kolommen toevoegen, zoals het berekenen van btw op een prijs. Deze kunnen worden gecombineerd om gegevens programmatisch te valideren. Als u een berekende kolom wilt toevoegen, klikt u op +kolomtoevoegen en selecteert u Meer

Opmerking: Berekende velden kunnen alleen op hun eigen rij worden gebruikt, zodat u niet kunt verwijzen naar een waarde in een andere rij of kolommen in een andere lijst of bibliotheek. Opzoekvelden worden niet ondersteund in een formule en de id van de nieuw ingevoegde rij kan niet worden gebruikt omdat de id niet bestaat wanneer de formule wordt verwerkt.

Bij het invoeren van formules, tenzij anders opgegeven, zijn er geen spaties tussen trefwoorden en operatoren. Het volgende is geen uitputtende lijst. Als u alle formules wilt weergeven, bekijkt u de alfabetische lijst aan het einde van dit artikel.

Opmerking: Berekende velden kunnen alleen op hun eigen rij worden gebruikt, zodat u niet kunt verwijzen naar een waarde in een andere rij of kolommen in een andere lijst of bibliotheek. Opzoekvelden worden niet ondersteund in een formule en de id van de nieuw ingevoegde rij kan niet worden gebruikt omdat de id niet bestaat wanneer de formule wordt verwerkt.

Selecteer hieronder een kop om deze te openen en bekijk de gedetailleerde instructies. 

U kunt de volgende formules gebruiken om de voorwaarde van een instructie te testen en een ja of nee-waarde als resultaat te geven, om een alternatieve waarde te testen, zoals OK of Niet OK, of om een leeg of streepje als resultaat te geven voor een null-waarde.

Controleren of een getal groter is dan of kleiner is dan een ander getal

Gebruik de functie ALS om deze vergelijking uit te voeren.

Kolom1

Kolom2

Formule

Beschrijving (mogelijk resultaat)

15000

9000

=[Kolom1]>[Kolom2]

Is Kolom1 groter dan Kolom2? (Ja)

15000

9000

=ALS([Kolom1]<=[Kolom2], "OK", "Niet OK")

Is Kolom1 kleiner dan of gelijk aan Kolom2? (Niet OK)

Een logische waarde retourneren na het vergelijken van kolominhoud

Voor een resultaat dat een logische waarde is (Ja of Nee), gebruikt u de functies AND, OFen NOT.

Kolom1

Kolom2

Kolom3

Formule

Beschrijving (mogelijk resultaat)

15

9

8

=EN([Kolom1]>[Kolom2], [Kolom1]<[Kolom3])

Is 15 groter dan 9 en kleiner dan 8? (Nee)

15

9

8

=OF([Kolom1]>[Kolom2], [Kolom1]<[Kolom3])

Is 15 groter dan 9 of kleiner dan 8? (Ja)

15

9

8

=NIET([Kolom1]+[Kolom2]=24)

Is 15 plus 9 niet gelijk aan 24? (Nee)

Voor een resultaat dat een andere berekening is, of een andere waarde dan Ja of Nee, gebruikt u de functies ALS, ENen OF.

Kolom1

Kolom2

Kolom3

Formule

Beschrijving (mogelijk resultaat)

15

9

8

=ALS([Kolom1]=15, "OK", "Niet OK")

Als de waarde in Kolom1 gelijk is aan 15, retourneert u 'OK'. (OK)

15

9

8

=ALS(EN([Kolom1]>[Kolom2], [Kolom1]<[Kolom3]), "OK", "Niet OK")

Als 15 groter is dan 9 en kleiner dan 8, retournt u 'OK'. (Niet OK)

15

9

8

=ALS(OF([Kolom1]>[Kolom2], [Kolom1]<[Kolom3]), "OK", "Niet OK")

Als 15 groter is dan 9 of kleiner dan 8, retournt u 'OK'. (OK)

Nullen weergeven als lege of streepjes

Als u een nul wilt weergeven, voert u een eenvoudige berekening uit. Als u een leeg of een streepje wilt weergeven, gebruikt u de functie ALS.

Kolom1

Kolom2

Formule

Beschrijving (mogelijk resultaat)

10

10

=[Kolom1]-[Kolom2]

Tweede getal afgetrokken van het eerste (0)

15

9

=ALS([Kolom1]-[Kolom2],"-",[Kolom1]-[Kolom2])

Geeft als resultaat een streepje wanneer de waarde nul is (-)

Foutwaarden in kolommen verbergen

Als u een streepje, #N/A of NA wilt weergeven in plaats van een foutwaarde, gebruikt u de functie ISFOUT.

Kolom1

Kolom2

Formule

Beschrijving (mogelijk resultaat)

10

0

=[Kolom1]/[Kolom2]

Resulteert in een fout (#DIV/0)

10

0

=ALS(ISFOUT([Kolom1]/[Kolom2]),"NA",[Kolom1]/[Kolom2])

Geeft ALS als resultaat wanneer de waarde een fout is

10

0

=ALS(ISFOUT([Kolom1]/[Kolom2]),"-",[Kolom1]/[Kolom2])

Geeft als resultaat een streepje wanneer de waarde een fout is

Controleren op lege velden

U kunt de formule ISBLANK gebruiken om lege velden te zoeken.

Kolom1

Formule

Beschrijving (mogelijk resultaat)

"Geleibonen"

=ISBLANK([Kolom1]

Retourneert Ja of Nee als leeg of niet

"Staal"

=ALS(ISBLANK([Kolom1]), "Niet OK", "OK")

Vul uw eigen keuzes in: eerst als leeg, tweede als niet

Zie IS-functies voor meer IS-functies.

U kunt de volgende formules gebruiken om berekeningen uit te voeren die zijn gebaseerd op datums en tijden, zoals het toevoegen van een aantal dagen, maanden of jaren aan een datum, het berekenen van het verschil tussen twee datums en het converteren van tijd naar een decimale waarde.

Datums toevoegen

Als u een aantal dagen aan een datum wilt toevoegen, gebruikt u de operator Optelling (+).

Opmerking: Wanneer u datums manipuleert, moet het retourtype van de berekende kolom zijn ingesteld op Datum en tijd.

Kolom1

Kolom2

Formule

Beschrijving (resultaat)

6/9/2007

3

=[Kolom1]+[Kolom2]

Hiermee worden 3 dagen toegevoegd aan 9-6-2007 (12-6-2007)

12/10/2008

54

=[Kolom1]+[Kolom2]

Hiermee wordt 54 dagen toegevoegd aan 10-12-2008 (2-2-2009)

Als u een aantal maanden aan een datum wilt toevoegen, gebruikt u de functies DATUM,JAAR,MAANDen DAG.

Kolom1

Kolom2

Formule

Beschrijving (resultaat)

6/9/2007

3

=DATUM(JAAR([Kolom1]),MAAND([Kolom1])+[Kolom2],DAG([Kolom1]))

Hiermee wordt 3 maanden toegevoegd aan 9-6-2007 (9-9-2007)

12/10/2008

25

=DATUM(JAAR([Kolom1]),MAAND([Kolom1])+[Kolom2],DAG([Kolom1]))

Hiermee worden 25 maanden toegevoegd aan 10-12-2008 (10-1-2011)

Als u een aantal jaren aan een datum wilt toevoegen, gebruikt u de functies DATUM,JAAR,MAANDen DAG.

Kolom1

Kolom2

Formule

Beschrijving (resultaat)

6/9/2007

3

=DATUM(JAAR([Kolom1])+[Kolom2],MAAND([Kolom1]),DAG([Kolom1]))

Hiermee wordt 3 jaar toegevoegd aan 9-6-2007 (9-6-2010)

12/10/2008

25

=DATUM(JAAR([Kolom1])+[Kolom2],MAAND([Kolom1]),DAG([Kolom1]))

Hiermee wordt 25 jaar toegevoegd aan 10-12-2008 (10-12-2033)

Als u een combinatie van dagen, maanden en jaren wilt toevoegen aan een datum, gebruikt u de functies DATUM,JAAR,MAANDen DAG.

Kolom1

Formule

Beschrijving (resultaat)

6/9/2007

=DATUM(JAAR([Kolom1])+3;MAAND([Kolom1])+1;DAG([Kolom1])+5)

Hiermee worden 3 jaar, 1 maand en 5 dagen toegevoegd aan 9-6-2007 (14-7-2010)

12/10/2008

=DATUM(JAAR([Kolom1])+1;MAAND([Kolom1])+7;DAG([Kolom1])+5)

Hiermee worden 1 jaar, 7 maanden en 5 dagen toegevoegd aan 10-12-2008 (15-7-2010)

Het verschil tussen twee datums berekenen

Gebruik de functie DATEDIF om deze berekening uit te voeren.

Kolom1

Kolom2

Formule

Beschrijving (resultaat)

01-jan-1995

15-jun-1999

=VERD.ALS([Kolom1], [Kolom2],"d")

Be retourneert het aantal dagen tussen de twee datums (1626)

01-jan-1995

15-jun-1999

=VERD.ALS([Kolom1], [Kolom2],"ym")

Be retourneert het aantal maanden tussen de datums, waarbij het jaardeel wordt genegeerd (5)

01-jan-1995

15-jun-1999

=VERD.ALS([Kolom1], [Kolom2],"yd")

Be retourneert het aantal dagen tussen de datums, waarbij het jaardeel wordt genegeerd (165)

Het verschil tussen twee tijden berekenen

Als u het resultaat wilt presenteren in de standaardtijdnotatie (uren:minuten:seconden), gebruikt u de operator aftrekken (-) en de functie TEKST. Als deze methode werkt, mogen de uren niet langer zijn dan 24 en mogen minuten en seconden niet langer zijn dan 60.

Kolom1

Kolom2

Formule

Beschrijving (resultaat)

09-06-2007 10:35 uur

09-06-2007 15:30

=TEKST([Kolom2]-[Kolom1],"h")

Uren tussen twee tijden (4)

09-06-2007 10:35 uur

09-06-2007 15:30

=TEKST([Kolom2]-[Kolom1],"h:mm")

Uren en minuten tussen twee tijden (4:55)

09-06-2007 10:35 uur

09-06-2007 15:30

=TEKST([Kolom2]-[Kolom1],"h:mm:ss")

Uren, minuten en seconden tussen twee tijden (4:55:00)

Als u het resultaat wilt presenteren in een totaal dat is gebaseerd op één tijdeenheid, gebruikt u de functie INT of DE FUNCTIE UUR,MINUUTof SECONDE.

Kolom1

Kolom2

Formule

Beschrijving (resultaat)

09-06-2007 10:35 uur

06-10-2007 15:30

=INT(([Kolom2]-[Kolom1])*24)

Totaal aantal uren tussen twee tijden (28)

09-06-2007 10:35 uur

06-10-2007 15:30

=INT(([Kolom2]-[Kolom1])*1440)

Totaal aantal minuten tussen twee tijden (1735)

09-06-2007 10:35 uur

06-10-2007 15:30

=INT(([Kolom2]-[Kolom1])*86400)

Totaal aantal seconden tussen twee tijden (104100)

09-06-2007 10:35 uur

06-10-2007 15:30

=UUR([Kolom2]-[Kolom1])

Uren tussen twee tijden, wanneer het verschil niet groter is dan 24 (4)

09-06-2007 10:35 uur

06-10-2007 15:30

=MINUUT([Kolom2]-[Kolom1])

Minuten tussen twee tijden, wanneer het verschil niet groter is dan 60 (55)

09-06-2007 10:35 uur

06-10-2007 15:30

=SECOND([Kolom2]-[Kolom1])

Seconden tussen twee tijden, wanneer het verschil niet groter is dan 60 (0)

Tijden converteren

Als u uren wilt converteren van de standaardtijdnotatie naar een decimaal getal, gebruikt u de functie INT.

Kolom1

Formule

Beschrijving (resultaat)

10:35 UUR

=([Kolom1]-INT([Kolom1]))*24

Aantal uren sinds 12:00 uur (10,583333)

12:15

=([Kolom1]-INT([Kolom1]))*24

Aantal uren sinds 12:00 uur (12,25)

Als u uren wilt converteren van een decimaal getal naar de standaardtijdnotatie (uren:minuten:seconden), gebruikt u de delingsoperator en de functie TEKST.

Kolom1

Formule

Beschrijving (resultaat)

23:58

=TEKST(Kolom1/24, "hh:mm:ss")

Uren, minuten en seconden sinds 12:00 uur (00:59:55)

2:06

=TEKST(Kolom1/24; "h:mm")

Uren en minuten sinds 12:00 uur (0:05)

Juliaanse datums invoegen

Een Juliaanse datum verwijst naar een datumnotatie die een combinatie is van het huidige jaar en het aantal dagen sinds het begin van het jaar. Zo wordt 1 januari 2007 weergegeven als 2007001 en 31 december 2007 als 2007365. Deze indeling is niet gebaseerd op de Juliaanse agenda.

Als u een datum wilt converteren naar een Juliaanse datum, gebruikt u de functies TEKST en DATUMWAARDE.

Kolom1

Formule

Beschrijving (resultaat)

6/23/2007

=TEKST([Kolom1],"yy")&TEKST(([Kolom1]-DATUMWAARDE("1/1/"& TEKST([Kolom1],"yy"))+1),"000")

Datum in Juliaanse notatie, met een jaar met twee cijfers (07174)

6/23/2007

=TEKST([Kolom1],"yyyy")&TEKST(([Kolom1]-DATUMWAARDE("1/1/"&TEKST([Kolom1],"yy"))+1),"000")

Datum in Juliaanse notatie, met een jaartal van vier cijfers (2007174)

Als u een datum wilt converteren naar een Juliaanse datum die wordt gebruikt in de astronomie, gebruikt u de constante 2415018,50. Deze formule werkt alleen voor datums na 1-3-1901 en als u het datumsysteem 1900 gebruikt.

Kolom1

Formule

Beschrijving (resultaat)

6/23/2007

=[Kolom1]+2415018,50

Datum in Juliaanse indeling, gebruikt in de astronomie (2454274,50)

Datums als de dag van de week laten zien

Als u datums wilt converteren naar de tekst voor de dag van de week, gebruikt u de functies TEKST en WEEKDAG.

Kolom1

Formule

Beschrijving (mogelijk resultaat)

19-feb-2007

=TEKST(WEEKDAG([Kolom1]), "dddd")

Berekent de dag van de week voor de datum en retourneert de volledige naam van de dag (maandag)

3-jan-2008

=TEKST(WEEKDAG([Kolom1]), "ddd")

Berekent de dag van de week voor de datum en retourneert de verkorte naam van de dag (do)

U kunt de volgende formules gebruiken om verschillende wiskundige berekeningen uit te voeren, zoals het optellen, aftrekken, vermenigvuldigen en delen van getallen, het berekenen van het gemiddelde of de mediaan van getallen, het ronden van een getal en het tellen van waarden.

Getallen toevoegen

Als u getallen in twee of meer kolommen in een rij wilt toevoegen, gebruikt u de opteloperator (+) of de functie SOM.

Kolom1

Kolom2

Kolom3

Formule

Beschrijving (resultaat)

6

5

4

=[Kolom1]+[Kolom2]+[Kolom3]

Hiermee worden de waarden in de eerste drie kolommen (15) toegevoegd

6

5

4

=SOM([Kolom1],[Kolom2],[Kolom3])

Hiermee worden de waarden in de eerste drie kolommen (15) toegevoegd

6

5

4

=SOM(ALS([Kolom1]>[Kolom2], [Kolom1]-[Kolom2], 10), [Kolom3])

Als Kolom1 groter is dan Kolom2, voegt u het verschil en Kolom3 toe. Anders toevoegen 10 en Kolom3 (5)

Getallen aftrekken

Als u getallen in twee of meer kolommen in een rij wilt aftrekken, gebruikt u de operator aftrekken (-) of de functie SOM met negatieve getallen.

Kolom1

Kolom2

Kolom3

Formule

Beschrijving (resultaat)

15000

9000

-8000

=[Kolom1]-[Kolom2]

Trekt 9000 af van 15000 (6000)

15000

9000

-8000

=SOM([Kolom1], [Kolom2], [Kolom3])

Hiermee voegt u getallen op in de eerste drie kolommen, inclusief negatieve waarden (16000)

Het verschil tussen twee getallen berekenen als percentage

Gebruik de operatoren aftrekken (-) en deling (/) en de functie ABS.

Kolom1

Kolom2

Formule

Beschrijving (resultaat)

2342

2500

=([Kolom2]-[Kolom1])/ABS([Kolom1])

Percentagewijziging (6,75% of 0,06746)

Getallen vermenigvuldigen

Als u getallen in twee of meer kolommen in een rij wilt vermenigvuldigen, gebruikt u de vermenigvuldigingsoperator (*) of de functie PRODUCT.

Kolom1

Kolom2

Formule

Beschrijving (resultaat)

5

2

=[Kolom1]*[Kolom2]

Vermenigvuldigt de getallen in de eerste twee kolommen (10)

5

2

=PRODUCT([Kolom1], [Kolom2])

Vermenigvuldigt de getallen in de eerste twee kolommen (10)

5

2

=PRODUCT([Kolom1],[Kolom2],2)

Vermenigvuldigt de getallen in de eerste twee kolommen en het getal 2 (20)

Getallen delen

Als u getallen in twee of meer kolommen in een rij wilt delen, gebruikt u de delingsoperator (/).

Kolom1

Kolom2

Formule

Beschrijving (resultaat)

15000

12

=[Kolom1]/[Kolom2]

Deelt 15000 door 12 (1250)

15000

12

=([Kolom1]+10000)/[Kolom2]

Hiermee worden 15000 en 10000 toegevoegd en wordt het totaal vervolgens door 12 (2083) verdeeld.

Het gemiddelde van getallen berekenen

Het gemiddelde wordt ook wel het gemiddelde genoemd. Als u het gemiddelde van getallen in twee of meer kolommen in een rij wilt berekenen, gebruikt u de functie GEMIDDELDE.

Kolom1

Kolom2

Kolom3

Formule

Beschrijving (resultaat)

6

5

4

=GEMIDDELDE([Kolom1], [Kolom2],[Kolom3])

Gemiddelde van de getallen in de eerste drie kolommen (5)

6

5

4

=GEMIDDELDE(ALS([Kolom1]>[Kolom2], [Kolom1]-[Kolom2], 10), [Kolom3])

Als Kolom1 groter is dan Kolom2, berekent u het gemiddelde van het verschil en Kolom3. Anders berekent u het gemiddelde van de waarde 10 en Kolom3 (2,5)

De mediaan van getallen berekenen

De mediaan is de waarde in het midden van een geordend bereik met getallen. Gebruik de functie MEDIAAN om de mediaan van een groep getallen te berekenen.

A

B

C

D

E

F

Formule

Beschrijving (resultaat)

10

7

9

27

0

4

=MEDIAAN(A, B, C, D, E, F)

Mediaan van getallen in de eerste 6 kolommen (8)

Het kleinste of grootste getal in een bereik berekenen

Als u het kleinste of grootste getal in twee of meer kolommen in een rij wilt berekenen, gebruikt u de functies MIN en MAX.

Kolom1

Kolom2

Kolom3

Formule

Beschrijving (resultaat)

10

7

9

=MIN([Kolom1], [Kolom2], [Kolom3])

Kleinste getal (7)

10

7

9

=MAX([Kolom1], [Kolom2], [Kolom3])

Grootste getal (10)

Waarden tellen

Als u numerieke waarden wilt tellen, gebruikt u de functie AANTAL.

Kolom1

Kolom2

Kolom3

Formule

Beschrijving (resultaat)

Appel

12/12/2007

=AANTAL([Kolom1], [Kolom2], [Kolom3])

Telt het aantal kolommen dat numerieke waarden bevat. Sluit datum en tijd, tekst en null-waarden (0) uit

$ 12

#DIV/0!

1.01

=AANTAL([Kolom1], [Kolom2], [Kolom3])

Telt het aantal kolommen met numerieke waarden, maar sluit fout- en logische waarden uit (2)

Een getal met een percentage verhogen of verlagen

Gebruik de operator Percentage (%) om deze berekening uit te voeren.

Kolom1

Kolom2

Formule

Beschrijving (resultaat)

23

3%

=[Kolom1]*(1+5%)

Aantal in kolom1 met 5% (24,15)

23

3%

=[Kolom1]*(1+[Kolom2])

Het getal in kolom1 wordt verhoogd met de procentwaarde in Kolom2: 3% (23,69)

23

3%

=[Kolom1]*(1-[Kolom2])

Vermindert het getal in kolom1 met de procentwaarde in Kolom2: 3% (22,31)

Een getal verhogen tot een macht

Gebruik de exponentiatieoperator (^) of de functie POWER om deze berekening uit te voeren.

Kolom1

Kolom2

Formule

Beschrijving (resultaat)

5

2

=[Kolom1]^[Kolom2]

Berekent vijf kwadraat (25)

5

3

=POWER([Kolom1], [Kolom2])

Berekent vijf kubussen (125)

Een getal ronden

Als u een getal wilt ronden, gebruikt u de functie ROUNDUP,ODDof EVEN.

Kolom1

Formule

Beschrijving (resultaat)

20.3

=ROUNDUP([Kolom1],0)

Rondt 20,3 naar boven af op het dichtstbijzijnde gehele getal (21)

-5.9

=ROUNDUP([Kolom1],0)

Rondt -5,9 naar boven af op het dichtstbijzijnde gehele getal (-5)

12.5493

=ROUNDUP([Kolom1],2)

Hiermee wordt 12,5493 naar boven naar boven rond de dichtstbijzijnde honderdste, twee decimalen (12,55)

20.3

=EVEN([Kolom1])

Rondt 20,3 naar boven af op het dichtstbijzijnde even getal (22)

20.3

=ONEVEN([Kolom1])

Rondt 20,3 naar boven af op het dichtstbijzijnde oneven getal (21)

Als u een getal wilt ronden, gebruikt u de functie ROUNDDOWN.

Kolom1

Formule

Beschrijving (resultaat)

20.3

=ROUNDDOWN([Kolom1],0)

Hiermee wordt 20,3 naar beneden rondt op het dichtstbijzijnde gehele getal (20)

-5.9

=ROUNDDOWN([Kolom1],0)

Rondt -5,9 naar beneden af op het dichtstbijzijnde gehele getal (-6)

12.5493

=ROUNDDOWN([Kolom1],2)

Hiermee wordt 12,5493 omlaag naar beneden naar de dichtstbijzijnde honderdste, twee decimalen (12,54)

Als u een getal wilt ronden op het dichtstbijzijnde getal of de dichtstbijzijnde breuk, gebruikt u de functie ROUND.

Kolom1

Formule

Beschrijving (resultaat)

20.3

=ROND([Kolom1],0)

Rondt 20,3 omlaag af, omdat het breukdeel kleiner is dan 0,5 (20)

5.9

=ROND([Kolom1],0)

Rondt 5,9 omhoog af, omdat het breukdeel groter is dan 0,5 (6)

-5.9

=ROND([Kolom1],0)

Rondt -5,9 omlaag af, omdat het breukdeel kleiner is dan -,5 (-6)

1.25

=ROND([Kolom1], 1)

Hiermee wordt het getal naar het dichtstbijzijnde tiende getal (één decimaal) rondt. Omdat het te ronden gedeelte 0,05 of groter is, wordt het getal naar boven afgerond (resultaat: 1,3)

30.452

=ROND([Kolom1], 2)

Hiermee wordt het getal naar het dichtstbijzijnde honderdste getal (twee decimalen) rondt. Omdat het te ronden gedeelte, 0,002, kleiner is dan 0,005, wordt het getal naar beneden afgerond (resultaat: 30,45)

Als u een getal wilt ronden op het significante cijfer boven 0, gebruikt u de functies ROUNDUP, ROUNDUP,ROUNDDOWN,INTen LEN.

Kolom1

Formule

Beschrijving (resultaat)

5492820

=ROND([Kolom1],3-LENGTE(INT([Kolom1])))

Rondt het getal af op 3 significante cijfers (5490000)

22230

=ROUNDDOWN([Kolom1],3-LENGTE(INT([Kolom1])))

Rondt het onderste getal af op 3 significante cijfers (22200)

5492820

=ROUNDUP([Kolom1], 5-LENGTE(INT([Kolom1])))

Rondt het bovenste getal af tot 5 significante cijfers (5492900)

U kunt de volgende formules gebruiken om tekst te manipuleren, zoals het combineren of samenvoegen van de waarden uit meerdere kolommen, het vergelijken van de inhoud van kolommen, het verwijderen van tekens of spaties en het herhalen van tekens.

Het geval van tekst wijzigen

Als u het hoofdlettergebruik van tekst wilt wijzigen, gebruikt u de functie BOVEN,ONDERof JUIST.

Kolom1

Formule

Beschrijving (resultaat)

nina Vietzen

=BOVEN([Kolom1])

Wijzigt tekst in hoofdletters (NINA VIETZEN)

nina Vietzen

=LOWER([Kolom1])

Wijzigt tekst in kleine letters (nina vietzen)

nina Vietzen

=JUIST([Kolom1])

Wijzigt tekst in titelcase (Nina Vietzen)

Voor- en achternamen combineren

Als u voor- en achternamen wilt combineren, gebruikt u de ampersand operator (&) of de functie SAMENVOEGEN.

Kolom1

Kolom2

Formule

Beschrijving (resultaat)

Carlos

Carvallo

=[Kolom1]&[Kolom2]

Combineert de twee tekenreeksen (CarlosCarvallo)

Carlos

Carvallo

=[Kolom1]&" "&[Kolom2]

Combineert de twee tekenreeksen, gescheiden door een spatie (Carlos Carvallo)

Carlos

Carvallo

=[Kolom2]&", "&[Kolom1]

Combineert de twee tekenreeksen, gescheiden door een komma en een spatie (Carvallo, Carlos)

Carlos

Carvallo

=TEKST.SAMENVOEGEN([Kolom2], ",", [Kolom1])

Combineert de twee tekenreeksen, gescheiden door een komma (Carvallo,Carlos)

Tekst en getallen uit verschillende kolommen combineren

Als u tekst en getallen wilt combineren, gebruikt u de functie TEKST SAMENVOEGEN, de ampersand operator (&) of de functie TEKST en de ampersand operator.

Kolom1

Kolom2

Formule

Beschrijving (resultaat)

Yang

28

=[Kolom1]&" verkocht "&[Kolom2]&" eenheden.

Hiermee combineert u de bovenstaande inhoud tot een woordgroep (Yang heeft 28 eenheden verkocht.)

Dubois

40%

=[Kolom1]&" verkocht "&TEKST([Kolom2],"0%")&" van de totale verkoop."

Hiermee combineert u de bovenstaande inhoud in een woordgroep (Dubois heeft 40% van de totale verkoop verkocht.)

Opmerking: Met de functie TEKST wordt de opgemaakte waarde van Kolom2 in plaats van de onderliggende waarde , 0,4, toevoegen.

Yang

28

=TEKST.SAMENVOEGEN([Kolom1]," verkocht ",[Kolom2]," eenheden.")

Hiermee combineert u de bovenstaande inhoud tot een woordgroep (Yang heeft 28 eenheden verkocht.)

Tekst combineren met een datum of tijd

Als u tekst wilt combineren met een datum of tijd, gebruikt u de functie TEKST en de ampersand operator (&).

Kolom1

Kolom2

Formule

Beschrijving (resultaat)

Factureringsdatum

5-06-2007

="Datum van instructie: "&TEKST([Kolom2], "d-mmm-yyyy")

Tekst combineren met een datum (datum van de instructie: 5-06-2007)

Factureringsdatum

5-06-2007

=[Kolom1]&" "&TEKST([Kolom2], "mmm-dd-yyyy")

Hiermee worden tekst en datum uit verschillende kolommen gecombineerd in één kolom (factureringsdatum 05-05-2007)

Kolominhoud vergelijken

Als u een kolom wilt vergelijken met een andere kolom of een lijst met waarden, gebruikt u de functies EXACT en OF.

Kolom1

Kolom2

Formule

Beschrijving (mogelijk resultaat)

BD122

BD123

=EXACT([Kolom1],[Kolom2])

Vergelijkt de inhoud van de eerste twee kolommen (Nee)

BD122

BD123

=EXACT([Kolom1], "BD122")

De inhoud van Kolom1 en de tekenreeks 'BD122' (Ja)

Controleren of een kolomwaarde of een deel ervan overeenkomt met specifieke tekst

Als u wilt controleren of een kolomwaarde of een deel ervan overeenkomt met specifieke tekst, gebruikt u de functies ALS,ZOEKEN,ZOEKEN enISNUMMER.

Kolom1

Formule

Beschrijving (mogelijk resultaat)

Vietzen

=ALS([Kolom1]="Vietzen", "OK", "Niet OK")

Hiermee wordt gecontroleerd of Kolom1 Vietzen is (OK)

Vietzen

=ALS(ISGETAL(VIND("v";;[Kolom1])), "OK", "Niet OK")

Hiermee wordt gecontroleerd of Kolom1 de letter v bevat (OK)

BD123

=ISGETAL(VIND("BD";[Kolom1]))

Hiermee wordt gecontroleerd of Kolom1 BD bevat (Ja)

Niet-lege kolommen tellen

Als u niet-lege kolommen wilt tellen, gebruikt u de functie AANTAL.A.

Kolom1

Kolom2

Kolom3

Formule

Beschrijving (resultaat)

Verkoop

19

=AANTAL.A([Kolom1], [Kolom2])

Telt het aantal niet-lege kolommen (2)

Verkoop

19

=AANTAL.A([Kolom1], [Kolom2], [Kolom3])

Telt het aantal niet-lege kolommen (2)

Tekens uit tekst verwijderen

Als u tekens uit tekst wilt verwijderen, gebruikt u de functies LENGTE,LINKSen RECHTS.

Kolom1

Formule

Beschrijving (resultaat)

Vitamine A

=LINKS([Kolom1],LENGTE([Kolom1])-2)

Be retourneert 7 tekens (9-2) vanaf links (Vitamine)

Vitamine B1

=RECHTS([Kolom1], LENGTE([Kolom1])-8)

Be retourneert 2 tekens (10-8) vanaf rechts (B1)

Spaties verwijderen aan het begin en einde van een kolom

Als u spaties uit een kolom wilt verwijderen, gebruikt u de functie TRIM.

Kolom1

Formule

Beschrijving (resultaat)

 Hallo jij daar!

=TRIM([Kolom1])

Hiermee verwijdert u de spaties van het begin en einde (Hallo daar!)

Een teken in een kolom herhalen

Als u een teken in een kolom wilt herhalen, gebruikt u de functie REPT.

Formule

Beschrijving (resultaat)

=HERHALING(".",3)

Herhaalt een punt 3 keer (...)

=HERHALING("-";10)

Herhaalt een streepje 10 keer (----------)

Alfabetische lijst met functies

Hieronder volgt een alfabetische lijst met koppelingen naar functies die beschikbaar zijn voor SharePoint gebruikers. Het bevat trigonometrische, statistische en financiële functies, evenals formules voor voorwaardelijke gegevens, datum, wiskunde en tekst.

ABS, functie

ACOS, functie

ACOSH, functie

AND, functie

ASIN, functie

ASINH, functie

ATAN, functie

ATAN2, functie

GEMIDDELDE, functie

GEMIDDELDEA, functie

BETA.VERD, functie

BETAINV, functie

BINOM.VERD, functie

CEILING, functie

CHAR, functie

CHI.VERD, functie

CHOOSE, functie

CODE, functie

TEKST SAMENVOEGEN, functie

BETROUWBAARHEID, functie

COS, functie

AANTAL, functie

AANTAL.A, functie

CRITBINOM, functie

DATUM, functie

DATED.ALS, functie

DATUMWAARDE, functie

DAG, functie

DAGEN360, functie

DDB, functie

GRADEN, functie

DOLLAR, functie

EVEN, functie

EXACTE, functie

EXPONDIST, functie

FACT, functie

F.VERD, functie

FIND, functie

FINV, functie

FISHER, functie

OPGELOST, functie

GAMMA.VERD, functie

GAMMA.INV, functie

GAMMALN, functie

GEOMEAN, functie

HARMEAN, functie

UUR, functie

HYPGEOMDIST, functie

ALS, functie

INT, functie

IPmt, functie

IS-functies

LINKS, functie

LENGTE, functie

LN, functie

Log, functie

LOG10, functie

LOGINV, functie

LOGNORM.VERD, functie

LOWER, functie

MAX, functie

Ik, functie

MEDIAAN, functie

MID, functie

MIN, functie

MINA, functie

MINUTE, functie

MOD, functie

MAAND, functie

NEGBINOM.VERD, functie

NORM.VERD, functie

NORM.VERD, functie

NORM.INV, functie

NOT, functie

NPER, functie

NHW, functie

ONEVEN, functie

OF, functie

PMT, functie

POWER, functie

PPMT, functie

PRODUCT, functie

PROPER, functie

PV, functie

RADIALEN, functie

VERVANGEN, functie

REPT, functie

RECHTS, functie

ROUND, functie

ROUNDDOWN, functie

ROUNDUP, functie

SEARCH, functie

SECOND, functie

SIGN, functie

SIN, functie

SINH, functie

SQRT, functie

STANDAARDISEREN, functie

STDEVA, functie

STDEVP, functie

STDEVPA, functie

SOM, functie

SOMMENQ, functie

SYD, functie

TANH, functie

T.VERD, functie

TEKST, functie

TIJD, functie

TINV, functie

VANDAAG, functie

TRIM, functie

WAAR, functie

UPPER, functie

USDOLLAR, functie

WAARDE, functie

VAR, functie

VARA, functie

VARP, functie

VARPA, functie

Weekdag, functie

WEIBULL, functie

JAAR, functie

Overige informatiebronnen

Als u niet ziet wat u hier probeert te doen, kijk dan of u dit kunt doen in Excel. Hier zijn enkele extra bronnen. Sommige van deze versies kunnen oudere versies omvatten, dus er kunnen verschillen zijn in de weergegeven gebruikersinterface. Items in het menu Siteactiesin SharePoint staan nu in het Instellingen Office 365 knop Setttings - ziet eruit als een tandwiel naast uw naam menu.

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft Office Insiders

Was deze informatie nuttig?

Hoe tevreden bent u met de taalkwaliteit?
Wat heeft uw ervaring beïnvloed?

Bedankt voor uw feedback.

×