Tip: Probeer de nieuwe functie XLOOKUP te gebruiken, een verbeterde versie van VERT.ZOEKEN die in elke richting werkt en standaard exacte overeenkomsten retourneert, waardoor het gemakkelijker en gemakkelijker te gebruiken is dan zijn voorganger.

Gebruik VERT.ZOEKEN als u dingen wilt zoeken in een tabel of een bereik per rij. Zoek bijvoorbeeld een prijs van een auto-onderdeel op op basis van het onderdeelnummer of zoek een naam van een werknemer op basis van hun werknemers-id.

In zijn eenvoudigste vorm ziet de functie VERT.ZOEKEN er als volgt uit:

=VERT.ZOEKEN(Wat u wilt opschonen, waar u het wilt zoeken, het kolomnummer in het bereik met de waarde die u wilt retourneren, retourneert een Geschatte of Exacte overeenkomst, aangegeven als 1/WAAR of 0/ONWAAR).

Uw browser biedt geen ondersteuning voor video.

Tip: Het geheim van VERT.ZOEKEN is om uw gegevens zo te organiseren dat de waarde die u opzoekt (Fruit) links van de retourwaarde (Hoeveelheid) staat die u wilt zoeken.

Gebruik de functie VERT.ZOEKEN om een waarde in een tabel op te zoeken.

Syntaxis 

VERT.ZOEKEN(zoekwaarde;tabelmatrix;kolomindex_getal;[benaderen])

Bijvoorbeeld:

  • =VERT.ZOEKEN(A2;A10:C20;2;WAAR)

  • =VERT.ZOEKEN("Spel",B2:E7,2,ONWAAR)

  • =VERT.ZOEKEN(A2;'Clientgegevens'! A:F,3;ONWAAR)

Naam argument

Beschrijving

zoekwaarde    (vereist)

De waarde die u wilt opzoeken. De waarde die u wilt op zoeken, moet zich in de eerste kolom van het cellenbereik dat u opgeeft in het argument table_array waarden.

Als tabelarray bijvoorbeeld cellen B2:D7 omvat, moet lookup_value in kolom B staan.

Lookup_value kan een waarde of een verwijzing naar een cel zijn.

Tabelmatrix    (vereist)

Het celbereik waarin met VERT.ZOEKEN wordt gezocht naar de zoekwaarde en de retourwaarde. U kunt een benoemd bereik of een tabel gebruiken en u kunt namen gebruiken in het argument in plaats van celverwijzingen. 

De eerste kolom in het celbereik moet de lookup_value. Het celbereik moet ook de retourwaarde bevatten die u wilt zoeken.

Meer informatie over het selecteren van bereiken in een werkblad.

kolomindex_getal    (vereist)

Het kolomnummer (beginnend met 1 voor de meest linkse kolom table_array) die de retourwaarde bevat.

benaderen    (optioneel)

Een logische waarde die aangeeft of VERT.ZOEKEN exacte of niet-geheel exacte overeenkomsten moet zoeken:

  • Geschatte overeenkomst- 1/WAAR gaat ervan uit dat de eerste kolom in de tabel numeriek of alfabetisch is gesorteerd en zoekt vervolgens naar de dichtstbijzijnde waarde. Dit is de standaardmethode als u deze niet opgeeft. Bijvoorbeeld= VERT.ZOEKEN(90;A1:B100;2;WAAR).

  • Exacte overeenkomst - 0/ONWAAR zoekt naar de exacte waarde in de eerste kolom. Bijvoorbeeld= VERT.ZOEKEN("Smith",A1:B100,2;ONWAAR).

Aan de slag

Er zijn vier onderdelen die u nodig hebt om de syntaxis van VERT.ZOEKEN te bouwen:

  1. De waarde die u wilt opzoeken, ook wel de opzoekwaarde genoemd.

  2. Het bereik waarin de opzoekwaarde zich bevindt. Houd er rekening mee dat de opzoekwaarde altijd in de eerste kolom in het bereik van VERT.ZOEKEN moet staan om deze correct te laten werken. Als de opzoekwaarde zich bijvoorbeeld in cel C2 bevindt, dan moet uw bereik beginnen met C.

  3. Het kolomnummer in het bereik waarin de retourwaarde zich bevindt. Als u bijvoorbeeld B2:D11 opgeeft als het bereik, moet u B tellen als de eerste kolom, C als tweede, en ga zo maar door.

  4. Desgewenst kunt u WAAR opgeven als u een niet-geheel exacte overeenkomst van de retourwaarde wilt of WAAR voor een exacte overeenkomst. Als u niets opgeeft, is de standaardwaarde altijd WAAR (niet-geheel exacte overeenkomst).

Stel dan nu alles hierboven als volgt samen:

=VERT.ZOEKEN(opzoekwaarde, bereik met de opzoekwaarde, het kolomnummer in het bereik met de retourwaarde, Geschatte overeenkomst (WAAR) of Exacte overeenkomst (ONWAAR)).

Voorbeelden

Hier zijn enkele voorbeelden van VERT.ZOEKEN:

Voorbeeld 1

=VERT.ZOEKEN (B3;B2:E7;2;ONWAAR)

VERT.ZOEKEN zoekt Naar Fontana in de eerste kolom (kolom B) in de table_array B2:E7 en retourneert Olivier uit de tweede kolom (kolom C) van de table_array.  Onwaar retourneert een exacte overeenkomst.

Voorbeeld 2

=VERT.ZOEKEN (102;A2:C7,2;ONWAAR)

VERT.ZOEKEN zoekt naar een exacte overeenkomst (ONWAAR) van de achternaam voor 102 (lookup_value) in de tweede kolom (kolom B) in het bereik A2:C7 en retourneert Fontana.

Voorbeeld 3

=ALS(VERT.ZOEKEN(103;A1:E7,2;ONWAAR)="Souse","Locatie";"Niet gevonden")

ALS controleert of VERT.ZOEKEN Sousa retourneert als achternaam van werknemer correspoinding naar 103 (lookup_value) in A1:E7 (table_array). Omdat de achternaam die overeenkomt met 103 Leal is, is de voorwaarde ALS onwaar en wordt Niet gevonden weergegeven.

Voorbeeld 4

=INT(JAARFRAC(DATUM(2014;6,30),VERT.ZOEKEN(105;A2:E7,5;FLASE);1))

VERT.ZOEKEN zoekt naar de geboortedatum van de werknemer die overeenkomt met 109 (lookup_value) in het A2:E7-bereik (table_array) en retourneert 03-04-1955. YearFRAC trekt deze geboortedatum af van 2014/6/30 en geeft een waarde als resultaat, die vervolgens door INY wordt geconverteerd naar het gehele getal 59.

Voorbeeld 5

ALS(ISNA(VERT.ZOEKEN(105;A2:E7;2;FLASE))=WAAR,"Werknemer niet gevonden",VERT.ZOEKEN(105;A2:E7,2;ONWAAR))

ALS controleert of VERT.ZOEKEN een waarde voor achternaam retourneert uit kolom B voor 105 (lookup_value). Als VERT.ZOEKEN een achternaam vindt, wordt in ALS de achternaam weergegeven, anders wordt ALS werknemer niet gevonden. ISNA zorgt ervoor dat als VERT.ZOEKEN een #N/A retourneert, de fout wordt vervangen door Werknemer niet gevonden, in plaats van #N/A.



In dit voorbeeld is de retourwaarde Burke, de achternaam die overeenkomt met 105.

U kunt VERT.ZOEKEN gebruiken om meerdere tabellen in één tabel te combineren, zolang een van de tabellen velden gemeen heeft met alle andere tabellen. Dit kan vooral handig zijn als u een werkmap wilt delen met personen met oudere versies van Excel die geen ondersteuning bieden voor gegevensfuncties met meerdere tabellen als gegevensbronnen. Door de bronnen in één tabel te combineren en de gegevensbron van de gegevensfunctie te wijzigen in de nieuwe tabel, kan de gegevensfunctie worden gebruikt in oudere Excel-versies (mits de gegevensfunctie zelf wordt ondersteund door de oudere versie).

Een werkblad met kolommen die VERT.ZOEKEN gebruiken om gegevens uit andere tabellen op te halen

Hier bevatten kolommen A-F en H waarden of formules die alleen waarden op het werkblad gebruiken, en de rest van de kolommen gebruiken VERT.ZOEKEN en de waarden van kolom A (Clientcode) en kolom B (Attorney) om gegevens uit andere tabellen te halen.

  1. Kopieer de tabel met de algemene velden naar een nieuw werkblad en geef deze een naam.

  2. Klik op >Hulpmiddelen voor gegevens > relaties om het dialoogvenster Relaties beheren te openen.

    Het dialoogvenster Relaties beheren
  3. Let op het volgende voor elke weergegeven relatie:

    • Het veld dat de tabellen koppelt (tussen haakjes in het dialoogvenster). Dit is de lookup_value voor uw VERT.ZOEKEN-formule.

    • De naam van de gerelateerde opzoektabel. Dit is de table_array in de FORMULE VERT.ZOEKEN.

    • Het veld (kolom) in de gerelateerde opzoektabel met de gegevens die u wilt gebruiken in de nieuwe kolom. Deze informatie wordt niet weergegeven in het dialoogvenster Relaties beheren. U moet de tabel Gerelateerde opzoekgegevens bekijken om te zien welk veld u wilt ophalen. U wilt het kolomnummer (A=1) noteren: dit is de col_index_num in uw formule.

  4. Als u een veld aan de nieuwe tabel wilt toevoegen, voert u de formule VERT.ZOEKEN in de eerste lege kolom in met de gegevens die u hebt verzameld in stap 3.

    In ons voorbeeld gebruikt kolom G Attorney (het lookup_value)om de factuurpercentagegegevens uit de vierde kolom(col_index_num = 4) op te halen uit de werkbladtabel Advocaten, tblAttorneys (de table_array),met de formule =VERT.ZOEKEN([@Attorney],tbl_Attorneys,4,ONWAAR).

    De formule kan ook een celverwijzing en een bereikverwijzing gebruiken. In ons voorbeeld is het =VERT.ZOEKEN(A2;'Advocaten'! A:D,4;ONWAAR).

  5. Ga door met het toevoegen van velden totdat u alle velden hebt die u nodig hebt. Als u een werkmap wilt voorbereiden met gegevensfuncties die meerdere tabellen gebruiken, wijzigt u de gegevensbron van de gegevensfunctie in de nieuwe tabel.

Probleem

Wat is er fout gegaan

Verkeerde waarde wordt geretourneerd

Als benaderen WAAR is of wordt weggelaten, moet de eerste kolom worden gesorteerd op alfabetische of numerieke volgorde. Als de eerste kolom niet wordt gesorteerd, kan de retourwaarde een onverwacht resultaat opleveren. Sorteer de eerste kolom of gebruik ONWAAR voor een exacte overeenkomst.

#N/B in cel

  • Als benaderen WAAR is, krijgt u de foutwaarde #N/B als de waarde in de zoekwaarde kleiner is dan de kleinste waarde in de eerste kolom van de tabelmatrix.

  • Als benaderen ONWAAR is, geeft de foutwaarde #N/B aan dat het precieze aantal niet kan worden gevonden.

Zie Een fout #N/B corrigeren in de functie VERT.ZOEKEN voor meer informatie over het oplossen van #N/B-fouten in VERT.ZOEKEN.

#REF! in cel

Als col_index_num groter is dan het aantal kolommen intabelarray, krijgt u de #REF! foutwaarde #WAARDE!.

Voor meer informatie over het oplossen van #REF! fouten in VERT.ZOEKEN, zie Een fout corrigeren #REF!.

#WAARDE! in cel

Als de table_array kleiner is dan 1, krijgt u de #VALUE! foutwaarde #WAARDE!.

Voor meer informatie over het oplossen van #VALUE! fouten in VERT.ZOEKEN, zie Een fout #VALUE! corrigeren in de functie VERT.ZOEKEN.

#NAAM? in cel

De foutwaarde #NAAM? betekent meestal dat er aanhalingstekens ontbreken aan de formule. Als u de naam van een persoon wilt opzoeken, zorg er dan voor dat u aanhalingstekens gebruikt rond de naam in de formule. Voer bijvoorbeeld de naam "Spel" in in VERT.ZOEKEN("Spel",B2:E7,2,ONWAAR).

Zie De fout #NAAM! corrigeren.

#SPILL! in cel

Deze specifieke #SPILL! fout betekent meestal dat uw formule afhankelijk is van impliciet snijpunt voor de opzoekwaarde en dat een hele kolom als verwijzing wordt gebruikt. Bijvoorbeeld = VERT.ZOEKEN(A:A,A:C,2;ONWAAR). U kunt het probleem oplossen door de zoekverwijzing als dit te verankeren met de operator @: =VERT.ZOEKEN(@A:A,A:C,2;ONWAAR). U kunt ook de traditionele verT.ZOEKEN-methode gebruiken en verwijzen naar één cel in plaats van een hele kolom: =VERT.ZOEKEN(A2,A:C,2;ONWAAR).

Werkwijze

Waarom

Gebruik absolute verwijzingen voor benaderen

Als u absolute verwijzingen gebruikt, kunt u een formule naar omlaag doorvoeren zodat er altijd hetzelfde bereik wordt gebruikt.

Informatie over het gebruik van absolute celverwijzingen.

Sla getallen of datums niet als tekst op.

Wanneer u naar getal- of datumwaarden zoekt, moet u ervoor zorgen dat de gegevens in de eerste kolom van tabelmatrix niet worden opgeslagen als tekstwaarden. Anders kan met VERT.ZOEKEN een onjuist of onverwacht resultaat worden geretourneerd.

De eerste kolom sorteren

Sorteer de eerste kolom van de tabelmatrix voordat u de functie VERT.ZOEKEN gebruikt als benaderen WAAR is.

Jokertekens gebruiken

Als range_lookup onWAAR is en lookup_value tekst is, kunt u de jokertekens (?) en sterretje (*)) gebruiken in lookup_value. Een vraagteken staat voor een willekeurig teken. Een sterretje staat voor een willekeurige reeks tekens. Als u echt een vraagteken of een sterretje zoekt, typt u een tilde (~) vóór het vraagteken of sterretje.

Bijvoorbeeld: =VERT.ZOEKEN("Fontan?",B2:E7,2;ONWAAR) zoekt naar alle exemplaren van Fontana met een laatste letter die kan variëren.

Zorg ervoor dat uw gegevens geen foutieve tekens bevatten.

Wanneer u in de eerste kolom naar tekstwaarden zoekt, moet u ervoor zorgen dat de gegevens in de eerste kolom geen voorloop- of volgspaties en geen niet-afdrukbare tekens bevatten, en dat rechte en gekrulde aanhalingstekens (enkel en dubbel) op consistente wijze worden gebruikt. Anders kan VERT.ZOEKEN een onverwacht resultaat opleveren.

Voor nauwkeurige resultaten gebruikt u de functie WISSEN of SPATIES.WISSEN om volgspaties na de tabelwaarden in een cel te verwijderen.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community of ondersteuning vragen in de Answers-community.

Zie ook

Snelzoekkaart: VERT.ZOEKEN-vernieuwing
Snelzoekkaart: tips voor het oplossen van vert.ZOEKEN
Een fout #VALUE! corrigeren in de functie VERT.ZOEKEN
Een fout #N/A corrigeren in de functie VERT.ZOEKEN
Overzicht van formules in Excel
Gebroken formules voorkomen
Fouten in formules detecteren
Excel functies (alfabetisch)
Excel functies (per categorie)
VERT.ZOEKEN (gratis preview)

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft insiders

Was deze informatie nuttig?

Hoe tevreden bent u met de vertaalkwaliteit?
Wat heeft uw ervaring beïnvloed?

Bedankt voor uw feedback.

×