VERT.ZOEKEN, functie

Tip: Probeer de nieuwe X.ZOEKEN-functie te gebruiken, een verbeterde versie van VERT.ZOEKEN die in alle richtingen werkt en standaard exacte overeenkomsten retourneert, zodat deze eenvoudiger en gebruiks gemakkelijker te gebruiken is dan zijn voorafgaande taak.

Gebruik VERT.ZOEKEN als u gegevens wilt zoeken in een tabel of bereik per rij. Zoek bijvoorbeeld de prijs van een auto-onderdeel op onderdeelnummer of zoek de naam van een werknemer op basis van zijn of haar werknemers-id.

Tip: Bekijk deze YouTube-video's van Microsoft Creators voor meer hulp bij VERT.ZOEKEN!

In zijn eenvoudigste vorm ziet de functie VERT.ZOEKEN er als volgt uit:

=VERT.ZOEKEN(Wat u wilt opzoekt, waar u ernaar wilt zoeken, het kolomnummer in het bereik dat de waarde bevat die u wilt retourneren, retourneert een niet-exacte overeenkomst , aangegeven als 1/WAAR of 0/ONWAAR).

Uw browser biedt geen ondersteuning voor video.

Tip: Het geheim van VERT.ZOEKEN is om uw gegevens zo te ordenen dat de waarde die u opzoekt (Fruit) links staat van de retourwaarde (Bedrag) die u zoekt.

Gebruik de functie VERT.ZOEKEN om een waarde in een tabel op te zoeken.

Syntaxis

VERT.ZOEKEN(zoekwaarde;tabelmatrix;kolomindex_getal;[benaderen])

Bijvoorbeeld:

  • =VERT.ZOEKEN(A2;A10:C20;2;WAAR)

  • =VERT.ZOEKEN("Spel",B2:E7,2,ONWAAR)

  • =VERT.ZOEKEN(A2;'Klantdetails'! A:F,3,ONWAAR)

Naam argument

Beschrijving

zoekwaarde    (vereist)

De waarde die u wilt opzoeken. De waarde die u wilt opmaken, moet zich in de eerste kolom van het celbereik opgeven in table_array argument.

Als tabel array bijvoorbeeld de cellen B2:D7 omvat, moet lookup_value kolom B staan.

Lookup_value kan een waarde of een verwijzing naar een cel zijn.

Tabelmatrix    (vereist)

Het celbereik waarin met VERT.ZOEKEN wordt gezocht naar de zoekwaarde en de retourwaarde. U kunt een benoemd bereik of een tabel gebruiken en u kunt namen gebruiken in het argument in plaats van celverwijzingen. 

De eerste kolom in het celbereik moet de lookup_value. Het celbereik moet ook de retourwaarde bevatten die u wilt zoeken.

Meer informatie over het selecteren van bereiken in een werkblad.

kolomindex_getal    (vereist)

Het kolomnummer (beginnend met 1 voor de meest linkse kolom van table_array)die de retourwaarde bevat.

benaderen    (optioneel)

Een logische waarde die aangeeft of VERT.ZOEKEN exacte of niet-geheel exacte overeenkomsten moet zoeken:

  • Niet-benadering van overeenkomst - 1/WAAR gaat ervan uit dat de eerste kolom in de tabel numeriek of alfabetisch is gesorteerd en wordt vervolgens gezocht naar de meest overeenkomende waarde. Dit is de standaardmethode als u deze niet opgeeft. Bijvoorbeeld =VERT.ZOEKEN(90;A1:B100;2;WAAR).

  • Exacte overeenkomst: 0/ONWAAR zoekt naar de exacte waarde in de eerste kolom. Bijvoorbeeld =VERT.ZOEKEN("Smit",A1:B100,2,ONWAAR).

Aan de slag

Er zijn vier onderdelen die u nodig hebt om de syntaxis van VERT.ZOEKEN te bouwen:

  1. De waarde die u wilt opzoeken, ook wel de opzoekwaarde genoemd.

  2. Het bereik waarin de opzoekwaarde zich bevindt. Houd er rekening mee dat de opzoekwaarde altijd in de eerste kolom in het bereik van VERT.ZOEKEN moet staan om deze correct te laten werken. Als de opzoekwaarde zich bijvoorbeeld in cel C2 bevindt, dan moet uw bereik beginnen met C.

  3. Het kolomnummer in het bereik waarin de retourwaarde zich bevindt. Als u bijvoorbeeld B2:D11 opgeeft als het bereik, moet B worden geteld als de eerste kolom, C als de tweede, en meer.

  4. Desgewenst kunt u WAAR opgeven als u een niet-geheel exacte overeenkomst van de retourwaarde wilt of WAAR voor een exacte overeenkomst. Als u niets opgeeft, is de standaardwaarde altijd WAAR (niet-geheel exacte overeenkomst).

Stel dan nu alles hierboven als volgt samen:

=VERT.ZOEKEN(opzoekwaarde, bereik met de opzoekwaarde, het kolomnummer in het bereik dat de retourwaarde bevat, niet-exacte overeenkomst (WAAR) of Exacte overeenkomst (ONWAAR)).

Voorbeelden

Hier ziet u een paar voorbeelden van VERT.ZOEKEN:

Voorbeeld 1

VERT.ZOEKEN: voorbeeld 1

Voorbeeld 2

VERT.ZOEKEN: voorbeeld 2

Voorbeeld 3

VERT.ZOEKEN: voorbeeld 3

Voorbeeld 4

VERT.ZOEKEN: voorbeeld 4

Voorbeeld 5

VERT.ZOEKEN: voorbeeld 5

U kunt VERT.ZOEKEN gebruiken om meerdere tabellen tot één tabel te combineren, zolang een van de tabellen velden gemeen heeft met alle andere tabellen. Dit kan vooral handig zijn als u een werkmap wilt delen met personen met oudere versies van Excel die geen ondersteuning bieden voor gegevensfuncties met meerdere tabellen als gegevensbronnen. Door de bronnen te combineren in één tabel en de gegevensbron van de gegevensfunctie te wijzigen in de nieuwe tabel, kan de gegevensfunctie worden gebruikt in oudere Excel-versies (mits de gegevensfunctie zelf wordt ondersteund door de oudere versie).

Een werkblad met kolommen die VERT.ZOEKEN gebruiken om gegevens uit andere tabellen op te halen

In dit artikel bevatten de kolommen A-F en H waarden of formules die alleen waarden in het werkblad gebruiken, terwijl in de rest van de kolommen VERT.ZOEKEN en de waarden in kolom A (Clientcode) en kolom B (Advocaten) worden gebruikt om gegevens uit andere tabellen op te halen.

  1. Kopieer de tabel met de gemeenschappelijke velden naar een nieuw werkblad en geef deze een naam.

  2. Klik op Hulpmiddelen > voor >om het dialoogvenster Relaties beheren te openen.

    Het dialoogvenster Relaties beheren
  3. Houd rekening met het volgende voor elke vermelde relatie:

    • Het veld dat de tabellen koppelt (tussen haakjes in het dialoogvenster). Dit is de lookup_value de formule VERT.ZOEKEN.

    • De naam van de gerelateerde opzoektabel. Dit is de table_array in de formule VERT.ZOEKEN.

    • Het veld (kolom) in de gerelateerde opzoektabel met de gegevens die u in de nieuwe kolom wilt hebben. Deze informatie wordt niet weergegeven in het dialoogvenster Relaties beheren. U moet de gerelateerde opzoektabel bekijken om te zien welk veld u wilt ophalen. U wilt het kolomnummer noteren (A=1), dit is col_index_num kolomnummer in de formule.

  4. Als u een veld aan de nieuwe tabel wilt toevoegen, voert u de formule VERT.ZOEKEN in de eerste lege kolom in met behulp van de gegevens die u hebt verzameld in stap 3.

    In dit voorbeeld gebruikt kolom G Advocaten (het lookup_value)om de factuurtariefgegevens uit de vierde kolom(col_index_num = 4) op te halen uit de werkbladtabel Advocaten, tblAttorneys (de table_array),met de formule =VERT.ZOEKEN([@Attorney],tbl_Attorneys,4,ONWAAR).

    In de formule kunnen ook een celverwijzing en een bereikverwijzing worden gebruikt. In ons voorbeeld is dat =VERT.ZOEKEN(A2;'Advocaten'! A:D,4,ONWAAR).

  5. Ga verder met het toevoegen van velden totdat u alle velden hebt die u nodig hebt. Als u een werkmap wilt voorbereiden die gegevensfuncties bevat waarin meerdere tabellen worden gebruikt, wijzigt u de gegevensbron van de gegevensfunctie in de nieuwe tabel.

Probleem

Wat is er fout gegaan

Verkeerde waarde wordt geretourneerd

Als benaderen WAAR is of wordt weggelaten, moet de eerste kolom worden gesorteerd op alfabetische of numerieke volgorde. Als de eerste kolom niet wordt gesorteerd, kan de retourwaarde een onverwacht resultaat opleveren. Sorteer de eerste kolom of gebruik ONWAAR voor een exacte overeenkomst.

#N/B in cel

  • Als benaderen WAAR is, krijgt u de foutwaarde #N/B als de waarde in de zoekwaarde kleiner is dan de kleinste waarde in de eerste kolom van de tabelmatrix.

  • Als benaderen ONWAAR is, geeft de foutwaarde #N/B aan dat het precieze aantal niet kan worden gevonden.

Zie Een fout #N/B corrigeren in de functie VERT.ZOEKEN voor meer informatie over het oplossen van #N/B-fouten in VERT.ZOEKEN.

#REF! in cel

Als col_index_num groter is dan het aantal kolommen intabel matrix, krijgt u de #REF! foutwaarde #WAARDE!.

Voor meer informatie over het oplossen van #REF! fouten in VERT.ZOEKEN, zie Een fout #REF!.

#WAARDE! in cel

Als de table_array kleiner is dan 1, krijgt u de #VALUE! foutwaarde #WAARDE!.

Voor meer informatie over het oplossen van #VALUE! fouten in VERT.ZOEKEN, zie Een fout #VALUE! in de functie VERT.ZOEKEN corrigeren.

#NAAM? in cel

De foutwaarde #NAAM? betekent meestal dat er aanhalingstekens ontbreken aan de formule. Als u de naam van een persoon wilt opzoeken, zorg er dan voor dat u aanhalingstekens gebruikt rond de naam in de formule. Voer bijvoorbeeld de naam "Spel" in in VERT.ZOEKEN("Spel",B2:E7,2,ONWAAR).

Zie De fout #NAAM! corrigeren.

#SPILL! in cel

Deze specifieke #SPILL! betekent meestal dat uw formule afhankelijk is van impliciet snijpunt voor de opzoekwaarde en dat een hele kolom als verwijzing wordt gebruikt. Voorbeeld: =VERT.ZOEKEN(A:A,A:C,2,ONWAAR). U kunt dit probleem oplossen door de zoekverwijzing als volgende te verankeren met de operator @: =VERT.ZOEKEN(@A:A,A:C,2,ONWAAR). U kunt ook de traditionele methode VERT.ZOEKEN gebruiken en naar één cel verwijzen in plaats van naar een hele kolom: =VERT.ZOEKEN(A2,A:C,2,ONWAAR).

Werkwijze

Waarom

Gebruik absolute verwijzingen voor benaderen

Als u absolute verwijzingen gebruikt, kunt u een formule naar omlaag doorvoeren zodat er altijd hetzelfde bereik wordt gebruikt.

Informatie over het gebruik van absolute celverwijzingen.

Sla getallen of datums niet als tekst op.

Wanneer u naar getal- of datumwaarden zoekt, moet u ervoor zorgen dat de gegevens in de eerste kolom van tabelmatrix niet worden opgeslagen als tekstwaarden. Anders kan met VERT.ZOEKEN een onjuist of onverwacht resultaat worden geretourneerd.

De eerste kolom sorteren

Sorteer de eerste kolom van de tabelmatrix voordat u de functie VERT.ZOEKEN gebruikt als benaderen WAAR is.

Jokertekens gebruiken

Als range_lookup ONWAAR is en lookup_value tekst is, kunt u dejokertekens vraagteken (?) en sterretje (*) in lookup_value. Een vraagteken staat voor een willekeurig teken. Een sterretje staat voor een willekeurige reeks tekens. Als u echt een vraagteken of een sterretje zoekt, typt u een tilde (~) vóór het vraagteken of sterretje.

Met =VERT.ZOEKEN("Fontan?",B2:E7,2,ONWAAR) wordt bijvoorbeeld gezocht naar alle instanties van Fontana met een laatste letter die kan variëren.

Zorg ervoor dat uw gegevens geen foutieve tekens bevatten.

Wanneer u in de eerste kolom naar tekstwaarden zoekt, moet u ervoor zorgen dat de gegevens in de eerste kolom geen voorloop- of volgspaties en geen niet-afdrukbare tekens bevatten, en dat rechte en gekrulde aanhalingstekens (enkel en dubbel) op consistente wijze worden gebruikt. Anders kan VERT.ZOEKEN een onverwacht resultaat opleveren.

Voor nauwkeurige resultaten gebruikt u de functie WISSEN of SPATIES.WISSEN om volgspaties na de tabelwaarden in een cel te verwijderen.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

Snelzoekkaart: Geheugenkaart voor VERT.ZOEKEN
Snelzoekkaart: Tips voor het oplossen van problemen met VERT.ZOEKEN
YouTube: VERT.ZOEKEN-video's van Microsoft Creators
Een fout in #VALUE! corrigeren in de functie VERT.ZOEKEN
Een fout #N/A corrigeren in de functie VERT.ZOEKEN
Overzicht van formules in Excel
Niet-afgebroken formules voorkomen
Fouten opsporen in formules
Excel-functies (alfabetisch)
Excel-functies (per categorie)
VERT.ZOEKEN (gratis preview)

Meer hulp nodig?

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×