FIX: Foutbericht wanneer u een WMI-gebeurteniswaarschuwing probeert te maken met behulp van de sp_add_alert opgeslagen procedure in SQL Server 2008: "Het @wmi_query kan niet worden uitgevoerd in het @wmi_namespace opgegeven veld"

Fout: #50004003 (SQL-hotfix)

Microsoft distribueert Microsoft SQL Server 2008-oplossingen als één downloadbaar bestand. Omdat de oplossingen cumulatief zijn, bevat elke nieuwe release alle hotfixes en alle beveiligingspatches die aanwezig waren in de vorige release voor oplossingen voor SQL Server 2008.

Symptomen

Wanneer u probeert een WMI-gebeurteniswaarschuwing (Windows Management Instrumentation) te maken met behulp van de
 sp_add_alert
  opgeslagen procedure op een benoemd clusterexemplaar van Microsoft SQL Server 2008, wordt het volgende foutbericht weergegeven:

Opmerking

Msg 22022, Level 16, State 1, Line 0

  SQLServerAgent-fout: WMI-fout: 0x80041013.

  Msg 14511, Level 16, State 1, Procedure sp_verify_alert, Line 300

  Het @wmi\_query kon niet worden uitgevoerd in de @wmi\_namespace voorziene. Controleer of een gebeurtenisklasse die in de query is geselecteerd, bestaat in de naamruimte en of de query de juiste syntaxis heeft.

Opmerking
  Dit probleem doet zich niet voor als de SQL-netwerknaam van het cluster uit precies 15 tekens bestaat.

  De naam van het SQL-netwerk wordt ook wel de naam van de virtuele SQL Server genoemd.

Oorzaak

Dit probleem doet zich voor omdat de WMI-gebeurtenisprovider geen verbinding kan maken met de database-engine van SQL Server.

Oplossing

De oplossing voor dit probleem is voor het eerst uitgebracht in cumulatieve update 3. Klik voor meer informatie over het verkrijgen van dit cumulatieve updatepakket voor SQL Server 2008 op het volgende artikelnummer in de Microsoft Knowledge Base:

960484 Cumulatief updatepakket 3 voor SQL Server 2008Opmerking Omdat de builds cumulatief zijn, bevat elke nieuwe fixversie alle hotfixes en alle beveiligingspatches die aanwezig waren bij de vorige SQL Server 2008-fixversie. Het is raadzaam om de meest recente fixversie toe te passen die deze hotfix bevat. Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:

956909 De builds van SQL Server 2008 die zijn uitgebracht nadat SQL Server 2008 zijn uitgebracht

Tijdelijke oplossing

U kunt dit probleem omzeilen door een standaardclusterexemplaar te installeren in plaats van een benoemd clusterexemplaar. Of geef het cluster een SQL-netwerknaam die uit precies 15 tekens bestaat.

Voordat u de naam van de virtuele SQL Server probeert te wijzigen, moet u de volgende items hebben gelezen:

  • SQL Server biedt geen ondersteuning voor het hernoemen van servers die betrokken zijn bij replicatie, tenzij u logboekverzending gebruikt in combinatie met replicatie. De naam van de secundaire server bij het verzenden van logboeken kan worden gewijzigd als de primaire server definitief verloren gaat. Ga voor meer informatie naar de volgende MSDN-website (Microsoft Developer Network):
    https://msdn.microsoft.com/library/ms151224.aspx
  • Wanneer u de naam wijzigt van een virtuele server die is geconfigureerd voor het gebruik van databasespiegeling, moet u databasespiegeling uitschakelen voordat u de naam wijzigt. Vervolgens moet u databasespiegeling opnieuw instellen met de nieuwe naam van de virtuele server. Metagegevens voor databasespiegeling worden niet automatisch bijgewerkt met de nieuwe naam van de virtuele server.

Ga naar de volgende MSDN-website voor meer informatie over het wijzigen van de naam van een virtueel exemplaar van SQL Server:

https://msdn.microsoft.com/library/ms178083.aspx

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.

Meer informatie

Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over welke bestanden er zijn gewijzigd en voor informatie over eventuele vereisten voor toepassing van het cumulatieve updatepakket met de hotfix die in dit Microsoft Knowledge Base-artikel wordt beschreven:

960484 Cumulatief updatepakket 3 voor SQL Server 2008Het foutbericht dat wordt vermeld in de sectie 'Symptomen' is een algemene WMI-fout. Deze foutmelding kan ook optreden onder diverse andere omstandigheden die niet in dit artikel worden beschreven. In die gevallen zijn de oplossingen die in dit artikel worden beschreven, niet van toepassing. Ga voor meer informatie over één gedocumenteerde zaak naar de volgende Microsoft-website:

https://connect.microsoft.com/sqlserver/feedback/viewfeedback.aspx?feedbackid=351556

Meer informatie

Voor meer informatie over de lijst met builds die beschikbaar zijn na de release van SQL Server 2008, klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:

956909 De builds van SQL Server 2008 die zijn uitgebracht nadat SQL Server 2008 zijn uitgebracht

Voor meer informatie over het Incremental Servicing Model voor SQL Server klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:

935897 Er is een incrementeel servicemodel beschikbaar van het SQL Server-team om hotfixes voor gemelde problemen te leveren

Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over het naamgevingsschema voor SQL Server-updates:

822499 Nieuw naamgevingsschema voor software-updatepakketten voor Microsoft SQL Server Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over software-updateterminologie:

824684 Beschrijving van de standaardterminologie die wordt gebruikt om Microsoft-software-updates te beschrijven