Este artigo destina-se a pessoas com deficiências visuais ou cognitivas que usam um programa de leitor de tela, como o Narrador da Microsoft, JAWS ou NVDA com os produtos Microsoft 365. Este artigo faz parte do conjunto de conteúdo de suporte ao leitor de tela do Microsoft 365 , em que você pode encontrar mais informações de acessibilidade em nossos aplicativos. Para obter ajuda geral, visite a página inicial do Suporte da Microsoft ou Correções e soluções alternativas para problemas recentes do Office.
- Versões mais recentes do Windows
- Versões mais recentes do Mac
- Office para iOS
- Office para Android
- Web
Use o Excel com o teclado e um leitor de tela para classificar e filtrar tabelas. A classificação de dados ajuda a organizar e a localizar os dados desejados rapidamente, a fim de proporcionar uma análise mais rápida. Com a filtragem de dados, você pode se concentrar em um determinado conjunto de dados, o que é especialmente útil para grandes planilhas.
Precisa de instruções sobre como classificar ou filtrar dados no Excel, mas não usar um leitor de tela? Consulte Classificar dados em um intervalo ou tabela ou Filtrar dados em um intervalo ou tabela.
Observação
- Saiba mais sobre leitores de tela, acesse Como os leitores de tela funcionam com o Microsoft 365.
Neste tópico
- Atalhos de teclado para classificação e filtragem
- Saiba mais sobre classificação no Excel
- Classificar texto em uma tabela ou intervalo
- Classificar números
- Classificar datas e horas
- Classificar por mais de uma coluna
- Dicas para problemas com classificação
- Filtrar dados em uma tabela
- Filtrar dados em um intervalo
Atalhos de teclado para classificação e filtragem
Esta tabela mostra atalhos de teclado para classificação e filtragem.
| Para | Pressione |
|---|---|
| Ativar e desativar o menu suspenso Filtro Automático em um título de coluna | Ctrl+Shift+L |
| Classificar do menor para o maior ou de A a Z | Alt+A, S, A ou Alt+Seta para baixo, S |
| Classificar do maior para o menor ou de Z a A | Alt+A, S, D ou Alt+Seta para baixo, O |
| Abrir a caixa de diálogo Classificar | Alt+A, S, S ou Alt+H, S, U |
| Aplicar novamente uma classificação após alterar os dados | Ctrl+Alt+L ou Alt+A, Y, 3 |
| Filtrar por cor | Alt+Seta para baixo, I |
| Filtrar por número ou texto | Alt+Seta para baixo, F |
| Abra a caixa de diálogo Formatar Células | Alt+H, O, I |
| Usar a função ARRUMAR | Alt+M, T e vá para APARAR com a tecla de seta para baixo |
Saiba mais sobre classificação no Excel
Você pode classificar dados por texto (de A a Z ou de Z a A), por números (em ordem crescente ou decrescente) e por datas e horas (do mais antigo para o mais recente ou vice-versa) em uma ou mais colunas. Você pode também classificar por uma lista personalizada (como Grande, Médio e Pequeno) ou por formatação, incluindo cor da célula, cor da fonte ou conjunto de ícones. A maioria das operações de classificação é aplicada às colunas, mas você pode também classificar por linhas.
Quando você classifica uma tabela, o Excel salva os critérios usados na pasta de trabalho para que você possa aplicá-los novamente sempre que abrir essa pasta. Esse recurso é especialmente importante para classificações de várias colunas ou para classificações que levam muito tempo para serem criadas. No entanto, esse recurso só funciona para dados em uma tabela, ele não se aplica apenas a um intervalo de células. Se você quiser salvar critérios de classificação para que possa reaplicar periodicamente uma classificação ao abrir uma pasta de trabalho, use uma tabela.
Observação
Depois de classificar os dados, você não poderá restaurar a ordem original. Se você não salvou o arquivo após a classificação, poderá usar desfazer (Ctrl Z+) para voltar. Se você vai fazer classificações e sempre quiser restaurar a ordem original, adicione uma coluna e preencha-a com uma série (1,2,3 e assim por diante) como um índice antes de começar. Quando quiser restaurar a ordem original, classifique a coluna índice.
Classificar texto em uma tabela ou intervalo
Classificar texto em uma tabela
- Use as teclas de direção para ir para a linha de cabeçalho na tabela. Quando estiver na linha de cabeçalho, você ouvirá "Item de cabeçalho" após o local da célula.
- Pressione a teclaSeta para a direita ou Seta para a esquerda para ir para o cabeçalho da coluna dos dados que você deseja classificar.
- Pressione a tecla Alt+Seta para baixo para abrir o menu de filtro e pressione Tab até ouvir "Menu, Classificar de A a Z, item de menu desmarcado".
- As opções que aparecem dependem do tipo de dados na coluna. Por exemplo, você pode classificar dados numéricos do menor para o maior ou do maior para o menor. Você pode classificar dados alfanuméricos de A a Z ou de Z a A. Você também pode classificar por cor.
- Use a teclaSeta para baixo para navegar pelas opções e pressione Enter para selecionar uma opção. Você ouvirá "Classificado", seguido pela opção selecionada.
Classificar texto em um intervalo
Use as teclas de direção para ir para uma coluna de dados alfanuméricos em um intervalo de células ou para uma coluna de tabela contendo dados alfanuméricos.
Pressione Alt+A. A guia Dados é aberta e você ouve "Guias da faixa de opções, selecionado, item da guia Dados".
Execute uma destas ações:
- Para classificar em ordem alfanumérica crescente (Classificar de A a Z), pressione S e depois A.
- Para classificar em ordem alfanumérica decrescente (Classificar de Z a A), pressione S e depois D.
Classificar diferenciando maiúsculas de minúsculas
- Use as teclas de direção para navegar para uma coluna de dados alfanuméricos em um intervalo de células ou para uma coluna de tabela contendo dados alfanuméricos.
- Pressione Alt+H, S, U. A caixa de diálogo Classificar é aberta e você ouve "Janela Classificar, botão OK".
- Pressione Alt+O para abrir a caixa de diálogo Opções de Classificação e você ouvirá "Opções de classificação. Caixa de seleção Desmarcada, diferencia maiúsculas de minúsculas."
- Pressione a Barra de espaços para marcar a caixa de seleção Diferenciar maiúsculas e minúsculas .
- Pressione Enter. A caixa de diálogo Opções de Classificação é fechada e você ouve "Botão Classificar, Opções".
- Para fechar a caixa de diálogo Classificar e aplicar suas alterações, pressione Tab até ouvir "botão OK" e pressione Enter.
- Classifique o texto conforme explicado em Classificar texto em um intervalo.
Dica
Se a coluna que você classificar incluir uma combinação de números e texto, convém formatar tudo como texto. Caso contrário, o Excel classifica primeiro os números como números e, em seguida, classifica o texto. Para formatar os dados, pressione Ctrl+e a Barra de espaço para selecionar todos os dados na coluna e pressione Alt+H, F, N. Pressione a tecla de seta para a esquerda até ouvir "Selecionado, item da guia Número", pressione Tab uma vez e, em seguida, pressione a tecla Seta para baixo até ouvir "Texto". Pressione Tab uma vez para ir para o botão OK e pressione Enter.
r
- Use as teclas de direção para ir para uma coluna de dados numéricos em um intervalo de células ou para uma coluna de tabela que contenha dados numéricos.
- Pressione Alt+A. A guia Dados é aberta e você ouve "Guias da faixa de opções, selecionado, item da guia Dados".
- Siga um destes procedimentos:
- Para classificar do menor para o maior, pressione S e depois A.
- Para classificar do maior para o menor, pressione S e depois D.
Verificar se os números estão armazenados como números
- Use as teclas de direção para ir para uma coluna de dados numéricos em um intervalo de células ou para uma coluna de tabela que contenha dados numéricos. Em seguida, pressione Ctrl+Barra de espaço para selecionar todos os dados na coluna.
- Pressione Alt+H, F, N. A caixa de diálogo Formatar Células é aberta e você ouve "Formatar células".
- Para ir para a guia Número , use a tecla deseta para a esquerda (ou pressione Ctrl+Tab). Você ouvirá "Item da guia Número".
- Pressione Tab. A lista Categoria é aberta e você ouve a categoria selecionada no momento, como "Geral" ou "Data".
- Pressione a tecla Seta para cima ou Seta para baixo até ouvir "Número".
- Pressione Tab até ouvir "Casas decimais", seguido pelo número de casas decimais usadas no momento. Se você quiser alterar esse valor, digite o novo número de casas decimais. Para remover completamente os decimais, digite 0.
- Para fechar a caixa de diálogo Formatar Células e aplicar suas alterações, pressione Tab até ouvir "botão OK" e pressione Enter.
Classificar datas e horas
- Use as teclas de direção para ir para uma coluna de datas ou horas em um intervalo de células, ou para uma coluna de tabela contendo datas ou horas.
- Pressione Alt+A. A guia Dados é aberta e você ouve "Guias da faixa de opções, selecionada, guia Dados".
- Siga um destes procedimentos:
- Para classificar do mais antigo para o mais recente, pressione S e depois A.
- Para classificar do mais recente para o mais antigo, pressione S e depois D.
- Para reaplicar uma classificação após alterar os dados, selecione uma célula no intervalo ou tabela e pressione Ctrl+Alt+L.
Classificar por mais de uma coluna
Você também pode classificar por mais de uma coluna ou linha quando tiver dados que queira agrupar pelo mesmo valor em uma coluna ou linha e, em seguida, classificar outra coluna ou linha dentro desse grupo de valores iguais. Por exemplo, se você tiver uma coluna Departamento e uma coluna Funcionários, é possível classificar primeiro por Departamento (para agrupar todos os funcionários no mesmo departamento) e, em seguida, classificar por nome (para colocar os nomes em ordem alfabética em cada departamento). Você pode classificar por até 64 colunas.
Observação
Para obter melhores resultados, o intervalo de células classificado deve apresentar títulos de coluna. Para classificar por linhas, verifique se a caixa de seleção Minha tabela tem títulos está desmarcada na caixa de diálogo Classificar . Pressione Alt+H, S, U para abrir a caixa de diálogo Classificar e pressione Tab até ouvir "Marque, os meus dados têm caixa de seleção de cabeçalhos" ou "Desmarcado, os meus dados têm caixa de seleção de cabeçalhos". Se precisar desmarcar a caixa de seleção, pressione a Barra de espaços, pressione Tab até ouvir "OK, botão" e pressione Enter para aplicar a alteração.
Use as teclas de direção para navegar para um intervalo de células com duas ou mais colunas de dados ou para uma tabela com duas ou mais colunas.
Pressione Alt+A, S, S. A caixa de diálogo Classificar é aberta e você ouve "Botão Classificar, OK".
Pressione Tab até encontrar a caixa de combinação Coluna: Classificar por . Você ouvirá "Classificar por", seguido pelo nome da coluna e, em seguida, "Caixa de combinação editável". Use as setaspara cima e para baixo para selecionar a primeira coluna que você deseja classificar.
Pressione Tab até encontrar a caixa de combinação Classificar em . Você ouvirá "Classificar em, Valores de célula, caixa de combinação editável". Se você não ouvir "Valores de célula", pressione as teclas de direçãopara cima e para baixo até ouvir.
Para selecionar como você deseja classificar os valores da célula, pressione Tab até encontrar a caixa de combinação Ordem . Você ouvirá "Ordem", seguido pela opção selecionada no momento e, em seguida, "caixa de combinação editável". Use as teclas de direçãopara cima e para baixo para selecionar de A a Z, de Z a A, do Menor para o Maior ou do Maior para o Menor.
Para adicionar outra coluna pela qual classificar, use Tab para ir para o botão Adicionar Nível , pressione Enter e repita as etapas de três a cinco.
Observação
A caixa de combinação Classificar por é chamada de Depois por para as colunas adicionais.
Para reaplicar uma coluna, classifique depois de alterar os dados, selecione uma célula no intervalo ou tabela e pressione Ctrl+Alt+L.
Observação
Ctrl++ AltL não reaplica uma classificação de linha.
Dicas para problemas com a classificação
Se você obtiver resultados inesperados quando classificar os dados:
- Verifique se os valores retornados por uma fórmula foram alterados. Se os dados que você classificou contiverem uma ou mais fórmulas, os valores retornados dessas fórmulas podem mudar quando a planilha for recalculada. Nesse caso, não deixe de reaplicar a classificação para obter resultados atualizados.
- Exiba novamente as linhas e colunas antes de classificá-las. Colunas ocultas não são movidas quando você classifica colunas, e linhas ocultas não são movidas quando você classifica linhas. Antes de classificar dados, reexiba as colunas e linhas ocultas.
- Verifique a configuração de localidade. As ordens de classificação variam de acordo com a configuração de localidade. Verifique se você tem a configuração adequada em Configurações Regionais ou Opções Regionais e de Idioma no Painel de Controle do seu computador.
- Habilite ou desabilite a linha de título. Geralmente, é melhor ter uma linha de título ao classificar uma coluna para facilitar a compreensão do significado dos dados. Por padrão, o valor no título não está incluído na operação de classificação. Ocasionalmente, talvez seja necessário ativar ou desativar o título de modo que o valor no título seja ou não incluído na operação de classificação.
- Para excluir a primeira linha de dados da classificação por ser um título de coluna, pressione Alt+H, S, U. Na caixa de diálogo Classificação personalizada , marque a caixa de seleção Meus dados têm cabeçalhos .
- Para incluir a primeira linha de dados na classificação por não ser um título de coluna, pressione Alt+H, S, U. Na caixa de diálogo Classificação personalizada , desmarque a caixa de seleção Meus dados têm cabeçalhos .
Filtrar dados em uma tabela
Quando você coloca seus dados em uma tabela, o Excel adiciona automaticamente um menu suspenso de Filtro Automático a cada cabeçalho de coluna. Você pode abrir este menu para filtrar rapidamente. Para remover o menu suspenso Filtro Automático de um título de coluna, selecione o cabeçalho e pressione Ctrl+Shift+L.
- No cabeçalho da coluna que você deseja filtrar, pressione Alt+Seta para baixo. O menu suspenso Filtro Automático é aberto e você ouve "Menu".
- No menu Filtro Automático, se a coluna tiver números, use a tecla Seta para baixo para ir até Filtros de Número e pressione Enter. Se a coluna tiver entradas de texto, use a tecla Seta para baixo para ir para Filtros de Texto e pressione Enter. O submenu é aberto e você ouve "Igual a".
- Para ir para a opção de filtragem desejada, use as teclas de direção e pressione Enter. A caixa de diálogo Filtro Automático Personalizado é aberta, e você ouvirá "Filtro Automático Personalizado".
- Digite ou escolha as condições de filtragem.
Por exemplo, para mostrar números acima de um determinado valor, selecione Maior ou Igual a e insira o número que você tem em mente na próxima caixa de combinação.
Para filtrar por duas condições, insira condições de filtragem em ambos os conjuntos de caixas de combinação de edição. Para que ambas as condições sejam verdadeiras, pressione Shift+A para selecionar a condição And . Para que qualquer uma das condições seja verdadeira, pressione Shift+O para selecionar a condição Ou . - Para fechar a caixa de diálogo, pressione Tab até ouvir "Botão OK" e pressione Enter.
Filtrar dados em um intervalo
- Escolha as células que deseja filtrar. Vá para a célula desejada como a célula superior esquerda da seleção. Mantenha a tecla Shift pressionada e use as teclas Seta para a direita e Seta para baixo para expandir o intervalo de células selecionado.
- Pressione Ctrl+Shift+L. O Excel adiciona um menu suspenso de Filtro Automático à primeira célula de cada coluna no intervalo.
- No cabeçalho da coluna que você deseja filtrar, pressione Alt+Seta para baixo. O menu suspenso Filtro Automático é aberto e você ouve "Menu".
- Use as teclas de direção e Tab para ir para as opções de filtragem desejadas. Use a Barra de espaços para desmarcar ou selecionar a caixa de seleção de um valor de filtro.
- Ao fazer suas seleções, pressione Enter para aplicar o filtro.
Para limpar o filtro e remover os menus suspensos de Filtro Automático, selecione qualquer célula no intervalo e pressione Ctrl+Shift+L.
Confira também
Usar um leitor de tela para atribuir um título a uma tabela no Excel
Usar um leitor de tela para adicionar comentários a uma planilha do Excel
Usar um leitor de tela para criar cabeçalhos de coluna em uma tabela no Excel
Tarefas básicas usando um leitor de tela no Excel
Configurar seu dispositivo para operar com acessibilidade no Microsoft 365
Suporte técnico para clientes com deficiências
A Microsoft quer proporcionar a melhor experiência possível para todos os clientes. Se você tiver alguma deficiência ou dúvidas sobre acessibilidade, contate o Answer Desk de Acessibilidade da Microsoft para obter assistência técnica. A equipe de suporte do Answer Desk Acessibilidade é treinada no uso de várias tecnologias adaptativas populares e pode oferecer assistência em espanhol, francês, inglês e na língua de sinais dos EUA. Acesse o site do Microsoft Answer Desk Acessibilidade para descobrir os detalhes de contato para a sua região.
Se você for um usuário empresarial, comercial ou governamental, entre em contato com o Answer Desk de Deficiência corporativo.