KB3178297 - Repositório de Consultas a limpeza automática de dados falha em edições diferentes das edições Enterprise e Developer do SQL Server 2016

Aplica-se a
SQL Server 2016 Express - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Web - duplicate (do not use)

Sintomas

A limpeza automática de dados do Repositório de Consultas pode falhar em edições do SQL Server 2016 diferentes do Enterprise e Developer. Portanto, se os dados não forem limpos manualmente, o espaço usado pelo Repositório de Consultas aumentará ao longo do tempo até que o limite configurado seja atingido. Se esse problema não for resolvido, o espaço em disco alocado para os logs de erro também será preenchido, pois cada tentativa de executar a limpeza produzirá um arquivo de despejo. O período de ativação da limpeza depende da frequência da carga de trabalho. No entanto, não excede 15 minutos.

Resolução

A correção para esse problema está incluída na seguinte atualização cumulativa para o SQL Server:

Atualização cumulativa 1 para o SQL Server 2016
      

Sobre atualizações cumulativas para o SQL Server

Cada nova atualização cumulativa do SQL Server contém todos os hotfixes e todas as correções de segurança incluídas na atualização cumulativa anterior. Confira as atualizações cumulativas mais recentes para o SQL Server:

Atualização cumulativa mais recente do SQL Server 2016
      

Solução alternativa

Para contornar esse problema, se você planeja usar o Repositório de Consultas em edições diferentes da Enterprise e Developer, precisará desativar explicitamente as políticas de limpeza. Você pode fazer isso no SQL Server Management Studio (página Propriedades do Banco de Dados) ou usando o seguinte script Transact-SQL:

ALTER DATABASE database_name SET QUERY_STORE (OPERATION_MODE = READ_WRITE, CLEANUP_POLICY = (STALE_QUERY_THRESHOLD_DAYS = 0), SIZE_BASED_CLEANUP_MODE = OFF)
Além disso, considere as opções de limpeza manual para evitar que o Repositório de Consultas faça a transição para o modo somente leitura. Por exemplo, execute a seguinte consulta para limpar periodicamente o espaço de dados:

ALTERAR database_name DO BANCO DE DADOS DEFINIR QUERY_STORE LIMPAR
Além disso, execute periodicamente os seguintes procedimentos armazenados do Repositório de Consultas para limpar estatísticas de tempo de execução, consultas específicas ou planos:

  • sp_query_store_reset_exec_stats
  • sp_query_store_remove_plan
  • sp_query_store_remove_query

      

Status

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Referências

Saiba mais sobre a terminologia que a Microsoft usa para descrever atualizações de software.