KB4014734 - CORREÇÃO: SQL Server serviço Launchpad não será iniciado se a versão instalada do R Services (no banco de dados) for diferente do Mecanismo de Banco de Dados no SQL Server 2016

Aplica-se a
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1

Sintomas

Se você instalar o R Services (no banco de dados) separadamente do Mecanismo de Banco de Dados no Microsoft SQL Server 2016 e se suas versões forem diferentes, o serviço Launchpad do SQL Server poderá falhar ao iniciar. Além disso, as mensagens de erro semelhantes às seguintes são registradas no log de erros do SQL Server:

Observação

  • Um tempo limite foi atingido (30000 milissegundos) enquanto se aguardava o serviço SQL Server Launchpad (BI_DW) se conectar.
  • O serviço SQL Server Launchpad (BI_DW) não foi iniciado devido ao seguinte erro: O serviço não respondeu à solicitação de início ou controle em tempo hábil.

Resolução

Esse problema é corrigido nas seguintes atualizações cumulativas para o SQL Server:

Atualização cumulativa 5 para o SQL Server 2016 RTM

Atualização cumulativa 2 para o SQL Server 2016 SP1

Sobre atualizações cumulativas para o SQL Server

Cada nova atualização cumulativa do SQL Server contém todos os hotfixes e todas as correções de segurança incluídas na atualização cumulativa anterior. Confira as atualizações cumulativas mais recentes para o SQL Server:

Atualização cumulativa mais recente do SQL Server 2016

Status

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Referências

Saiba mais sobre a terminologia que a Microsoft usa para descrever atualizações de software.