KB4541385 - CORRECÇÃO: A inicialização do banco de dados pode falhar usando a propagação automática no SQL Server 2016

Aplica-se a
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Sintomas

Suponha que você use o Microsoft SQL Server 2016. Ao tentar inicializar vários bancos de dados em um AG (grupo de disponibilidade) SQL Server Always On usando a propagação automática, você percebe que a propagação para alguns bancos de dados pode falhar e precisa tentar novamente em uma ou mais réplicas secundárias.

Status

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Resolução

Esse problema é corrigido na seguinte atualização cumulativa para o SQL Server:

Sobre atualizações cumulativas para o SQL Server:

Cada nova atualização cumulativa do SQL Server contém todos os hotfixes e todas as correções de segurança incluídas na atualização cumulativa anterior. Confira as atualizações cumulativas mais recentes para o SQL Server:

Solução alternativa

Para contornar esse problema, você pode tentar novamente em uma ou mais réplicas secundárias, usar backup ou usar restauração para inicialização.

Referências

Saiba mais sobre a terminologia que a Microsoft usa para descrever atualizações de software.