Проблема
Предположим, что вы используете функцию групп доступности AlwaysOn в SQL Server 2017. Может произойти нарушение прав доступа и приостановка перемещения данных для баз данных в группе доступности. Кроме того, в журнале ошибок SQL Server могут появляться сообщения об ошибках, похожие на следующие:
DateTime spid# Группы доступности AlwaysOn Перемещение данных для базы данных "SSISDB" приостановлено по следующей причине: "system" (Source ID #; Исходная строка: '#'). Чтобы возобновить перемещение данных в базе данных, необходимо возобновить ее вручную. Сведения о том, как возобновить работу базы данных доступности, см. в книгах по SQL Server в Интернете.
Ошибка: 3313, Серьезность: 21, Состояние: 2.
DateTime spid# — во время повтора операции в базе данных SSISDB произошла ошибка с идентификатором записи журнала (638:319687:1). Как правило, конкретный сбой ранее регистрировался как ошибка в журнале ошибок операционной системы. Восстановите базу данных из полной резервной копии или восстановите базу данных.
Состояние
Корпорация Майкрософт подтвердила, что это проблема продуктов Microsoft, перечисленных в разделе «Относится к».
Решение
Эта проблема устранена в следующем накопительном пакете обновления для SQL Server:
Сведения о накопительных обновлениях для SQL Server:
Каждый новый накопительный пакет обновления для SQL Server содержит все исправления и исправления безопасности, которые входили в состав предыдущего накопительного пакета обновления. Ознакомьтесь с последними накопительными пакетами обновления для SQL Server:
Ссылки
Узнайте о терминологии, используемой корпорацией Майкрософт для описания обновлений программного обеспечения.