Tip: Zkuste použít novou funkci XLOOKUP, což je vylepšená verze funkce SVYHLEDAT, která funguje v libovolném směru a ve výchozím nastavení vrací přesné shody, což usnadňuje a usnadňuje používání než jeho předchůdce.

Funkce SVYHLEDAT se používá, když potřebujete najít věci v tabulce nebo oblasti po řádku. Můžete třeba vyhledat cenu automobilové části podle čísla dílu nebo najít jméno zaměstnance na základě JEHO ID zaměstnance.

V nejjednodušší podobě funkce SVYHLEDAT říká:

=SVYHLEDAT(Co chcete hledat, kde ho chcete hledat, číslo sloupce v oblasti obsahující hodnotu, která se má vrátit, vrátit přibližnou nebo přesnou shodu – označenou jako 1/PRAVDA nebo 0/NEPRAVDA).

Váš prohlížeč nepodporuje video.

Tip: Tajným kódem funkce SVYHLEDAT je uspořádání dat tak, aby hledaná hodnota (Ovoce) byla nalevo od vrácené hodnoty (Částka), kterou chcete najít.

Funkce SVYHLEDAT se používá k vyhledání hodnoty v tabulce.

Syntaxe 

SVYHLEDAT(hledat;tabulka;sloupec;[typ])

Příklady:

  • =SVYHLEDAT(A2;A10:C20;2;PRAVDA)

  • =SVYHLEDAT("Hernady";B2:E7;2;NEPRAVDA)

  • =SVYHLEDAT(A2;'Podrobnosti o klientovi'! A:F;3;NEPRAVDA)

Název argumentu

Popis

hledat    (povinné)

Hodnota, kterou chcete vyhledat. Hodnota, kterou chcete hledat, musí být v prvním sloupci oblasti buněk, kterou zadáte v table_array argumentu.

Pokud například matice tabulky přesahuje buňky B2:D7, musí lookup_value být ve sloupci B.

Hledat může být hodnota nebo odkaz na buňku.

tabulka    (povinné)

Oblast buněk, ve které bude funkce SVYHLEDAT hledat hodnotu hledat a ze které bude vracet hodnotu. Můžete použít pojmenovanou oblast nebo tabulku a místo odkazů na buňky můžete použít názvy v argumentu. 

První sloupec v oblasti buněk musí obsahovat lookup_value. Oblast buněk také musí obsahovat vrácenou hodnotu, kterou chcete najít.

Podívejte se, jak vybrat oblast v listu.

sloupec    (povinné)

Číslo sloupce (počínaje hodnotou 1 pro sloupec nejvíce vlevo table_array),který obsahuje vrácenou hodnotu.

typ    (volitelné)

Jedná se o logickou hodnotu, která určuje, jestli má funkce SVYHLEDAT najít přibližnou nebo přesnou hodnotu:

  • Přibližná shoda : Hodnota 1/PRAVDA předpokládá, že první sloupec v tabulce je seřazený číselně nebo abecedně a potom vyhledá nejbližší hodnotu. Tento způsob se použije jako výchozí, pokud žádný nezadáte. Například =SVYHLEDAT(90;A1:B100;2;PRAVDA).

  • Přesná shoda – 0/NEPRAVDA vyhledá přesnou hodnotu v prvním sloupci. Příklad: =SVYHLEDAT("Novák";A1:B100;2;NEPRAVDA).

Jak začít

K sestavení syntaxe pro funkci SVYHLEDAT budete potřebovat 4 informace:

  1. Hodnota, kterou chcete vyhledat, označovaná taky jako vyhledávací hodnota.

  2. Oblast, ve které se nachází vyhledávací hodnota. Mějte na paměti, že aby funkce SVYHLEDAT správně fungovala, měla by vyhledávací hodnota být vždycky v prvním sloupci oblasti. Pokud je vyhledávací hodnota třeba v buňce C2, měla by oblast začínat sloupcem C.

  3. Číslo sloupce v oblasti, ve kterém je hodnota, která se má vrátit. Pokud například jako oblast zadáte B2:D11, měli byste počítat B jako první sloupec, C jako druhý a tak dále.

  4. Volitelně můžete zadat PRAVDA v případě, že požadujete přibližnou shodu, nebo NEPRAVDA v případě, že požadujete přesnou shodu hodnoty, která se má vrátit. Pokud žádnou z těchto hodnot nezadáte, bude výchozí hodnotou PRAVDA, tedy přibližná shoda.

Teď dáme vše nahoře uvedené dohromady:

=SVYHLEDAT(vyhledávací hodnota, oblast obsahující vyhledávací hodnotu, číslo sloupce v oblasti obsahující vrácenou hodnotu, Přibližná shoda (PRAVDA) nebo Přesná shoda (NEPRAVDA)).

Příklad

Tady je několik příkladů funkce SVYHLEDAT:

Příklad 1

=SVYHLEDAT (B3;B2:E7;2;NEPRAVDA)

Funkce SVYHLEDAT hledá Fontana v prvním sloupci (sloupci B) v table_array B2:E7 a vrátí z druhého sloupce (sloupce C) table_array.  Funkce Nepravda vrátí přesnou shodu.

Příklad 2

=SVYHLEDAT (102;A2:C7;2;NEPRAVDA)

Funkce SVYHLEDAT hledá přesnou shodu (NEPRAVDA) příjmení 102 (lookup_value) ve druhém sloupci (sloupci B) v oblasti A2:C7 a vrátí Hodnotu Fontana.

Příklad 3

=KDYŽ(SVYHLEDAT(103;A1:E7;2;NEPRAVDA)="Souse";"Nachází se";"Nebyl nalezen")

Když zkontroluje, jestli funkce SVYHLEDAT vrátí sousu jako příjmení zaměstnance, který odpovídá 103 (lookup_value) v A1:E7 (table_array). Vzhledem k tomu, že příjmení odpovídající 103 je Leal, je podmínka KDYŽ nepravdivá a zobrazí se funkce Nenalehledno.

Příklad 4

=INT(YEARFRAC(DATUM(2014;6;30);SVYHLEDAT(105;A2:E7;5;FLASE);1))

Funkce SVYHLEDAT vyhledá datum narození zaměstnance odpovídající 109 (lookup_value) v oblasti A2:E7 (table_array) a vrátí hodnotu 04.3.1955. Potom funkce YEARFRAC odečte toto datum narození od 30. 6. 2014 a vrátí hodnotu, která se pak převede pomocí funkce INY na celé číslo 59.

Příklad 5

KDYŽ(ISNA(SVYHLEDAT(105;A2:E7;2;FLASE))=PRAVDA;"Zaměstnanec nebyl nalezen",SVYHLEDAT(105;A2:E7;2;NEPRAVDA))

Funkce KDYŽ zkontroluje, jestli funkce SVYHLEDAT vrátí hodnotu příjmení ze sloupce B pro hodnotu 105 (lookup_value). Pokud funkce SVYHLEDAT najde příjmení, zobrazí funkce KDYŽ příjmení, jinak funkce KDYŽ vrátí hodnotu Zaměstnanec nebyl nalezen. Funkce ISNA zajistí, že pokud funkce SVYHLEDAT vrátí hodnotu #N/A, bude chyba nahrazena příkazem Zaměstnanec nebyl nalezen, #N/A.



V tomto příkladu je vrácená hodnota Burke, což je příjmení odpovídající 105.

Pomocí funkce SVYHLEDAT můžete sloučit více tabulek do jedné, pokud má jedna z tabulek pole společná se všemi ostatními. To může být užitečné hlavně v případě, že potřebujete sdílet sešit s lidmi se staršími verzemi Excel, které nepodporují datové funkce s více tabulkami jako zdroji dat – sloučením zdrojů do jedné tabulky a změnou zdroje dat funkce dat na novou tabulku lze funkci dat použít ve starších verzích Excel (za předpokladu, že starší verze podporuje samotnou funkci dat).

List se sloupci, které používají funkce SVYHLEDAT k získání dat z jiných tabulek

Tady sloupce A-F a H mají hodnoty nebo vzorce, které používají jenom hodnoty na listu, a zbytek sloupců používá funkce SVYHLEDAT a hodnoty sloupce A (Kód klienta) a sloupce B (Attorney) k získání dat z jiných tabulek.

  1. Zkopírujte tabulku, která obsahuje společná pole, do nového listu a pojmete ji.

  2. Kliknutím na > Data Tools > Relationships (Relace) otevřete dialogové okno Manage Relationships (Spravovat relace).

    Dialogové okno Spravovat relace
  3. U každé uvedené relace si všimněte následujícího:

    • Pole, které provází tabulky (uvedené v závorkách v dialogovém okně). Toto je lookup_value pro vzorec SVYHLEDAT.

    • Název související vyhledávací tabulky Toto je table_array ve vzorci SVYHLEDAT.

    • Pole (sloupec) v související vyhledávací tabulce, které obsahuje data, která chcete mít v novém sloupci. Tyto informace se nezobrazí v dialogovém okně Spravovat relace – budete se muset podívat na související vyhledávací tabulku, abyste viděli, které pole chcete načíst. Chcete si poznamenat číslo sloupce (A=1) – toto je col_index_num ve vzorci.

  4. Pokud chcete přidat pole do nové tabulky, zadejte vzorec SVYHLEDAT do prvního prázdného sloupce pomocí informací, které jste shromáždili v kroku 3.

    V našem příkladu používá sloupec G attorney (lookup_value) k získání dat Sazby faktur ze čtvrtého sloupce(col_index_num = 4) z tabulky listu Attorneys, tblAttorneys (table_array), se vzorcem =SVYHLEDAT([@Attorney],tbl_Attorneys;4;NEPRAVDA).

    Vzorec může také použít odkaz na buňku a odkaz na oblast. V našem příkladu by to bylo =SVYHLEDAT(A2;'Právníci'! A:D;4;NEPRAVDA).

  5. Pokračujte v přidávání polí, dokud nemáte všechna pole, která potřebujete. Pokud se pokoušíte připravit sešit obsahující funkce dat, které používají více tabulek, změňte zdroj dat funkce dat na novou tabulku.

Problém

Co je špatně

Nesprávná vrácená hodnota

Pokud má argument Typ hodnotu PRAVDA nebo pokud se vynechá, první sloupec musí být seřazený abecedně nebo číselně. Pokud první sloupec seřazený není, může se vrátit neočekávaná hodnota. Buď první sloupec seřaďte, nebo použijte hodnotu NEPRAVDA pro přesnou shodu.

Chyba #NENÍ_K_DISPOZICI v buňce

  • Pokud se pro argument Typ používá hodnota PRAVDA, pak se v případě, že je hodnota v argumentu Hledat menší než nejmenší hodnota v prvním sloupci tabulky, zobrazí chybová hodnota #NENÍ_K_DISPOZICI.

  • Pokud se pro argument Typ používá hodnota NEPRAVDA, pak chybová hodnota #NENÍ_K_DISPOZICI vyjadřuje, že se nenašlo přesné číslo.

Další informace o opravách chyb #NENÍ_K_DISPOZICI ve funkci SVYHLEDAT najdete v tématu Oprava chyby #NENÍ_K_DISPOZICI u funkce SVYHLEDAT.

Chyba #ODKAZ! v buňce

Pokud col_index_num je větší než počet sloupců v matici tabulky,dostanete #REF! chybová hodnota.

Další informace o řešení #REF! chyby ve SVYHLEDAT najdete v tématu Oprava chyby #REF!..

Chyba #HODNOTA! v buňce

Pokud je table_array menší než 1, dostanete #VALUE! chybová hodnota.

Další informace o opravách chyb #HODNOTA! ve funkci SVYHLEDAT najdete v tématu Oprava chyby #HODNOTA! u funkce SVYHLEDAT.

Chyba #NÁZEV? v buňce

Chybová hodnota #NÁZEV? obvykle vyjadřuje, že ve vzorci chybí uvozovky. Když hledáte jméno, nezapomeňte ho ve vzorci uvést do uvozovek. Třeba jméno "Hernady" zadejte takto: =SVYHLEDAT("Hernady";B2:E7;2;NEPRAVDA).

Další informace najdete v článku Jak opravit chybu #NAME!..

Chyby #PRESAH! v buňce

Tato konkrétní #SPILL! Obvykle to znamená, že vzorec je závislý na implicitním průniku pro vyhledávací hodnotu a použití celého sloupce jako odkazu. Příklad: =SVYHLEDAT(A:A;A:C;2;NEPRAVDA). Tento problém můžete vyřešit ukotvením vyhledávacího odkazu pomocí operátoru @ takhle: =SVYHLEDAT(@A:A,A:C;2;NEPRAVDA). Můžete také použít tradiční metodu SVYHLEDAT a odkazovat na jednu buňku místo celého sloupce: =SVYHLEDAT(A2,A:C;2;NEPRAVDA).

Udělejte toto

Proč?

Používejte pro argument Typ absolutní odkazy.

Když budete používat absolutní odkazy, bude se ve vzorci, který vyplníte dolů do dalších buněk, vždycky hledat ve stejné oblasti.

Naučte se používat absolutní odkazy na buňky.

Neukládejte číselné hodnoty ani hodnoty kalendářních dat jako text.

Při hledání číselných nebo datových hodnot zkontrolujte, jestli nejsou údaje v prvním sloupci oblasti Tabulka uložené jako textové hodnoty. Jinak může funkce SVYHLEDAT vrátit nesprávnou nebo neočekávanou hodnotu.

Seřaďte si první sloupec.

Než pro argument typ funkce SVYHLEDAT nastavíte hodnotu PRAVDA, seřaďte si první sloupec v tabulce.

Používejte zástupné znaky.

Pokud range_lookup nepravda a lookup_value je text, můžete použít zástupné znaky (otazník (?) a hvězdička (*)– v lookup_value. Otazník zastupuje jeden libovolný znak. Hvězdička zastupuje jakoukoli posloupnost libovolných znaků. Pokud chcete vyhledat skutečný znak otazníku nebo hvězdičky, zadejte před ně vlnovku (~).

Například =SVYHLEDAT("Fontan?";B2:E7;2;NEPRAVDA) vyhledá všechny výskyty Fontana s posledním písmenem, které se může lišit.

Zkontrolujte, že v údajích nemáte něco špatně napsané.

Při hledání textových hodnot v prvním sloupci zkontrolujte, že údaje v prvním sloupci oblasti nemají mezery na začátku nebo konci textu, jestli se v nich konzistentně používají rovné uvozovky ( ' nebo " ) a oblé uvozovky ( ‘ nebo “) a jestli v nich nejsou netisknutelné znaky. V takových případech může funkce SVYHLEDAT vrátit nesprávnou nebo neočekávanou hodnotu.

Abyste dostali přesné výsledky, zkuste použít funkci VYČISTIT nebo funkci PROČISTIT k odebrání koncových mezer, které jsou v buňce za hodnotami tabulky.

Potřebujete další pomoc?

Kdykoliv se můžete zeptat některého odborníka v technické komunitě Excelu nebo získat podporu v komunitě pro odpovědi.

Viz také

Karta Rychlá reference: Obnovovací funkce SVYHLEDAT
Stručná referenční karta: Tipy pro řešení potíží s funkcí SVYHLEDAT
Jak opravit chybu #VALUE! ve funkci SVYHLEDAT
Jak opravit chybu #N/A ve funkci SVYHLEDAT
Přehled vzorců v Excel
Jak se vyhnout nefunkční vzorce
Zjišťování chyb ve vzorcích
Excel (abecední)
Excel (podle kategorie)
SVYHLEDAT (bezplatný náhled)

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou překladu?

Co ovlivnilo váš názor?

Máte další zpětnou vazbu? (Nepovinné)

Děkujeme za váš názor!

×