Tip: Zkuste použít novou funkci XLOOKUP, což je vylepšená verze funkce VLOOKUP, která funguje v libovolném směru a ve výchozím nastavení vrací přesné shody, což zaručuje snadnější a pohodlnější používání, než jeho předchůdce.

Funkci SVYHLEDAT použijte, když potřebujete najít položky v tabulce nebo oblasti po řádcích. Můžete například vyhledat cenu automobilového dílu podle čísla dílu nebo najít jméno zaměstnance na základě ID zaměstnance.

V nejjednodušší podobě funkce SVYHLEDAT říká:

=SVYHLEDAT(Co chcete vyhledat, kde ho chcete vyhledat, číslo sloupce v oblasti obsahující vrácenou hodnotu, vrátí přibližnou nebo přesnou shodu – označenou jako 1/TRUE nebo 0/FALSE).

Váš prohlížeč nepodporuje video. Nainstalujte si Microsoft Silverlight, Adobe Flash Player nebo Internet Explorer 9.

Tip: Tajným kódem funkce SVYHLEDAT je uspořádat data tak, aby hodnota, kterou hledáte (Ovoce), byla nalevo od vrácené hodnoty (částka), kterou chcete najít.

Funkce SVYHLEDAT se používá k vyhledání hodnoty v tabulce.

Syntaxe 

SVYHLEDAT(hledat;tabulka;sloupec;[typ])

Příklady:

  • =SVYHLEDAT(A2;A10:C20;2;PRAVDA)

  • =SVYHLEDAT("Hernady";B2:E7;2;NEPRAVDA)

  • =SVYHLEDAT(A2;'Podrobnosti o klientovi'! A:F,3,FALSE)

Název argumentu

Popis

hledat    (povinné)

Hodnota, kterou chcete vyhledat. Hodnota, kterou chcete vyhledat, musí být v prvním sloupci oblasti buněk, kterou zadáte v argumentu table_array .

Pokud například pole tabulky překlenuje buňky B2:D7, musí být vaše lookup_value ve sloupci B.

Hledat může být hodnota nebo odkaz na buňku.

tabulka    (povinné)

Oblast buněk, ve které bude funkce SVYHLEDAT hledat hodnotu hledat a ze které bude vracet hodnotu. Můžete použít pojmenovanou oblast nebo tabulku a místo odkazů na buňky můžete v argumentu použít názvy. 

První sloupec v oblasti buněk musí obsahovat lookup_value. Oblast buněk musí také obsahovat vrácenou hodnotu, kterou chcete najít.

Podívejte se, jak vybrat oblast v listu.

sloupec    (povinné)

Číslo sloupce (počínaje hodnotou 1 pro sloupec table_array nejvíce vlevo), který obsahuje návratovou hodnotu.

typ    (volitelné)

Jedná se o logickou hodnotu, která určuje, jestli má funkce SVYHLEDAT najít přibližnou nebo přesnou hodnotu:

  • Přibližná shoda – hodnota 1/TRUE předpokládá, že první sloupec v tabulce je seřazený číselně nebo abecedně a potom vyhledá nejbližší hodnotu. Tento způsob se použije jako výchozí, pokud žádný nezadáte. Například =SVYHLEDAT(90;A1:B100;2;PRAVDA).

  • Přesná shoda – 0/FALSE vyhledá přesnou hodnotu v prvním sloupci. Například =SVYHLEDAT("Novák";A1:B100;2;NEPRAVDA).

Jak začít

K sestavení syntaxe pro funkci SVYHLEDAT budete potřebovat 4 informace:

  1. Hodnota, kterou chcete vyhledat, označovaná taky jako vyhledávací hodnota.

  2. Oblast, ve které se nachází vyhledávací hodnota. Mějte na paměti, že aby funkce SVYHLEDAT správně fungovala, měla by vyhledávací hodnota být vždycky v prvním sloupci oblasti. Pokud je vyhledávací hodnota třeba v buňce C2, měla by oblast začínat sloupcem C.

  3. Číslo sloupce v oblasti, ve kterém je hodnota, která se má vrátit. Pokud například zadáte oblast B2:D11, měli byste počítat B jako první sloupec, C jako druhý a tak dále.

  4. Volitelně můžete zadat PRAVDA v případě, že požadujete přibližnou shodu, nebo NEPRAVDA v případě, že požadujete přesnou shodu hodnoty, která se má vrátit. Pokud žádnou z těchto hodnot nezadáte, bude výchozí hodnotou PRAVDA, tedy přibližná shoda.

Teď dáme vše nahoře uvedené dohromady:

=SVYHLEDAT(vyhledávací hodnota, oblast obsahující vyhledávací hodnotu, číslo sloupce v oblasti obsahující návratovou hodnotu, přibližná shoda (PRAVDA) nebo přesná shoda (NEPRAVDA)).

Příklady

Tady je několik příkladů funkce SVYHLEDAT:

Příklad 1

=SVYHLEDAT (B3;B2:E7;2;NEPRAVDA)

Funkce SVYHLEDAT vyhledá Fontana v prvním sloupci (sloupci B) v table_array B2:E7 a vrátí Položku z druhého sloupce (sloupce C) table_array.  Funkce False vrátí přesnou shodu.

Příklad 2

=SVYHLEDAT (102;A2:C7;2;NEPRAVDA)

Funkce SVYHLEDAT hledá přesnou shodu (FALSE) příjmení 102 (lookup_value) ve druhém sloupci (sloupci B) v oblasti A2:C7 a vrátí fontana.

Příklad 3

=KDYŽ(SVYHLEDAT(103;A1:E7;2;NEPRAVDA)="Souse";"Nachází se";"Nenalezeno")

KDYŽ zkontroluje, jestli funkce SVYHLEDAT vrátí Sousa jako příjmení zaměstnance, které odpovídá 103 (lookup_value) v A1:E7 (table_array). Vzhledem k tomu, že příjmení odpovídající 103 je Leal, podmínka KDYŽ je false a zobrazí se nenalezeno.

Příklad 4

=INT(YEARFRAC(DATE(2014;6;30);VLOOKUP(105;A2:E7;5;FLASE);1))

Funkce SVYHLEDAT vyhledá datum narození zaměstnance odpovídající 109 (lookup_value) v rozsahu A2:E7 (table_array) a vrátí hodnotu 03/04/1955. Funkce YEARFRAC pak odečte toto datum narození od 6. 2014 a vrátí hodnotu, která se pak převede funkcí INY na celé číslo 59.

Příklad 5

IF(ISNA(SVYHLEDAT(105;A2:E7;2;FLASE))=PRAVDA;"Zaměstnanec nebyl nalezen";SVYHLEDAT(105;A2:E7;2;NEPRAVDA))

Když zkontroluje, jestli funkce SVYHLEDAT vrátí hodnotu příjmení ze sloupce B pro hodnotu 105 (lookup_value). Pokud funkce SVYHLEDAT najde příjmení, funkce KDYŽ zobrazí příjmení, jinak funkce KDYŽ vrátí hodnotu Zaměstnanec nebyl nalezen. Funkce ISNA zajistí, že pokud funkce SVYHLEDAT vrátí #N/A, nahradí se místo #N/A chybou Zaměstnanec nenalezeno.



V tomto příkladu je vrácená hodnota Burke, což je příjmení odpovídající 105.

Pomocí funkce SVYHLEDAT můžete zkombinovat více tabulek do jedné, pokud má jedna z tabulek společná pole se všemi ostatními. To může být užitečné zejména v případě, že potřebujete sdílet sešit s lidmi, kteří mají starší verze Excel, které nepodporují datové funkce s více tabulkami jako zdroji dat . Když zkombinujete zdroje do jedné tabulky a změníte zdroj dat datové funkce na novou tabulku, můžete tuto funkci použít ve starších verzích Excel (za předpokladu, že starší verze podporuje samotnou datovou funkci).

List se sloupci, které k získání dat z jiných tabulek používají funkci SVYHLEDAT

Sloupce A-F a H mají hodnoty nebo vzorce, které používají pouze hodnoty na listu, a zbytek sloupců používá funkci SVYHLEDAT a hodnoty sloupce A (Klientský kód) a sloupec B (Attorney) k získání dat z jiných tabulek.

  1. Zkopírujte tabulku, která obsahuje společná pole, do nového listu a pojmenujte ji.

  2. Kliknutím na Data > Datové nástroje > Relace otevřete dialogové okno Správa relací.

    Dialogové okno Správa relací
  3. U každé uvedené relace mějte na paměti následující:

    • Pole, které propojuje tabulky (uvedené v závorkách v dialogovém okně). Toto je lookup_value vzorce SVYHLEDAT.

    • Název související vyhledávací tabulky. Toto je table_array ve vzorci SVYHLEDAT.

    • Pole (sloupec) v související vyhledávací tabulce obsahující požadovaná data v novém sloupci. Tyto informace se nezobrazují v dialogovém okně Správa relací – budete se muset podívat na související vyhledávací tabulku, abyste zjistili, které pole chcete načíst. Chcete si poznamenat číslo sloupce (A=1) – toto je col_index_num ve vzorci.

  4. Pokud chcete do nové tabulky přidat pole, zadejte vzorec SVYHLEDAT do prvního prázdného sloupce pomocí informací, které jste získali v kroku 3.

    V našem příkladu sloupec G používá advokáta ( lookup_value) k získání dat o vyúčtování ze čtvrtého sloupce (col_index_num = 4) z tabulky listu Advokáti, tblAttorneys ( table_array) se vzorcem =SVYHLEDAT([@Attorney],tbl_Attorneys;4;NEPRAVDA).

    Vzorec může také použít odkaz na buňku a odkaz na oblast. V našem příkladu by to bylo =SVYHLEDAT(A2,'Advokáti'! A:D,4;FALSE).

  5. Pokračujte v přidávání polí, dokud nebudete mít všechna pole, která potřebujete. Pokud se pokoušíte připravit sešit obsahující datové funkce, které používají více tabulek, změňte zdroj dat funkce dat na novou tabulku.

Problém

Co je špatně

Nesprávná vrácená hodnota

Pokud má argument Typ hodnotu PRAVDA nebo pokud se vynechá, první sloupec musí být seřazený abecedně nebo číselně. Pokud první sloupec seřazený není, může se vrátit neočekávaná hodnota. Buď první sloupec seřaďte, nebo použijte hodnotu NEPRAVDA pro přesnou shodu.

Chyba #NENÍ_K_DISPOZICI v buňce

  • Pokud se pro argument Typ používá hodnota PRAVDA, pak se v případě, že je hodnota v argumentu Hledat menší než nejmenší hodnota v prvním sloupci tabulky, zobrazí chybová hodnota #NENÍ_K_DISPOZICI.

  • Pokud se pro argument Typ používá hodnota NEPRAVDA, pak chybová hodnota #NENÍ_K_DISPOZICI vyjadřuje, že se nenašlo přesné číslo.

Další informace o opravách chyb #NENÍ_K_DISPOZICI ve funkci SVYHLEDAT najdete v tématu Oprava chyby #NENÍ_K_DISPOZICI u funkce SVYHLEDAT.

Chyba #ODKAZ! v buňce

Pokud je col_index_num větší než počet sloupců v tabulce, získáte #REF! chybovou hodnotu #HODNOTA!.

Další informace o řešení #REF! v nástroji SVYHLEDAT naleznete v tématu Oprava chyby #REF!..

Chyba #HODNOTA! v buňce

Pokud je table_array menší než 1, získáte #VALUE! chybovou hodnotu #HODNOTA!.

Další informace o opravách chyb #HODNOTA! ve funkci SVYHLEDAT najdete v tématu Oprava chyby #HODNOTA! u funkce SVYHLEDAT.

Chyba #NÁZEV? v buňce

Chybová hodnota #NÁZEV? obvykle vyjadřuje, že ve vzorci chybí uvozovky. Když hledáte jméno, nezapomeňte ho ve vzorci uvést do uvozovek. Třeba jméno "Hernady" zadejte takto: =SVYHLEDAT("Hernady";B2:E7;2;NEPRAVDA).

Další informace najdete v tématu Jak opravit chybu #NAME!..

Chyby #PRESAH! v buňce

Tato konkrétní chyba #SPILL! obvykle znamená, že vzorec spoléhá na implicitní průnik pro vyhledávací hodnotu a používá celý sloupec jako odkaz. Například =SVYHLEDAT(A:A;A:C;2;NEPRAVDA). Tento problém můžete vyřešit ukotvením vyhledávacího odkazu pomocí operátoru @ takto: =SVYHLEDAT(@A:A,A:C;2;NEPRAVDA). Alternativně můžete použít tradiční metodu SVYHLEDAT a místo celého sloupce odkazovat na jednu buňku: =SVYHLEDAT(A2;A:C;2;NEPRAVDA).

Udělejte toto

Proč?

Používejte pro argument Typ absolutní odkazy.

Když budete používat absolutní odkazy, bude se ve vzorci, který vyplníte dolů do dalších buněk, vždycky hledat ve stejné oblasti.

Naučte se používat absolutní odkazy na buňky.

Neukládejte číselné hodnoty ani hodnoty kalendářních dat jako text.

Při hledání číselných nebo datových hodnot zkontrolujte, jestli nejsou údaje v prvním sloupci oblasti Tabulka uložené jako textové hodnoty. Jinak může funkce SVYHLEDAT vrátit nesprávnou nebo neočekávanou hodnotu.

Seřaďte si první sloupec.

Než pro argument typ funkce SVYHLEDAT nastavíte hodnotu PRAVDA, seřaďte si první sloupec v tabulce.

Používejte zástupné znaky.

Pokud je range_lookup NEPRAVDA a lookup_value je text, můžete v lookup_value použít zástupné znaky – otazník (?) a hvězdička (*). Otazník zastupuje jeden libovolný znak. Hvězdička zastupuje jakoukoli posloupnost libovolných znaků. Pokud chcete vyhledat skutečný znak otazníku nebo hvězdičky, zadejte před ně vlnovku (~).

Například =SVYHLEDAT("Fontan?";B2:E7;2;NEPRAVDA) vyhledá všechny výskyty Fontana s posledním písmenem, které se může lišit.

Zkontrolujte, že v údajích nemáte něco špatně napsané.

Při hledání textových hodnot v prvním sloupci zkontrolujte, že údaje v prvním sloupci oblasti nemají mezery na začátku nebo konci textu, jestli se v nich konzistentně používají rovné uvozovky ( ' nebo " ) a oblé uvozovky ( ‘ nebo “) a jestli v nich nejsou netisknutelné znaky. V takových případech může funkce SVYHLEDAT vrátit nesprávnou nebo neočekávanou hodnotu.

Abyste dostali přesné výsledky, zkuste použít funkci VYČISTIT nebo funkci PROČISTIT k odebrání koncových mezer, které jsou v buňce za hodnotami tabulky.

Potřebujete další pomoc?

Kdykoliv se můžete zeptat některého odborníka v technické komunitě Excelu nebo získat podporu v komunitě pro odpovědi.

Viz také

Karta Rychlá reference: Aktualizační funkce
SVYHLEDAT Karta Rychlá reference: Tipy pro řešení potíží s funkcí SVYHLEDAT
Oprava chyby #VALUE! ve funkci SVYHLEDAT
Oprava chyby #N/A ve funkci
SVYHLEDAT Přehled vzorců v Excel
Jak se vyhnout nefunkčním vzorcům
Rozpoznat chyby ve vzorcích
Excel funkce (abecední)
Excel funkce (podle kategorie)
SVYHLEDAT (volný náhled)

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se systém Microsoft Office insiderům

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?

Děkujeme vám za zpětnou vazbu.

×