SVYHLEDAT (funkce)

Tip: Zkuste použít novou funkci XLOOKUP, vylepšenou verzi funkce SVYHLEDAT, která funguje libovolným směrem a ve výchozím nastavení vrací přesné shody, což usnadňuje a pohodlnější používání než její předchůdce.

Funkce SVYHLEDAT se používá, když potřebujete něco najít v tabulce nebo v oblasti buněk podle řádku. Můžete třeba vyhledat cenu automobilového dílu podle čísla dílu nebo najít jméno zaměstnance na základě JEHO ID zaměstnance.

Tip: Podívejte se na tato videa z YouTube od Microsoft Creators, ve které najdete další pomoc s funkcí SVYHLEDAT.

V nejjednodušší podobě funkce SVYHLEDAT říká:

=SVYHLEDAT(Co chcete hledat, kde ho chcete hledat, číslo sloupce v oblasti obsahující hodnotu, která se má vrátit, přibližnou nebo přesnou shodu – označenou jako 1/PRAVDA nebo 0/NEPRAVDA).

Váš prohlížeč nepodporuje video.

Tip: Tajnou funkcí SVYHLEDAT je uspořádat data tak, aby hodnota, kterou budete hledat (Ovoce), byla nalevo od návratové hodnoty (Amount), kterou chcete najít.

Funkce SVYHLEDAT se používá k vyhledání hodnoty v tabulce.

Syntaxe

SVYHLEDAT(hledat;tabulka;sloupec;[typ])

Příklady:

  • =SVYHLEDAT(A2;A10:C20;2;PRAVDA)

  • =SVYHLEDAT("Hernady";B2:E7;2;NEPRAVDA)

  • =SVYHLEDAT(A2;'Podrobnosti o klientovi'! A:F,3,FALSE)

Název argumentu

Popis

hledat    (povinné)

Hodnota, kterou chcete vyhledat. Hodnota, kterou chcete hledat, musí být v prvním sloupci oblasti buněk, kterou zadáte v argumentu table_array buněk.

Pokud například tabulka přesahuje oblast buněk B2:D7, musí být lookup_value buňka ve sloupci B.

Hledat může být hodnota nebo odkaz na buňku.

tabulka    (povinné)

Oblast buněk, ve které bude funkce SVYHLEDAT hledat hodnotu hledat a ze které bude vracet hodnotu. Můžete použít pojmenovanou oblast nebo tabulku a místo odkazů na buňky můžete v argumentu použít názvy. 

První sloupec v oblasti buněk musí obsahovat lookup_value. Oblast buněk taky musí obsahovat vrácenou hodnotu, kterou chcete najít.

Podívejte se, jak vybrat oblast v listu.

sloupec    (povinné)

Číslo sloupce (počínaje číslem 1 v levém horním sloupci sloupce table_array)obsahující hodnotu, která se má vrátit.

typ    (volitelné)

Jedná se o logickou hodnotu, která určuje, jestli má funkce SVYHLEDAT najít přibližnou nebo přesnou hodnotu:

  • Přibližná shoda - 1/PRAVDA předpokládá, že první sloupec v tabulce je seřazený číselně nebo abecedně, a vyhledá nejbližší hodnotu. Tento způsob se použije jako výchozí, pokud žádný nezadáte. Příklad: =SVYHLEDAT(90;A1:B100;2;PRAVDA).

  • Přesná shoda : 0/NEPRAVDA hledá přesnou hodnotu v prvním sloupci. Příklad: =SVYHLEDAT("Novák";A1:B100;2;NEPRAVDA).

Jak začít

K sestavení syntaxe pro funkci SVYHLEDAT budete potřebovat 4 informace:

  1. Hodnota, kterou chcete vyhledat, označovaná taky jako vyhledávací hodnota.

  2. Oblast, ve které se nachází vyhledávací hodnota. Mějte na paměti, že aby funkce SVYHLEDAT správně fungovala, měla by vyhledávací hodnota být vždycky v prvním sloupci oblasti. Pokud je vyhledávací hodnota třeba v buňce C2, měla by oblast začínat sloupcem C.

  3. Číslo sloupce v oblasti, ve kterém je hodnota, která se má vrátit. Pokud jako oblast zadáte třeba B2:D11, měli byste počítat B jako první sloupec, C jako druhý sloupec a tak dále.

  4. Volitelně můžete zadat PRAVDA v případě, že požadujete přibližnou shodu, nebo NEPRAVDA v případě, že požadujete přesnou shodu hodnoty, která se má vrátit. Pokud žádnou z těchto hodnot nezadáte, bude výchozí hodnotou PRAVDA, tedy přibližná shoda.

Teď dáme vše nahoře uvedené dohromady:

=SVYHLEDAT(vyhledávací hodnota; oblast obsahující vyhledávací hodnotu; číslo sloupce v oblasti obsahující hodnotu, která se má vrátit; přibližná shoda (PRAVDA) nebo přesná shoda (NEPRAVDA)).

Příklady

Tady je pár příkladů funkce SVYHLEDAT:

Příklad 1

Funkce SVYHLEDAT – příklad 1

Příklad 2

Funkce SVYHLEDAT – příklad 2

Příklad 3

Funkce SVYHLEDAT – příklad 3

Příklad 4

Funkce SVYHLEDAT – příklad 4

Příklad 5

Funkce SVYHLEDAT – příklad 5

Pomocí funkce SVYHLEDAT můžete zkombinovat několik tabulek do jedné, pokud jedna z tabulek obsahuje pole společná se všemi ostatními. To může být zvlášť užitečné, pokud potřebujete sdílet sešit s lidmi se staršími verzemi Excelu, které nepodporují funkce dat s více tabulkami jako zdroje dat – spojením zdrojů do jedné tabulky a změnou zdroje dat funkce dat na novou tabulku, je možné funkci dat použít ve starších verzích Excelu (za předpokladu, že starší verze podporuje samotnou funkci dat).

List se sloupci, které pomocí funkce SVYHLEDAT nachytá data z jiných tabulek

Tady sloupce A–F a H mají hodnoty nebo vzorce, které používají jenom hodnoty na listu, a ve zbývajících sloupcích se k získání dat z jiných tabulek používají funkce SVYHLEDAT a hodnoty sloupce A (klientský kód) a sloupce B (právní zástupce).

  1. Zkopírujte do nového listu tabulku se společnými poli a pojmnujte ji.

  2. Kliknutím na > Data Tools > Relationships (Relace) otevřete dialogové okno Spravovat relace.

    Dialogové okno Spravovat relace
  3. U každé uvedené relace si poznamenejte následující:

    • Pole, které tabulky protází (zobrazí se v závorkách v dialogovém okně). Toto je první lookup_value pro vzorec funkce SVYHLEDAT.

    • Název související vyhledávací tabulky. Toto je první table_array ve vzorci funkce SVYHLEDAT.

    • Pole (sloupec) v související vyhledávací tabulce, které obsahuje data, která chcete mít v novém sloupci. Tyto informace se nezobrazovat v dialogovém okně Spravovat relace – abyste viděli, které pole chcete načíst, budete se muset podívat na související vyhledávací tabulku. Chcete si poznamenat číslo sloupce (A=1) – toto je col_index_num ve vzorci.

  4. Pokud chcete do nové tabulky přidat pole, zadejte pomocí informací shromážděných v kroku 3 vzorec SVYHLEDAT do prvního prázdného sloupce.

    V našem příkladu používá sloupec G funkci Attorney (lookup_value)k získání dat sazby faktury ze čtvrtého sloupce(col_index_num = 4) z tabulky listu Attorneys, tblAttorneys (the table_array), se vzorcem =SVYHLEDAT([@Attorney],tbl_Attorneys,4,FALSE).

    Vzorec by taky mohl použít odkaz na buňku a odkaz na oblast. V našem příkladu by to byla funkce =SVYHLEDAT(A2;'Právníci'! A:D,4,FALSE).

  5. Pokračujte v přidávání polí, dokud nedosá budete mít všechna pole, která potřebujete. Pokud se pokoušíte připravit sešit obsahující funkce dat, které používají více tabulek, změňte zdroj dat funkce dat na novou tabulku.

Problém

Co je špatně

Nesprávná vrácená hodnota

Pokud má argument Typ hodnotu PRAVDA nebo pokud se vynechá, první sloupec musí být seřazený abecedně nebo číselně. Pokud první sloupec seřazený není, může se vrátit neočekávaná hodnota. Buď první sloupec seřaďte, nebo použijte hodnotu NEPRAVDA pro přesnou shodu.

Chyba #NENÍ_K_DISPOZICI v buňce

  • Pokud se pro argument Typ používá hodnota PRAVDA, pak se v případě, že je hodnota v argumentu Hledat menší než nejmenší hodnota v prvním sloupci tabulky, zobrazí chybová hodnota #NENÍ_K_DISPOZICI.

  • Pokud se pro argument Typ používá hodnota NEPRAVDA, pak chybová hodnota #NENÍ_K_DISPOZICI vyjadřuje, že se nenašlo přesné číslo.

Další informace o opravách chyb #NENÍ_K_DISPOZICI ve funkci SVYHLEDAT najdete v tématu Oprava chyby #NENÍ_K_DISPOZICI u funkce SVYHLEDAT.

Chyba #ODKAZ! v buňce

Pokud col_index_num větší než počet sloupců v matici tabulky,bude #REF! která označuje chybu.

Další informace o řešení #REF! ve funkce SVYHLEDAT, podívejte se, jak opravit chybu #REF!..

Chyba #HODNOTA! v buňce

Pokud table_array míň než 1, dostanete #VALUE! která označuje chybu.

Další informace o opravách chyb #HODNOTA! ve funkci SVYHLEDAT najdete v tématu Oprava chyby #HODNOTA! u funkce SVYHLEDAT.

Chyba #NÁZEV? v buňce

Chybová hodnota #NÁZEV? obvykle vyjadřuje, že ve vzorci chybí uvozovky. Když hledáte jméno, nezapomeňte ho ve vzorci uvést do uvozovek. Třeba jméno "Hernady" zadejte takto: =SVYHLEDAT("Hernady";B2:E7;2;NEPRAVDA).

Další informace najdete v článku Oprava chyby #NAME!..

Chyby #PRESAH! v buňce

Tato konkrétní #SPILL! obvykle znamená, že vzorec spoléhá na implicitní průnik vyhledávací hodnoty a jako odkaz používá celý sloupec. Příklad: =SVYHLEDAT(A:A;A:C;2;NEPRAVDA). Problém můžete vyřešit ukotvení vyhledávacího odkazu pomocí operátoru @: =SVYHLEDAT( @A:A,A:C,2,NEPRAVDA). Můžete také použít tradiční metodu SVYHLEDAT a odkazovat na jednu buňku místo celéhosloupce: =SVYHLEDAT( A2;A:C;2;NEPRAVDA).

Udělejte toto

Proč?

Používejte pro argument Typ absolutní odkazy.

Když budete používat absolutní odkazy, bude se ve vzorci, který vyplníte dolů do dalších buněk, vždycky hledat ve stejné oblasti.

Naučte se používat absolutní odkazy na buňky.

Neukládejte číselné hodnoty ani hodnoty kalendářních dat jako text.

Při hledání číselných nebo datových hodnot zkontrolujte, jestli nejsou údaje v prvním sloupci oblasti Tabulka uložené jako textové hodnoty. Jinak může funkce SVYHLEDAT vrátit nesprávnou nebo neočekávanou hodnotu.

Seřaďte si první sloupec.

Než pro argument typ funkce SVYHLEDAT nastavíte hodnotu PRAVDA, seřaďte si první sloupec v tabulce.

Používejte zástupné znaky.

Pokud range_lookup NEPRAVDA a lookup_value text, můžete zástupné znaky – otazník (?) a hvězdička (*) použít v lookup_value. Otazník zastupuje jeden libovolný znak. Hvězdička zastupuje jakoukoli posloupnost libovolných znaků. Pokud chcete vyhledat skutečný znak otazníku nebo hvězdičky, zadejte před ně vlnovku (~).

Třeba funkce =SVYHLEDAT("Fontan?";B2:E7;2;NEPRAVDA) vyhledá všechny výskyty Fontan s posledním písmenem, které se může lišit.

Zkontrolujte, že v údajích nemáte něco špatně napsané.

Při hledání textových hodnot v prvním sloupci zkontrolujte, že údaje v prvním sloupci oblasti nemají mezery na začátku nebo konci textu, jestli se v nich konzistentně používají rovné uvozovky ( ' nebo " ) a oblé uvozovky ( ‘ nebo “) a jestli v nich nejsou netisknutelné znaky. V takových případech může funkce SVYHLEDAT vrátit nesprávnou nebo neočekávanou hodnotu.

Abyste dostali přesné výsledky, zkuste použít funkci VYČISTIT nebo funkci PROČISTIT k odebrání koncových mezer, které jsou v buňce za hodnotami tabulky.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení ve fóru Excel User Voice.

Viz také

Karta Rychlá reference: Funkce SVYHLEDAT – aktualizace
Karta Rychlá reference: Funkce SVYHLEDAT – tipy pro odstraňování potíží
YouTube: Videa funkce SVYHLEDAT od Microsoft Creators
Oprava chyby #VALUE! u funkce SVYHLEDAT
Oprava chyby #N A u funkce SVYHLEDAT
Přehled vzorců v Excelu
Jak se vyhnout nefunkčním vzorci
Zjišťování chyb ve vzorcích
Funkce Excelu (podle abecedy)
Funkce Excelu (podle kategorie)
FUNKCE SVYHLEDAT (volná verze Preview)

Potřebujete další pomoc?

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×