I dette emne beskrives de mest almindelige årsager til, at fejlen #VÆRDI! opstår i funktionerne SUM.HVIS og SUM.HVISER, og hvordan du kan rette dem.

Problem: Formlen henviser til celler i en lukket projektmappe

Funktionerne SUM.HVIS/SUM.HVISER, der refererer til en celle eller et område i en lukket projektmappe, resulterer i en #VALUE! som fejl.

Bemærk: Dette er et kendt problem med flere andre funktioner Excel f.eks. TÆL.HVIS, TÆL.HVISER, ANTAL.BLANKE, for blot at nævne nogle få. Se, at funktionerne SUM.HVIS, TÆL.HVIS og ANTAL.BLANKE returnerer "#VALUE!" Fejl for at få flere oplysninger.

Løsning: Åbn projektmappen, der er angivet i formlen, og tryk på F9 for at opdatere formlen.

Du kan løse dette problem ved at bruge funktionerne SUM og IF sammen i en matrixformel. Se, at funktionerne SUM.HVIS, TÆL.HVIS og ANTAL.BLANKE returnerer #VALUE!. for at få flere oplysninger.

Problem: Kriteriestrengen er på mere end 255 tegn

Funktionen SUM.HVIS/SUM.HVISER returnerer forkerte resultater, når du bruger den til at matche strenge på mere end 255 tegn.

Løsning: Afkort strengen, hvis det er muligt. Hvis du ikke kan forkorte strengen, skal du bruge funktionen SAMMENKÆDE eller og-tegnet (&) til at opdele værdi i flere strenge. For eksempel:

=SUM.HVIS(B2:B12,"lang streng"&"en anden lang streng")

Problem: I SUM.HVISER er argumentet kriterieområde ikke i overensstemmelse med argumentet sumområde.

Områdeargumenterne skal altid være ens i SUM.HVISER. Det betyder, at argumenterne kriterieområde og sumområde skal indeholde samme antal rækker og kolonner.

I følgende eksempel skal formlen returnere summen af det daglige salg af æbler i Bellevue. Argumentet sum_range (C2:C10) svarer dog ikke til det samme antal rækker og kolonner i criteria_range-argumenterne (A2:A12 & B2:B12). Hvis du bruger syntaksen =SUM.HVISER(C2:C10,A2:A12,A14,B2:B12,B14), bliver #VALUE! som fejl.

Den forkerte formel er =SUM.HVIS(C2:C10,A2:A12,A14,B2:B12,B14), hvor C2:C10 skal være C2:C12

Løsning: I dette eksempel skal du ændre sumområde til C2:C12 og prøve formlen igen.

Bemærk!:  SUM.HVIS kan bruge forskellige størrelsesintervaller.

Har du et bestemt spørgsmål til en funktion?

Stil et spørgsmål i Excel-communityforummet

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community eller få support i Answers-forummet

Se også

Rette fejlen #VÆRDI! fejl

Funktionen SUM.HVIS

Funktionen SUM.HVISER

Videoer med funktionen Avanceret HVIS

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Find fejl i formler

Alle Excel-funktioner (alfabetisk)

Alle Excel-funktioner (efter kategori)

Har du brug for mere hjælp?

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Deltag i Microsoft Office Insiders

Var disse oplysninger nyttige?

Hvor tilfreds er du med kvaliteten af sproget?
Hvad påvirkede din oplevelse?

Tak for din feedback!

×