EINFÜHRUNG
In diesem Artikel werden die Fehler aufgeführt, die in Microsoft SQL Server 2008 R2 Service Pack 1 (SP1) behoben wurden.
Notizen
- Andere Fixes, die nicht dokumentiert sind, sind möglicherweise im Service Pack enthalten.
- Dieser Artikel wird aktualisiert, sobald weitere Artikel verfügbar sind.
Weitere Informationen zum Beziehen von Service Packs für SQL Server 2008 R2 finden Sie im folgenden Artikel der Microsoft Knowledge Base:
2527041 Installieren des neuesten Service Packs für SQL Server 2008 R2
Weitere Informationen
Zusätzlich zu den in diesem Artikel aufgelisteten Updates enthält SQL Server 2008 R2 SP1 die Hotfixes, die im kumulativen Update 1 bis zum kumulativen Update 6 für SQL Server 2008 R2 enthalten waren. Dieses Service Pack enthält auch alle Sicherheitsupdates, die bis Juli 2011 veröffentlicht wurden.
Weitere Informationen zu den kumulativen Updatepaketen, die für SQL Server 2008 R2 verfügbar sind, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
981356 SQL Server 2008 R2-Builds, die nach der Freigabe von SQL Server 2008 R2 veröffentlicht wurden
Fehlerbehebungen in diesem Service Pack
Weitere Informationen zu den in SQL Server 2008 R2 SP1 behobenen Fehlern finden Sie in den folgenden Artikeln der Microsoft Knowledge Base.
| VSTS-Fehlernummer | KB-Artikelnummer | Beschreibung |
|---|---|---|
| 657377 | 949775 | Der Zielserver kann keinen Multiserverauftrag vom Master Server herunterladen, wenn auf dem Zielserver eine deutsche oder eine französische Version von SQL Server 2005 ausgeführt wird |
| 657404 | 2216478 | Fehlermeldung beim Ausführen von Get-Command in einer PowerShell Version 2-Umgebung auf einem Server unter SQL Server 2008: "Objektverweis nicht auf eine instance eines Objekts festgelegt" |
| 649451 | 2216485 | FIX: Der Ressourcenmonitor tritt auf einem Server mit SQL Server 2008 in eine Bedingung ohne Rendite ein |
| 649479 | 2216489 | Concern for 2008 SP2 [SQL Server Destination [19]] Fehler: SSIS-Masseneinfügung kann nicht für das Einfügen von Daten vorbereitet werden |
| 649504 | 2216497 | FIX: Geometrie-Polygon-Datentypen mit inneren Ringen im Spatial Storage geben durch verschiedene geometrische Operationen falsche Daten zurück |
| 649529 | 2216501 | FIX: Multiserveraufträge werden nicht von SQL Server 2000 in der MSX-Rolle auf SQL Server 2008 in der TSX-Rolle heruntergeladen |
| 649457 | 2448971 | UPDATE: Die Sperren einer Tabelle werden nicht eskaliert, wenn Sie viele Zeilen in eine Tabelle in SQL Server 2008 einfügen |
| 628428 | 2463682 | FIX: Auf eine Datenbank, die für Transparent Data Encryption aktiviert ist, kann möglicherweise nicht mehr zugegriffen werden, wenn das Zertifikat, das zum Verschlüsseln des Datenbankverschlüsselungsschlüssels verwendet wird, gelöscht wird. |
| 625028 | 2494517 | FIX: Ein versteckter Textfeldwert, auf den in der Tablix-Kopfzeile verwiesen wird, wird nur auf der ersten Seite angezeigt, nachdem Sie einen Bericht in einen harten Seitenumbruch-Renderer exportiert haben |
| 447613 | 2515006 | DataSet-Filter, die während der SharedDataSet- oder Parameterverarbeitung angewendet werden, verwenden falsche Sortierungseinstellungen |
| 697406 | 2525273 | FIX: Ein Clusteringmodell, das den K-Means-Algorithmus verwendet, generiert unterschiedliche Ergebnisse, die von PredictOnly-Spalten in SQL Server 2008 R2 Analysis Services beeinflusst werden |
| 649480 | 2216491 | Das Hilfsprogramm SQL Dumper kann auf einem SQL Server 2008- oder SQL Server 2008 R2-Failovercluster auf einer Advanced/Enterprise-Failoverclusterinstallation keine Fehlerabbilddateien generieren |
| 649339 | 2216460 | Fehlermeldung beim Versuch, ein Projekt in SQL Server 2008 oder SQL Server 2008 R2 zu öffnen: "Die Manifestdefinition der gefundenen Assembly stimmt nicht mit dem Assemblyverweis überein" |
| 405512 | 2105809 | Beim Umschalten vom verbundenen Modus zum lokalen Modus wird die Fehlermeldung "ReportServer-Dienst auf dem Computer <Computername> kann nicht beendet werden" angezeigt |
| 405514 | 981588 | Sie erhalten eine Fehlermeldung, wenn Sie versuchen, nach dem Erstellen einer SharePoint-Anspruchswebsite direkt zum Berichtsserver SSRS 2008 R2 zu navigieren |
| 665971 | 2546901 | FIX: Wenn Sie eine parallele Abfrage, die eine Rangfolgefunktion in SQL Server 2005, SQL Server 2008 oder SQL Server 2008 R2 verwendet, auf einem Computer mit 8 oder mehr CPUs ausführen |
| 650006 | 2563828 | Assert in function = Microsoft.ReportingServices.ReportProcessing.ParameterBase.Cast file = line = 0 expression = Unbehandelte verwaltete Ausnahme: Type = System.InvalidCastException, Message = Objekt vom Typ 'System.Boolean' kann nicht in 'Syste. |
| 689073 | 2531482 | BEHEBUNG: Das IntelliSense-Feature in SSMS 2008 R2 funktioniert nach der Installation von Visual Studio 2010 SP1 möglicherweise nicht mehr |
| 649856 | 2584903 | FIX: Das Löschen von Daten aus der MDW-Datenbank in SQL Server 2008 R2 dauert lange. |
Zusätzliche Korrekturen in diesem Service Pack
Lösungen für die folgenden Probleme sind auch in SQL Server 2008 R2 SP1 enthalten.
| ID | Beschreibung |
|---|---|
| 418521 | Der HTML-Renderer löst keine ArgumentOutOfRangeException-Ausnahme mehr aus, wenn für einen Bericht die ConsumeContainerWhitespace-Eigenschaft auf TRUE festgelegt ist und ein horizontaler Leerraum zum Ausfüllen verfügbar ist. |
| 346804 | FIX: Die "FORCESEEK"-Indexhinweissyntax akzeptiert jetzt optionale Parameter. Ein neuer FORCESCAN-Abfragehinweis wird hinzugefügt. Weitere Informationen finden Sie unter "Abfragehinweise (Transact-SQL)" (http://msdn.microsoft.com/en-us/library/ms181714.aspx). |
| 405562 | Verbindungszeichenfolgen wie 'server="tcp:"' und 'server="np:"' werden in SQL Server Native Client 2008 unterstützt, um Verbindungen mit der lokalen Instance herzustellen. Mit diesem Fix funktionieren diese Verbindungszeichenfolgen jetzt in SQL Server Native Client 2008 R2 und ermöglichen Verbindungen mit der lokalen Instance. |
| 447996 | Ein Problem bei der Logiküberprüfung tritt nicht mehr auf, wenn eine partitionierte Spalte einer indizierten Sicht mit der partitionierten Spalte der partitionierten Basistabelle übereinstimmt. Das Wechseln von "Tabellen ändern" ist in nicht partitionsausgerichteten indizierten Sichten nicht mehr aktiviert. |
| 471571 | Verwenden von SQL 10.5 BIDS zum Bereitstellen von Berichtsteilen in einem SQL Server 2008 R2 (und höheren Versionen) Der Berichtsserver schlägt nicht mehr fehl oder generiert eine SQL-Versionsverwaltungsfehlermeldung. |
| 512199 | Die Zeitstempel sind jetzt korrekt, wenn erweiterte Ereignisse oder SQL-Überwachungsdateien auf einem anderen Computer als demjenigen gelesen werden, der die Datei erstellt hat. Zeitstempel sind nun auch nach einem Server-Neustart korrekt. |
| 528501 | Rendern eines Berichts im synchronen Anzeigemodus mithilfe von Reporting Services 2008 R2-Webparts sind jetzt sichtbar, wenn der Bericht Leerzeichen im Berichtsnamen enthält. Es wird keine StreamNotFound-Fehlermeldung mehr generiert. |
| 538455 | Wenn Sie HTML anzeigen, indem Sie die DeviceInfo-Einstellung "StyleStream" auf TRUE festgelegt haben, gehen die Stileinstellungen nicht mehr in Textfeldern oder im Text verloren, wenn Aktionen definiert sind. |
| 540725 | Für die Engine und die Analysis Services werden zwei neue Ablaufverfolgungsvorlagendateien generiert. Dadurch kann Profiler alle Ereignisse und Spalten sowohl für das Modul als auch für die Analysis Services anzeigen. |
| 550635 | FIX: Falsche Textberichterstattung, wenn der SP 2010 Health Analyzer eine Fehlermeldung über Analysis Services zurückgibt, die im VertiPaq-Modus ausgeführt werden. |
| 550947 | In einem Tablix-Berichtselement mit 20 oder mehr Zeilen, die geschachtelte Containerberichtselemente (Rechteck und Tablix) enthalten, reagiert die BIDS-Shell nicht mehr, wenn Sie eine neue Zeile über oder unter einem Tablix-Element einfügen. |
| 555701 | Die Meldung "Außerhalb der Reihenfolge" verursacht beim Starten des DBM-Objekts keinen Zugriffsverletzungsfehler mehr. |
| 617987 | Die Installation des neuen Servers meldet nicht mehr, dass bei der Installation der BI Appliance kein Secure Store master key generiert wird. (Die Meldung wurde generiert, obwohl die Installation erfolgreich war.) |
| 623819 | Ein Problem wurde behoben, bei dem eine Fehlermeldung angezeigt wurde, wenn der Abfrageoptimierer für einige Abfragen für partitionierte Sichten keinen Plan erstellen konnte. Dies wird im Microsoft Connect-Problem 620614 beschrieben. Der Fix befindet sich unter einem Traceflag (siehe KB-Artikel 974006). |
| 624909 | Die Leistung verringert sich nicht mehr, wenn Sie den Berichts-Viewer verwenden oder in HTML anzeigen, wenn Sie mehrere Webparts auf einer einzelnen SharePoint-Seite haben. |
| 624951 | Sie erhalten nicht mehr die Ausnahme "Fehler beim Entladen von appdomain", wenn Sie eine WPF-Anwendung schließen, die das ReportViewer-Steuerelement enthält. |
| 626205 | Analysis Services kann keinen lokalen Cube aus einem Servercube erstellen, der Dimensionselemente aufweist, die mit dem Unknown-Element verknüpft sind. |
| 626243 | PowerPivot wird nun erfolgreich in einer vorhandenen Farm installiert, wenn freigegebene SQL Server-Komponenten an einem nicht standardmäßigen Speicherort installiert sind. |
| 629973 | BIDS und Report Builder 3 stürzen nicht mehr ab, wenn Sie folgende Aktionen ausführen: Ziehen Sie eine Zelle in einer Tabelle am Rahmen, wechseln Sie in den Modus "Berichtselement verschieben", verschieben Sie das Objekt außerhalb der Tabelle, und drücken Sie dann ESC, während Sie klicken und die Maustaste gedrückt halten. |
| 636999 | Wenn der Aktualisierungsratgeber eine Ablaufverfolgungsdatei nicht scannen kann, kann der Aktualisierungsratgeber dem Benutzer nun eine aussagekräftige Fehlermeldung anzeigen. |
| 639182 | Das Anmeldedialogfeld für Report Builder 3.0. Dies wird aufgerufen, wenn die Formularauthentifizierung für SSRS verwendet wird, und wird nicht mehr durch das modale Dialogfeld "Assistent für neue Berichte" verdeckt. (Aufgrund des Problems wissen die Benutzer möglicherweise nicht, dass eine Anmeldung angefordert wird.) |
| 643961 | Alle spezifischen Benutzerkontooptionen funktionieren jetzt nach Datenquellenzeitplänen. |
| 646473 | Eine Anwendung, die in der Umgebung von .NET Framework 4.0 entworfen wurde, schlägt nicht mehr fehl, wenn RSP die zugehörigen Konfigurationsinformationen nicht finden kann. Die Informationen werden jetzt sowohl in den .NET Framework 4.0- als auch in den .NET Framework 3.5-Konfigurationsdateien durchsucht. |
| 658405 | Sie können jetzt benutzerdefinierte Berichte mithilfe der ODC-Datei im IT-Verwaltungsdashboard erstellen. |
| 665971 | Übertragungen von Parallelitätsoperatoren haben jetzt die richtige Reihenfolge. Der Optimierer kann nun einen suboptimalen Plan auswählen. Daher erfordert dieser Fix ein traceflag. Um diesen Fix zu verwenden, müssen Sie das Traceflag 4134 aktivieren. |
| 674357 | Für den Moduldienst und für den Analysedienst werden jetzt zwei neue Ablaufverfolgungsvorlagendateien generiert. Dadurch stellen Sie sicher, dass Profiler alle Ereignisse und Spalten für beide Dienste anzeigen kann. |
| 679035 | Ein kleiner Tippfehler auf der Seite "Central Admin" wurde behoben. |
| 684435 | StringCchPrintf_l erwartet die Größe des Zielpuffers in Zeichen. Die Größe wurde in Bytes übergeben. Daher wurde der OACR-Fehler – BUFFER_OVERFLOW ausgelöst. Der Code wurde korrigiert, indem die richtige Länge übergeben wurde. |
| 649475 | Sammlungssätze funktionieren beim Erfassen von Leistungsindikatoren in einem Cluster nicht ordnungsgemäß, wenn der Name der SQL-Instance mit dem Namen des virtuellen Netzwerks identisch ist. |
| 649357 | In einer bestimmten Datenbank kann die Verwendung eines Serverzeigers, der für eine SELECT-Anweisung deklariert ist, die eine beliebige Systemsicht enthält, zu falschen Ergebnissen führen, nachdem diese Datenbank angefügt und wieder angefügt wurde. |
| 649391 | DBCC-Beschädigungsfehler treten bei SQL Server 2008 R2-Sortierungen auf, wenn Zeichenfolgen mit Jamo-Sequenzen verwendet werden, die dem japanischen verlängerten Vorzeichen folgen. |
| 657399 | In SQL Server Management Studio und in SQL Server Reporting Services wird eine falsche Versionsnummer angezeigt. Dies führt zu Verwirrung, da die angezeigte Nummer nicht von der RTM-Versionsnummer nach einem Upgrade abweicht. |
| 649476 | FIX: Verbesserte und zusätzliche Informationen werden für InvalidReportParameterException in der ausführlichen Ausgabe protokolliert, wenn bestimmte Bedingungen während der Parameterverarbeitung auftreten. |
| 649557 | BEHEBUNG: Ein Problem mit der Barrierefreiheit, das auftritt, weil der Microsoft Active Accessibility-Name "Symbol" gleich Null ist. Namen für Microsoft Active Accessibility werden aktualisiert und sind jetzt auffindbar. |
| 649447 | ReportBuilder 2.0 ClickOnce zeigt beim Start einen leeren Bericht an, wenn ein Benutzer den Bericht mithilfe von ReportBuilder 2.0 über eine SharePoint 12-Website bearbeitet. |
| 649575 | MSAA-Namen für das Dialogfeld Eigenschaften der Radialskala sind falsch und nicht barrierefrei. |
| 519534 | Die Verwendung von Tabellenwertparametern für LOB-Spalten kann zu einer Zugriffsverletzung auf dem Server führen. |
| 645824 | Während der Ausführung von erweiterten gespeicherten Prozeduren unter Bedingungen mit hoher Belastung kann ein Zugriffsverletzungsfehler auftreten. |
| 649559 | FIX: Die Leistung der Indexerstellung durch DDL-Anweisungen für Tabellen mit vielen Partitionen und ohne Daten wurde verbessert. Zuvor nahm die für diesen Prozess erforderliche Zeit in einer geometrischen Abfolge mit der Anzahl der Partitionen zu. Die benötigte Zeit erhöht sich nun in einer linearen Progression. |
| 649537, 448009 | Unter bestimmten Bedingungen kann der Name der partitionierten Spalte in Fehlermeldung 11405 falsch sein. Dadurch wird ein falscher Spaltenname gedruckt. |
| 649530 | Eine sekundäre Ausnahme kann auftreten, wenn Analysis Services eine Watson-Abbilddatei generiert. Dies gilt unabhängig davon, ob die Watson-Abbilddatei aufgrund einer tatsächlichen Ausnahme oder aufgrund einer expliziten Anforderung zum Sichern bestimmter Fehler generiert wird. Wenn die sekundäre Ausnahme auftritt, kann der Server eine unendliche Rekursion erfahren. Dadurch werden viele Sicherungsdateien generiert und der Server wird heruntergefahren. |
| 649524 | Wenn ein Benutzer einen benutzerdefinierten Typ und eine Tabellenwertfunktion in derselben Transaktion erstellt und die Funktion über eine Rückgabetabelle verfügt, die eine Spalte des benutzerdefinierten Typs enthält, tritt ein automatischer Deadlock auf. Darüber hinaus wird die Verbindung, die versucht, diese Vorgänge auszuführen, beendet. |
| 649532 | Ein räumlicher Index kann nicht sicher in einer Tabelle erstellt werden, die CELL_ID, CELL_ATTRIBUTES oder SRID für Spaltennamen verwendet. |
| 657405 | SQL Server generiert manchmal die Fehlermeldung "Es ist nicht genügend Systemspeicher im Ressourcenpool 'intern', um diese Abfrage auszuführen". Diese Situation ist häufig vermeidbar. |
| 649434 | Wenn Parameter, die von der SQLBindParameter-Funktion gebunden werden, eine Länge von SQL_DATA_AT_EXEC angeben, verursacht der ODC-Treiber SQL Server 2008 R2 Native Client eine Zugriffsverletzung, wenn die SQLPutData-Funktion eine Länge von SQL_NULL_DATA angibt, wenn der Parameterwert zur Ausführung angegeben wird. |
| 512170 | Wenn MARS verwendet wird, zeigt die sys.dm_os_tasks-Ansicht denselben Wert in der Spalte request_id für alle Aufgaben an, anstatt den korrekten Wert zu melden, der jedem Vorgang zugeordnet ist. |
| 649425 | In der Ansicht sys.dm_os_wait_stats werden duplizierte Zeilen für den Wartetyp VERSCHIEDENES angezeigt. Dies kann zu Problemen bei Überwachungstools führen. |
| 649346 | Das asynchrone Bucketingziel zeigt falsche Wert-Zeichenfolgen-Paare für zugeordnete Felder an, wenn es mit den in dm_xe_map_values verfügbaren Informationen verglichen wird. |
| 649340 | FIX: Die syscolpars-Systembasistabelle zeigte doppelte Zeilen an. Dieser Fix unterscheidet sie durch Hinzufügen der Prozedurnummer im DBCC-Prüfkatalog. |
| 649427 | BEHEBUNG: Ein neuer Fehlercode (6257) wird zurückgegeben, wenn ein Benutzer versucht, eine CLR-Assembly zu registrieren, die für eine neuere Laufzeit, z. B. CLR v4, erstellt wurde. Die vorherige Fehlermeldung (Code 6218) war verwirrend und gab nicht das eigentliche Problem an. Sehen Sie sich den Fehler an, um detaillierte Informationen zu erhalten. |
| 649433 | Ein Grenzfall fügt einen Identitätswert außerhalb des aktuellen Bereichs in den Modus "identity_insert TABLE_NAME aktivieren" ein. Dieses Problem tritt auch bei Backup-/Wiederherstellungsvorgängen auf. |
| 649450 | Beim Abrufen von Spaltenmetadaten werden falsche Spaltensortierungsinformationen BCP.exe zurückgegeben. |
| 649527 | Die Verwendung einer PeriodsToDate-Funktion mit einem Null-Memberparameter kann zu einem Fehler vom Typ "Unerwartete Ausnahme" führen. |
| 649341 | Wenn die Abfrage über einen Filter verfügt, der auf eine Spalte in der sys.dm_server_audit_status Ansicht verweist, wird der Filter ignoriert, und alle Zeilen werden von sys.dm_server_audit_status zurückgegeben. |
| 629570 | Fehler 955 tritt auf, wenn Benutzer versuchen, das Verwaltungs-Data Warehouse zu konfigurieren, wenn sie Datenbanken auf ihrem Server haben, die nicht online sind. |
| 649374 | Der Ringpuffer zeigt unvollständige Ereignisdaten (von dm_xe_session_targets ausgegebene Ereignisse) an, wenn die Größenbeschränkung für die XML-Ausgabe erreicht ist. |
| 677560 | Behebt ein Problem, bei dem eine Remoteabfrage den Fehlercode 7359 in SQL Server 2008 R2 liefert. Dieses Problem tritt auf, wenn eine benutzerdefinierte Funktion ein Synonym für eine verknüpfte Tabelle verwendet, ein Ausführungsplan für die benutzerdefinierte Funktion auf dem lokalen Server vorhanden ist und eine Schemaversion der verknüpften Tabelle auf einem Remoteserver aktualisiert wird. |
| 562310 | Behebt den Fehler "Read AV in FullXactImpBase::GetXdes xact.cpp @ 2536", der auftritt, wenn eine Datenbank db1 erstellt wird, eine Abfrage für db1 zwischengespeichert wird, dann db1 gelöscht wird, eine zweite Datenbank erstellt wird, dann db1 erneut erstellt wird und die zwischengespeicherte Abfrage erneut ausgeführt wird. |
| 623804 | Behebt ein falsches Ergebnis von Abfragen, die innerhalb von Triggertexten ausgeführt werden. Das Szenario erfordert einen eindeutigen gefilterten Index. Der Trigger muss eine Abfrage enthalten, die davon abhängt, ob eine Spalte für die gesamte Tabelle eindeutig ist. |
| 636156 | Behebt ein Problem, bei dem Sicherungen beschädigt werden, wenn Datenbanken Transparent Database Encryption aktiviert haben, Seitenprüfsummen aktiviert sind und die Sicherung Prüfsummen verwendet. |
| 657511 | FIX: Dieser Fix behebt Timeouts und Deadlocks, die während der Abonnementverarbeitung auftreten können, wenn viele Abonnements gleichzeitig verarbeitet werden. Der Hotfix wird angewendet, wenn Reporting Services im integrierten SharePoint-Modus bereitgestellt wird. |
| 676139 | Behebt ein Problem, bei dem der Kunde eine Sortierung durchführen muss und eine Sortierseite auf den Datenträger verstreut wird. Darüber hinaus berührt der TDE-Scan gleichzeitig diese bestimmte Seite. Sie können den Computer neu starten, um das Problem zu umgehen. Sie können dieses Problem jedoch nicht vollständig vermeiden, es sei denn, Sie deaktivieren TDE. |
| 676491 | Behebt ein potenzielles Problem, das nach der Installation eines Hotfixes auftritt, der in VSTS Bug 473052 beschrieben wird. |
| 679886 | Behebt ein Problem, bei dem erweiterte Ereignisse oder gesammelte SQL-Audit-Trail-Dateien möglicherweise falsche Zeitstempelinformationen anzeigen. |
| 686401 | Behebt ein Problem, bei dem ein C#-Nullwert in dbNull konvertiert wird, bevor er beibehalten wird. |
| 620861 | FIX: In den Datacenter-, Enterprise-, Developer- und Evaluierungseditionen von Microsoft SQL Server 2008 R2 SP1 werden maximal 15.000 Partitionen in Tabellen und Indizes unterstützt. Weitere Informationen zur Aktivierung und Deaktivierung dieser Unterstützung, zu ihren Einschränkungen sowie zu einigen bekannten Problemen und Problemumgehungen finden Sie im Whitepaper "Unterstützung für 15.000 Partitionen" https://go.microsoft.com/fwlink/?linkid=199773 |
| 296354 | FIX: Die Standardwerte der SqlDumperDumpTimeOut-Eigenschaft liegen in Microsoft SQL Server 2008 R2 SP1 nicht in einem gültigen Bereich. Der gültige Wertebereich reicht von 0 (ms) bis MAXDWORD. |
| 417616 | FIX: Die Logik zum Abrufen von SPNs für Dienstkonten ist jetzt so festgelegt, dass sie immer protokolliert wird. Bevor dieser Fix angewendet wird, wird die Logik so festgelegt, dass sie nur protokolliert wird, wenn EP aktiviert ist. Diese Informationen können zur Behebung von Kerberos-Problemen verwendet werden. |
| 517329 | Ein Programmfehler bewirkt, dass verschiedene Diagnosetools melden, dass Abfragen in der master-Datenbank statt in der Datenbank ausgeführt wurden, in der sie tatsächlich ausgeführt wurden. |
| 615697 | Für wichtige Features in Microsoft SQL Server 2008 oder einer späteren Version von SQL Server fehlen SQM-Punkte. Dieser Fix fügt einige wichtige SQM-Punkte hinzu, die zum Nachverfolgen von Kundennutzungsmetriken nützlich sind. |
| 645245 | FIX: Die Logik für die erneute Verbindung und die erneute Ausführung werden aus dem Codepfad der Abfrageausführung im SQL-Editor entfernt. Diese Information ist nicht mehr erforderlich, da sich das Leerlauf-Verbindungstimeout für Microsoft SQL Azure auf 30 Minuten erhöht hat. |
| 674580 | Die neue Ablaufverfolgungsvorlagendatei ("Microsoft Analysis Services TraceDefinition 10.50.0.xml") in Analysis Services muss neu generiert werden, um neu hinzugefügte Ablaufverfolgungsereignisse einzuschließen, damit Profiler alle Ereignisse und Spalten anzeigen kann. |
| 707007 | Importe schlagen in Dallas-Szenarien fehl. |
| 710263 | Beim Versuch, Momentaufnahmen im Berichtskatalog zu generieren, wenn Internet Explorer 9 als Browser verwendet wird, wird eine Fehlermeldung zurückgegeben. |
| 710433 | FIX: Die Registrierung wird aktualisiert, um Dateinamen als Parameter an ssms.exe zu übergeben, wenn Sie auf eine .sql Datei doppelklicken. |
| 656177 | FIX: Eine Zugriffsverletzung tritt auf, wenn Sie eine gespeicherte Prozedur oder eine benutzerdefinierte Funktion verwenden, um eine Tabellenvariable in SQL Server 2008 oder in SQL Server 2008 R2 zu erstellen |
Referenzmaterial
Weitere Informationen zum Ermitteln der aktuellen Version und Edition von SQL Server finden Sie im folgenden Artikel der Microsoft Knowledge Base:
321185
Identifizierung Ihrer SQL Server-Version und -Edition
Die in diesem Artikel genannten Drittanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.