Erscheinungsdatum: Freitag, 15. September 2021
Version: 13.0.6300.2
Dieser Artikel enthält wichtige Informationen, die Sie lesen sollten, bevor Sie Microsoft SQL Server 2016 Service Pack 3 (SP3) installieren. Sie erfahren, wie Sie das Service Pack erhalten, die Liste der im Service Pack enthaltenen Fixes, bekannte Probleme und eine Liste der Urheberrechtsangaben für das Produkt.
Hinweis
Dieser Artikel dient als Einzelquelle für Informationen zum Auffinden aller Dokumentation zu diesem Service Pack. Es enthält alle Informationen, die Sie zuvor in den Versionshinweisen und „Readme.txt“-Dateien gefunden haben.
Bekannte Probleme bei diesem Update
Wenn Sie die Funktion für die Änderungsnachverfolgung verwenden, können Fehler auftreten. Weitere Informationen finden Sie unter KB5007039 , bevor Sie dieses Updatepaket anwenden.
Liste der in SQL Server 2016 SP3 enthaltenen Korrekturen
Microsoft SQL Server 2016 Service Packs sind kumulative Updates. SQL Server 2016 SP3 aktualisiert alle Editionen und Servicelevel von SQL Server 2016 auf SQL Server 2016 SP3. Zusätzlich zu den in diesem Artikel aufgelisteten Updates enthält SQL Server 2016 SP3 Hotfixes, die im kumulativen Update 1 (CU1) für SQL Server SQL Server 2016 SP2 CU17 enthalten waren.
Sie finden weitere Informationen zu den kumulativen Updates, die in SQL Server 2016 verfügbar sind, unter SQL Server 2016-Buildversionen.
Hinweis
- Zusätzliche Fixes, die hier nicht dokumentiert sind, können ebenfalls im Service Pack enthalten sein.
- Dieser Artikel wird aktualisiert, sobald weitere Artikel verfügbar sind.
Weitere Informationen zu den in SQL Server 2016 SP3 behobenen Fehlern finden Sie in den folgenden Microsoft Knowledge Base-Artikeln.
| Fehlerreferenz |
Area Path |
Beschreibung |
|
14048342 |
Verbesserung: Verfügbarkeitsgruppen-Listener ohne Lastenausgleich in SQL Server 2019, 2017 und 2016 (KB4578579) |
Hochverfügbarkeit |
|
12344341 |
FIX: Das Transaktionsprotokoll wird nicht auf einer einzelnen Knoten-Verfügbarkeitsgruppe in SQL Server (KB4515772) abgeschnitten |
Hochverfügbarkeit |
|
13323519 |
FIX: Bei Always On Verfügbarkeitsgruppe in Microsoft SQL Server (KB4541303) kann ein Planfehler ohne Ergebnis auftreten |
Hochverfügbarkeit |
|
14059362 |
FIX: Die Protokollzeile ist ausführlich, wenn Always On Verfügbarkeitsgruppe in SQL Server 2019 und 2016 (KB5003596) über viele Datenbanken verfügt. |
Hochverfügbarkeit |
|
13829857 |
Behebt eine Zugriffsverletzungsausnahme, die bei sp_server_diagnostics der Ausführung auftreten kann. |
Hochverfügbarkeit |
|
14031841 |
Behebt ein Problem, das dazu führt, dass die Datenbank log_reuse_wait_desc geändert AVAILABILITY_REPLICA wird, wenn eine Datenbank aus der Verfügbarkeitsgruppe entfernt wird. |
Hochverfügbarkeit |
|
13435419 |
Behebt die Sicherheitsanfälligkeiten CVE-2015-6420 und CVE-2017-15708 |
Integration Services |
|
13163658 |
FIX: Setup schlägt fehl, wenn Sie SQL Server auf FCI mit Bereitstellungspunkten (KB5005686) installieren |
Setup & Installation |
|
14056703 |
Verbesserung: DNN-Funktion in SQL Server FCI 2019 und 2016 aktivieren (KB4537868) |
SQL-Konnektivität |
|
13526297 |
Fehler bei INSERT EXEC because the stored procedure changed the schema of the target table error in SQL Server 2016 (Fehler bei INSERT EXEC, weil die gespeicherte Prozedur das Schema der Zieltabelle geändert hat |
SQL Engine |
|
12670403 |
Verbesserung: Verbessern der CDC-Unterstützbarkeit und Benutzerfreundlichkeit mit In-Memory Datenbanken (KB4500511) |
SQL Engine |
|
13330609 |
Verbesserung: Größe und Aufbewahrungsrichtlinie werden in den SQL Server 2019, 2017 und 2016 (KB4541132) im standardmäßigen XEvent-Ablaufverfolgungs-system_health erhöht |
SQL Engine |
|
13032229 |
Verbesserung: Neue XEvents-temp_table_cache_trace und -temp_table_destroy_list_trace werden in SQL Server 2019 und 2016 erstellt (KB5003937) |
SQL Engine |
|
11324212 |
FIX: Assertion tritt auf, wenn Sie über MARS in SQL Server 2017 oder 2016 (KB4046056) auf eine speicheroptimierte Tabelle zugreifen |
SQL Engine |
|
12920913 |
FIX: Fehler tritt auf, wenn sp_addarticle verwendet wird, um einen Artikel für die Transaktionsreplikation zur speicheroptimierten Tabelle auf dem Abonnenten in SQL Server 2017 und 2016 hinzuzufügen (KB4493329) |
SQL Engine |
|
13048725 |
FIX: Geocentric Datum of Australia 2020 wird zu SQL Server 2017, 2016 und 2014 hinzugefügt (KB4506023) |
SQL Engine |
|
13186160 |
BEHEBUNG: Das SQL-Updatepaket aktualisiert lokale DB-Dateien nicht ordnungsgemäß, wenn es mit SqlLocalDb.msi (KB4526524) installiert wird |
SQL Engine |
|
12107073 |
FIX: Assertion tritt auf, wenn sys.sp_cdc_enable_table verwendet wird, um CDC für eine Spaltensatztabelle in SQL Server 2017 und 2016 (KB4531386) zu aktivieren |
SQL Engine |
|
13128336 |
FIX: Korrigieren Sie eine falsche Speicherseitenbuchhaltung, die in SQL Server (KB4536005) Fehler aufgrund von unzureichendem Arbeitsspeicher verursacht |
SQL Engine |
|
13127842 |
FIX: Zugriffsverletzungsausnahme tritt beim Heraufstufen von Latches häufig verwendeter Datenbankseiten in SQL Server 2017 und 2016 auf (KB4551720) |
SQL Engine |
|
13345987 |
FIX: Die verwaltete Sicherung kann keine vollständige Sicherung erstellen, wenn die Sicherungseinstellung auf Read-Only sekundären SQL Server 2016 (KB5004059) festgelegt ist. |
SQL Engine |
|
14048422 |
UPDATE: Update SQL Server 2017 und 2016 CEIP-Dienst zum Senden von Nutzungs- und Diagnosedaten an einen neuen Endpunkt (KB5004466) |
SQL Engine |
|
14037575 |
BEHEBUNG: SQLLocalDB.exe Informationen werden keine Informationen über die angegebene LocalDB-instance angezeigt, wenn SQL LocalDB 2016 SP2 installiert ist (KB5005453) |
SQL Engine |
|
13327250 |
BEHEBUNG: "SQLLocalDB.exe Versionen" listet die auf dem Computer installierten Versionen von LocalDB nicht mehr auf, wenn SQL LocalDB 2016 SP1/SP2 installiert ist (KB5005687) |
SQL Engine |
|
13965515 |
Behebt EXCEPTION_INVALID_CRT_PARAMETER eine Ausnahme, wenn Sie eine breite replizierte Tabelle ausführen\INSERTUPDATE. |
SQL Engine |
|
13990061 |
Behebt einen Speicherverlust, wenn Sie die räumliche STDistance-Methode mit einem räumlichen Index verwenden. |
SQL Engine |
|
13992219 |
Behebt das Problem, dass in der sp_hadr_verify_replication_publisher Fehlermeldung ein falscher Verteilungsdatenbankname angezeigt wird. |
SQL Engine |
|
14034656 |
Führt neue Protokollierung und XEvents ein, um die Problembehandlung bei langwierigen Pufferpool-Scans zu unterstützen. Weitere Informationen finden Sie unter Vorgänge, die einen SQL Server-Pufferpool scannen, sind auf großen Speichercomputern langsam. |
SQL Engine |
|
14042368 |
Behebt ein Problem, bei dem einige der temporären Arbeitsordner nicht gelöscht werden, wenn viele R-Abfragen parallel ausgeführt werden. |
SQL Engine |
|
14043334 |
Korrigiert die folgende Assertion, die dazu führen kann, dass SQL Server ein Speicherabbild generiert: RecXdes::AnalyzeLogRecord file =FilePath\FileName line = LineNumber expression = m_state == XDES_COMMITTED |
SQL Engine |
|
14068486 |
Behebt ein Problem, bei dem Sie verwaltete Sicherung auf SQL Server 2016 nicht einrichten können, indem Sie aufgrund des Ablaufs von SAS Azure SAS-Anmeldeinformationen mit einem langen Geheimnis verwenden. |
SQL Engine |
|
14072767 |
Aktiviert ein neues Protokollierungsformat für SQL Writer, das zusätzliche Problembehandlungsdaten in einem einfach zu lesenden/zu analysierenden Format bietet, zusammen mit einer verbesserten Kontrolle der Ausführlichkeit des Protokolls und Aktivieren/Deaktivieren. Weitere Informationen finden Sie unter Protokollierung von SQL Server VSS Writer. |
SQL Engine |
|
14117764 |
Behebt Leistungsproblem mit dem Momentaufnahmen-Agent, das unter SQL 2016 SP2 CU13 und höher beobachtet wurde. |
SQL Engine |
|
14130908 |
Behebt ein Problem mit fehlenden Daten in der Seitentabelle "Change Data Mitschreiben" (CDC) und fügt eine weitere Fehlerbehandlung hinzu, um Datenverluste zu verhindern. |
SQL Engine |
|
14187407 |
Behebt ein Problem, bei dem Sie keine Machine Learning-Dienste (R-Skripts) ausführen können, wenn Sie eine Installation von Microsoft SQL Server 2016 ohne vc_redist 2015 (msvcp140.dll) streamen. |
SQL Engine |
|
14193631 |
Behebt ein Problem, bei dem eine Zugriffsverletzung auftritt und Schlüsselwörter EXCEPTION_ACCESS_VIOLATION sowie FFtFileObject::ProcessSetInfo im SQL Server-Fehlerprotokoll angezeigt werden, wenn Sie das FileTable-Feature in SQL Server auf dem Computer verwenden, auf dem Windows Defender Antivirus verwendet wird.
Hinweis: Dieses Problem kann nach Windows Defender-Updates unter Windows 10, Version 1607 oder einer höheren Version, Windows Server 2016 und Windows Server 2019 auftreten. |
SQL Engine |
|
12904837 |
Verbesserung: Die Verbesserung fügt XEvent in SQL Server 2017 und 2016 sql_statement_post_compile (KB4480630) hinzu |
SQL-Leistung |
|
1198541513377244 |
Verbesserung: Beschädigte Statistiken können durch Verwendung von extended_logical_checks in SQL Server 2019 und 2016 (KB4530907) erkannt werden |
SQL-Leistung |
|
12994428 |
Erhöht die Genauigkeit der CPU-Zeit und -Dauer, die von xevent query_plan_profile gemeldet werden. Weitere Informationen finden Sie unter Query Profiling Infrastructure. |
SQL-Leistung |
|
13989322 |
Behebt den Zugriffsverletzungsfehler, der auftritt, wenn ALTER INDEX die Ausführung über den Abfragespeicher erzwungen wird. |
SQL-Leistung |
|
14056563 |
Behebt ein Stack-Überlaufproblem, wenn Sie eine Abfrage ausführen, die eine sehr große Anzahl von UNION Klauseln enthält. |
SQL-Leistung |
|
14080827 |
Behebt eine Assertion in CQPOnDemandTask::ExecuteQPJob, wenn die automatische asynchrone Updatestatistik aktiviert ist. |
SQL-Leistung |
|
10087766 |
FIX: SQL Server startet nicht mit Fehlermeldungen, wenn ein falsches Zertifikat für SSL bereitgestellt wird (KB5005689) |
SQL-Sicherheit |
Erhalten von SQL Server 2016 SP3
SQL Server 2016 SP3, Microsoft SQL Server 2016 SP3 Express und Microsoft SQL Server 2016 SP3 Feature Pack können auf den folgenden Microsoft Download Center-Websites manuell heruntergeladen und installiert werden.
Hinweis
Nach der Installation dieses Service Packs sollte die SQL Server-Serviceversion 13.0.6300.2 sein. Microsoft SQL Server 2016 Service Packs sind kumulative Updates. SQL Server 2016 SP3 aktualisiert alle Editionen und Servicelevel von SQL Server 2016 auf SQL Server 2016 SP3.
Dateihashinformationen
| Dateiname |
SHA256-Hash |
| SQLServer2016SP3-KB5003279-x64-ENU.exe |
CAE75F65C7C3C263A7BDBAEF0F4AFD0AE49BAF57C08AB27141A7B26008658A91 |
| SQLServer2016-SSEI-Expr.exe |
25692917049A856B9CCEA2C1242F42A1A585D3AD94F1F449E93BE183F17C397A |
Hinweise zu diesem Update
Sie finden weitere Informationen zum Aktualisieren Ihrer SQL Server-Installation auf SQL Server 2016 SP3 unter Unterstützte Versions- und Editionsupgrades.
Deinstallieren von SQL Server 2016 SP3 (nicht empfohlen)
Wenn Sie sich aus irgendeinem Grund für die Deinstallation von SQL Server 2016 SP3 entscheiden, wird die Deinstallation von SQL Server 2016 SP3 nicht blockiert, und Sie können SQL Server 2016 SP3 auf dieselbe Weise wie andere Service Packs deinstallieren. Wenn Sie jedoch die Standard-, Web- oder Express-Editionen von SQL Server ausführen und einige neue Features verwenden, die nur beim Starten von SQL Server 2016 SP3 entsperrt werden, treten möglicherweise Fehler auf oder es wird angezeigt, dass Datenbanken in einem verdächtigen Zustand nach der Deinstallation von SQL Server 2016 SP3 verbleiben. Noch viel schlimmer: Wenn die Systemdatenbanken neue Features verwenden (zum Beispiel partitionierte Tabellen in master-Datenbanken), kann dies dazu führen, dass SQL Server-Instanzen nach der Deinstallation von SQL Server 2016 SP3 nicht gestartet werden können.
Es wird empfohlen, dass Sie überprüfen, ob alle neuen Features deaktiviert oder verworfen wurden, bevor Sie SQL Server 2016 SP3 für andere Editionen als die Enterprise Edition deinstallieren. Sie können die memory_optimized_data Dateigruppe nicht in Ihrer Datenbank mit SP3 ablegen. Sie sollten SQL Server 2016 SP3 nicht deinstallieren. Andernfalls gerät die Datenbank in einen verdächtigen Zustand und der folgende Eintrag wird im Fehlerprotokoll protokolliert:
<Datum/Uhrzeit> Fehler: 41381, Schweregrad: 21, Zustand: 1.< DatumUhrzeit> Die Datenbank kann in dieser Edition von SQL Server nicht gestartet werden, da sie eine MEMORY_OPTIMIZED_DATA Dateigruppe enthält. Sie finden weitere Informationen in Online-Bücher über die Funktionsunterstützung in verschiedenen SQL Server-Editionen.
So installieren Sie R Services
Informationen zum Installieren von SQL Server 2016 R Services unter Windows finden Sie unter Installieren von SQL Server 2016 R Services
Urheberrechte
Dieses Produkt enthält Software, die von der Xerox Sichere Hash Funktion abgeleitet wurde.
Dieses Produkt enthält Software aus der allgemeinen Komprimierungsbibliothek von zlib.
Teile dieser Software basieren zum Teil auf der Arbeit von RSA Data Security, Inc. Da Microsoft die Software RSA Data Security, Inc. in dieses Produkt aufgenommen hat, muss Microsoft den folgenden Text einfügen, der mit dieser Software geliefert wurde:
Copyright 1990, RSA Data Security, Inc. Alle Rechte vorbehalten.
Die Lizenz zum Kopieren und Verwenden dieser Software wird unter der Voraussetzung gewährt, dass sie in allen Materialien, die diese Software oder diese Funktion erwähnen oder auf diese verweisen, als „RSA Data Security, Inc. MD5 Message-Digest Algorithm“ gekennzeichnet ist. Die Lizenz wird auch für die Erstellung und Nutzung abgeleiteter Arbeiten erteilt, sofern diese Arbeiten in allen Materialien, die das abgeleitete Werk erwähnen oder referenzieren, als „von RSA Data Security, Inc., MD5 Message-Digest Algorithm abgeleitet“ gekennzeichnet sind.
RSA Data Security, Inc., gibt keine Zusicherungen hinsichtlich der Marktgängigkeit dieser Software oder der Eignung dieser Software für einen bestimmten Zweck. Sie werden „wie gesehen“ ohne ausdrückliche oder implizite Garantie jeglicher Art bereitgestellt.
Diese Hinweise müssen in allen Kopien dieser Dokumentation oder Software aufbewahrt werden.
Die Reporting Services-Zuordnungsfunktion verwendet Daten aus TIGER/Line Shapefiles, die mit freundlicher Genehmigung des USA Census Bureau zur Verfügung gestellt werden. TIGER/Line Shapefiles sind ein Auszug ausgewählter geografischer und kartografischer Informationen aus der Datenbank Census MAF/TIGER. TIGER/Line Shapefiles sind kostenlos beim USA Census Bureau erhältlich. Weitere Informationen zu den TIGER/Line Shapefiles finden Sie unter TIGER/Line Shapefiles. Die Grenzinformationen in den TIGER/Line Shapefiles dienen ausschließlich der statistischen Datenerfassung und der Tabellierung. Ihre Darstellung und Bezeichnung zu statistischen Zwecken stellt keine Bestimmung der gerichtlichen Zuständigkeit, der Eigentumsrechte oder des Anspruchs dar und spiegelt keine rechtlichen Landbeschreibungen wider. Census TIGER und TIGER/Line sind eingetragene Marken des USA Census Bureau.
Copyright 2012 Microsoft. Alle Rechte vorbehalten.
Referenzmaterial
Sie finden weitere Informationen zum Ermitteln der aktuellen SQL Server-Version und -Edition, indem Sie die folgende Artikelnummer auswählen, um zu dem Artikel in der Microsoft Knowledge Base zu gelangen:
321185 So identifizieren Sie Ihre SQL Server Version und Edition
Die in diesem Artikel genannten Drittanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.