KB3171021 - Versionsinformationen von SQL Server 2014 Service Pack 2

Gilt für
SQL Server 2014 Service Pack 2

Dieser Artikel enthält wichtige Informationen, die Sie lesen sollten, bevor Sie Microsoft SQL Server 2014 Service Pack 2 (SP2) installieren. Sie erfahren, wie Sie das Service Pack erhalten, die Liste der im Service Pack enthaltenen Fixes, die Auswahl des richtigen Downloads basierend auf Ihrer aktuell installierten Version und eine Liste der Urheberrechtsangaben für das Produkt.

Hinweis Dieser Artikel dient als Einzelquelle für Informationen zum Auffinden aller Dokumentation zu diesem Service Pack. Es enthält alle Informationen, die Sie zuvor in den Versionshinweisen und „Readme.txt“-Dateien gefunden haben.

Weitere Informationen

Erhalten von SQL Server 2014 SP2

SQL Server 2014 SP2 steht auf der Download-Seite für SQL Server 2014 SP2 zum Download zur Verfügung. Sie können das SQL Server 2014 SP2 Feature Pack hier herunterladen.

Hinweis Nach der Installation des Service Packs sollte die SQL Server-Dienstversion 12.0.5000.0 sein.

Liste der in SQL Server 2014 SP2 enthaltenen Korrekturen

Microsoft SQL Server 2014 Service Packs sind kumulative Updates. SQL Server 2014 SP2 aktualisiert alle Editionen und Servicelevel von SQL Server 2014 auf SQL Server 2014 SP2. Zusätzlich zu den in diesem Artikel aufgelisteten Updates enthält SQL Server 2014 SP2 Hotfixes, die in SQL Server 2014 SP1 CU1 für SQL Server 2014 SP1 CU7 enthalten waren.

Sie finden weitere Informationen zu den kumulativen Updates, die in SQL Server 2014 verfügbar sind, unter SQL Server 2014 Build-Versionen.

Notizen

  • Zusätzliche Fixes, die hier nicht dokumentiert sind, können ebenfalls im Service Pack enthalten sein.
  • Dieser Artikel wird aktualisiert, sobald weitere Artikel verfügbar sind.

Weitere Informationen zu den in SQL Server 2014 SP2 behobenen Fehlern finden Sie in den folgenden Microsoft Knowledge Base-Artikeln.

VSTS-Fehlernummer KB-Artikelnummer Beschreibung
5694597 3173766 FIX: DBCC CHECKDB oder CHECKTABLE gibt falsch positive Ergebnisse für Datenbeschädigung und Assertionsfehler in SQL Server 2014 zurück
6935655 3177838 DBCC CLONEDATABASE (Transact-SQL) wird in SQL Server 2014 Service Pack 2 eingeführt
7810838 3173767 Verbessert die Leistung für Datenbanken mit einer großen Anzahl von Partitionen in SQL Server 2014 SP2
7579503 3173157 Fügt eine gespeicherte Prozedur für die manuelle Bereinigung der Seitentabelle für die Änderungsnachverfolgung in SQL Server 2014 SP2 hinzu
3913004 3172998 FIX: Bei Verwendung des sys.dm_db_uncontained_entities DMV in SQL Server 2014 kommt es zu einem schwerwiegenden Fehler
6988068 3173156 Update fügt erweiterte AlwaysOn-Ereignisse und Leistungsindikatoren in SQL Server 2014 hinzu
2197153 3172997 Update zum Hinzufügen einer Warnung zur Speicherzuweisung zum Showplan-XML-Code in SQL Server 2014 SP2
4297600 3170123 Unterstützt DROP TABLE DDL für Artikel, die in der Transaktionsreplikation in SQL Server 2014 enthalten sind
6723609 3170116 FIX: Die für die Ausführung der optimierten Join geschachtelter Schleifen erforderliche Speicherzuweisung wird in Showplan XML in SQL Server 2014 nicht berücksichtigt
6170324 3170115 Informationen zu aktivierten Ablaufverfolgungsflags werden der Showplan XML in SQL Server 2014 SP2 hinzugefügt
5990425 3170114 Update zum Hinzufügen von DMF-sys.dm_db_incremental_stats_properties im SQL Server 2014
6685025, 3512277 3170113 Update, um operatorspezifische Abfrageausführungsstatistiken in Showplan XML und erweiterten Ereignissen in SQL Server 2014 SP2 verfügbar zu machen
6170317 3170112 Update, um den maximalen Speicher verfügbar zu machen, der für eine einzelne Abfrage in Showplan XML in SQL Server 2014 aktiviert ist
6852946 3170044 FIX: Fehler "Ungültiges Namenszeichen" beim Analysieren module_end Ereignisausgabe in SQL Server 2014
6927342 3170043 Schlechte Leistung, wenn Abfrage Anti-Join für ein komplexes Prädikat in SQL Server 2014 SP1 enthält
6727876 3170042 DMV-sys.dm_db_index_operational_stats gibt falschen range_scan_count Wert in SQL Server 2014 zurück
6936784 3170022 Update ermöglicht SQL Server 2014 die Verwendung des gesamten virtuellen Adressraums im Benutzermodus für einen Prozess
6945027 3170020 Informationsnachrichten für die Konfiguration "Tempdb" im SQL Server-Fehlerprotokoll in SQL Server 2014 SP2 hinzugefügt
6944985 3170019 Update zum Hinzufügen von Informationen über das SQL Server Startup-Konto zur Sicherheitsrichtlinie im Fehlerprotokoll von SQL Server 2014
7638613 3170015 DMV sys.dm_os_memory_nodes gibt für den pages_kb Wert für den DAC-Knoten in SQL Server 2014 einen Wert ungleich Null zurück
6651348 3156304 Verbesserung für die Unterstützung von SQL Server AlwaysOn Lease Timeout-Unterstützung in SQL Server 2012 und 2014
7003572 3154421 FIX: Filestreamverzeichnis ist nicht sichtbar, nachdem ein AlwaysOn-Replikat in SQL Server 2012 oder 2014 neu gestartet wurde
6715815 3136780 UTF-8-Codierungsunterstützung für das Hilfsprogramm BCP und den Befehl BULK INSERT Transact-SQL in SQL Server 2014 SP2
6589061, 6589062, 6589063,
6589064
3112363 Verbesserungen für die Unterstützung von SQL Server AlwaysOn Lease Timeout in SQL Server 2012 und 2014
6588983 3112362 FIX: Sie erhalten keine Informationen über das Replikat, wenn es in der Verfügbarkeitsgruppe in SQL Server nicht sichtbar ist
6588982 3112361 FIX: Das erweiterte Ereignis alwayson_ddl_executed enthält nicht die Fehlernummer in SQL Server 2012 oder 2014
6588981 3107401 Im SQL Server 2012 stehen neue Optionen für die Zuweisung von Abfragespeicher zur Verfügung (min_grant_percent und max_grant_percent)
6589060 3107400 Verbesserte tempdb-Überlauf Diagnose im Showplan XML-Schema in SQL Server 2012 und 2014
6588999 3107399 Räumliche Leistungsverbesserungen in SQL Server 2012 und 2014
6588995 3107398 Verbesserte Diagnose der Speicherzuweisung bei Verwendung von DMV in SQL Server 2012 und 2014
6589011 3107397 Verbesserte Diagnose für Abfrageausführungspläne mit Restprädikat-Pushdown in SQL Server 2012 und 2014
6589007 3107172 Verbessern des tempdb-Überlaufs Diagnose mithilfe erweiterter Ereignisse in SQL Server 2012 und 2014
6589587 3065060 FIX: Fehler "Wiederherstellungsplan kann aufgrund von Unterbrechung in der LSN-Kette nicht erstellt werden" beim Wiederherstellen der differenziellen Sicherung in SSMS
1046313 2925865 Fehler beim Ausführen des SSIS-Pakets unter FIPS-fähigem Windows

Zusätzliche Lösungen

Lösungen für die folgenden Probleme sind auch in SQL Server 2014 SP2 enthalten.

VSTS-Fehlernummer Beschreibung
6650726 Spalte in Tabelle kann nicht umbenannt werden, obwohl CDC nicht mehr aktiviert ist.
6810365 Drucken des Tabellennamens und des PK-Werts der Zeile für den Fehler 20598 in msdistribution_history
6810368 Drucken Sie die Cmd, die QueryTimeout-Fehler verursacht hat, ohne dass eine ausführliche Protokollierung erforderlich ist
6821167 Bieten eine einfache Möglichkeit zum Drucken von "change_tracking_hardened_cleanup_version" und "safe_cleanup_version" für das Verfahren "sys.sp_flush_commit_table_on_demand"
6925734 Index neu erstellen für 2012/2014 entfernt entsprechende Nutzungsstatistiken in sys.dm_db_index_usage_stats (Regression von 2008 R2)
6943695 Protokollleser Asserts und Sicherungen, wenn die Zieltabelle eine leere Zeichenfolge ist
3988550 Das Vorhandensein von Batch-Sortierung / optimierten geschachtelten Schleifenoperatoren führt zu extremen Speicherzuweisungen - verursacht Serverstabilitäts- & Leistungsprobleme
3781287 Query_hash als UNIT64 definiert ist, stimmt nicht mit XEvent query_hash überein und query_hash von sys.dm_exec_query_stats als varbinary definiert ist
7168415 Der Benutzer verfügt nicht über die ALTER TRACE-Berechtigung, konnte den Befehl DELETE nicht für eine Tabelle mit Filtern in der Mergereplikation ausführen
7343398 Fehler beim Ausführen der Geschäftsregel, wenn der Feldname zu lang ist
6167933 Bereitstellen einer Methode zum Ermitteln des von der Clientverbindung verwendeten TLS/SSL-Protokolls
6588970 Niederländisches FTS mit Formen OfInflectional funktioniert nicht wie erwartet
6588974 Ladelogik für msxmlsql.dll führt zu der falschen Meldung "Fehler beim Überprüfen der Authenticode-Signatur"
2128386 SqlCmd wird ohne Fehler mit einer Kombination aus eingebetteten Kommentaren und geschweiften Klammern beendet ( 2 Stimmen )
2288369 Das Erstellen eines nicht gruppierten Indexes führt dazu, dass DBCC CheckDB mit Extended_Logical_Checks Beschädigungsfehler auslöst
5052858 Format JJJJ/MM/TT für DATUM, das nicht in BCP verarbeitet wird (im Gegensatz zu früherer Datetime)
5783955 NULL-Werte werden ignoriert, nachdem eine Spalte von text in varchar(max) geändert wurde
6589326 EKM DEK kann nicht für Schlüssel mit Fingerabdruck initialisiert werden, die kleiner als die maximale Größe sind
6616118 Zugriffsverletzung beim Aktualisieren inkrementeller Statistiken nach dem Entfernen von Partitionen CPartitionFn::CPartitionFn
6589000 "Set statistics io on'" zeigt nicht die Arbeitstabellenstatistik von Sort an.

Die richtige Datei zum Herunterladen und Installieren auswählen

Die Download-Seite für SQL Server 2014 SP2 enthält die Systemanforderungen für die Installation von SQL Server 2014 SP2 und grundlegende Installationsanweisungen. Sie finden weitere Informationen zum Aktualisieren von installierten 2014 SP2-Komponenten mit einem SQL Server 2014-Wartungsupdate unter Installieren von SQL Server 2014-Updates.

Verwenden Sie die folgende Tabelle, um den Speicherort und den Namen der herunterzuladenden Datei basierend auf Ihrer aktuell installierten Version anzugeben. Die Seiten zum Herunterladen enthalten Systemanforderungen und grundlegende Installationsanweisungen.

Version, die Sie derzeit installiert haben Aktion, die Sie ausführen möchten Datei zum Herunterladen und Installieren
Eine 32-Bit-Version von einer beliebigen Edition von SQL Server 2014 Aktualisieren auf die 32-Bit-Version von SQL Server 2014 SP2 SQLServer2014SP2-KB3171021-x86-ENU.exe von hier aus
Eine 32-Bit-Version von SQL Server 2014 RTM oder SP1 Express Aktualisieren auf die 32-Bit-Version von SQL Server 2014 Express SP2 SQLServer2014SP2-KB3171021-x86-ENU.exe von hier aus
Eine 32-Bit-Version von nur ded Client- und Verwaltbarkeitstools für SQL Server 2014 (einschließlich SQL Server 2014 Management Studio) Aktualisieren der Client- und Verwaltbarkeitstools auf die 32-Bit-Version von SQL Server 2014 SP2 SQLManagementStudio_x86_ENU.exe von hier
Eine 32-Bit-Version von SQL Server 2014 Management Studio Express Aktualisieren auf die 32-Bit-Version von SQL Server 2014 SP2 Management Studio Express SQLManagementStudio_x86_ENU.exe von hier
Eine 32-Bit-Version einer beliebigen Edition von SQL Server 2014 und eine 32-Bit-Version der Client- und Verwaltbarkeitstools (einschließlich SQL Server 2014 RTM Management Studio) Aktualisieren aller Produkte auf die 32-Bit-Version von SQL Server 2014 SP2 SQLServer2014SP2-KB3171021-x86-ENU.exe von hier aus
Eine 32-Bit-Version eines oder mehrerer Tools aus dem Microsoft SQL Server 2014 RTM Feature Pack oder dem Microsoft SQL Server 2014 SP1 Feature Pack Aktualisieren der Tools auf die 32-Bit-Version von Microsoft SQL Server 2014 SP2 Feature Pack Eine oder mehrere Dateien aus dem Microsoft SQL Server 2014 SP2 Feature Pack
Keine 32-Bi-Installation von SQL Server 2014 Management Studio Installieren der 32-Bit-Version von SQL Server 2014 Management Studio einschließlich SP2 SQLManagementStudio_x86_ENU.exe von hier
Keine 32-Bit-Version von SQL Server 2014 Express Installieren der 32-Bit-Version von SQL Server 2014 Express einschließlich SP2 SQLEXPR32_x86_ENU.exe von hier
Eine 64-Bit-Version von einer beliebigen Edition von SQL Server 2014 Aktualisieren auf die 64-Bit-Version von SQL Server 2014 SP2 SQLServer2014SP2-KB3171021-x64-ENU.exe von hier aus
Eine 64-Bit-Version von SQL Server 2014 RTM oder SP1 Express Aktualisieren auf die 64-Bit-Version von SQL Server 2014 SP2 SQLServer2014SP2-KB3171021-x64-ENU.exe von hier aus
Eine 64-Bit-Version von nur ded Client- und Verwaltbarkeitstools für SQL Server 2014 (einschließlich SQL Server 2014 Management Studio) Aktualisieren der Client- und Verwaltbarkeitstools auf die 64-Bit-Version von SQL Server 2014 SP2 SQLManagementStudio_x64_ENU.exe von hier
Eine 64-Bit-Version von SQL Server 2014 Management Studio Express Aktualisieren auf die 64-Bit-Version von SQL Server 2014 SP2 Management Studio Express SQLManagementStudio_x64_ENU.exe von hier
Eine 64-Bit-Version einer beliebigen Edition von SQL Server 2014 und eine 64-Bit-Version der Client- und Verwaltbarkeitstools (einschließlich SQL Server 2014 RTM Management Studio) Aktualisieren aller Produkte auf die 64-Bit-Version von SQL Server 2014 SP2 SQLServer2014SP2-KB3171021-x64-ENU.exe von hier aus
Eine 64-Bit-Version eines oder mehrerer Tools aus dem Microsoft SQL Server 2014 RTM Feature Pack oder dem Microsoft SQL Server 2014 SP1 Feature Pack Aktualisieren der Tools auf die 64-Bit-Version von Microsoft SQL Server 2014 SP2 Feature Pack Eine oder mehrere Dateien aus dem Microsoft SQL Server 2014 SP2 Feature Pack
Keine 64-Bi-Installation von SQL Server 2014 Management Studio Installieren der 64-Bit-Version von SQL Server 2014 Management Studio einschließlich SP2 SQLManagementStudio_x64_ENU.exe von hier
Keine 64-Bit-Version von SQL Server 2014 Express Installieren der 64-Bit-Version von SQL Server 2014 Express einschließlich SP2 SQLEXPR_x64_ENU.exe von hier

            
Sie finden weitere Informationen zum Aktualisieren Ihrer SQL Server-Installation auf SQL Server 2014 SP2 unter Unterstützte Versions- und Editionsupgrades.

  • Dieses Produkt enthält Software, die von der Xerox Sichere Hash Funktion abgeleitet wurde.

  • Dieses Produkt enthält Software aus der allgemeinen Komprimierungsbibliothek von zlib.

  • Teile dieser Software basieren zum Teil auf der Arbeit von RSA Data Security, Inc. Da Microsoft die Software RSA Data Security, Inc. in dieses Produkt aufgenommen hat, muss Microsoft den folgenden Text einfügen, der mit dieser Software geliefert wurde:

    • Copyright 1990, RSA Data Security, Inc. Alle Rechte vorbehalten.
    • Die Lizenz zum Kopieren und Verwenden dieser Software wird unter der Voraussetzung gewährt, dass sie in allen Materialien, die diese Software oder diese Funktion erwähnen oder auf diese verweisen, als „RSA Data Security, Inc. MD5 Message-Digest Algorithm“ gekennzeichnet ist. Die Lizenz wird auch für die Erstellung und Nutzung abgeleiteter Arbeiten erteilt, sofern diese Arbeiten in allen Materialien, die das abgeleitete Werk erwähnen oder referenzieren, als „von RSA Data Security, Inc., MD5 Message-Digest Algorithm abgeleitet“ gekennzeichnet sind.
    • RSA Data Security, Inc., gibt keine Zusicherungen hinsichtlich der Marktgängigkeit dieser Software oder der Eignung dieser Software für einen bestimmten Zweck. Sie werden „wie gesehen“ ohne ausdrückliche oder implizite Garantie jeglicher Art bereitgestellt.

    Diese Hinweise müssen in allen Kopien dieser Dokumentation oder Software aufbewahrt werden.

  • Das Reporting Services-Mapping-Feature verwendet Daten aus TIGER/Line Shapefiles, die mit freundlicher Genehmigung des USA Census Bureau (http://www.census.gov/) zur Verfügung gestellt werden. TIGER/Line Shapefiles sind ein Auszug ausgewählter geografischer und kartografischer Informationen aus der Datenbank Census MAF/TIGER. TIGER/Line Shapefiles sind kostenlos beim USA Census Bureau erhältlich. Weitere Informationen zu den TIGER/Line Shapefiles finden Sie unter http://www.census.gov/geo/www/tiger. Die Grenzinformationen in den TIGER/Line Shapefiles dienen ausschließlich der statistischen Datenerfassung und der Tabellierung. Ihre Darstellung und Bezeichnung zu statistischen Zwecken stellt keine Bestimmung der gerichtlichen Zuständigkeit, der Eigentumsrechte oder des Anspruchs dar und spiegelt keine rechtlichen Landbeschreibungen wider. Census TIGER und TIGER/Line sind eingetragene Marken des USA Census Bureau.

Copyright 2012 Microsoft. Alle Rechte vorbehalten.

Referenzmaterial

Sie finden weitere Informationen zum Ermitteln der aktuellen SQL Server-Version und -Edition, indem Sie die folgende Artikelnummer auswählen, um zu dem Artikel in der Microsoft Knowledge Base zu gelangen:

321185
  Identifizierung Ihrer SQL Server-Version und -Edition
 Die in diesem Artikel genannten Drittanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.