EINFÜHRUNG
In diesem Artikel werden die Fehler aufgeführt, die in Microsoft SQL Server 2008 R2 Service Pack 2 (SP2) behoben wurden.
Notizen
- Weitere Fixes, die nicht dokumentiert sind, können ebenfalls im Service Pack enthalten sein.
- Dieser Artikel wird aktualisiert, sobald weitere Artikel verfügbar sind.
Weitere Informationen zum Beziehen von Service Packs für SQL Server 2008 R2 finden Sie im folgenden Artikel der Microsoft Knowledge Base:
2527041 Installieren des neuesten Service Packs für SQL Server 2008 R2
Weitere Informationen
Zusätzlich zu den in diesem Artikel aufgelisteten Updates enthält SQL Server 2008 R2 SP2 die Hotfixes, die im kumulativen Update 1 bis zum kumulativen Update 5 für SQL Server 2008 R2 Service Pack 1 (SP1) enthalten waren.
Hinweis: Wenn Sie ein Upgrade von SQL Server 2008 R2 SP1 kumulatives Update 6 durchführen, müssen Sie nach dem Upgrade auf SQL Server 2008 R2 SP2 ein kumulatives Update nach SQL Server 2008 R2 SP2 anwenden, um alle Fixes zu erhalten.
Weitere Informationen zu den kumulativen Updatepaketen, die für SQL Server 2008 R2 SP1 verfügbar sind, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
2567616 SQL Server 2008 R2-Builds, die nach der Freigabe von SQL Server 2008 R2 Service Pack 1 veröffentlicht wurden
Die in diesem Service Pack behobenen Probleme
Weitere Informationen zu den in SQL Server 2008 R2 SP2 behobenen Fehlern finden Sie in den folgenden Artikeln der Microsoft Knowledge Base.
| VSTS-Fehlernummer | KB-Artikelnummer | Beschreibung |
|---|---|---|
| 820875 | 922578 | FEHLERBEHEBUNG: Viele Nachrichten mit der Nachrichten-ID 19030 und der Nachrichten-ID 19031 werden in SQL Server 2005, SQL Server 2008 oder SQL Server 2008 R2 Fehlerprotokolldatei protokolliert, wenn Sie das SQL Server-Profil in SQL Server 2005, SQL Server 2008 oder in SQL Server verwenden 2008 R2 |
| 728527 | 2216456 | Verbesserungen von SQL Server 2008 Service Pack 2 und SQL Server 2008 R2 Service Pack 2 an der Fehlermeldung "Vorgang wurde abgebrochen" in Analysis Services |
| 820858 | 2550375 | FIX: In sys.dm_database_encryption_keys DMV in SQL Server 2008 R2 kann es zu einem Deadlock kommen, wenn Sie den Protokollversand von vielen Datenbanken an einen sekundären Server ausführen |
| 820878 | 2565683 | BEHEBUNG: Sie erhalten möglicherweise falsche Ergebnisse, wenn Sie eine komplexe Abfrage ausführen, die Aggregatfunktionen, Joinfunktionen und unterschiedliche Funktionen in Unterabfragen in einer SQL Server 2008- oder SQL Server 2008 R2-Umgebung enthält |
| 820756 | 2588050 | FIX: Slipstream-Installation eines Service Packs für SQL Server 2008 oder SQL Server 2008 R2 schlägt fehl, wenn Sie der SQL-instance neue Features hinzufügen, wenn das Datenbankmodul installiert ist |
| 901689 | 2653857 | FIX: Sie können keine Verbindung zu SQL Server mithilfe des JDBC-Treibers für SQL Server herstellen, nachdem Sie auf JRE 6 Update 29 oder eine neuere Version aktualisiert haben |
| 873603 | 2682488 | FIX: Sicherungsvorgang schlägt in einer SQL Server 2008-, einer SQL Server 2008 R2- oder einer SQL Server 2012-Datenbank fehl, nachdem die Änderungsnachverfolgung aktiviert wurde |
| 958983 | 2719217 | FIX: Latch-Timeoutfehler bei Heaptabellen und aktivierter Datenkomprimierung in SQL Server 2008 R2 oder SQL Server 2012 |
Weitere Probleme, die in dieser CTP-Version des Service Packs behoben werden
Lösungen für die folgenden Probleme sind auch in SQL Server 2008 R2 SP2 enthalten.
| VSTS-Fehlernummer | Beschreibung |
|---|---|
| 820845 | begeistert von der Verwendung der BindParameter-Methode und dem Verweis auf lange Typparameter, die von dieser Methode verwendet werden. |
| 852397 | Updates UpgradeIncompleteFeatureConfigEventHandler.cs, das RebuildDatabase-Szenario einzubeziehen, wenn Sie ConfigurationState zurücksetzen. |
| 887672 | Bei Dokumentbibliotheken, bei denen die Einstellung "Dokumente im Browser öffnen" auf "In der Clientanwendung öffnen" festgelegt ist, ignoriert GetSnapshot.exe die Konfiguration und zeigt die Arbeitsmappe immer mit Excel Services an, als ob die Einstellung "Im Browser öffnen" wäre. |
| 820805 | FIX: In einem russisch lokalisierten Build des Reporting Services Konfigurations-Manager enthalten die Informationen zum Ausführungskonto abgeschnittene Zeichenfolgen. |
| 718430 | Die Verwendungszahlen von ExpectedCount und ExpectedElapsedMs werden aktualisiert, um die tatsächlichen Zahlen widerzuspiegeln. |
| 737914 | Behebt ein Problem, bei dem SQL Server 2008 R2 Analysis Services während der Datenbanksynchronisierung abstürzt. |
| 788389 | Das Ablaufverfolgungsflag 1264 wurde entfernt, sodass der Prozessname standardmäßig in Szenario-Abbildern ohne Ergebnis erfasst wird. Die Anzahl der Threaddatensätze in Szenario-Abbilddateien ohne Ergebnis wird von 1K auf 16K erhöht. |
| 820762 | SQL Server 2008 R2 ändert den Parameter FireAgain in True, wenn ein Ereignis protokolliert werden soll. Nachdem einige Codes versehentlich entfernt wurden, fehlen jedoch einige Protokolle, da der Parameter FireAgain nur vom externen Ereignislistener bestimmt wird. Nachdem Sie diesen Hotfix angewendet haben, ist das Problem behoben. |
| 820764 | Nehmen Sie folgendes Szenario an. Sie haben indizierte Ansichtsprojekte spalten aus Basis- und Nicht-Basistabellen in SQL Server 2008 R2. Eine Spalte aus der Nicht-Basistabelle hat die gleiche Reihenfolge-ID und den gleichen Typ wie eine Spalte der Basistabelle. In diesem Szenario wechselt SQL Server 2008 R2 die Partitionen. Nachdem Sie den Hotfix angewendet haben, tritt in SQL Server 2008 R2 ein Fehler auf, anstatt die Partitionen zu wechseln. |
| 820792 | Behebt ein Problem, bei dem ein Objekt, das einem SOS_Task PMO zugeordnet ist, auch von einer anderen AUFGABE mit einer anderen Lebensdauer verwendet werden konnte. Dieses Service Pack verwendet das richtige PMO für die Zuordnung des Objekts. |
| 820796 | Nachdem Sie den Hotfix angewendet haben, erkennt der Optimierer, dass CRYPT_GEN_RANDOM für dieselbe Eingabe unterschiedliche Ausgaben zurückgeben können. |
| 820859 | Behebt ein Problem, bei dem ein falscher Wert zurückgegeben wird, wenn SCOPE_IDENTITY() ausgeführt wird. |
| 820864 | Behebt ein Problem, bei dem das Setup von SQL Server 2008 R2 abstürzt, wenn Sie SxS mit Shiloh OLAP SP3a installieren. Dieses Problem tritt auf, weil Shiloh OLAP SP3a den Versionsregistrierungsschlüssel fälschlicherweise als "Service Pack 3.0" schreibt. |
| 820873 | Behebt ein Problem, bei dem eine falsche CPU-Zeit von sys.dm_exec_query_stats gemeldet wird, wenn parallele Abfragepläne beteiligt sind. |
| 820880 | Behebt ein Problem, das auftritt, wenn interne asynchrone Dateilesepuffer das mehrstellige Spaltentrennzeichen in zwei Teile teilen. Die Lösung besteht darin, den aktuellen Analysezeiger nach dem Wechseln der Puffer ordnungsgemäß zurückzusetzen. |
| 847805 | Verwendet die Synchronisierung nur, wenn der SQLWixCompilerExtension-Vorgang in Candle ausgeführt wird. |
| 890643 | Ändert den HierarchyGet-Vorgang, um einen bestimmten Codepfad für die explizite Obergrenze zu vermeiden, der nur für den abgeleiteten Teil der Hierarchie gilt. Das Update ist ein einzeiliges Update mit geringem Risiko. |
| 731796 | Behebt ein Problem, bei dem beim Löschen von snapshots.notable_query_text Fehler in einer Anweisung angezeigt werden. |
| 820829 | Fehlerhafte GUID-Werte, die aus Flatfiles analysiert werden, können Fehler verursachen. Die Lösung besteht darin, in einen Abschneidemodus zurückzugreifen, wenn der Quellpuffer größer als die maximale Größe einer GUID-Zeichenfolge ist. |
| 677173 | Berechnet den Schwellenwert für die Latch-Heraufstufung regelmäßig neu, um Abweichungen aufgrund eines Berechnungsfehlers beim Start zu vermeiden. |
| 725819 | Die vorgeschlagene Lösung besteht darin, Anrufkonventionen zwischen Anrufer und angerufener Person anzugleichen. |
| 769975 | Behebt einen Absturz beim Start, wenn der Computer über leere Prozessorsteckplätze verfügt oder die Neustartoption /setgroupsize verwendet wird. |
| 788233 | Reduziert die Zeitspanne, in der die Verriegelung bei einem Spinlock zurückgesetzt wird. Dies trägt zur Verbesserung der Leistung bei |
| 840461 | Behebt eine Racebedingung während des XE-Sitzungsstarts, die zum Absturz von SQL Server führen konnte. |
Referenzmaterial
Weitere Informationen zum Ermitteln der aktuellen Version und Edition von SQL Server finden Sie im folgenden Artikel der Microsoft Knowledge Base:
321185
Identifizierung Ihrer SQL Server-Version und -Edition
Die in diesem Artikel genannten Drittanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.