EINFÜHRUNG
In diesem Artikel werden die in Microsoft SQL Server 2008 Service Pack 2 (SP2) behobenen Fehler aufgeführt.
Notizen
- Andere Fixes, die nicht dokumentiert sind, sind möglicherweise im Service Pack enthalten.
- Dieser Artikel wird aktualisiert, sobald weitere Artikel verfügbar sind.
Weitere Informationen zum Beziehen von SQL Server 2008 Service Packs finden Sie im folgenden Artikel der Microsoft Knowledge Base:
968382
Installieren des neuesten Service Packs für SQL Server 2008
Weitere Informationen
Zusätzlich zu den in diesem Artikel aufgelisteten Updates enthält SQL Server 2008 SP2 die Hotfixes, die im kumulativen Update 1 bis zum kumulativen Update 8 für SQL Server 2008 Service Pack 1 (SP1) enthalten waren. Weitere Informationen zu den kumulativen Updatepaketen, die für SQL Server 2008 SP1 verfügbar sind, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
970365 Die SQL Server 2008-Builds, die nach der Freigabe von SQL Server 2008 SP1 veröffentlicht wurden
Die in diesem Service Pack behobenen Fehler
Weitere Informationen zu den in SQL Server 2008 SP2 behobenen Fehlern finden Sie in den folgenden Artikeln der Microsoft Knowledge Base.
| VSTS-Fehlernummer | KB-Artikelnummer | Beschreibung |
|---|---|---|
| 249682 | 2216454 | FIX: Fehlermeldung beim Ausführen des Befehls "ProcessAdd", nachdem Sie Änderungen an der Partition auf einem Server mit SQL Server 2008 vorgenommen haben: "Interner Fehler: Unerwartete Ausnahme ist aufgetreten" |
| 256736 | 2322209 | FIX: Falsche Ergebnisse, wenn Sie SELECT in einer Anweisung mit einem gemeinsamen Tabellenausdruck in SQL Server 2008 in Klammern setzen |
| 258076 | 2216456 | FIX: In SQL Server 2008 Service Pack 2 wurde der Fehlermeldung "Vorgang abgebrochen" in Analysis Services verbessert |
| 270561 | 2216460 | Fehlermeldung beim Versuch, ein Projekt in SQL Server 2008 zu öffnen: "Die Manifestdefinition der gefundenen Assembly stimmt nicht mit dem Assemblyverweis überein" |
| 274280 | 2216461 | Installation von SQL Server 2008 auf einem Windows Server 2008-basierten Clusterbereitstellungspunkt fehlgeschlagen |
| 284360 | 955850 | Fehlermeldung, wenn Sie versuchen, die Binärdateien aus dem SQL Server System CLR Types-Paket (SQLSysClrTypes.msi) zu verwenden: "DLL 'SqlServerSpatial.dll' kann nicht geladen werden: Diese Anwendung konnte nicht gestartet werden, weil die Anwendungskonfiguration falsch ist" |
| 301603 | 2216465 | Die Slipstream-Installation von SQL Server 2008 schlägt fehl, wenn /PCUSOURCE oder /CUSOURCE ein Leerzeichen im Pfad enthält. |
| 317800 | 2216472 | Eine ROLAP-Abfrage von SQL Server 2008 oder SQL Server 2005 Analysis Services liefert falsche Ergebnisse |
| 340066 | 2216474 | BEHEBUNG: Wenn Sie eine UPDATE-Anweisung mit einer SET-Klausel verwenden, die die Typen time, datetime2 und datetimeoffset in SQL Server 2008 verwendet, kann es zu Datenverlusten kommen |
| 347731 | 2216478 | Fehlermeldung beim Ausführen von Get-Command in einer PowerShell Version 2-Umgebung auf einem Server unter SQL Server 2008: "Objektverweis nicht auf eine instance eines Objekts festgelegt" |
| 351286 | 2216480 | FIX: Die Ränder werden in einem Bericht nicht beibehalten, wenn der Bericht auf einem Server mit SQL Server 2008 nach Excel exportiert wird und Sie dann eine Vorschau des Berichts in Excel anzeigen |
| 351981 | 2216484 | FIX: Fehlermeldung beim Exportieren eines Berichts nach Excel im Berichts-Manager auf einem Server mit SQL Server 2008: "Unbehandelte verwaltete Ausnahme: Typ = System.ArgumentOutOfRangeException" |
| 357416 | 2216485 | FIX: Ressourcenmonitor tritt auf einem SQL Server 2008-Server in eine nicht ertragsgebende Bedingung ein |
| 390126 | 2216491 | Das Hilfsprogramm SQL Dumper kann in einem SQL Server 2008-Failovercluster bei einer Advanced/Enterprise-Failoverclusterinstallation keine Fehlerabbilddateien generieren |
| 396527 | 980671 | Korrigieren des Fehlens einer kryptografischen Salt-Variation in SQL Server sa login hash |
| 402453 | 2019402 | Fehler beim Hinzufügen eines Knotens zu einem SQL Server 2008-Failovercluster |
| 426753 | 2216499 | Sie können keine SQL Server 2008-Datenbank-instance in einem SQL Server Utility registrieren |
| 426753 | 2253128 | Sie können keine Data-Tier Anwendung in einer SQL Server 2008-Datenbank bereitstellen instance |
| 427703 | 2216501 | FIX: Multiserveraufträge werden nicht von einem SQL Server 2000 in der MSX-Rolle auf einen SQL Server 2008 in der TSX-Rolle heruntergeladen |
| 524642 | 2283072 | FIX: Ein Hotfix ist verfügbar, der es SQL Server 2008 R2 Reporting Services ermöglicht, einen 2048-Bit-RSA-Schlüssel zum Verschlüsseln eines Reporting Services-Schlüssels für die FIPS-Konformität zu verwenden |
| 370540 | 2448971 | FIX: Die Sperren einer Tabelle werden nicht eskaliert, wenn Sie viele Zeilen in eine Tabelle in SQL Server 2008 einfügen |
Weitere in diesem Service Pack behobene Probleme
Lösungen für die folgenden Probleme sind auch in SQL Server 2008 SP2 enthalten.
| VSTS-Fehlernummer | Beschreibung |
|---|---|
| 270934 | DBCC-Beschädigungsfehler treten während SQL Server 2008-Sortierungen auf, wenn Zeichenfolgen mit Jamo-Sequenzen verwendet werden, die dem japanischen verlängerten Vorzeichen folgen. |
| 271554 | FIX: Die syscolpars-Systembasistabelle zeigte doppelte Zeilen an. Dieser Fix unterscheidet sie durch Hinzufügen der Prozedurnummer im DBCC-Prüfkatalog. |
| 271708 | Wenn die Abfrage über einen Filter verfügt, der auf eine Spalte in der sys.dm_server_audit_status Ansicht verweist, wird der Filter ignoriert, und alle Zeilen werden von sys.dm_server_audit_status zurückgegeben. |
| 280004 | Das asynchrone Bucketing-Ziel zeigt falsche Wert-Zeichenfolgen-Paare für zugeordnete Felder im Vergleich zu den in dm_xe_map_values verfügbaren Informationen. |
| 284760 | FIX: Die nicht übereinstimmende Ansicht kann mehrere Ansichten mit unterschiedlich vielen Indizes enthalten. Dieser Fix erzwingt eine deterministische Reihenfolge von Ansichten zum Vergleich, die auf übereinstimmenden Funktionen und der Anzahl übereinstimmender Indizes basiert. |
| 285377 | Benutzer erhalten die Fehlermeldung "Zugriff verweigert", wenn sie lokal zum Berichts-Manager navigieren, wenn die UAC aktiviert ist. Das Hinzufügen einer aktualisierten Meldung "Zugriff verweigert" zur Erwähnung der UAC könnte es Benutzern ermöglichen, die Einstellung entsprechend zu ändern. |
| 291707 | In einer bestimmten Datenbank kann die Verwendung eines Servercursors, der für eine SELECT-Anweisung deklariert ist, die eine beliebige Systemansicht enthält, zu falschen Ergebnissen führen, nachdem diese Datenbank angefügt und wieder angefügt wurde. |
| 293089 | Benutzer von radialen Messgeräten, die versuchen, "RateOfChange" oder "Integral" als Formeltyp für den MaximumValue oder MinimumValue auf dem Messgerät zu verwenden, sehen keinen Wert in der Dropdownliste des Eigenschaftenrasters. |
| 296314 | BEHEBUNG: Die FailoverAnalysis.sql-Datei wird während der Einrichtung eines SQL Server Failoverclusters installiert. Dieses Skript wird automatisch aufgerufen, wenn ein Fehler auftritt. Die private Eigenschaft SqlDMVScriptTimeout steuert, wie viele Millisekunden das Skript in Anspruch nehmen kann. |
| 302563 | Benutzer erhalten einen Fehler bei der Überprüfung, wenn sie freigegebene Datenquellen aktualisieren, die ein Leerzeichen im Namen enthalten. Der Fehler gibt an, dass der Name keine Leerzeichen enthalten darf. |
| 302707 | Die Installation von Service Pack 1 für SQL Server Business Intelligence Development Studio 2008 schlägt aufgrund einer fehlenden Konfigurationsdatei fehl. |
| 304390 | Der Ringpuffer zeigt unvollständige Ereignisdaten (von dm_xe_session_targets ausgegebene Ereignisse) an, wenn die Größenbeschränkung für die XML-Ausgabe erreicht ist. |
| 307313 | Benutzer können nicht mehrere Cookies in ihrem HTTP-Modul zurückgeben. Dies wirkt sich auf Benutzer aus, wenn sie versuchen, eine benutzerdefinierte Authentifizierung zu implementieren. |
| 309869 | Die Aktionen sqlsos.task_address, sqlsos.worker_address und sqlsos.scheduler_address Erweiterte Ereignisse zeigen eine falsche Adresse an. |
| 310483 | Reporting Services 2008 Designer rechnet in Tablix Zentimeter in Zoll um. Dies führt zu einem Verlust der Layoutgenauigkeit. |
| 313780 | Durch die Deinstallation der ersten von zwei benannten AS-Instanzen wird der SQL-Browser deaktiviert. Dies bewirkt, dass die zweite benannte Instance nicht erreichbar ist. |
| 319216 | Benutzer können gespeicherte Anmeldeinformationen in ihren Datenquellen nicht verwenden, wenn eine Smartcard erforderlich ist. |
| 322046 | Eine Abfrage mit einer subselect-Klausel, die einen Mengenausdruck verwendet, der keine berechneten Elemente zurückgibt, gibt eine Fehlermeldung zurück, die besagt, dass Teilauswahlen mit berechneten Elementen nicht zulässig sind. |
| 327301 | In Analysis Services führt das Festlegen eines Dimensionsstandardelements mithilfe eines MDX-Ausdrucks mit einer NonEmpty-Funktion dazu, dass der Server einen internen Fehler zurückgibt, wenn er versucht, den Cube zu öffnen. |
| 328752 | In der Ansicht sys.dm_os_wait_stats werden duplizierte Zeilen für den Wartetyp VERSCHIEDENES angezeigt. Dies kann zu Problemen bei Überwachungstools führen. |
| 331630 | Ein ganzzahliger Wert wird im Designer für wiederverwendbare Abfragen SQL Server Reporting Services falsch gerundet. |
| 333544 | BEHEBUNG: Ein neuer Fehlercode (6257) wird zurückgegeben, wenn ein Benutzer versucht, eine CLR-Assembly zu registrieren, die für eine neuere Laufzeit, z. B. CLR v4, erstellt wurde. Die vorherige Fehlermeldung (Code 6218) war verwirrend und gab nicht das eigentliche Problem an. |
| 336809 | Ein Grenzfall fügt einen Identitätswert außerhalb des aktuellen Bereichs in den Modus "identity_insert TABLE_NAME aktivieren" ein. Dieses Problem tritt auch bei Backup-/Wiederherstellungsvorgängen auf. |
| 338247 | Wenn Parameter, die von der SQLBindParameter-Funktion gebunden werden, eine Länge von SQL_DATA_AT_EXEC angeben, verursacht der ODBC-Treiber von SQL Server 2008 Native Client eine Zugriffsverletzung, wenn die SQLPutData-Funktion eine Länge von SQL_NULL_DATA angibt, wenn der Parameterwert zur Ausführung angegeben wird. |
| 338999 | In SQL Server Reporting Services 2008 tritt ein Verbindungsverlust auf, wenn ein Benutzer die SOAP-Schnittstelle zum Ausführen und Exportieren eines Berichts verwendet. |
| 347779 | SQL Server generiert manchmal die Fehlermeldung "Es ist nicht genügend Systemspeicher im Ressourcenpool 'intern', um diese Abfrage auszuführen". Diese Situation ist oft vermeidbar. |
| 350670 | Benutzer erhalten die Fehlermeldung "Seite abgelaufen", wenn sie versuchen, auf einen gerenderten Bericht zu verweisen, nachdem der Bericht eine Stunde lang inaktiv war. |
| 352788 | Fehler 955 tritt auf, wenn Benutzer versuchen, das Verwaltungs-Data Warehouse zu konfigurieren, wenn sie Datenbanken auf ihrem Server haben, die nicht online sind. |
| 352862 | ReportBuilder 2.0 ClickOnce zeigt beim Start einen leeren Bericht an, wenn ein Benutzer den Bericht mithilfe von ReportBuilder 2.0 über eine SharePoint 12-Website bearbeitet. |
| 355222 | Wenn MARS verwendet wird, zeigt die sys.dm_os_tasks-Ansicht denselben Wert in der Spalte request_id für alle Aufgaben an, anstatt den korrekten Wert zu melden, der jedem Vorgang zugeordnet ist. |
| 355228 | FIX: Eine neue Fehlermeldung zeigt die Ursache einer Zugriffsverletzung an, die auftritt, wenn die Bucketizer-Zielparameter falsch eingestellt sind. |
| 356127 | Beim Abrufen von Spaltenmetadaten werden falsche Spaltensortierungsinformationen BCP.exe zurückgegeben. |
| 360584 | Abonnements schlagen während der Ausführung aufgrund eines In-Memory-Datenstrukturproblems während der versuchten E-Mail-Zustellung eines in MHTML gerenderten Berichts fehl. |
| 368388 | BIDS 2008 Berichts-Designer zusammen mit SQL Server Reporting Services 2008 abstürzt, wenn Benutzer die Größe einer Tabellenzeile ändern. |
| 376257 | Die Felder "An", "CC" und "BCC" des Dialogfelds "Berichtsübermittlungsoptionen" werden gelöscht, nachdem Benutzer das Dialogfeld "Zeitplandetails" abgebrochen oder geschlossen haben, um zu "Zustellungsoptionen melden" zurückzukehren. |
| 383747 | Sammlungssätze funktionieren beim Erfassen von Leistungsindikatoren in einem Cluster nicht ordnungsgemäß, wenn der Name der SQL-Instance mit dem Namen des virtuellen Netzwerks identisch ist. |
| 384800 | FIX: Verbesserte und zusätzliche Informationen werden für InvalidReportParameterException in der ausführlichen Ausgabe protokolliert, wenn bestimmte Bedingungen während der Parameterverarbeitung auftreten. |
| 393410 | Wenn Benutzer die Auswahl von einem oder mehreren Monaten in einem monatlichen Zeitplan aufheben, erstellt SSRS separate Zeitpläne für jeden Monat, der noch ausgewählt ist. In einigen Fällen kann dies zu einem Fehler "@active_end_date kann vorher @active\_start\_datenicht sein" führen. |
| 393879 | Data-Driven Abonnement schlägt fehl, wenn ein NULL-Wert zurückgegeben wird, wenn es dem Berichtsparameter zugeordnet wird, der einen NULL-Wert akzeptiert. |
| 394977 | Abonnement- und Zustellungsprobleme sind in der Reporting Services-Ablaufverfolgungsdatei schwer zu diagnostizieren. Eine ausführlichere Protokollierung ist erforderlich. |
| 415084 | Benutzer erhalten die Meldung "Der Index lag außerhalb des zulässigen Bereichs. Muss nicht negativ und kleiner als die Größe der Sammlung sein", wenn sie in PDF exportiert werden. |
| 419740 | Benutzer können die benutzerdefinierte Authentifizierung in der Web-SKU von SQL Server 2008 nicht verwenden. |
| 424595 | Wenn ein Benutzer einen benutzerdefinierten Typ und eine Funktion mit einem Tabellenwert in derselben Transaktion erstellt und die Funktion über eine Rückgabetabelle verfügt, die eine Spalte des benutzerdefinierten Typs enthält, tritt ein automatischer Deadlock auf. Außerdem wird die Verbindung, die versucht, diese Vorgänge auszuführen, beendet. |
| 421922 | BEHEBUNG: In den Enterprise-, Developer- und Evaluierungseditionen von Microsoft SQL Server 2008 SP2 werden maximal 15.000 Partitionen in Tabellen und Indizes unterstützt. Weitere Informationen zur Aktivierung und Deaktivierung dieser Unterstützung, zu ihren Einschränkungen sowie zu einigen bekannten Problemen und Problemumgehungen finden Sie im Whitepaper "Support für 15.000 Partitionen" (http://go.microsoft.com/fwlink/?LinkId=199773). |
| 424804 | In Analysis Services kann es bei einigen Kunden zu Zugriffsverletzungen kommen, wenn sie eine Hierarchie über- und untergeordneter Elemente in der Bedingung einer IIF-Funktion verwenden. |
| 426631 | Die Verwendung einer PeriodsToDate-Funktion mit einem Null-Memberparameter kann zu einem Fehler vom Typ "Unerwartete Ausnahme" führen. |
| 429253 | In SQL Server Management Studio und in SQL Server Reporting Services wird eine falsche Versionsnummer angezeigt. Dies führt zu Verwirrung, da die angezeigte Nummer nicht von der RTM-Versionsnummer nach einem Upgrade abweicht. |
| 430703 | Eine sekundäre Ausnahme kann auftreten, wenn Analysis Services ein Watson-Speicherabbild generiert. Dies gilt unabhängig davon, ob das Watson-Speicherabbild aufgrund einer tatsächlichen Ausnahme oder aufgrund einer expliziten Anforderung zum Abbild bestimmter Fehler generiert wird. Wenn die sekundäre Ausnahme auftritt, kann der Server eine unendliche Rekursion erfahren. Dadurch werden viele Speicherabbilder generiert und der Server wird dann heruntergefahren. |
| 431298 | BEHEBUNG: In SSRS 2008 Service Pack 2 wird das RS-Add-In für SharePoint 2007 für die Kommunikation mit dem SSRS 2008 R2-Berichtsserver aktualisiert. Dies ermöglicht den Zugriff auf bestimmte Funktionen in ReportBuilder 3.0, ReportParts und ATOM-Renderer, einschließlich der neuen Berichtsvorschau in ReportBuilder 3.0. |
| 431301 | Das Verarbeiten von Objekten in einer Datenbank, die Tausende von Metadatenobjekten enthält, nimmt viel Zeit in Anspruch, um mit dem Importieren der Daten zu beginnen. Dies liegt daran, dass der Server einen Auftragszeitplan erstellen muss, bevor der Datenimport beginnt. Darüber hinaus verursacht der Algorithmus, der zum Bestimmen von Abhängigkeiten verwendet wird, eine langsame Leistung, wenn viele Metadatenobjekte in der Datenbank vorhanden sind. |
| 432094 | Ein räumlicher Index kann nicht sicher in einer Tabelle erstellt werden, die CELL_ID, CELL_ATTRIBUTES oder SRID für Spaltennamen verwendet. |
| 448007 | Unter bestimmten Bedingungen kann der Name der partitionierten Spalte in Fehlermeldung 11405 falsch sein. Dadurch wird ein falscher Spaltenname gedruckt. |
| 455538 | Die Verwendung der Zellsicherheit zusammen mit Berechnungen führt zu falschen Ergebnissen, wenn eine NON EMPTY-Klausel verwendet wird. |
| 456534 | Eine Lesezugriffsverletzung tritt während eines Commit-Prozesses auf, wenn zwei Transaktionen gleichzeitig ausgeführt werden: eine zum Ändern oder Erstellen einer Partition und eine zum Verarbeiten einer Dimension. |
| 471363 | Wenn Microsoft Office 12 in SQL Server 2008 Reporting Services integriert ist, wird die SharePoint-Integration nicht standardmäßig auf die Report Builder ClickOnce-URL festgelegt, sodass Report Builder nicht gestartet werden kann. |
| 471421 | FIX: Lokalisierungsproblem in der türkischen SKU: Breadcrumbs werden jetzt auf neuen Reportpart-Bibliotheksseiten lokalisiert. |
| 499162 | BEHEBUNG: Ein Problem mit der Barrierefreiheit, das auftritt, weil der MSAA-Name "Symbol" gleich Null ist. MSAA-Namen werden aktualisiert und sind jetzt auffindbar. |
| 503096 | FIX: Die Leistung der Indexerstellung durch DDL-Anweisungen für Tabellen mit vielen Partitionen und ohne Daten wurde verbessert. Zuvor nahm die für diesen Prozess erforderliche Zeit mit zunehmender Anzahl der Partitionen in einer geometrischen Progression zu. Die benötigte Zeit erhöht sich nun in einer linearen Progression. |
| 515240 | Die Verwendung von Tabellenwertparametern für LOB-Spalten kann zu einer Zugriffsverletzung auf dem Server führen. |
| 520700 | MSAA-Namen für das Dialogfeld Eigenschaften der Radialskala sind falsch und nicht barrierefrei. |
| 525601 | Während einer Überprüfung auf eine granulare Überwachung kann es bei dem Algorithmus, der zum Auflisten aller Audits verwendet wird, die das Ereignis enthalten, zu Speicherverlusten in der Liste der Überwachungen kommen. Dies wird so lange fortgesetzt, bis Fehler mit zu wenig Arbeitsspeicher auftreten und der Dienst neu gestartet werden muss, um den Arbeitsspeicher freizugeben. |
Hinweis: Wenn Sie ein Upgrade von SQL Server 2008 SP1 Kumulatives Update 9 oder einer höheren Version durchführen, müssen Sie nach dem Upgrade auf SQL Server 2008 SP2 ein kumulatives Update nach SQL Server 2008 SP2 anwenden, um alle Fixes zu erhalten.
Weitere Informationen zum kumulativen Update nach SQL Server 2008 SP2 finden Sie im folgenden Artikel der Microsoft Knowledge Base:
2289254 Kumulatives Updatepaket 1 für SQL Server 2008 Service Pack 2
Referenzmaterial
Weitere Informationen zum Ermitteln der aktuellen Version und Edition von SQL Server finden Sie im folgenden Artikel der Microsoft Knowledge Base:
321185
Identifizierung Ihrer SQL Server-Version und -Edition
Die in diesem Artikel genannten Drittanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.