KB2958062 - FIX: Error 515 when you add a subscription and then delete it in SQL Server 2012 or SQL Server 2014

Applies To
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptoms

Consider the following scenario:

  • You use Replication in Microsoft SQL Server 2012 or SQL Server 2014.
  • You add a subscription in the Replication subscription, and then delete it.

In this scenario, you may receive the following error 515:

Note

Cannot insert the value NULL into column 'article_id', table '<DistributionDatabaseName>.dbo.MSrepl_commands'; column does not allow nulls. INSERT fails.

      

Cause

The issue occurs because of a regression of SQL Server 2012. When you add a subscription, and then you delete it, Replication Metadata about the subscription is immediately deleted because there is a delay before the LogReader encounters the command to add the subscription.

Resolution

The issue was first fixed in the following cumulative update of SQL Server.

Cumulative Update 1 for SQL Server 2012 SP2 /en-us/help/2976982

Cumulative Update 2 for SQL Server 2014 /en-us/help/2967546

Cumulative Update 10 for SQL Server 2012 SP1 /en-us/help/2954099

About cumulative updates for SQL Server

Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. Check out the latest cumulative updates for SQL Server:

      

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.