Celdas

Importar o exportar archivos de texto (.txt o .csv)

Importar o exportar archivos de texto (.txt o .csv)

Hay dos formas de importar datos de un archivo de texto con Excel: puede abrirlos en Excel o importarlos como una rango de datos externos. Para exportar datos de Excel a un archivo de texto, use el comando Guardar como y cambie el tipo de archivo desde el menú desplegable.

Hay dos formatos de archivo de texto que se usan con frecuencia:

  • Archivos de texto delimitados (.txt), en los que el carácter TAB (código de carácter ASCII 009) suele separar cada campo de texto.

  • Archivos de texto con valores separados por comas (.csv), en los que el carácter de coma (,) suele separar cada campo de texto.

Puede cambiar el carácter separador que se usa en los archivos de texto delimitados y .csv. Esto puede ser necesario para asegurarse de que la operación de importación o exportación funciona como desee.

Nota: Puede importar o exportar hasta 1.048.576 filas y 16.384 columnas.

Importar un archivo de texto al abrirlo en Excel

Puede abrir un archivo de texto que creó en otro programa como libro de Excel mediante el comando Abrir. La apertura de un archivo de texto en Excel no cambia el formato del archivo( puede verlo en la barra de título de Excel, donde el nombre del archivo conserva la extensión de nombre de archivo de texto (por ejemplo, .txt o .csv).

  1. Vaya a Archivo > Abrir y busque la ubicación que contiene el archivo de texto.

  2. Seleccione Archivos de texto en la lista desplegable tipo de archivo en el cuadro de diálogo Abrir.

  3. Busque y haga doble clic en el archivo de texto que desea abrir.

    • Si el archivo es un archivo de texto (.txt), Excel inicia el Asistente para importar texto. Cuando haya terminado con los pasos, haga clic en Finalizar para completar la operación de importación. Vea Asistente para importar texto para obtener más información sobre delimitadores y opciones avanzadas.

    • Si el archivo es un archivo .csv, Excel abre automáticamente el archivo de texto y muestra los datos en un libro nuevo.

      Nota: Cuando Excel abre un archivo .csv, usa la configuración de formato de datos predeterminada actual para interpretar cómo importar cada columna de datos. Si desea más flexibilidad para convertir columnas a diferentes formatos de datos, puede usar el Asistente para importar texto. Por ejemplo, el formato de una columna de datos en el archivo .csv puede ser MDY, pero el formato de datos predeterminado de Excel es YMD, o bien quiere convertir una columna de números que contiene ceros a la izquierda en texto para que pueda conservar los ceros a la izquierda. Para obligar a Excel a ejecutar el Asistente para importar texto, puede cambiar la extensión de nombre de archivo de .csv a .txt antes de abrirlo, o puede importar un archivo de texto conectándose a él (para obtener más información, vea la sección siguiente).

Importar un archivo de texto conectándose a él (Power Query)

Puede importar datos de un archivo de texto a una hoja de cálculo existente.

  1. En la pestaña Datos, en el grupo Obtener & transformar datos, haga clic en Desde texto/CSV.

  2. En el cuadro de diálogo Importar datos, busque y haga doble clic en el archivo de texto que desea importar y haga clic en Importar.

  3. En el cuadro de diálogo vista previa, tiene varias opciones:

    • Seleccione Cargar si desea cargar los datos directamente en una nueva hoja de cálculo.

    • Como alternativa, seleccione Cargar a si desea cargar los datos en una tabla, tabla dinámica o gráfico dinámico, una hoja de cálculo de Excel existente o nueva, o simplemente cree una conexión. También tiene la opción de agregar los datos al modelo de datos.

    • Seleccione Transformar datos si desea cargar los datos en Power Query y editarlos antes de llevarlos a Excel.

Si Excel no convierte una columna concreta de datos al formato que desee, puede convertir los datos después de importarlos. Para obtener más información, vea Convertir números almacenados como texto en números y Convertir fechas almacenadas como texto en fechas.

Exportar datos a un archivo de texto guardéndolos

Puede convertir una hoja de cálculo de Excel en un archivo de texto mediante el comando Guardar como.

  1. Vaya a Archivo > Guardar como.

  2. Haga clic en Examinar.

  3. En el cuadro de diálogo Guardar como, en El cuadro Guardar como tipo, elija el formato de archivo de texto para la hoja de cálculo; por ejemplo, haga clic en Texto (delimitado por tabulaciones) o CSV (delimitado por comas).

    Nota: Los diferentes formatos admiten distintos conjuntos de características. Para obtener más información sobre los conjuntos de características compatibles con los diferentes formatos de archivo de texto, vea Formatos de archivo compatibles con Excel.

  4. Busque la ubicación donde desea guardar el nuevo archivo de texto y, a continuación, haga clic en Guardar.

  5. Aparece un cuadro de diálogo que le recuerda que solo la hoja de cálculo actual se guardará en el nuevo archivo. Si está seguro de que la hoja de cálculo actual es la que desea guardar como archivo de texto, haga clic en Aceptar. Puede guardar otras hojas de cálculo como archivos de texto independientes repitiendo este procedimiento para cada hoja de cálculo.

    También puede ver una alerta debajo de la cinta de opciones de que algunas características podrían perderse si guarda el libro en un formato CSV.

Para obtener más información sobre cómo guardar archivos en otros formatos, vea Guardar un libro en otro formato de archivo.

Importar un archivo de texto conectándose a él

Puede importar datos de un archivo de texto a una hoja de cálculo existente.

  1. Haga clic en la celda donde desea colocar los datos del archivo de texto.

  2. En la pestaña Datos, en el grupo Obtener datos externos, haga clic en Desde texto.

  3. En el cuadro de diálogo Importar datos, busque y haga doble clic en el archivo de texto que desea importar y haga clic en Importar.

    Siga las instrucciones del Asistente para importación de texto. Haga clic Imagen del botón ayuda en cualquier página del Asistente para importación de texto para obtener más información sobre el uso del asistente. Cuando haya terminado con los pasos del asistente, haga clic en Finalizar para completar la operación de importación.

  4. En el cuadro de diálogo Importar datos, haga lo siguiente:

    1. En ¿Dónde desea colocar los datos?, realice una de las siguientes acciones:

      • Para devolver los datos a la ubicación seleccionada, haga clic en Hoja de cálculo existente.

      • Para devolver los datos a la esquina superior izquierda de una nueva hoja de cálculo, haga clic en Nueva hoja de cálculo.

    2. Opcionalmente, haga clic en Propiedades para establecer opciones de actualización, formato y diseño para los datos importados.

    3. Haga clic en Aceptar.

      Excel coloca el rango de datos externos en la ubicación que especifique.

Si Excel no convierte una columna de datos al formato que desee, puede convertir los datos después de importarlos. Para obtener más información, vea Convertir números almacenados como texto en números y Convertir fechas almacenadas como texto en fechas.

Exportar datos a un archivo de texto guardéndolos

Puede convertir una hoja de cálculo de Excel en un archivo de texto mediante el comando Guardar como.

  1. Vaya a Archivo > Guardar como.

  2. Aparecerá el cuadro de diálogo Guardar como.

  3. En el cuadro Guardar como tipo, elija el formato de archivo de texto para la hoja de cálculo.

    • Por ejemplo, haga clic en Texto (delimitado por tabulaciones) o CSV (delimitado por comas).

    • Nota: Los diferentes formatos admiten distintos conjuntos de características. Para obtener más información sobre los conjuntos de características compatibles con los diferentes formatos de archivo de texto, vea Formatos de archivo compatibles con Excel.

  4. Busque la ubicación donde desea guardar el nuevo archivo de texto y, a continuación, haga clic en Guardar.

  5. Aparece un cuadro de diálogo que le recuerda que solo la hoja de cálculo actual se guardará en el nuevo archivo. Si está seguro de que la hoja de cálculo actual es la que desea guardar como archivo de texto, haga clic en Aceptar. Puede guardar otras hojas de cálculo como archivos de texto independientes repitiendo este procedimiento para cada hoja de cálculo.

  6. Aparece un segundo cuadro de diálogo que le recuerda que la hoja de cálculo puede contener características que no son compatibles con los formatos de archivo de texto. Si solo está interesado en guardar los datos de la hoja de cálculo en el nuevo archivo de texto, haga clic en . Si no está seguro y desea saber más sobre qué características de Excel no son compatibles con los formatos de archivo de texto, haga clic en Ayuda para obtener más información.

Para obtener más información sobre cómo guardar archivos en otros formatos, vea Guardar un libro en otro formato de archivo.

La forma en que cambia el delimitador al importar es diferente en función de cómo importe el texto.

  • Si usa Obtener & Transformar datos > Desde texto/CSV, después de elegir el archivo de texto y hacer clic en Importar,elija un carácter para usar de la lista en Delimitador. Puede ver el efecto de la nueva opción inmediatamente en la vista previa de datos, por lo que puede asegurarse de que elige la opción que desee antes de continuar.

  • Si usa el Asistente para importar texto para importar un archivo de texto, puede cambiar el delimitador que se usa para la operación de importación en el paso 2 del Asistente para importación de texto. En este paso, también puede cambiar la forma en que se controlan los delimitadores consecutivos, como las comillas consecutivas.

    Vea Asistente para importar texto para obtener más información sobre delimitadores y opciones avanzadas.

Si desea usar un punto y coma como separador de lista predeterminado al guardar como .csv, pero necesita limitar el cambio a Excel, considere la posibilidad de cambiar el separador decimal predeterminado a una coma, esto obliga a Excel a usar un punto y coma para el separador de lista. Obviamente, esto también cambiará la forma en que se muestran los números decimales, por lo que también puede cambiar el separador De miles para limitar cualquier confusión.

  1. Desactive Opciones de Excel> opciones> de edición >usar separadores de sistema.

  2. Establezca separador decimal en , (una coma).

  3. Establecer separador de miles en . (un punto).

Al guardar un libro como un archivo .csv, el separador de lista predeterminado (delimitador) es una coma. Puede cambiarlo a otro carácter separador con la configuración de región de Windows. 

Precaución: Cambiar la configuración de Windows provocará un cambio global en el equipo, que afectará a todas las aplicaciones. Para cambiar solo el delimitador de Excel, vea Cambiar el separador de lista predeterminado para guardar archivos como texto (.csv) en Excel.

  1. En Microsoft Windows 10, haga clic con el botón derecho en el botón Inicio y, a continuación, haga clic en Configuración.

  2. Haga clic en & idioma y,a continuación, haga clic en Región en el panel izquierdo.

  3. En el panel principal, en Configuración regional,haga clic en Fecha adicional, hora y configuración regional.

  4. En Región,haga clic en Cambiar formatos de fecha, hora o número.

  5. En el cuadro de diálogo Región, en la pestaña Formato, haga clic en Configuración adicional.

  6. En el cuadro de diálogo Personalizar formato, en la pestaña Números, escriba un carácter para usarlo como nuevo separador en el cuadro Separador de lista.

  7. Haga clic dos veces en Aceptar.

  1. En Microsoft Windows, haga clic en el botón Inicio y, a continuación, haga clic en Panel de control.

  2. En Reloj, idioma y región, haga clic en Cambiar formato de fecha, hora o número.

  3. En el cuadro de diálogo Región, en la pestaña Formato, haga clic en Configuración adicional.

  4. En el cuadro de diálogo Personalizar formato, en la pestaña Números, escriba un carácter para usarlo como nuevo separador en el cuadro Separador de lista.

  5. Haga clic dos veces en Aceptar.

Nota:  Después de cambiar el carácter separador de lista para el equipo, todos los programas usan el nuevo carácter como separador de lista. Puede volver a cambiar el carácter al carácter predeterminado siguiendo el mismo procedimiento.

¿Necesita más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtenga soporte en la Comunidad de respuestas.

Vea también

Importar datos de orígenes de datos externos (Power Query)

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×