INTRODUCTION
La mise à jour cumulative 4 contient des correctifs logiciels pour les problèmes de Microsoft SQL Server 2008 R2 qui ont été résolus depuis la publication de SQL Server 2008 R2.
Remarque : cette version de ce package de mise à jour cumulative est également appelée build 10.50.1746.0.
Nous vous recommandons de tester les correctifs logiciels avant de les déployer dans un environnement de production. Étant donné que les builds sont cumulatives, chaque nouvelle publication de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif de SQL Server 2008 R2. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
981356 Builds SQL Server 2008 R2 publiées après SQL Server 2008 R2
Remarques importantes sur le package de mise à jour cumulative
- Les correctifs logiciels contenus dans ce package de mise à jour cumulative sont inclus dans SQL Server 2008 R2 Service Pack 1 (SP1).
- Les correctifs logiciels de SQL Server 2008 R2 sont désormais multilingues. Il n’existe donc qu’un seul correctif logiciel cumulatif pour toutes les langues.
- Un correctif logiciel cumulatif inclut tous les packages des composants. Le package de mise à jour cumulative met à jour uniquement les composants installés sur le système.
Informations supplémentaires
Procédure pour obtenir la mise à jour cumulative 4 pour SQL Server 2008 R2
Un package de mise à jour cumulative pris en charge est désormais disponible auprès de Microsoft. Toutefois, elle est destinée à corriger uniquement les problèmes décrits dans cet article. Appliquez-le uniquement aux systèmes qui rencontrent ces problèmes spécifiques. Ce package de mise à jour cumulative peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par l’un de ces problèmes, nous vous recommandons d’attendre le prochain Service Pack SQL Server 2008 R2 qui contiendra les correctifs logiciels contenus dans ce package de mise à jour cumulative.
Si la mise à jour cumulative est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le package de mise à jour cumulative auprès des services de Support technique Microsoft.
Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à ce package de mise à jour cumulative. Pour obtenir la liste complète des numéros de téléphone des services d’assistance technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site web de Microsoft à l’adresse suivante :
Correctifs logiciels SQL Server 2008 inclus dans la mise à jour cumulative 4 pour SQL Server 2008 R2
Les articles de la Base de connaissances Microsoft qui traitent de ces correctifs logiciels seront publiés dès qu’ils seront disponibles.
Pour plus d’informations sur les bogues de SQL Server, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
| Numéro de bogue VSTS | Numéro d’article de la Base de connaissances | Description |
|---|---|---|
| 549034 | aucun | La tâche de capture CDC peut rencontrer la condition d’assertion suivante lorsque CDC est activé sur des tables de base de données qui ont des colonnes XML ou d’autres colonnes de type de données blob : Assertion : Fichier : <nom du fichier> line=<numéro> de ligne Assertion ayant échoué = 'fNoWriters' -ET- line=<numéro> de ligne Échec de l’assertion = 'fNoReaderWriterConflict' |
| 548984 | 980570 | CORRECTIF : Message d’erreur « Erreur d’index de texte intégral pendant la compression ou la décompression » lors de la reconstruction de l’index de recherche en texte intégral dans Microsoft SQL Server 2008 ou Microsoft SQL Server 2008 R2 |
| 548986 | 980832 | CORRECTIF : message d’erreur « Une assertion système case activée a échoué » lors de l’exécution d’une requête Transaction-SQL dans Microsoft SQL Server 2008 ou dans Microsoft SQL Server 2008 R2 |
| 451119 | 980849 | CORRECTIF : Vous constatez une latence élevée pour les agents de distribution pair à pair dans Microsoft SQL Server 2005, Microsoft SQL Server 2008 ou Microsoft SQL Server 2008 R2 |
| 548988 | 981120 | CORRECTIF : Message d’erreur lors de l’activation de TDE sur une base de données pour laquelle l’isolation de capture instantanée est activée dans SQL Server 2008 ou SQL Server 2008 R2 |
| 548990 | 982034 | CORRECTIF : la fonctionnalité de traduction ne fonctionne pas lorsque vous effectuez une action de regroupement dans un tableau croisé dynamique Excel qui utilise SSAS 2008 ou SSAS 2008 R2 comme source de données |
| 548996 | 982854 | CORRECTIF : message d’erreur « La mémoire système est insuffisante dans la liste de ressources « interne » pour exécuter cette requête lors de l’exécution d’une requête en texte intégral qui utilise des mots composés dans Microsoft SQL Server 2008 ou Microsoft SQL Server 2008 R2 |
| 548998 | 982857 | CORRECTIF : Message d’erreur lors de la configuration d’une réplication transactionnelle pour une base de données dans SQL Server 2008 ou SQL Server 2008 R2 |
| 549014 | 983577 | CORRECTIF : le processus d’exportation ne se termine jamais lorsque vous exportez un rapport qui a imbriqué des éléments de tableau matriciel dans Microsoft SQL Server Reporting Services 2008 vers les extensions prises en charge par les convertisseurs de saut de page dur |
| 442541 | 2022254 | SQL Server peut signaler l’erreur 18272 pendant les opérations de restauration |
| 549019 | 2028406 | CORRECTIF : des espaces vides entre certains éléments sont générés de manière incorrecte dans un rapport SQL Server 2008 ou SQL Server 2008 R2 |
| 549021 | 2028755 | CORRECTIF : un résultat incorrect est renvoyé lorsque vous exécutez une requête LIKE avec des caractères génériques et le classement Latin1_General_100_CS_AS dans Microsoft SQL Server 2008 ou dans Microsoft SQL Server 2008 R2 |
| 549040 | 2200755 | CORRECTIF : Message d’erreur lors de l’exécution d’une requête MDX dans SSAS 2008 ou SSAS 2008 R2 |
| 549042 | 2220252 | CORRECTIF : Un rapport de SQL Server 2005 utilisant la fonctionnalité de bascules de visibilité ne s’exécute pas correctement dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 547877 | 2222998 | CORRECTIF : une estimation de cardinalité incorrecte est renvoyée lorsque vous exécutez une requête dans SQL Server 2005, SQL Server 2008 ou SQL Server 2008 R2 |
| 549032 | 2248999 | CORRECTIF : un index est corrompu lorsque vous mettez à jour un affichage dans Microsoft SQL Server 2008 ou Microsoft SQL Server 2008 R2 |
| 549044 | 2255410 | Une requête renvoie des résultats incohérents avant la préparation du cache de données dans SSAS 2008 ou SSAS 2008 R2 |
| 561761 | 2261403 | CORRECTIF : L’objet de performance « SQL Server :SSIS Pipeline 10.0 » n’apparaît pas dans la liste « Objet de performance » alors qu’un autre utilisateur accède à des compteurs de pipeline SSIS dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 549030 | 2264562 | CORRECTIF : l’exécution d’une requête en texte intégral qui utilise le prédicat CONTAINS ou FREETEXT avec l’opérateur « OU » est longue dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 561767 | 2276330 | CORRECTIF : la fonction « CHANGETABLE » est lente dans SQL Server 2008 et dans SQL Server 2008 R2 |
| 519628 | 2276495 | CORRECTIF : Une « erreur du système de fichiers » se produit lorsque vous essayez d’exécuter une opération de mise à jour de processus sur une dimension dans Microsoft SQL Server 2008 R2 Analysis Services |
| 561769 | 2276717 | CORRECTIF : code d’erreur 1456 lorsque vous ajoutez un témoin à une nouvelle session de mise en miroir de bases de données portant le même nom de base de données qu’une session de mise en miroir de bases de données existante dans Microsoft SQL Server 2005, Microsoft SQL Server 2008 et Microsoft SQL Server 2008 R2 |
| 561772 | 2278042 | CORRECTIF : une transformation de colonne dérivée peut générer des résultats incorrects dans SSIS 2008 ou SSIS 2008 R2 lorsqu’une colonne est dérivée à la fois en lecture seule et en lecture/écriture |
| 524544 | 2284503 | CORRECTIF : Vous rencontrez deux problèmes lorsque vous utilisez Microsoft SQL Server 2008 R2 Master Data Services (MDS) |
| 528558 | 2291551 | CORRECTIF : Une erreur se produit lorsque vous essayez de configurer une base de données de serveur de rapports distante à l’aide de Reporting Services Configuration Manager dans la Datacenter édition de SQL Server 2008 R2 Reporting Services |
| 526900 | 2291705 | CORRECTIF : les assemblys AMO, ADOMD.NET et XMLA pour Microsoft SQL Server 2008 R2 ont des dépendances incorrectes sur l’assembly Microsoft.SharePoint.dll et l’assembly Microsoft.AnalysisServices.SharePoint.Integration.dll |
| 536667 | 2293053 | CORRECTIF : l’ID d’en-tête de colonne contient de manière incorrecte des informations de préfixe lorsque vous utilisez le contrôle « ReportViewer » de Visual Studio 2010 pour exécuter un rapport localement |
| 547891 | 2295869 | CORRECTIF : Un blocage non résolu se produit lors de la récupération d’une base de données dans SQL Server 2005 SP3 ou dans SQL Server 2008 R2 |
| 534262 | 2297308 | CORRECTIF : Une tentative de configuration filestream précédente était incomplète et une violation d’accès se produisent lorsque vous effectuez une configuration post-installation de la fonctionnalité FILESTREAM sur un cluster de basculement SQL Server 2008 ou SQL Server 2008 R2 |
| 534101 | 2300689 | CORRECTIF : Vous ne pouvez pas restaurer la sauvegarde d’une base de données sur une autre instance de SQL Server si vous désactivez le chiffrement transparent des données avant de créer la sauvegarde dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 544205 | 2344694 | CORRECTIF : certaines fonctions de suivi des modifications et vues de gestion dynamique ne fonctionnent pas correctement après le basculement automatique de la mise en miroir de bases de données dans SQL Server 2008 R2 |
| 536267 | 2359606 | CORRECTIF : Le message d’erreur « System.OverflowException : La valeur était trop grande ou trop petite pour un Int32 » se produit lorsque vous essayez de générer un rapport dans Microsoft SQL Server 2008 R2 Reporting Services |
| 561798 | 2380361 | CORRECTIF : Message d’erreur lors de l’exécution de la procédure stockée « sp_createstats » dans SQL Server 2008 ou SQL Server 2008 R2 si la table contient une colonne calculée non déterministe |
| 561800 | 2380435 | CORRECTIF : le plan de requête pour une procédure stockée n’est pas mis en cache si la procédure stockée utilise une variable BLOB et que la variable est utilisée dans une fonction de chaîne dans Microsoft SQL Server 2008 ou Microsoft SQL Server 2008 R2 |
| 561804 | 2384766 | CORRECTIF : la propriété ANSI_NULLS d’une vue indexée prend la valeur FALSE après la réplication de la vue indexée dans la base de données d’abonnement dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 561806 | 2387686 | CORRECTIF : Le message d’erreur « Une erreur de syntaxe MOF s’est produite » apparaît lorsque vous essayez d’installer SQL Server 2008 ou SQL Server 2008 R2 |
| 549656 | 2397020 | CORRECTIF : « L’accès est refusé. Le message d’erreur [0x80070005] » se produit dans SSCM lorsque vous essayez de modifier le mot de passe d’un compte SQL Server 2008 R2 dans Windows Vista ou dans une version ultérieure de Windows |
| 548720 | 2401453 | CORRECTIF : Message « Échec de la recherche : Impossible de récupérer les données pour cette requête » lorsque vous recherchez des objets de base de données SQL Azure dans l’onglet « Détails de l’Explorateur d’objets » de SQL Server 2008 R2 Management Studio |
| 554322 | 2407088 | CORRECTIF : l’erreur « Sys.ArgumentNullException » se produit lorsque vous ouvrez un rapport d’extraction dans un composant WebPart Report Viewer si vous utilisez le mode intégré SharePoint dans SQL Server 2008 R2 Reporting Services |
| 555924 | 2410425 | CORRECTIF : Une exception s’affiche lorsque vous essayez de créer une base de données MDS dans SQL Server 2008 R2 MDS si une table de base de données non-MDS est nommée « tblSystem » |
| 555933 | 2412136 | CORRECTIF : la grille de l’Explorateur d’entités affiche quelques lignes dans un site web MDS SQL Server 2008 R2 si vous utilisez une faible résolution d’écran |
| 560368 | 2421014 | CORRECTIF : Message d’erreur « Une erreur grave s’est produite sur la commande actuelle » lors de l’utilisation de la fonction Freetexttable ou Containstable sur une vue indexée dans une requête CTE dans SQL Server 2008 R2 |
| 554345 | 2428397 | CORRECTIF : Un message d’erreur « Incompatibilité de type » s’affiche lorsque vous essayez de supprimer une base de données PowerPivot incorporée d’une instance de SQL Server 2008 R2 Analysis Services installée en mode d’intégration SharePoint |
| 558922 | 2431362 | CORRECTIF : message d’erreur lors de la tentative de création d’une requête nommée dans un projet qui utilise Microsoft SQL Server 2008 R2 Parallel Data Warehouse comme source de données : Mot clé non pris en charge |
Informations sur le package de mise à jour cumulative
Informations sur le redémarrage
Vous devrez peut-être redémarrer l’ordinateur après avoir appliqué cette mise à jour cumulative.
Informations sur le Registre
Pour utiliser l’un des correctifs logiciels contenus dans ce package, il n’est pas nécessaire de modifier le Registre.
Comment désinstaller le package de mise à jour cumulative
Pour désinstaller le package de mise à jour cumulative, procédez comme suit :
Dans le Panneau de configuration, ouvrez le
Ajouter ou supprimer des programmes
l’objet.Cliquez sur
Modifier ou supprimer des programmes
.Pour afficher toutes les mises à jour de l’installation de SQL Server 2008 R2, cliquez pour sélectionner le bouton
Afficher les mises à jour
.Désinstallez le correctif logiciel cumulatif.
Références
Pour plus d’informations sur le modèle de maintenance incrémentielle pour SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.
935897
Un modèle de service incrémentiel est disponible auprès de l’équipe SQL Server pour proposer des correctifs logiciels pour les problèmes signalés
Pour plus d’informations sur le schéma d’appellation pour les mises à jour de SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
822499
Nouveau schéma d’appellation pour les packages de mise à jour logicielle Microsoft SQL Server
Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
824684
Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft