Package de mise à jour cumulative 5 pour SQL Server 2008 R2

S’applique à
SQL Server 2008 R2 Datacenter SQL Server 2008 R2 Developer SQL Server 2008 R2 Enterprise SQL Server 2008 R2 Express SQL Server 2008 R2 Express with Advanced Services SQL Server 2008 R2 Standard SQL Server 2008 R2 Standard Edition for Small Business SQL Server 2008 R2 Web SQL Server 2008 R2 Workgroup

INTRODUCTION

La mise à jour cumulative 5 contient des correctifs logiciels pour les problèmes de Microsoft SQL Server 2008 R2 qui ont été résolus depuis la publication de SQL Server 2008 R2.

Remarque : cette version de ce package de mise à jour cumulative est également appelée build 10.50.1753.0.

Nous vous recommandons de tester les correctifs logiciels avant de les déployer dans un environnement de production. Étant donné que les builds sont cumulatives, chaque nouvelle publication de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif de SQL Server 2008 R2. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

981356 Builds SQL Server 2008 R2 publiées après SQL Server 2008 R2

Remarques importantes sur le package de mise à jour cumulative

  • Les correctifs logiciels contenus dans ce package de mise à jour cumulative sont inclus dans SQL Server 2008 R2 Service Pack 1 (SP1).
  • Les correctifs logiciels de SQL Server 2008 R2 sont désormais multilingues. Il n’existe donc qu’un seul correctif logiciel cumulatif pour toutes les langues.
  • Un correctif logiciel cumulatif inclut tous les packages des composants. Le package de mise à jour cumulative met à jour uniquement les composants installés sur le système.

Informations supplémentaires

Procédure pour obtenir la mise à jour cumulative 5 pour SQL Server 2008 R2

Un package de mise à jour cumulative pris en charge est désormais disponible auprès de Microsoft. Toutefois, elle est destinée à corriger uniquement les problèmes décrits dans cet article. Appliquez-le uniquement aux systèmes qui rencontrent ces problèmes spécifiques. Ce package de mise à jour cumulative peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par l’un de ces problèmes, nous vous recommandons d’attendre le prochain Service Pack SQL Server 2008 R2 qui contiendra les correctifs logiciels contenus dans ce package de mise à jour cumulative.

Si la mise à jour cumulative est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le package de mise à jour cumulative auprès des services de Support technique Microsoft.

Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à ce package de mise à jour cumulative. Pour obtenir la liste complète des numéros de téléphone des services d’assistance technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site web de Microsoft à l’adresse suivante :

/contactus/ ?ws=support

Correctifs logiciels SQL Server 2008 inclus dans la mise à jour cumulative 5 pour SQL Server 2008 R2

  Les articles de la Base de connaissances Microsoft qui traitent de ces correctifs logiciels seront publiés dès qu’ils seront disponibles.

  Pour plus d’informations sur les bogues de SQL Server, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :

Numéro de bogue VSTS Numéro d’article de la Base de connaissances Description
561808 942712 CORRECTIF : le processus W3WP.exe d’Internet Information Services s’arrête de manière inattendue lorsque vous configurez une réplication de fusion qui utilise la synchronisation Web dans SQL Server 2005, SQL Server 2008 et SQL Server 2008 R2
621237 975752 CORRECTIF : Le message d’erreur « ConnConnectAndSetCryptoForXpstar failed (0) » se produit lorsque vous essayez de démarrer le service SQL Server Agent à partir d’une session Bureau à distance dans SQL Server 2008 ou dans SQL Server 2008 R2
548994 982564 CORRECTIF : il est impossible d’exécuter la visionneuse de profils de données pour ouvrir un profil de données dans SQL Server 2008 ou SQL Server 2008 R2 si le composant Integration Services n’est pas installé sur le serveur
561818 982808 Un rapport d’extraction peut ne pas fonctionner correctement si l’option « Demander des informations d’identification » est utilisée dans les sources de données de SQL Server 2008 Reporting Service ou de SQL Server 2008 R2 Reporting Services
561747 2214666 CORRECTIF : Un package SSIS qui utilise la transformation Unpivot peut produire des résultats incohérents dans SQL Server 2008 ou SQL Server 2008 R2
561753 2256829 CORRECTIF : Un certain nombre des dernières colonnes XML peut ne pas être répliqué correctement si vous utilisez la synchronisation web pour la réplication de fusion dans SQL Server 2008 ou SQL Server 2008 R2
561759 2260502 CORRECTIF : les performances de requête diminuent après la mise à niveau vers SQL Server 2008 ou SQL Server 2008 R2 à partir de SQL Server 2000 si la requête utilise une fonction scalaire définie par l’utilisateur
561792 2287990 CORRECTIF : la transformation « Colonne dérivée » peut produire des résultats incorrects lorsque vous exécutez un package dans Microsoft SQL Server 2008 ou SQL Server 2008 R2 Integration Services
561790 2292725 CORRECTIF : vous rencontrez une diminution des performances lors de l’exécution d’une requête MDX dans SQL Server 2008 SP1 pour lequel la mise à jour cumulative 5 ou une version ultérieure du package de mise à jour est installée
571992 2295460 Correctif : Message d’erreur de réplication lors de l’inscription d’un résolveur personnalisé dans une réplication de fusion dans SQL Server 2005 ou SQL Server 2008 si une colonne BIGINT contient une valeur NULL
571988 2295878 CORRECTIF : les pages métier allouées dans une instruction INSERT ayant échoué peuvent ne pas être récupérées après l’application de SQL Server 2005 SP3 ou de SQL Server 2008 SP1
561784 2297709 CORRECTIF : Un message d’erreur peut s’afficher lorsque vous exécutez une requête « BULK INSERT » sur une base de données qui utilise le modèle de récupération « BULK_LOGGED » ou « Simple » dans SQL Server 2008
561788 2306162 CORRECTIF : Des performances médiocres et quelques erreurs occasionnelles de planification non productives se produisent lorsque vous créez une vue complexe qui référence un grand nombre de vues ou de tables imbriquées dans SQL Server 2008
561794 2344600 CORRECTIF : L’erreur « Planificateur non productif » peut se produire lorsque vous utilisez la fonction CONTAINSTABLE avec de nombreux prédicats OU et ET dans SQL Server 2008
561796 2352413 CORRECTIF : Un échec de requête et un message d’erreur « Nom de colonne non valide » se produisent lorsque vous exécutez une requête de serveur lié sur une autre instance de SQL Server 2008
561743 2379466 CORRECTIF : le code d’erreur « 0x84B10001 », l’échec de l’installation de SQL Server 2008 et une exception non gérée se produisent lors de l’installation de SQL Server 2008
621235 2380361 CORRECTIF : Message d’erreur lors de l’exécution de la procédure stockée « sp_createstats » dans SQL Server 2008 ou SQL Server 2008 R2 si la table contient une colonne calculée non déterministe
621231 2404865 CORRECTIF : utilisation élevée du processeur lors de l’exécution d’une tâche SQL Server Agent dans SQL Server 2008 ou SQL Server 2008 R2 si une colonne d’une instruction SELECT dynamique contient une valeur de plusieurs caractères
572008 2407172 CORRECTIF : Une exception se produit avant que la sortie d’erreur pour les données non valides d’une tâche « Source XML » ne soit redirigée dans SSIS 2005 ou SSIS 2008
621233 2412203 Le message d’erreur « L’insertion en bloc avec un autre jeu de résultats en suspens doit être exécuté avec XACT_ABORT activé » peut apparaître lorsque vous exécutez une transaction DTC ou MARS dans SQL Server 2008 ou SQL Server 2008 R2
572015 2413430 CORRECTIF : Le message d’erreur « Impossible de localiser l’enregistrement de version et la page n’est pas allouée » se produit lorsque vous reconstruisez un index à l’aide de l’option EN LIGNE dans SQL Server 2005 ou SQL Server 2008
560662 2422010 CORRECTIF : une fuite de mémoire se produit lorsque vous utilisez SQL Server Native Client 10.5 pour exécuter des instructions préparées dans une instance de SQL Server
564121 2428310 CORRECTIF : Vous pouvez obtenir des résultats incohérents lorsque vous utilisez l’opérateur APPLY dans une requête dans Microsoft SQL Server 2008 R2
621239 2428916 CORRECTIF : Une alerte de condition de performances est incorrectement déclenchée dans SQL Server 2008 ou SQL Server 2008 R2 si un classement sensible à la casse est configuré
621229 2430162 CORRECTIF : Le message d’erreur « L’expression contient une fonction qui ne peut pas fonctionner sur un ensemble avec plus de 4 294 967 296 tuples » se produit lorsque vous essayez d’exécuter une requête MDX dans SSAS 2008 ou dans SSAS 2008 R2
568300 2431178 CORRECTIF : message d’erreur et l’état n’est pas imprimé à partir du site web Report Manager dans SSRS 2008 ou SQL Server 2008 R2 si vous utilisez le mode protégé Internet Explorer dans Internet Explorer 8
621225 2431212 CORRECTIF : les rapports au format HTML ne sont pas conformes à l’article 1194.22 des Normes pour l’accessibilité en matière de technologies de l’information et de l’électronique lorsque vous utilisez SSRS 2008 ou SSRS 2008 R2 pour générer le rapport
621241 2432235 CORRECTIF : une consommation élevée de mémoire peut se produire lorsque vous reconstruisez une partition unique de la table de segment de mémoire dans SQL Server 2008
572059 2444085 CORRECTIF : erreur « La transaction est déjà abandonnée (WinMgmt) » lorsque vous exécutez des transactions DTC de BizTalk Server 2009 vers SQL Server 2008 R2 si les notifications d’événements sont activées
568305 2445751 CORRECTIF : erreur « Une erreur s’est produite au cours de cette opération » lors de l’impression d’un rapport à partir d’un site web SharePoint Server 2010 dans Internet Explorer 8
621254 2446036 CORRECTIF : des erreurs de compilation MOF se produisent et l’installation échoue pour SQL Server 2008 ou SQL Server 2008 R2
577525 2448991 CORRECTIF : Les variables d’un package SSIS 2008 ou 2005 sont évaluées de manière incorrecte lorsque vous exécutez le package en parallèle
609268 2452564 CORRECTIF : Signaler une erreur de projet de serveur lors d’une opération de génération, de propre ou d’aperçu dans SQL Server 2008 R2 BIDS
612738 2455614 CORRECTIF : BIDS for SQL Server 2008 R2 répond très lentement lorsque vous concevez une requête MDX qui a de nombreux paramètres de requête
612910 2456499 CORRECTIF : Message d’erreur lorsque vous essayez d’exécuter une requête sémantique basée sur un projet de modèle de rapport qui utilise une base de données PDW SQL Server 2008 R2 comme source de données
551035 2458438 CORRECTIF : Microsoft SQL Server 2008 R2 Analysis introduit de nouveaux événements de trace pour suivre l’utilisation des ressources et l’activité de verrouillage dans SQL Server Profiler
619190 2462084 CORRECTIF : Une feuille de calcul Excel contient des sous-totaux automatiques inattendus lors de l’exportation d’un rapport SSRS 2008 R2 qui utilise la fonctionnalité bascule de visibilité vers un fichier Excel
620430 2463203 CORRECTIF : Une grille analytique connectée à SSAS 2008 R2 renvoie des données incorrectes lorsque vous appliquez un filtre à la grille analytique dans le PerformancePoint Dashboard Designer
618731 2476357 CORRECTIF : Un rapport d’extraction n’est pas affiché si vous installez CU3 pour une application complémentaire SSRS 2008 R2 sur un serveur SharePoint 2010
649242 2496375 CORRECTIF : Avertissement « Impossible d’ouvrir la mémoire partagée globale pour communiquer avec une DLL de performance » lors de l’exécution d’un package SSIS 2008 ou SSIS 2008 R2 sur un ordinateur exécutant Windows XP

Informations sur le package de mise à jour cumulative

Informations sur le redémarrage

  Vous devrez peut-être redémarrer l’ordinateur après avoir appliqué cette mise à jour cumulative.

Informations sur le Registre

  Pour utiliser l’un des correctifs logiciels contenus dans ce package, il n’est pas nécessaire de modifier le Registre.

Comment désinstaller le package de mise à jour cumulative

  Pour désinstaller le package de mise à jour cumulative, procédez comme suit :

  1. Dans le Panneau de configuration, ouvrez le
    Ajouter ou supprimer des programmes
      l’objet.

  2. Cliquez sur
    Modifier ou supprimer des programmes
      .

  3. Pour afficher toutes les mises à jour de l’installation de SQL Server 2008 R2, cliquez pour sélectionner le bouton
    Afficher les mises à jour
      .

  4. Désinstallez le correctif logiciel cumulatif.

Références

  Pour plus d’informations sur le modèle de maintenance incrémentielle pour SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

935897
  Un modèle de service incrémentiel est disponible auprès de l’équipe SQL Server pour proposer des correctifs logiciels pour les problèmes signalés

  Pour plus d’informations sur le schéma d’appellation pour les mises à jour de SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

822499
  Nouveau schéma d’appellation pour les packages de mise à jour logicielle Microsoft SQL Server
   Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

824684
  Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft