INTRODUCTION
La mise à jour cumulative 7 contient des correctifs logiciels pour les problèmes de Microsoft SQL Server 2008 R2 qui ont été résolus depuis la publication de SQL Server 2008 R2.
Remarque : cette version de ce package de mise à jour cumulative est également appelée build 10.50.1777.0.
Nous vous recommandons de tester les correctifs logiciels avant de les déployer dans un environnement de production. Étant donné que les builds sont cumulatives, chaque nouvelle publication de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif de SQL Server 2008 R2. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
981356 Builds SQL Server 2008 R2 publiées après SQL Server 2008 R2
Remarques importantes sur le package de mise à jour cumulative
- Les correctifs logiciels de SQL Server 2008 R2 sont désormais multilingues. Il n’existe donc qu’un seul correctif logiciel cumulatif pour toutes les langues.
- Un correctif logiciel cumulatif inclut tous les packages des composants. Le package de mise à jour cumulative met à jour uniquement les composants installés sur le système.
Informations supplémentaires
Procédure pour obtenir la mise à jour cumulative 7 pour SQL Server 2008 R2
Un package de mise à jour cumulative pris en charge est désormais disponible auprès de Microsoft. Toutefois, elle est destinée à corriger uniquement les problèmes décrits dans cet article. Appliquez-le uniquement aux systèmes qui rencontrent ces problèmes spécifiques. Ce package de mise à jour cumulative peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par l’un de ces problèmes, nous vous recommandons d’attendre le prochain Service Pack SQL Server 2008 R2 qui contiendra les correctifs logiciels contenus dans ce package de mise à jour cumulative.
Si la mise à jour cumulative est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le package de mise à jour cumulative auprès des services de Support technique Microsoft.
Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à ce package de mise à jour cumulative. Pour obtenir la liste complète des numéros de téléphone des services d’assistance technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site web de Microsoft à l’adresse suivante :
Problème connu
Problème de compatibilité IntelliSense avec Visual Studio 2010 SP1
Si vous avez SQL Server 2008 R2 Management Studio RTM installé sur un ordinateur qui exécute Visual Studio 2010 SP1, vous pouvez rencontrer un problème de compatibilité entre Microsoft SQL Server 2008 R2 Management Studio (SSMS 2008 R2) et le service de langage Transact-SQL inclus dans Visual Studio 2010 SP1. Pour résoudre ce problème, installez la mise à jour cumulative 7 pour SQL Server 2008 R2.
Remarque Pour plus d’informations sur ce problème, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
2531482 CORRECTIF : la fonctionnalité IntelliSense dans SQL Server Management Studio pour SQL Server 2008 R2 peut cesser de fonctionner après l’installation de Visual Studio 2010 Service Pack 1
Problème de compatibilité IntelliSense avec Visual Studio 2010 RTM
Si vous installez la mise à jour cumulative 7 pour SQL Server 2008 R2 sur un ordinateur avec Visual Studio 2010 RTM, vous risquez de perdre les fonctionnalités de SQL IntelliSense dans Visual Studio. Pour résoudre ce problème, installez Visual Studio 2010 Service Pack 1 (SP1). Pour télécharger ce Service Pack, reportez-vous au site Web de Microsoft à l’adresse suivante :
https://www.microsoft.com/download/en/details.aspx?familyid=75568aa6-8107-475d-948a-ef22627e57a5
Correctifs logiciels SQL Server 2008 inclus dans la mise à jour cumulative 7 pour SQL Server 2008 R2
Les articles de la Base de connaissances Microsoft qui traitent de ces correctifs logiciels seront publiés dès qu’ils seront disponibles.
Pour plus d’informations sur les bogues de SQL Server, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
| Numéro de bogue VSTS | Numéro d’article de la Base de connaissances | Description |
|---|---|---|
| 693751 | 968215 | CORRECTIF : Message d’erreur lorsque vous essayez d’insérer en bloc des données dans un tableau qui contient une colonne de type DATE qui utilise un format de date américain dans SQL Server 2008 ou dans SQL Server 2008 R2 : « Erreur de conversion de données de chargement en bloc » |
| 577391 | 2451688 | CORRECTIF : erreur « CPerIndexMetaQS ::ErrorAbort - Index corruption » lorsque vous essayez de mettre à jour une vue partitionnée dans SQL Server 2008 R2 |
| 693773 | 2476322 | CORRECTIF : une requête basée sur une expression de table commune qui utilise la fonction CHANGETABLE s’exécute très lentement dans SQL Server 2008 Service Pack 1 ou SQL Server 2008 R2 |
| 693789 | 2478514 | CORRECTIF : L’erreur « Le processus de fusion n’a pas pu accéder aux données de ligne » se produit lorsque le Agent de fusion s’arrête et que les lignes sont définies sur 4 dans la colonne genstatus de la table système msmerge_genhistory |
| 671187 | 2481274 | CORRECTIF : une requête qui utilise la fonction DATEDIFF peut s’exécuter lentement dans SQL Server 2005, SQL Server 2008 ou SQL Server 2008 R2 |
| 649228 | 2484392 | CORRECTIF : la colonne « xact_seqno » de la table « MSrepl_errors » n’enregistre pas une ligne ignorée dans SQL Server 2008 ou dans SQL Server 2008 R2 si vous utilisez le paramètre « -SkipErrors » dans le Agent de distribution |
| 669147 | 2489667 | CORRECTIF : SQL Server Agent tâche s’exécute de manière incorrecte si elle est planifiée pour s’exécuter toutes les heures le dernier jour de chaque semaine ou mois de SQL Server 2005, de SQL Server 2008 ou de SQL Server 2008 R2 |
| 693759 | 2491510 | CORRECTIF :une requête qui a un prédicat CONTAINS dans une clause WHERE prend beaucoup de temps à compiler dans SQL Server 2008 ou SQL Server 2008 R2 |
| 651087 | 2498818 | CORRECTIF : erreur 7359 lors de l’exécution d’une requête sur une fonction définie par l’utilisateur ou une vue qui utilise un synonyme sur un serveur lié dans SQL Server 2005, SQL Server 2008 ou SQL Server 2008 R2 |
| 658305 | 2503834 | CORRECTIF : erreur d’assertion lorsque vous essayez de récupérer une base de données dans SQL Server 2008 R2 |
| 658687 | 2504090 | CORRECTIF : violation d’accès lorsque vous insérez des données dans une nouvelle partition d’une table partitionnée après avoir supprimé une colonne de la table dans SQL Server 2008 R2 |
| 693790 | 2506795 | CORRECTIF : Erreur « Données insuffisantes pour une image » à l’ouverture d’un fichier .pdf exporté d’un environnement SQL Server 2008 Reporting Services ou SQL Server 2008 R2 Reporting Services |
| 663561 | 2506799 | CORRECTIF : les performances diminuent après le déplacement d’un rapport volumineux vers SQL Server 2008 R2 Reporting Services |
| 693793 | 2509659 | FIX : Le schéma dbo est préajouté lorsque vous utilisez une procédure stockée personnalisée dans la procédure stockée sp_addarticle |
| 693794 | 2510668 | Vous pouvez désormais utiliser l’Assistant Installation de package (Dtsinstall.exe) pour exécuter le fichier manifeste de déploiement d’un package SSIS lorsque SSIS 2008 ou SSIS 2008 R2 n’est pas installé |
| 693779 | 2511151 | CORRECTIF : la colonne d’une source de fichier plat n’est pas importée si les données de la colonne suivante sont d’un octet plus longues que la largeur de la colonne de sortie dans SSIS 2005, SSIS 2008 ou SSIS 2008 R2 |
| 696492 | 2515286 | CORRECTIF : « Il n’y a pas de fonction '{urn :schemas-microsoft-com :xml-sql} :variable() » pour une requête XQuery qui met à jour la valeur d’une colonne XML dans SQL Server 2005 ou dans SQL Server 2008 R2 |
| 674967 | 2515489 | CORRECTIF : les blocages « Exception 0xc0000005 EXCEPTION_ACCESS_VIOLATION » et SQL Server 2008 R2 se produisent lorsque vous démarrez une session d’événements étendus SQL Server et effectuez des actions liées aux événements de la session Xevent sur une base de données respectant la casse |
| 632655 | 2516163 | CORRECTIF : Report Builder 3.0 cesse de répondre après que vous avez exécuté une requête plus de deux fois sur un modèle de rapport dans SSRS 2008 R2 |
| 678726 | 2516439 | FIX : "Le script '/MDM/ScriptResource.axd' contient plusieurs appels à Sys.Application.notifyScriptLoaded(). Un seul est autorisé » sur un site web MDS SQL Server 2008 R2 |
| 676778 | 2518716 | CORRECTIF : le script d’un objet d’une base de données SQL Azure n’est pas généré lorsque vous utilisez SSMS 2008 R2 pour vous connecter à SQL Azure |
| 682304 | 2518808 | CORRECTION : erreur « Expression : (pCopySrc - command) <= (int) cmdLength » lorsque vous ajoutez une colonne à une table publiée dans une publication transactionnelle dans SQL Server 2008 R2 |
| 656666 | 2518876 | CORRECTIF : La requête MDX renvoie de manière incorrecte des valeurs NULL ou 0 pour certaines mesures si un membre calculé est utilisé sur l’axe des lignes dans SSAS 2008 R2 |
| 693777 | 2519358 | CORRECTIF : erreur « La valeur entière est hors limite » lorsque vous passez une valeur bigint comme argument last_sync_version de la fonction CHANGETABLE dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 687145 | 2520240 | CORRECTIF : erreur d’autorisation lors de l’affichage d’un dossier à l’aide du paramètre « ViewMode=WebpartList » dans la chaîne de requête pour Report Manager dans SQL Server 2008 R2 Reporting Services |
| 694625 | 2520808 | CORRECTIF : erreur de planificateur non productif lors de l’exécution d’une requête qui utilise un TVP dans SQL Server 2008 ou dans SQL Server 2008 R2 si SQL Profiler ou des événements étendus SQL Server sont utilisés |
| 666288 | 2521127 | CORRECTIF : la fenêtre PowerPivot ne s’ouvre pas lorsque vous ouvrez un fichier .xla ou .xlam dans Excel 2010 si PowerPivot pour Excel 2010 est installé |
| 691230 | 2522708 | CORRECTIF : les performances diminuent après le déplacement d’un rapport qui contient une grande liste de paramètres dans la liste déroulante à sélection multiple vers SQL Server 2008 R2 Reporting Services |
| 694834 | 2525273 | CORRECTIF : Un modèle de clustering qui utilise l’algorithme K-means génère différents résultats qui sont affectés par les colonnes PredictOnly dans SQL Server 2008 R2 Analysis Services |
| 680595 | 2526552 | CORRECTIF : SQL Server service de navigateur ne répond régulièrement pas aux demandes entrantes |
| 694133 | 2526959 | CORRECTIF : Problème de performances d’application lorsqu’une requête référence des tables temporaires créées dans une session dans SQL Server 2008 et SQL Server 2008 R2 |
| 701593 | 2531172 | CORRECTIF : erreur « Impossible d’obtenir le membre actuel » lors de l’exécution d’une requête MDX dans SQL Server 2008 R2 Analysis Services |
| 697004 | 2531482 | CORRECTIF : la fonctionnalité Intellisense dans SQL Server Management Studio pour SQL Server 2008 R2 peut cesser de fonctionner après l’installation de Visual Studio 2010 Service Pack 1 |
| 686145 | 2532079 | CORRECTIF : les instructions DML ne s’exécutent pas sur certaines colonnes d’une table après l’activation de CDC sur d’autres colonnes dans SQL Server 2008 R2 |
| 676778 | 2518716 | CORRECTIF : le script d’un objet d’une base de données SQL Azure n’est pas généré lorsque vous utilisez SSMS 2008 R2 pour vous connecter à SQL Azure |
Informations sur le package de mise à jour cumulative
Informations sur le redémarrage
Vous devrez peut-être redémarrer l’ordinateur après avoir appliqué cette mise à jour cumulative.
Informations sur le Registre
Pour utiliser l’un des correctifs logiciels contenus dans ce package, il n’est pas nécessaire de modifier le Registre.
Comment désinstaller le package de mise à jour cumulative
Pour désinstaller le package de mise à jour cumulative, procédez comme suit :
Dans le Panneau de configuration, ouvrez le
Ajouter ou supprimer des programmes
l’objet.Cliquez sur
Modifier ou supprimer des programmes
.Pour afficher toutes les mises à jour de l’installation de SQL Server 2008 R2, cliquez pour sélectionner le bouton
Afficher les mises à jour
.Désinstallez le correctif logiciel cumulatif.
Références
Pour plus d’informations sur le modèle de maintenance incrémentielle pour SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.
935897
Un modèle de service incrémentiel est disponible auprès de l’équipe SQL Server pour proposer des correctifs logiciels pour les problèmes signalés
Pour plus d’informations sur le schéma d’appellation pour les mises à jour de SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
822499
Nouveau schéma d’appellation pour les packages de mise à jour logicielle Microsoft SQL Server
Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
824684
Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft