KB2720425 - Package de mise à jour cumulative 1 pour SQL Server 2008 R2 Service Pack 2

S’applique à
SQL Server 2008 R2 Datacenter SQL Server 2008 R2 Developer SQL Server 2008 R2 Enterprise SQL Server 2008 R2 Express SQL Server 2008 R2 Express with Advanced Services SQL Server 2008 R2 Standard SQL Server 2008 R2 Standard Edition for Small Business SQL Server 2008 R2 Web SQL Server 2008 R2 Workgroup

INTRODUCTION

Cet article décrit le package de mise à jour cumulative 1 pour Microsoft SQL Server 2008 R2 Service Pack 2 (SP2). Cette mise à jour contient des correctifs logiciels pour des problèmes résolus après la publication de SQL Server 2008 R2 SP2.

Remarque Le numéro de build de ce package de mise à jour cumulative est 10.50.4260.0.

Nous vous recommandons de tester les correctifs logiciels avant de les déployer dans un environnement de production. Étant donné que les builds sont cumulatives, chaque nouvelle publication de mise à jour contient tous les correctifs logiciels et toutes les mises à jour de sécurité qui ont été inclus dans la version précédente de la mise à jour de SQL Server 2008 R2. Nous vous recommandons d’envisager d’appliquer la mise à jour la plus récente qui contient ce correctif.

  Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2730301 Les builds SQL Server 2008 R2 publiées après SQL Server 2008 R2 Service Pack 2

Remarques importantes sur ce package de mise à jour cumulative

  • Les correctifs logiciels de SQL Server 2008 R2 sont désormais multilingues. Par conséquent, le package de mise à jour cumulative ne s’applique pas à une seule langue et s’applique à toutes les langues prises en charge.
  • Un package de mise à jour cumulative contient tous les packages des composants. Toutefois, le package de mise à jour cumulative ne met à jour que les composants installés sur le système.

Informations supplémentaires

Comment obtenir ce package de mise à jour cumulative

Un package de mise à jour cumulative pris en charge est désormais disponible auprès de Microsoft. Toutefois, elle est destinée à corriger uniquement les problèmes décrits dans cet article. Appliquez-le uniquement aux systèmes qui rencontrent ces problèmes spécifiques. Ce package de mise à jour cumulative peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par l’un de ces problèmes, nous vous recommandons d’attendre le prochain Service Pack SQL Server 2008 R2 qui contiendra les correctifs logiciels contenus dans ce package de mise à jour cumulative.

Si la mise à jour cumulative est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le package de mise à jour cumulative auprès des services de Support technique Microsoft.

Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à ce package de mise à jour cumulative. Pour obtenir la liste complète des numéros de téléphone des services d’assistance technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site web de Microsoft à l’adresse suivante :

/contactus/ ?ws=support

Correctifs logiciels inclus dans ce package de mise à jour cumulative

Les articles de la Base de connaissances Microsoft qui traitent de ces correctifs logiciels seront publiés dès qu’ils seront disponibles.

Pour plus d’informations sur les problèmes liés à SQL Server, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :

Numéro de bogue VSTS Numéro d’article de la Base de connaissances Description
956228 2543687 CORRECTIF : Erreurs lorsqu’une application cliente envoie un signal d’attention à SQL Server 2008 ou SQL Server 2008 R2
956225 2554905 CORRECTIF : Message d’erreur « Erreur de fichier : les données ont peut-être été perdues » lorsque vous utilisez Excel 2010 pour ouvrir un fichier de rapport Excel qui a été exporté de SSRS 2008, SSRS 2008 R2 ou de SSRS 2012
969181 2618676 CORRECTIF : la sauvegarde du journal des transactions est créée même si la sauvegarde complète est annulée dans SQL Server 2008 ou dans SQL Server 2008 R2
980532 2625768 CORRECTIF : une page de base de données est copiée dans un instantané de base de données, même si la page n’est pas mise à jour quand vous effectuez une opération de lecture dans SQL Server 2008 ou SQL Server 2008 R2
956212 2637802 CORRECTIF : Les pages d’un rapport SSRS 2008 R2 ou SSRS 2012 sont envoyées de manière incorrecte si vous utilisez la méthode ReportExecutionService.Render pour afficher le rapport au format image ou au format EMF
980515 2658474 CORRECTIF : résultats incorrects lorsque la méthode SqlConnection.GetSchema récupère les informations de schéma d’une table dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012
969183 2661644 CORRECTIF : Violation d’accès dans le sqlservr ! Fonction ReplicaToPrimaryPageCopier ::ReadIoCompletionRoutine dans SQL Server 2008 R2
956226 2665649 CORRECTIF : assertion « bufferLen >= colLen » lors de l’exécution d’une requête parallèle dans SQL Server 2008, dans SQL Server 2008 R2 ou dans SQL Server 2012
969185 2667037 CORRECTIF : erreur « Le format chaîne de connexion n’est pas valide » lorsque vous essayez de créer un plan de maintenance pour un serveur SQL Server 2008 R2
980534 2673997 CORRECTIF : Message d’erreur « Les données d’index sont endommagées » lorsque vous exécutez une requête MDX sur une dimension ou une partition dans SSAS 2008, SSAS 2008 R2 ou SSAS 2012
980525 2674636 CORRECTIF : la taille d’un fichier de base de données n’est pas réduite lorsque vous utilisez la commande DBCC SHRINKFILE dans SQL Server 2008 R2
956218 2675233 CORRECTIF : Performances ralenties lors de l’exécution d’une requête MDX qui utilise des sous-requêtes dans SSAS 2008 R2 ou dans SSAS 2012
956213 2675522 CORRECTIF : violation d’accès lors de l’exécution d’instructions DML sur une table contenant des index partitionnés dans SQL Server 2008 R2 ou SQL Server 2012
956224 2678796 CORRECTIF : Vous ne pouvez pas rechercher un document Word ou un classeur Excel exporté à partir d’un rapport SSRS 2008 R2 ou SSRS 2012 à l’aide d’un mot clé dans le contenu du document ou du classeur dans SharePoint 2010
956221 2679342 CORRECTIF : la liste des champs du jeu de données disparaît de manière inattendue lorsqu’un rapport utilise une requête comme un jeu de données qui inclut des paramètres nommés dans SQL Server 2008 R2 ou dans SQL Server 2012
956229 2682819 CORRECTIF : SQL Server 2008 R2 peut cesser de répondre lorsque vous effectuez de nombreuses transactions d’écriture différée de cube de mise à jour sur plusieurs cubes appartenant à des bases de données SSAS 2008 R2 ou SSAS 2012 différentes
956204 2685132 CORRECTIF : le travail de restauration de copie des journaux de transaction restaure une sauvegarde de journal des transactions endommagée dans une base de données secondaire lorsque vous exécutez une tâche de sauvegarde de copie des journaux de transaction sur une instance de SQL Server 2008 R2 ou une instance de SQL Server 2012
956230 2689903 CORRECTIF : une non-convergence se produit lorsque vous exécutez une publication de réplication de fusion qui utilise la synchronisation web si la valeur d’une colonne est NULL dans SQL Server 2008 R2 ou dans SQL Server 2012
980517 2696161 CORRECTIF : Message d’erreur lors de la tentative d’affichage d’un rapport dans SSRS 2008 R2 : « Différents paramètres de requête ont entraîné un même hachage »
969189 2697983 CORRECTIF : une valeur incorrecte est stockée dans la colonne TIME_ZONE de la table BACKUPSET dans SQL Server 2008 R2
956215 2698639 CORRECTIF : les performances d’une instruction SELECT contenant un opérateur LIKE et une clause ESCAPE sont faibles dans SQL Server 2008 R2
969191 2699013 CORRECTIF : SQL Server 2008 R2 ou SQL Server 2008 cesse de répondre et une erreur « Planificateur non productif » est consignée
956206 2700227 CORRECTIF : Message d’erreur lorsque vous essayez de créer un document de service de données dans une bibliothèque de flux de données à partir d’une collection de sous-sites dans SharePoint 2010 pour publier des flux Atom : « Il n’y a pas de fichier avec une URL »
980529 2703152 CORRECTIF : violation d’accès lorsque vous appelez une procédure stockée CLR qui référence un paramètre de type de table défini par l’utilisateur dans SQL Server 2012 ou dans SQL Server 2008 R2
969193 2703214 CORRECTIF : SQL Server 2008 R2 peut ne pas accepter la demande de connexion du client lorsque vous effectuez une insertion en bloc et qu’une erreur de système d’exploitation se produit
969195 2706519 CORRECTIF : Une exception se produit lorsque la méthode SqlCommandBuilder.DeriveParameters est utilisée pour récupérer des informations de paramètres à partir d’une procédure stockée CLR dans SQL Server 2008 R2
969197 2706601 CORRECTIF : les groupes de séries d’un rapport sont manquants lorsque vous rendez le rapport dans SQL Server 2008 Reporting Services ou dans les versions ultérieures de Reporting Services
969199 2707015 CORRECTIF : erreur rsInternalError lors de l’exportation d’un rapport qui contient un contrôle Tablix dans SSRS 2008 R2
969201 2708027 CORRECTIF : Message d’erreur « Une erreur s’est produite lors du traitement du rapport » lorsque vous essayez d’afficher un aperçu d’un rapport SSRS 2008 R2 après avoir défini le classement du jeu de données sur le grec ou le Greek_100
969203 2708726 CORRECTIF : les fichiers Analyseur de performances .dll du dossier system32 ne sont pas mis à jour après l’application des mises à jour à SQL Server 2008 R2
969207 2713501 CORRECTIF : Un blocage se produit lorsque vous modifiez une partition et exécutez une instruction sur la partition en même temps dans SQL Server 2008 R2
969209 2714634 CORRECTIF : SQL Server 2008 R2 prend beaucoup de temps à générer des scripts pour une table partitionnée qui utilise la fonctionnalité de compression de données
969213 2715289 CORRECTIF : résultats incorrects lorsque vous convertissez une colonne datetimeoffset en une colonne smalldatetime dans SQL Server 2008 R2 lorsqu’il existe un index sur la colonne datetimeoffset
969211 2715312 CORRECTIF : Erreurs survenant lors de l’exécution d’une requête qui utilise la clause XML FOR en mode PATH dans SQL Server 2008 R2

            
            
          

Informations sur le package de mise à jour cumulative

Informations sur le redémarrage

  Vous devrez peut-être redémarrer votre ordinateur après avoir appliqué ce package de mise à jour cumulative.

Informations sur le Registre

  Pour utiliser l’un des correctifs logiciels contenus dans ce package, il n’est pas nécessaire de modifier le Registre.

Comment désinstaller ce package de mise à jour cumulative

Pour désinstaller ce package de mise à jour cumulative, procédez comme suit :

  1. Dans le Panneau de configuration, ouvrez l’élément Ajout/Suppression de programmes.

    Remarque Si vous utilisez Windows 7, ouvrez l’élément Programmes et fonctionnalités du Panneau de configuration.

  2. Recherchez l’entrée installée par ce package de mise à jour cumulative.

  3. Cliquez avec le bouton droit sur l’entrée et sélectionnez Désinstaller pour supprimer le package de mise à jour cumulative.

Références

  Pour plus d’informations sur le modèle de maintenance incrémentielle pour SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

935897
  Un modèle de service incrémentiel est disponible auprès de l’équipe SQL Server pour proposer des correctifs logiciels pour les problèmes signalés

  Pour plus d’informations sur le schéma d’appellation pour les mises à jour de SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

822499
  Nouveau schéma d’appellation pour les packages de mise à jour logicielle Microsoft SQL Server
   Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

824684
  Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft