INTRODUCTION
Cet article décrit le package de mise à jour cumulative 3 pour Microsoft SQL Server 2008 R2 Service Pack 2 (SP2). Cette mise à jour contient des correctifs logiciels pour des problèmes résolus après la publication de SQL Server 2008 R2 SP2.
Remarque Le numéro de build de ce package de mise à jour cumulative est 10.50.4266.0.
Nous vous recommandons de tester les correctifs logiciels avant de les déployer dans un environnement de production. Étant donné que les builds sont cumulatives, chaque nouvelle publication de mise à jour contient tous les correctifs logiciels et toutes les mises à jour de sécurité qui ont été inclus dans la version précédente de la mise à jour de SQL Server 2008 R2. Nous vous recommandons d’envisager d’appliquer la mise à jour la plus récente qui contient ce correctif.
Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
2730301 Les builds SQL Server 2008 R2 publiées après SQL Server 2008 R2 Service Pack 2
Remarques importantes sur ce package de mise à jour cumulative
- Les correctifs logiciels de SQL Server 2008 R2 sont désormais multilingues. Par conséquent, ce package de mise à jour cumulative ne s’applique pas à une seule langue, mais à toutes les langues prises en charge.
- Un package de mise à jour cumulative contient tous les packages des composants. Toutefois, le package de mise à jour cumulative ne met à jour que les composants installés sur le système.
Informations supplémentaires
Comment obtenir ce package de mise à jour cumulative
Un package de mise à jour cumulative pris en charge est désormais disponible auprès de Microsoft. Toutefois, elle est destinée à corriger uniquement les problèmes décrits dans cet article. Appliquez-le uniquement aux systèmes qui rencontrent ces problèmes spécifiques. Ce package de mise à jour cumulative peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par l’un de ces problèmes, nous vous recommandons d’attendre le prochain Service Pack SQL Server 2008 R2 qui contiendra les correctifs logiciels contenus dans ce package de mise à jour cumulative.
Si la mise à jour cumulative est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le package de mise à jour cumulative auprès des services de Support technique Microsoft.
Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à ce package de mise à jour cumulative. Pour obtenir la liste complète des numéros de téléphone des services d’assistance technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site web de Microsoft à l’adresse suivante :
Correctifs logiciels inclus dans ce package de mise à jour cumulative
Les articles de la Base de connaissances Microsoft qui traitent de ces correctifs logiciels seront publiés dès qu’ils seront disponibles.
Pour plus d’informations sur les problèmes liés à SQL Server résolus par cette mise à jour cumulative, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft.
| Numéro de bogue VSTS | Numéro d’article de la Base de connaissances | Description |
|---|---|---|
| 1022540 | 963659 | CORRECTIF : des messages d’erreur s’affichent lorsque vous effectuez un remplissage pour un index de recherche en texte intégral volumineux dans SQL Server 2008 ou SQL Server 2008 R2 |
| 1056313 | 2406666 | CORRECTION : erreur « [Base de données Teradata] [3737] » lorsque vous cliquez sur « Nombre » dans l’Assistant Conception d’agrégation dans SSAS 2008, SSAS 2012 ou SSAS 2008 R2 |
| 1033521 | 2633271 | CORRECTIF : Impossible d’arrêter les services SQL Server sur un ordinateur sur lequel SQL Server 2008 R2 Express Edition est installé |
| 1056307 | 2667742 | CORRECTIF : erreur « mémoire insuffisante » lorsque vous utilisez ODBC avec SQL Server 2012, SQL Server 2008 R2 ou SQL Server 2008 |
| 1027403 | 2699687 | CORRECTIF : erreur « L’opération OLE DB en plusieurs étapes a généré des erreurs » lorsque vous insérez des données de type DATETIME dans une colonne de type SMALLDATETIME dans SQL Server 2008 R2 |
| 1043421 | 2707185 | CORRECTIF : une requête MDX dans SQL Server 2008 R2 s’exécute très lentement si la requête contient des fonctions Crossjoin imbriquées |
| 1043441 | 2714634 | CORRECTIF : SQL Server 2008 R2 ou SQL Server 2012 prend beaucoup de temps pour générer des scripts pour une table partitionnée qui utilise la fonctionnalité de compression de données |
| 1046951 | 2718920 | CORRECTIF : SQL Server Agent enregistre les journaux détaillés dans le journal des applications lorsque vous démarrez un cluster de basculement instance dans SQL Server 2012 ou SQL Server 2008 R2 |
| 1043431 | 2723979 | CORRECTIF : violation d’accès dans le moniteur de blocage interne de SQL SQL Server lorsque vous exécutez plusieurs applications avec plusieurs jeux de résultats actifs activés dans SQL Server 2008 R2 ou dans SQL Server 2012 |
| 1043427 | 2728419 | CORRECTIF : message d’erreur « Le processus de réglage s’est arrêté de manière inattendue » lorsque vous exécutez Assistant Paramétrage du moteur de base de données sous le rôle db_owner dans SQL Server 2008 R2 ou dans SQL Server 2012 |
| 1043433 | 2728534 | CORRECTIF : erreur « une assertion système case activée a échoué » lorsque vous recréez un index non-cluster sur une colonne dans SQL Server 2008 R2 ou dans SQL Server 2012 |
| 1043437 | 2729495 | CORRECTIF : erreur « La syntaxe de la représentation en chaîne d’une valeur DateHeure est incorrecte » lorsque vous utilisez SQL Server 2008 R2 PowerPivot pour Excel 2010 |
| 1043429 | 2732742 | CORRECTIF : les performances diminuent lorsque vous exécutez une requête parallèle après la mise à niveau de SQL Server 2008 vers SQL Server 2008 R2 |
| 1043447 | 2733630 | L’agent de fusion peut échouer pendant la synchronisation de la réplication de fusion dans SQL Server 2008 R2 ou dans SQL Server 2012 |
| 1056326 | 2737161 | CORRECTIF : impossible d’ajouter un article à une publication qui se trouve dans un partenariat de mise en miroir de bases de données dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 1043435 | 2737499 | CORRECTIF : La propriété KeepTogether ne fonctionne pas lorsque vous générez un rapport contenant un tableau matriciel dans SSRS 2008 R2 ou SSRS 2012 |
| 1019746 | 2739213 | CORRECTIF : Message d’erreur lorsque vous affichez un rapport SSRS qui utilise le paramètre rc :Toolbar=false dans l’URL : « Une erreur s’est produite dans la base de données du serveur de rapports » |
| 1043443 | 2741143 | CORRECTIF : résultats incorrects lors de l’exécution d’une requête MDX en mode de stockage ROLAP dans SQL Server 2008 R2 Analysis Services |
| 1047773 | 2752432 | CORRECTIF : utilisation élevée du processeur lors de l’interrogation d’une colonne d’objet binaire volumineux à l’aide de l’indicateur NOLOCK dans SQL Server 2008 R2 |
| 1056329 | 2755079 | CORRECTIF : les modifications ne sont pas synchronisées pour les abonnés après la modification d’un filtre d’article dans une publication transactionnelle dans SQL Server 2008, SQL Server 2012 ou SQL Server 2008 R2 |
| 1050908 | 2755767 | CORRECTIF : une opération de restauration du journal des transactions prend plus de temps que prévu et une erreur 3402 se produit si un fichier de base de données est supprimé dans SQL Server 2008 R2 |
| 1053351 | 2762102 | CORRECTIF : résultat incorrect lorsque vous exécutez une requête MDX si la requête avec la fonction d’agrégation dans SSAS 2008 R2 |
Informations sur le package de mise à jour cumulative
Informations sur le redémarrage
Vous devrez peut-être redémarrer votre ordinateur après avoir appliqué ce package de mise à jour cumulative.
Informations sur le Registre
Pour utiliser l’un des correctifs logiciels contenus dans ce package, il n’est pas nécessaire de modifier le Registre.
Comment désinstaller ce package de mise à jour cumulative
Pour désinstaller ce package de mise à jour cumulative, procédez comme suit :
Dans le Panneau de configuration, ouvrez l’élément Ajout/Suppression de programmes.
Remarque Si vous utilisez Windows 7, ouvrez l’élément Programmes et fonctionnalités du Panneau de configuration.
Recherchez l’entrée installée par ce package de mise à jour cumulative.
Cliquez avec le bouton droit sur l’entrée, puis cliquez sur Désinstaller.
Références
Pour plus d’informations sur le modèle de maintenance incrémentielle pour SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.
935897
Un modèle de service incrémentiel est disponible auprès de l’équipe SQL Server pour proposer des correctifs logiciels pour les problèmes signalés
Pour plus d’informations sur le schéma d’appellation pour les mises à jour de SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
822499
Schéma d’appellation des packages de mise à jour logicielle de Microsoft SQL Server
Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
824684
Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft