KB4038634 - SQL Server 2017 用の累積的な更新プログラム 1

リリース日: 2017 年 10 月 24 日
バージョン: 14.0.3006.16

概要

この記事では、Microsoft SQL Server 2017 の累積的な更新プログラム パッケージ 1 (CU1) について説明します。 この更新プログラムには、SQL Server 2017 RTM のリリース後に発行された 71 個の修正が含まれており、次のビルドのコンポーネントを更新します。

  • SQL Server - 製品バージョン: 14.0.3006.16、ファイル バージョン: 2017.140.3006.16
  • Analysis Services - 製品バージョン: 14.0.1.439、ファイル バージョン: 2017.140.1.439

この更新プログラムの既知の問題

この累積的な更新プログラムに既知の問題はありません。

この更新プログラムに含まれる機能強化と修正プログラム

ビルドの概要リストと現在のサポート ライフサイクルを含む、ダウンロード可能な Excel ブックを用意しています。 また、Excel ファイルには、SQL Server 2019 とSQL Server 2017 の詳細な修正リストが含まれています。 この Excel ファイルを今すぐダウンロードすることを選択してください。

注

次の表の個々のエントリは、ブックマークから直接参照できます。 表でバグ リファレンス ID を選択すると、"#NNNNNNNN" 形式を使用して URL にブックマーク タグが追加されます。 その後、この URL を他のユーザーと共有して、テーブル内の目的の修正プログラムに直接ジャンプできます。

修正されたバグおよびこの累積的な更新プログラムに含まれる機能強化の詳細については、次のマイクロソフト サポート技術情報を参照してください。

バグ リファレンス 説明 修正領域 要素 プラットフォーム
10682349 修正プログラム: SQL Server 2017 および SQL Server 2016 (KB4024023) で .vmp ファイルにアクセスすると SSAS がクラッシュする Analysis Services Analysis Services すべて
10682367 修正: 表形式モード (KB4032543) の SSAS で DAX または MDX クエリを実行すると SSAS がクラッシュする Analysis Services Analysis Services すべて
10687745 修正: ディメンション セキュリティが SQL Server Analysis Services の Power BI Desktop によって無視される (多次元モデル) (KB4018908) Analysis Services Analysis Services すべて
10687757 修正: 別の階層 (KB4022753) の子メンバーである計算メンバーを参照する MDX クエリを実行すると、SSAS がクラッシュする Analysis Services Analysis Services すべて
10687784 修正: セキュリティ情報 MS16-136 で、SQL Server 2017 および SQL Server 2016 (KB4025402) の PowerPivot の SSRS データ ソースの種類が壊れる Analysis Services Analysis Services すべて
10868739 修正プログラム: SQL Server 2014 または 2017 で SSAS データベースまたはキューブを処理すると SSAS がクラッシュする (KB4039509) Analysis Services Analysis Services Windows
10868754 修正: SSAS (KB4033789) でプロセス更新操作を実行するとメモリ リークが発生する場合がある Analysis Services Analysis Services Windows
10868777 修正プログラム: SQL Server 2016 または 2017 Analysis Services が特定の状況でクラッシュすることがある (KB3208545) Analysis Services Analysis Services Windows
10965958 修正: XIRR メジャーが SSAS 2016 または 2017 で処理するレコードが多すぎると、予期しない例外エラーが発生する (KB4034789) Analysis Services Analysis Services Windows
10965991 修正: SQL Server 2016 または 2017 (KB4040085) で表形式モデル データベースを Analysis Services にデプロイするときの "あいまいなパス" エラー Analysis Services Analysis Services Windows
10682338 修正: SSAS (KB4022594) のテーブル階層メンバーでテーブルクロス結合が実行されると、MDX のクエリ結果が正しくありません Analysis Services Analysis Services すべて
10682343 修正プログラム: Power BI (KB4021994) で Null 値を参照するメジャーが追加されると、SSAS がクラッシュする Analysis Services Analysis Services すべて
10682356 修正プログラム: ProcessRecalc フェーズ (KB3212541) 中に数値集計列でエンコード スキームを変更する必要がある場合に、SSAS がクラッシュする Analysis Services Analysis Services すべて
10868755 修正: SQL Server 2017 (KB4040512) で Reporting Services レポートを PDF にエクスポートするとエラーが発生する Analysis Services Reporting Services すべて
10965982 修正: SSRS 2016 または 2017 (KB4039124) で基本認証モードを有効にすると、LSASS.EXE でメモリが急上昇する Analysis Services Reporting Services Windows
10965994 修正: SQL Server 2016 または 2017 (KB4043478) で iOS デバイスに SSRS レポートをエクスポートするとエラーが発生する Analysis Services Reporting Services Windows
10965998 修正: SSRS 2016 または 2017 Web ポータル (KB4039126) のサブスクリプション ページに水平スクロール バーが表示されない Analysis Services Reporting Services Windows
10965999 修正プログラム: "フォルダーは...SQL Server 2017 Reporting Service (KB4039125) の Web ポータルでフォルダーを削除すると、存在しない" というエラーが発生する Analysis Services Reporting Services Windows
10966008 修正: レポート ビューアー Web パーツで、特定の Web パーツの高さ (KB4039058) を設定した後に、完全な垂直スクロール バーが許可されない Analysis Services Reporting Services Windows
10729322 修正: Reporting Services "SortExpression" は、列に NULL 値が "DataTimeOffset" に設定されている場合 (KB4017827) rsComparisonError発生します Analysis Services Reporting Services Windows
10868736 修正: SQL Server 2014 または 2017 (KB4022483) で DQS クライアントにドメインを含む DQS サポート情報をエクスポートするとエラーが発生する データ品質サービス Import-Export Windows
10966015 修正: SQL Server 2016 または 2017 (KB4038590) の増分パッケージ展開後、ドイツ語のウムラウト文字を含む SSIS パッケージの実行が失敗する Integration Services ツール Windows
10867556 修正: SQL Server 年の Excel 用 MDS アドインもインストールされている場合 (KB4022895) Adobe Acrobat PDFMaker アドインを使用してブックを PDF ファイルとして保存すると、Excel がクラッシュする マスター データ サービス クライアント Windows
10687776 修正: SQL Server 2017 MDS および SQL Server 2016 MDS (KB4023865) では、[グループの管理] ページの [エンティティ] フォルダーの展開に時間がかかる マスター データ サービス サーバー すべて
10682313 修正: マスター データ サービス (KB4043103) で再帰階層を使用すると、ステージング テーブルからのデータの読み込みが完了するまでにかなり長い時間がかかる マスター データ サービス サーバー すべて
10986691 修正: DReplay 機能を使用して SQL Server 2017 (KB4045678) でキャプチャされたトレースを再生すると、予期しないエラーが発生する SQL Server クライアント ツール データベース パフォーマンス ツール Windows
10270905 修正: VSS ベースのアプリケーションを使用した可用性データベースのバックアップが SQL Server (KB4040108) で失敗する場合がある SQL Server エンジン バックアップの復元 すべて
10868723 修正: SQL Server マネージド バックアップで、SQL Server 2014 または 2017 (KB4038882) の保持期間を超えた古いバックアップが削除されない SQL Server エンジン バックアップの復元 Windows
10868726 修正: SQL Server 2014 または 2017 (KB4039511) の SQLVDI エラーが原因で、マネージド バックアップが断続的に失敗する SQL Server エンジン バックアップの復元 Windows
10868733 修正済み: SQL Server 2014 または 2017 (KB4040376) で大規模なデータベース バックアップ後に Microsoft Azure への管理されたバックアップが停止する SQL Server エンジン バックアップの復元 Windows
10966001 修正: SQL Server 2016 SP1 (KB4040531) 用の累積的な更新プログラム 2 をインストールした後に、managed_backup.fn_available_backups 関数によって制約違反エラーが返される SQL Server エンジン バックアップの復元 Windows
10966019 修正: SQL Server 2016 または 2017 SQL Server でスケジュールされたログ バックアップが実行されない (KB4040535) SQL Server エンジン バックアップの復元 Windows
10965952 SQL Server 2016 または 2017 の列ストア動的管理ビュー "column_store_row_groups" と "dm_db_column_store_row_group_physical_stats" のパフォーマンスを向上させるための更新プログラム (KB4024860) SQL Server エンジン 列ストア すべて
10936099 SQL Server 2017 Express エディションがデータベース ミラーリング セッション (KB4045687) で監視ロールとして動作できるようにする更新プログラム SQL Server エンジン 高可用性とディザスター リカバリー Windows
10921835 修正: SQL Server 2017 (KB4046065) DTC トランザクションの可用性グループ フェールオーバー中にメモリ破損が発生する SQL Server エンジン 高可用性とディザスター リカバリー Windows
10936097 修正: SQL Server 2017 では、コミットの試行中に一部のトランザクションでエラーが発生した場合でも、すべてのトランザクションが完了したと報告される (KB4046066) SQL Server エンジン 高可用性とディザスター リカバリー Windows
10965980 修正プログラム: SQL Server 2016 または 2017 (KB4042251) でデータベース ミラーリング フェールオーバーがエラー 3456 で失敗する SQL Server エンジン 高可用性とディザスター リカバリー Windows
10965988 修正: 可用性グループでの自動シード処理により、SQL Server 2016 または 2017 でエラー 41169 がランダムに発生する (KB4040519) SQL Server エンジン 高可用性とディザスター リカバリー すべて
10936183 修正: SQL Server 2016 または 2017 (KB4039868) で In-Memory OLTP を Always On 可用性グループと共に使用するとパフォーマンスが低下する SQL Server エンジン インメモリ OLTP Windows
10936185 修正: SQL Server 2016 または 2017 (KB4039776) で "where exists" ステートメントを使用してメモリ最適化テーブルを使用すると正しく動作しない SQL Server エンジン インメモリ OLTP Windows
10985578 修正: SQL Server 2017 (KB4045329) のストアド プロシージャから呼び出されたときに、インライン テーブル値関数にメモリ最適化テーブルを渡す際にエラーが発生する SQL Server エンジン インメモリ OLTP Windows
11000432 修正: SQL Server 2017 (KB4046099) でメモリオプティマイズド テーブルを含むデータベースのスナップショットバックアップを作成した後、数分または数時間以内にアサーション エラーが発生する SQL Server エンジン インメモリ OLTP Windows
10749795 修正: SQL Server 2017 (KB4043455) では、Windows と Linux のスケジューラのマッピング間で移植性とパフォーマンスが異なる SQL Server エンジン Linux Linux
11080104 修正: サンパウロのタイム ゾーンの DST の変更は、SQL Server 2017 on Linux (KB4052938) によって決定されない SQL Server エンジン Linux Linux
10966010 修正: SQL Server 2016 または 2017 の「managed_backup.fn_available_backups」テーブルでログ チェーンが中断される (KB4040530) SQL Server エンジン Management Services Windows
10936563 修正: SQL Server (KB4039089) で sys.sp_MScdc_capture_job ストアド プロシージャを実行するとエラー EXCEPTION_ACCESS_VIOLATION SQL Server エンジン Metadata すべて
10938809 修正: SQL Server 2017 (KB4044009) で新しいデータベースを作成するときにデッドロック状態が発生する SQL Server エンジン Metadata Windows
10070694 修正: SQL Server 2017 および SQL Server 2016 (KB4019840) で PolyBase 外部テーブルに対するクエリで重複する行が返される SQL Server エンジン PolyBase すべて
10965984 修正: SQL Server 2016 または 2017 (KB4039966) で CREATE EXTERNAL TABLE コマンドによって DDL トリガーが発生すると、アクセス違反が発生する SQL Server エンジン PolyBase Windows
10965968 修正: KB 3213683 で説明されている修正プログラムをインストールし、SQL Server 2016 または 2017 (KB4040533) で TF 176 を有効にした後、計算列にクエリを実行すると、誤った結果が返される SQL Server エンジン プログラミング すべて
10966016 修正済み: ユーザーが SYSADMIN アクセス許可を持たない CLR ストアド プロシージャによって実行された場合、SSIS パッケージが起動しない (KB4039736) SQL Server エンジン プログラミング Windows
10867554 修正: 不完全なデータ ファイルを一時テーブル (KB4043459) に一括ロードするストアド プロシージャの実行中に、SQL Server のリモート インスタンスがクラッシュする SQL Server エンジン プログラミング Windows
10966009 修正: SQL Server 2016 または 2017 (KB4038113) でsys.dm_os_memory_objects ステートメントを使用してクエリを実行するためのEXCEPTION_ACCESS_VIOLATION SQL Server エンジン クエリの実行 Windows
9704947 機能強化: SQL Server (KB4039284) の将来の統計更新のためにサンプリング レートを保持するために、CREATE ステートメントと UPDATE STATISTICS ステートメントに新しいキーワード (keyword)が追加されました。 SQL Server エンジン クエリ オプティマイザー すべて
10889338 修正: SQL Server 2017 (KB4042885) で並列クエリをシリアル モードで強制的に実行すると、ゼロ除算エラーが発生する SQL Server エンジン クエリ オプティマイザー Windows
11003299 修正: SQL Server 2017 (KB4046055) での最初の検証時に、FORCE_LAST_GOOD_PLAN推奨事項が "検証中" 状態でスタックする SQL Server エンジン クエリ ストア Windows
11003402 修正: SQL Server 2017 (KB4046022) の ModelDB で自動チューニング設定を構成できない SQL Server エンジン クエリ ストア Windows
10691456 修正済み: SQL Server (KB4023926) の P2P パブリケーションからストアド プロシージャ実行記事を削除できない SQL Server エンジン レプリケーション Windows
10691460 修正: SQL Server (KB4034376) の "Always Encrypted" 機能によって列が暗号化されている場合、"データ キャプチャの変更" を無効にできない SQL Server エンジン レプリケーション すべて
10978904 修正済み: SQL Server 2014 および 2017 (KB4043624) でChange Tracking手動クリーンアップがテーブルが存在しないエラーで失敗する SQL Server エンジン レプリケーション すべて
10687780 修正: 浮動小数点列のデータ マスクが SQL Server 2017 および SQL Server 2016 (KB4023995) に適用されない SQL Server エンジン セキュリティ インフラストラクチャ すべて
10867553 修正プログラム: SUSER_SNAME関数は SQL Server 2014 と SQL Server 2016 または 2017 (KB4025020) で異なる結果が返される SQL Server エンジン セキュリティ インフラストラクチャ Windows
10982548 修正: SQL CLR 関数が SQL Server 2017 (KB4046918) で偽装呼び出しを使用して Transact-SQL ステートメントを呼び出すと、実行が失敗する SQL Server エンジン セキュリティ インフラストラクチャ すべて
10868749 修正: SQL Server 2014 または 2017 (KB4040401) のリンク サーバー経由の空間データ型クエリに対するアクセス違反 SQL Server エンジン SQL OS Windows
11008122 SQL Server 2017 の新しい動的管理ビューと関数を有効にするための更新プログラム (KB4046638) SQL Server エンジン 記憶域の管理 Windows
10870647 修正プログラム: SQL Server 2016 または 2017 (KB4024622) で拡張インデックスまたは XML インデックスが含まれている場合、パーティション分割されたテーブルのパーティションを切り捨てることができませんでした SQL Server エンジン テーブル インデックス パーティション Windows
10998915 修正: 連鎖操作を使用する DML ステートメントが SQL Server 2017 (KB4046744) で失敗する SQL Server エンジン テンポラル Windows
10865727 修正: SQL Server 2016 または 2017 (KB4024393) で中断された可用性データベースを再開すると、セカンダリ レプリカでアサーション エラーが発生する SQL Server エンジン トランザクション サービス Windows
10936411 修正: SQL Server 2016 または 2017 で tempdb データベースの間接チェックポイントによって "Non-yielding scheduler" エラーが発生する (KB4040276) SQL Server エンジン トランザクション サービス Windows
10868768 修正: SQL Server 2014 または 2017 (KB4039510) で sp_xml_preparedocument を使用して XML ドキュメントを開くと、アクセス違反が発生する SQL Server エンジン XML Windows
10998673 修正: インスタンス名/ID/インストール パスに複数バイト文字が含まれている場合、SQL Server 2017 をインストールできない (KB4046044) SQL セットアップ 展開プラットフォーム Windows

これまたは最新の累積的な更新プログラム パッケージを取得またはダウンロードする方法

Windows の最新の累積的な更新プログラム パッケージを取得またはダウンロードする方法 (推奨)

次の更新プログラムは、Microsoft ダウンロード センターから入手できます。

SQL Server 2017 の最新の累積的な更新プログラム パッケージを今すぐダウンロードする

このダウンロード ページが表示されない場合は、Microsoft カスタマー サービス & サポートに問い合わせて累積的な更新プログラム パッケージを入手してください。

Microsoft Update カタログから Windows 用のこの累積的な更新プログラム パッケージを取得またはダウンロードする方法

注

SQL Server 2017 用の今後の累積的な更新プログラムがリリースされた後は、これおよび以前のすべての CU を Microsoft Update カタログからダウンロードできます。 しかし、入手できる最新の累積的な更新プログラムを常にインストールすることをお勧めします。

次の更新プログラムは、Microsoft Update カタログから入手できます。

SQL Server 2017 CU1 の累積的な更新プログラム パッケージを今すぐダウンロードする

Linux 向けの最新の累積的な更新プログラム パッケージを取得またはダウンロードする方法

Linux 上の SQL Server 2017 を最新の CU に更新するには、最初に累積的な更新プログラム リポジトリを構成する必要があります。 次に、適切なプラットフォーム固有の更新コマンドを使用して SQL Server パッケージを更新します。

インストール手順と CU パッケージのダウンロードへの直接リンクについては、SQL Server 2017 リリース ノートを参照してください。

ファイル情報

ファイル ハッシュ情報

次のコマンドを使用して、 SQLServer2017-KB4038634-x64.exe ファイルのハッシュを計算することにより、ダウンロードを確認できます。

certutil -hashfile SQLServer2017-KB4038634-x64.exe SHA256

ファイル名 SHA256 ハッシュ
SQLServer2017-KB4038634-x64.exe C1187BF68AC07294D8242C4126F021D3BEEF561F86931A8229B3D4AE86993A73
累積的な更新プログラム パッケージのファイル情報

このパッケージ (英語版) のファイル属性は次表のとおりです。ただし、これより新しいパッケージがリリースされている可能性もあります。 これらのファイルの日付と時刻は世界協定時 (UTC) で記載されています。 ファイル情報を表示すると、ファイルは現地時間に変換されます。 UTC とローカル時刻との時差を確認するには、[コントロール パネル] の [日付と時刻] の [タイム ゾーン] タブを使用してください。

x64 ベース バージョン

SQL Server 2017 Analysis Services

ファイル名 ファイルのバージョン ファイル サイズ 日付 時刻 プラットフォーム
Microsoft.analysisservices.server.core.dll 14.0.1.439 1380512 2017 年 10 月 1 日 2,206 x86
Microsoft.data.mashup.dll 2.49.4831.201 174816 2017 年 10 月 1 日 20:52 x86
Microsoft.data.mashup.oledb.dll 2.49.4831.201 36576 2017 年 10 月 1 日 20:52 x86
Microsoft.data.mashup.preview.dll 2.49.4831.201 48864 2017 年 10 月 1 日 20:52 x86
Microsoft.data.mashup.providercommon.dll 2.49.4831.201 105184 2017 年 10 月 1 日 20:52 x86
Microsoft.hostintegration.connectors.dll 2.49.4831.201 5167328 2017 年 10 月 1 日 20:52 x86
Microsoft.mashup.container.exe 2.49.4831.201 26336 2017 年 10 月 1 日 20:52 x64
Microsoft.mashup.container.netfx40.exe 2.49.4831.201 26848 2017 年 10 月 1 日 20:52 x64
Microsoft.mashup.container.netfx45.exe 2.49.4831.201 26848 19-Oct-17 12:13 x64
Microsoft.mashup.eventsource.dll 2.49.4831.201 159456 2017 年 10 月 1 日 20:52 x86
Microsoft.mashup.oauth.dll 2.49.4831.201 82656 2017 年 10 月 1 日 20:52 x86
Microsoft.mashup.oledbprovider.dll 2.49.4831.201 67296 19-Oct-17 12:13 x86
Microsoft.mashup.shims.dll 2.49.4831.201 25824 2017 年 10 月 1 日 20:52 x86
Microsoft.mashup.storage.xmlserializers.dll 1,000 151264 2017 年 10 月 1 日 20:52 x86
Microsoft.mashupengine.dll 2.49.4831.201 13032160 2017 年 10 月 1 日 20:52 x86
Microsoft.powerbi.adomdclient.dll 14.0.1.484 1044672 2017 年 10 月 1 日 20:52 x86
msmdlocal.dll 2017.140.1.439 40357024 2017 年 10 月 1 日 2,206 x86
msmdlocal.dll 2017.140.1.439 59898528 19-Oct-17 1,222 x64
Msmdpump.dll 2017.140.1.439 8544416 19-Oct-17 1,222 x64
Msmdsrv.exe 2017.140.1.439 60589352 2017 年 10 月 1 日 22:07 x64
msmgdsrv.dll 2017.140.1.439 8208544 2017 年 10 月 1 日 22:07 x64
msmgdsrv.dll 2017.140.1.439 7310496 19-Oct-17 1,215 x86
Powerbiextensions.dll 2.49.4831.201 5316832 2017 年 10 月 1 日 20:52 x64
Sql_as_keyfile.dll 2017.140.3006.16 100512 19-Oct-17 19:12 x64
Sqlboot.dll 2017.140.3006.16 194720 19-Oct-17 11:08 x64
Sqlceip.exe 14.0.3006.16 249504 19-Oct-17 1,218 x86

SQL Server 2017 データベース サービス共通コア

ファイル名 ファイルのバージョン ファイル サイズ 日付 時刻 プラットフォーム
Microsoft.analysisservices.adomdclient.dll 14.0.1.439 1088672 2017 年 10 月 1 日 22:04 x86
Microsoft.analysisservices.adomdclient.dll 14.0.1.439 1088672 2017 年 10 月 1 日 2,206 x86
Microsoft.analysisservices.core.dll 14.0.1.439 1380648 2017 年 10 月 1 日 22:04 x86
Microsoft.analysisservices.xmla.dll 14.0.1.439 741536 2017 年 10 月 1 日 22:04 x86
Microsoft.analysisservices.xmla.dll 14.0.1.439 741536 2017 年 10 月 1 日 2,206 x86
Pbsvcacctsync.dll 2017.140.3006.16 66720 19-Oct-17 19:12 x86
Pbsvcacctsync.dll 2017.140.3006.16 80544 19-Oct-17 1,222 x64
Sql_common_core_keyfile.dll 2017.140.3006.16 100512 19-Oct-17 19:12 x64
Sqlftacct.dll 2017.140.3006.16 53920 19-Oct-17 1,109 x86
Sqlftacct.dll 2017.140.3006.16 61088 19-Oct-17 1,222 x64
Sqlmgmprovider.dll 2017.140.3006.16 371864 19-Oct-17 1,215 x86
Sqlmgmprovider.dll 2017.140.3006.16 414880 19-Oct-17 12:21 x64

SQL Server 2017 データベース サービス コア インスタンス

ファイル名 ファイルのバージョン ファイル サイズ 日付 時刻 プラットフォーム
Datacollectorcontroller.dll 2017.140.3006.16 224928 19-Oct-17 11:08 x64
Fssres.dll 2017.140.3006.16 88224 19-Oct-17 12:21 x64
Hadrres.dll 2017.140.3006.16 186528 19-Oct-17 12:21 x64
Hkcompile.dll 2017.140.3006.16 1421472 19-Oct-17 11:08 x64
Hkengine.dll 2017.140.3006.16 5858464 19-Oct-17 11:08 x64
Hkruntime.dll 2017.140.3006.16 161952 19-Oct-17 12:21 x64
Microsoft.analysisservices.applocal.xmla.dll 14.0.1.439 740136 19-Oct-17 1,220 x86
Microsoft.sqlautoadmin.autobackupagent.dll 14.0.3006.16 237216 19-Oct-17 1,220 x86
Microsoft.sqlautoadmin.sqlautoadmin.dll 14.0.3006.16 79520 19-Oct-17 12:09 x86
Microsoft.sqlserver.xevent.linq.dll 2017.140.3006.16 303776 19-Oct-17 11:02 x64
Qds.dll 2017.140.3006.16 1164448 19-Oct-17 14:38 x64
Sqagtres.dll 2017.140.3006.16 72864 19-Oct-17 1,222 x64
Sql_engine_core_inst_keyfile.dll 2017.140.3006.16 100512 19-Oct-17 19:12 x64
Sqlaccess.dll 2017.140.3006.16 474784 19-Oct-17 11:08 x64
Sqlagent.exe 2017.140.3006.16 578720 19-Oct-17 12:21 x64
Sqlagentctr140.dll 2017.140.3006.16 60576 19-Oct-17 11:08 x64
Sqlagentctr140.dll 2017.140.3006.16 51872 19-Oct-17 1,215 x86
Sqlboot.dll 2017.140.3006.16 194720 19-Oct-17 11:08 x64
Sqlceip.exe 14.0.3006.16 249504 19-Oct-17 1,218 x86
Sqlcmdss.dll 2017.140.3006.16 71840 19-Oct-17 12:21 x64
Sqldk.dll 2017.140.3006.16 2789024 19-Oct-17 14:38 x64
Sqlevn70.rll 2017.140.3006.16 3288224 19-Oct-17 11:00 x64
Sqlevn70.rll 2017.140.3006.16 3587232 19-Oct-17 11:00 x64
Sqlevn70.rll 2017.140.3006.16 1441440 19-Oct-17 11:00 x64
Sqlevn70.rll 2017.140.3006.16 2084512 19-Oct-17 11:00 x64
Sqlevn70.rll 2017.140.3006.16 3205792 19-Oct-17 01:11 x64
Sqlevn70.rll 2017.140.3006.16 3329696 19-Oct-17 01:11 x64
Sqlevn70.rll 2017.140.3006.16 3769504 19-Oct-17 01:11 x64
Sqlevn70.rll 2017.140.3006.16 3907232 19-Oct-17 01:11 x64
Sqlevn70.rll 2017.140.3006.16 3904160 19-Oct-17 11:02 x64
Sqlevn70.rll 2017.140.3006.16 2031264 19-Oct-17 11:02 x64
Sqlevn70.rll 2017.140.3006.16 4015264 19-Oct-17 11:02 x64
Sqlevn70.rll 2017.140.3006.16 3472032 19-Oct-17 1,103 x64
Sqlevn70.rll 2017.140.3006.16 3776672 19-Oct-17 1,103 x64
Sqlevn70.rll 2017.140.3006.16 3358368 19-Oct-17 1,103 x64
Sqlevn70.rll 2017.140.3006.16 3282592 19-Oct-17 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3625632 19-Oct-17 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3393184 19-Oct-17 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3579032 19-Oct-17 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3666592 19-Oct-17 1,105 x64
Sqlevn70.rll 2017.140.3006.16 1494176 19-Oct-17 1,105 x64
Sqlevn70.rll 2017.140.3006.16 3810976 19-Oct-17 11:06 x64
Sqlevn70.rll 2017.140.3006.16 3775136 19-Oct-17 11:07 x64
Sqllang.dll 2017.140.3006.16 41170080 19-Oct-17 14:57 x64
Sqlmin.dll 2017.140.3006.16 40221344 19-Oct-17 1,450 x64
Sqlolapss.dll 2017.140.3006.16 106656 19-Oct-17 11:08 x64
Sqlos.dll 2017.140.3006.16 26272 19-Oct-17 1,103 x64
Sqlpowershellss.dll 2017.140.3006.16 66720 19-Oct-17 12:21 x64
Sqlrepss.dll 2017.140.3006.16 63136 19-Oct-17 12:21 x64
Sqlscm.dll 2017.140.3006.16 69280 19-Oct-17 11:08 x64
Sqlscriptdowngrade.dll 2017.140.3006.16 27800 19-Oct-17 11:08 x64
Sqlscriptupgrade.dll 2017.140.3006.16 5871264 19-Oct-17 09:52 x64
Sqlservr.exe 2017.140.3006.16 485024 19-Oct-17 14:38 x64
Sqlsvc.dll 2017.140.3006.16 160416 19-Oct-17 12:21 x64
Sqltses.dll 2017.140.3006.16 9536160 19-Oct-17 14:38 x64
Sqsrvres.dll 2017.140.3006.16 259744 19-Oct-17 1,222 x64
Svl.dll 2017.140.3006.16 153760 19-Oct-17 1,222 x64
Xpadsi.exe 2017.140.3006.16 88224 19-Oct-17 12:21 x64
Xplog70.dll 2017.140.3006.16 74400 19-Oct-17 1,222 x64
Xpsqlbot.dll 2017.140.3006.16 32416 19-Oct-17 1,222 x64
Xpstar.dll 2017.140.3006.16 436384 19-Oct-17 12:21 x64

SQL Server 2017 データベース サービス コア共有

ファイル名 ファイルのバージョン ファイル サイズ 日付 時刻 プラットフォーム
Dts.dll 2017.140.3006.16 2996896 19-Oct-17 19:12 x64
Dtsconn.dll 2017.140.3006.16 495264 19-Oct-17 19:12 x64
Dtshost.exe 2017.140.3006.16 103072 19-Oct-17 12:21 x64
Dtspipeline.dll 2017.140.3006.16 1264288 19-Oct-17 19:12 x64
Dtutil.exe 2017.140.3006.16 145568 19-Oct-17 19:12 x64
Microsoft.analysisservices.applocal.core.dll 14.0.1.439 1381536 2017 年 10 月 1 日 2,206 x86
Msxmlsql.dll 2017.140.3006.16 1450656 19-Oct-17 11:08 x64
Sql_engine_core_shared_keyfile.dll 2017.140.3006.16 100512 19-Oct-17 19:12 x64
Sqlscm.dll 2017.140.3006.16 59544 19-Oct-17 01:11 x86
Sqlscm.dll 2017.140.3006.16 69280 19-Oct-17 11:08 x64
Sqlsvc.dll 2017.140.3006.16 133280 19-Oct-17 01:11 x86
Sqlsvc.dll 2017.140.3006.16 160416 19-Oct-17 12:21 x64

SQL Server 2017 sql_extensibility

ファイル名 ファイルのバージョン ファイル サイズ 日付 時刻 プラットフォーム
Launchpad.exe 2017.140.3006.16 1121440 19-Oct-17 12:21 x64
Sql_extensibility_keyfile.dll 2017.140.3006.16 100512 19-Oct-17 19:12 x64
Sqlsatellite.dll 2017.140.3006.16 918688 19-Oct-17 1,222 x64

SQL Server 2017 Full-Text エンジン

ファイル名 ファイルのバージョン ファイル サイズ 日付 時刻 プラットフォーム
Fd.dll 2017.140.3006.16 665760 19-Oct-17 11:08 x64
Fdhost.exe 2017.140.3006.16 113312 19-Oct-17 12:21 x64
Fdlauncher.exe 2017.140.3006.16 61600 19-Oct-17 11:08 x64
Sql_fulltext_keyfile.dll 2017.140.3006.16 100512 19-Oct-17 19:12 x64
Sqlft140ph.dll 2017.140.3006.16 66208 19-Oct-17 11:08 x64

SQL Server 2017 sql_inst_mr

ファイル名 ファイルのバージョン ファイル サイズ 日付 時刻 プラットフォーム
Imrdll.dll 14.0.3006.16 23712 19-Oct-17 11:08 x86
Sql_inst_mr_keyfile.dll 2017.140.3006.16 100512 19-Oct-17 19:12 x64

SQL Server 2017 Integration Services

ファイル名 ファイルのバージョン ファイル サイズ 日付 時刻 プラットフォーム
Attunity.sqlserver.cdccontroltask.dll 5.0.0.70 75248 15-Sep-17 06:38 x86
Attunity.sqlserver.cdcsplit.dll 5.0.0.70 36336 15-Sep-17 06:38 x86
Attunity.sqlserver.cdcsrc.dll 5.0.0.70 76272 19-Oct-17 1,210 x86
Dts.dll 2017.140.3006.16 2548384 19-Oct-17 01:11 x86
Dts.dll 2017.140.3006.16 2996896 19-Oct-17 19:12 x64
Dtsconn.dll 2017.140.3006.16 397984 19-Oct-17 01:11 x86
Dtsconn.dll 2017.140.3006.16 495264 19-Oct-17 19:12 x64
Dtshost.exe 2017.140.3006.16 88224 19-Oct-17 1,215 x86
Dtshost.exe 2017.140.3006.16 103072 19-Oct-17 12:21 x64
Dtspipeline.dll 2017.140.3006.16 1057440 19-Oct-17 1,210 x86
Dtspipeline.dll 2017.140.3006.16 1264288 19-Oct-17 19:12 x64
Dtutil.exe 2017.140.3006.16 125088 19-Oct-17 01:11 x86
Dtutil.exe 2017.140.3006.16 145568 19-Oct-17 19:12 x64
Isdeploymentwizard.exe 14.0.3006.16 477344 19-Oct-17 12:58 x86
Isdeploymentwizard.exe 14.0.3006.16 476832 19-Oct-17 1,308 x64
Microsoft.analysisservices.applocal.core.dll 14.0.1.439 1381536 2017 年 10 月 1 日 22:04 x86
Microsoft.analysisservices.applocal.core.dll 14.0.1.439 1381536 2017 年 10 月 1 日 2,206 x86
Microsoft.sqlserver.integrationservices.isserverdbupgrade.dll 14.0.3006.16 493728 19-Oct-17 09:51 x86
Microsoft.sqlserver.integrationservices.isserverdbupgrade.dll 14.0.3006.16 493728 19-Oct-17 11:08 x86
Microsoft.sqlserver.integrationservices.server.dll 14.0.3006.16 83616 19-Oct-17 1,215 x86
Microsoft.sqlserver.integrationservices.server.dll 14.0.3006.16 83616 19-Oct-17 1,220 x86
Microsoft.sqlserver.integrationservices.wizard.common.dll 14.0.3006.16 415392 19-Oct-17 12:42 x86
Microsoft.sqlserver.integrationservices.wizard.common.dll 14.0.3006.16 415392 19-Oct-17 1,259 x86
Msdtssrvr.exe 14.0.3006.16 219808 19-Oct-17 12:21 x64
Sql_is_keyfile.dll 2017.140.3006.16 100512 19-Oct-17 19:12 x64
Sqlceip.exe 14.0.3006.16 249504 19-Oct-17 1,218 x86

SQL Server 2017 sql_polybase_core_inst

ファイル名 ファイルのバージョン ファイル サイズ 日付 時刻 プラットフォーム
Sqlevn70.rll 2017.140.3006.16 1494176 19-Oct-17 1,105 x64
Sqlevn70.rll 2017.140.3006.16 3904160 19-Oct-17 11:02 x64
Sqlevn70.rll 2017.140.3006.16 3205792 19-Oct-17 01:11 x64
Sqlevn70.rll 2017.140.3006.16 3907232 19-Oct-17 01:11 x64
Sqlevn70.rll 2017.140.3006.16 3810976 19-Oct-17 11:06 x64
Sqlevn70.rll 2017.140.3006.16 2084512 19-Oct-17 11:00 x64
Sqlevn70.rll 2017.140.3006.16 2031264 19-Oct-17 11:02 x64
Sqlevn70.rll 2017.140.3006.16 3579032 19-Oct-17 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3587232 19-Oct-17 11:00 x64
Sqlevn70.rll 2017.140.3006.16 1441440 19-Oct-17 11:00 x64
Sqlevn70.rll 2017.140.3006.16 3775136 19-Oct-17 11:07 x64

SQL Server 2017 sql_shared_mr

ファイル名 ファイルのバージョン ファイル サイズ 日付 時刻 プラットフォーム
Smrdll.dll 14.0.3006.16 23712 19-Oct-17 11:08 x86
Sql_engine_core_shared_keyfile.dll 2017.140.3006.16 100512 19-Oct-17 19:12 x64

SQL Server 2017 sql_tools_extensions

ファイル名 ファイルのバージョン ファイル サイズ 日付 時刻 プラットフォーム
Dts.dll 2017.140.3006.16 2548384 19-Oct-17 01:11 x86
Dts.dll 2017.140.3006.16 2996896 19-Oct-17 19:12 x64
Dtsconn.dll 2017.140.3006.16 397984 19-Oct-17 01:11 x86
Dtsconn.dll 2017.140.3006.16 495264 19-Oct-17 19:12 x64
Dtshost.exe 2017.140.3006.16 88224 19-Oct-17 1,215 x86
Dtshost.exe 2017.140.3006.16 103072 19-Oct-17 12:21 x64
Dtspipeline.dll 2017.140.3006.16 1057440 19-Oct-17 1,210 x86
Dtspipeline.dll 2017.140.3006.16 1264288 19-Oct-17 19:12 x64
Dtutil.exe 2017.140.3006.16 125088 19-Oct-17 01:11 x86
Dtutil.exe 2017.140.3006.16 145568 19-Oct-17 19:12 x64
Microsoft.sqlserver.astasksui.dll 14.0.3006.16 184480 19-Oct-17 1,308 x86
Microsoft.sqlserver.chainer.infrastructure.dll 14.0.3006.16 406688 19-Oct-17 01:11 x86
Microsoft.sqlserver.chainer.infrastructure.dll 14.0.3006.16 406688 19-Oct-17 1,220 x86
Microsoft.sqlserver.configuration.sco.dll 14.0.3006.16 2093216 19-Oct-17 1,215 x86
Microsoft.sqlserver.configuration.sco.dll 14.0.3006.16 2093216 19-Oct-17 1,220 x86
msmgdsrv.dll 2017.140.1.439 7310496 19-Oct-17 1,215 x86
Sql_tools_extensions_keyfile.dll 2017.140.3006.16 100512 19-Oct-17 19:12 x64
Sqlscm.dll 2017.140.3006.16 59544 19-Oct-17 01:11 x86
Sqlscm.dll 2017.140.3006.16 69280 19-Oct-17 11:08 x64
Sqlsvc.dll 2017.140.3006.16 133280 19-Oct-17 01:11 x86
Sqlsvc.dll 2017.140.3006.16 160416 19-Oct-17 12:21 x64

この更新プログラムについての注記

前提条件

この累積的な更新プログラム パッケージを適用するには、SQL Server 2017 を実行している必要があります。

再起動に関する情報

この累積的な更新プログラム パッケージの適用後、コンピューターの再起動が必要な場合があります。

レジストリ情報

このパッケージに含まれている修正プログラムを使用するために、レジストリを変更する必要はありません。

重要な通知

この記事では、以下の状況に関する重要な情報についても説明します。

  • Pacemaker: 入手可能な最新バージョンの Pacemaker を使用するディストリビューションで動作が変更されます。 軽減策が示されます。

  • クエリ ストア: クエリ ストアを使用し、以前に Microsoft SQL Server 2017 累積更新プログラム 2 (CU2) をインストールしている場合は、このスクリプトを実行する必要があります。

Analysis Services CU ビルド バージョン

Microsoft SQL Server 2017 以降、Analysis Services のビルド バージョン番号と SQL Server データベース エンジンのビルド バージョン番号が一致しません。 詳細については、Analysis Services 累積更新プログラムのビルド バージョンの確認を参照してください。

累積的な更新プログラム (CU)

累積的な更新プログラム (CU) は、現在 Microsoft ダウンロード センターで入手できます。

ダウンロード センターで入手できるのは、SQL Server 2017 用にリリースされた最新の CU だけです。

Linux 用の CU パッケージは、https://packages.microsoft.com で入手できます。

  • 最新の CU には、インストール済みの SQL Server バージョン用として前回の CU に含められていた修正プログラムがすべて含まれます。
  • SQL Server CU は Service Pack と同じレベルに認証されるため、同じ信頼レベルでインストールする必要があります。
  • 次のガイドラインに従って CU が入手可能になったら、継続的かつ予防的に CU をインストールすることをお勧めします。
    • 過去のデータは、リリース済みの CU で既に解決されている問題が多数のサポート ケースで扱われていることを物語っています。
    • CU には、修正プログラムを超えた付加価値が含まれている場合があります。 付加的な機能 (サポータビリティ、管理性、信頼性の更新ファイルなど) が含まれることもあります。
  • SQL Server CU を実稼働環境に展開する前にそれらをテストすることをお勧めします。
Pacemaker に関する注意事項

重要

利用可能な最新の Pacemaker パッケージ 1.1.18-11.el7 を使用するすべてのディストリビューション (RHEL 7.3 および 7.4 を含む) では、その値が false の場合、start-failure-is-fatal クラスター設定の動作変更が導入されます。 この変更はフェールオーバー ワークフローに影響します。 プライマリ レプリカで機能停止が発生した場合、クラスターは使用可能なセカンダリ レプリカの 1 つにフェールオーバーすると予想されます。 代わりに、ユーザーは、クラスターが障害の発生したプライマリ レプリカを起動しようとし続けていることがわかります。 そのプライマリがオンラインにならない場合 (永続的な機能停止のため)、クラスターは他の使用可能なセカンダリ レプリカにフェールオーバーすることはありません。

この問題は、累積的な更新プログラムのバージョンに関係なく、すべての SQL Server のバージョンに影響します。

この問題を軽減するには、以下のいずれかの方法を使用します。

方法 1

手順

  1. 既存のクラスターから start-failure-is-fatal オーバーライドを削除します。

    # RHEL、Ubuntu pcs プロパティ unset start-failure-is-fatal # または pcs property set start-failure-is-fatal=true # SLES crm configure property start-failure-is-fatal=true

  2. cluster-recheck-interval値を小さくします。

    # RHEL、Ubuntu pcs プロパティ設定 cluster-recheck-interval=<Xmin> # SLES crm configure property cluster-recheck-interval=<Xmin>

  3. 各 AG リソースに failure-timeout メタ プロパティを追加します。

    # RHEL、Ubuntu pcs リソース更新 ag1 meta failure-timeout=60s # SLES crm configure edit ag1 # テキスト エディターで、'param' の後、'op' の前に 'meta failure-timeout=60s' を追加します

    注

    このコードでは、必要に応じて <Xmin> の値を置き換えます。 レプリカが停止した場合、クラスターは failure-timeout 値と cluster-recheck-interval 値によってバインドされた間隔でレプリカの再起動を試みます。 たとえば、 failure-timeout が 60 秒に設定され、 cluster-recheck-interval が 120 秒に設定されている場合、再起動は 60 秒より長く 120 秒未満の間隔で試行されます。 failure-timeout を 60s に設定し、cluster-recheck-interval を 60 秒より大きい値に設定することをお勧めします。 cluster-recheck-interval を小さい値に設定しないことをお勧めします。 詳細については、Pacemaker のドキュメントを参照するか、システム プロバイダーまでお問い合わせください。

方法 2

Pacemaker バージョン 1.1.16 に戻します。

クエリ ストアに関する注意事項

重要

クエリ ストアを使用し、SQL Server 2017 累積更新プログラム 2 (CU2) から SQL Server 2017 累積更新プログラム 3 (CU3) またはそれ以降の累積的な更新プログラムに直接更新する場合は、このスクリプトを実行する必要があります。 SQL Server 2017 累積的な更新プログラム 3 (CU3) またはそれ以降の SQL Server 2017 累積的な更新プログラムを以前にインストールしたことがある場合は、このスクリプトを実行する必要はありません。

SET NOCOUNT ON;
DROP TABLE IF EXISTS #tmpUserDBs;

SELECT [database_id], 0 AS [IsDone]
INTO #tmpUserDBs
FROM master.sys.databases
WHERE [database_id] > 4
 AND [state] = 0 -- must be ONLINE
 AND is_read_only = 0 -- cannot be READ_ONLY
 AND [database_id] NOT IN (SELECT dr.database_id FROM sys.dm_hadr_database_replica_states dr -- Except all local Always On secondary replicas
  INNER JOIN sys.dm_hadr_availability_replica_states rs ON dr.group_id = rs.group_id
  INNER JOIN sys.databases d ON dr.database_id = d.database_id
  WHERE rs.role = 2 -- Is Secondary
   AND dr.is_local = 1
   AND rs.is_local = 1)

DECLARE @userDB sysname;

WHILE (SELECT COUNT([database_id]) FROM #tmpUserDBs WHERE [IsDone] = 0) > 0
BEGIN
 SELECT TOP 1 @userDB = DB_NAME([database_id]) FROM #tmpUserDBs WHERE [IsDone] = 0

 -- PRINT 'Working on database ' + @userDB

 EXEC ('USE [' + @userDB + '];
DECLARE @clearPlan bigint, @clearQry bigint;
IF EXISTS (SELECT [actual_state] FROM sys.database_query_store_options WHERE [actual_state] IN (1,2))
BEGIN
 IF EXISTS (SELECT plan_id FROM sys.query_store_plan WHERE engine_version = ''14.0.3008.27'')
 BEGIN
  DROP TABLE IF EXISTS #tmpclearPlans;

  SELECT plan_id, query_id, 0 AS [IsDone]
  INTO #tmpclearPlans
  FROM sys.query_store_plan WHERE engine_version = ''14.0.3008.27''

  WHILE (SELECT COUNT(plan_id) FROM #tmpclearPlans WHERE [IsDone] = 0) > 0
  BEGIN
   SELECT TOP 1 @clearPlan = plan_id, @clearQry = query_id FROM #tmpclearPlans WHERE [IsDone] = 0
   EXECUTE sys.sp_query_store_unforce_plan @clearQry, @clearPlan;
   EXECUTE sys.sp_query_store_remove_plan @clearPlan;

   UPDATE #tmpclearPlans
   SET [IsDone] = 1
   WHERE plan_id = @clearPlan AND query_id = @clearQry
  END;

  PRINT ''- Cleared possibly affected plans in database [' + @userDB + ']''
 END
 ELSE
 BEGIN
  PRINT ''- No affected plans in database [' + @userDB + ']''
 END
END
ELSE
BEGIN
 PRINT ''- Query Store not enabled in database [' + @userDB + ']''
END')
  UPDATE #tmpUserDBs
  SET [IsDone] = 1
  WHERE [database_id] = DB_ID(@userDB)
END
ハイブリッド環境の展開

更新プログラムをハイブリッド環境 (AlwaysOn、レプリケーション、クラスター、ミラーリングなど) に展開するときには、更新プログラムを展開する前に次の記事を参照することをお勧めします。

サポート言語

SQL Server CU は、現在多言語対応となっています。 したがって、この CU パッケージは 1 つの言語に固有のものではありません。 このパッケージはサポートされているすべての言語に使用できます。

更新されたコンポーネント (機能)

1 つの CU パッケージには、すべての SQL Server 2017 コンポーネント (機能) で利用可能なすべての更新プログラムが含まれています。 ただし、累積的な更新プログラム パッケージでは、サービス対象として選択した SQL Server インスタンスに現在インストールされているコンポーネントのみが更新されます。 この CU が適用された後に SQL Server の機能 (Analysis Services など) をインスタンスに追加する場合は、この CU を再適用して新しい機能をこの CU に更新する必要があります。

この更新プログラムのサポート

別の問題が発生した場合、またはトラブルシューティングが必要な場合には、サービス要求を作成しなければならない場合があります。 付加的なサポート質問と、この累積的な更新プログラム パッケージの対象とならない問題については、通常のサポート料金が適用されます。 Microsoft カスタマー サービス サポートの電話番号の一覧や、別のサービス リクエストを作成する方法などは、Microsoft サポート Web サイトを参照してください。

この更新プログラムのアンインストール方法

Windows でこの更新プログラムをアンインストールする方法
  1. コントロール パネルで [プログラムと機能] を開き、[インストールされた更新プログラムを表示] を選択します。
  2. SQL Server 2017 で、この累積的な更新プログラム パッケージに対応するエントリを見つけます。
  3. そのエントリを押し続け (または右クリックし)、[アンインストール] を選択します。
Linux でこの更新プログラムをアンインストールする方法

Linuxでこの CU をアンインストールするには、パッケージを前のバージョンにロール バックする必要があります。 インストールをロール バックする方法の詳細については、SQL Server のロールバックを参照してください。

サードパーティの情報に関する免責事項

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。 明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

参考資料