Når du arbeider med oversølte matrisefunksjoner, for eksempel SEKVENS ,er det mulig å referere til hele spillområdet ved å plassere den oversølte områdeoperatoren (#) etter området. I eksemplet nedenfor har vi =SEKVENS(10) i celle A2, som går over til A2:A11. I celle C2 har vi formelen =SUMMER(A2#), som tilsvarer =SUMMER(A2:A11), siden A2:A11 er spillområdet i formelen i A2. Dette returnerer 55, summen av alle verdiene i det oversølte matriseområdet.

Hvis søleområdet vokser eller kontrakter, for eksempel ved å endre formelen i A2 til =SEKVENS(20), gjenspeiler SUMMER-formelen automatisk dette. Hvis dette var et vanlig område, må vi angi =SUMMER(A2:A11), og oppdatere det manuelt hvis spillområdet endres. Ofte er det ikke sikkert at du oppdager om et område er endret, så dette kan fjerne mye gjettearbeid.

Operator for oversølt område for å referere til hele oversølte matriseområder med =SUMMER(A2#).

Her er et annet eksempel på hvordan du bruker den oversølte områdeoperatoren i flere formler, der vi oppretter en unik liste fra en liste over navn, sorterer listen og filtrerer deretter etter navn over tre tegn. Vi har =SORTER(C2#) i celle E2 og =FILTER(C2#,LENGDE(C2#)>3) i celle G2.

Oversvømt områdeoperator (#) for å referere til et helt oversvømt matriseområde med =FILTER(C2#,LENGDE(C2#)>3)

Kjente begrensninger

Operatoren for oversølt område støtter ikke referanser til lukkede arbeidsbøker. I stedet returneres en #REF! som feilverdi. Hvis du åpner arbeidsboken det refereres til, løses problemet.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excels tekniske fellesskap eller få hjelp i Svar-fellesskapet.

Se også

FILTER-funksjonen

TILFELDIGMATRISE-funksjonen

SEKVENS-funksjonen

SORTER-funksjonen

SORTER ETTER-funksjonen

UNIK-funksjonen

#OVERFLYT!-feil i Excel

Dynamiske matriser og overflytende matrise

implisitt skjæringspunktoperator: @

Trenger du mer hjelp?

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Microsoft Office Insider-deltakere

Var denne informasjonen nyttig?

Hvor fornøyd er du med kvaliteten på oversettelsen?
Hva påvirket opplevelsen din?

Takk for tilbakemeldingen!

×