#OVERFLYT-feil returneres når en formel returnerer flere resultater, og Excel ikke kan returnere resultatene til rutenettet. Hvis du vil ha mer informasjon om disse feiltypene, kan du se følgende hjelpeemner:

Denne feilen oppstår når overflytområdet for en overflytmatriseformel ikke er tom.

#OVERFLYT! feil – Overflytområdet er ikke tomt

Når formelen er merket, angir en stiplet kantlinje det tiltenkte overflytområdet.

Du kan velge feilflyten og velge alternativet Velg hindrende celler for umiddelbart å gå til de hindrende cellene. Du kan deretter fjerne feilen ved enten å slette eller flytte oppføringen i den hindrende cellen. Så snart hindringen er fjernet, flyter matriseformelen over som tiltenkt.

Excel kan ikke fastslå størrelsen på den overflytende matrisen fordi den er flyktig, og endrer størrelse mellom beregningoverføring. Formelen nedenfor utløser for eksempel denne #OVERFLYT! -feilen:

=SEKVENS(TILFELDIGMELLOM(1,1000))

Dynamiske matrisestørrelser kan utløse flere beregningoverføringer, for å sikre at regnearket er fullstendig beregnet. Hvis størrelsen på matrisen fortsetter å endres under disse ekstra passene og ikke stabiliseres, vil Excel løse den dynamiske matrisen som #OVERFLYT!.

Denne feilverdien er vanligvis knyttet til bruken av TILFELDIG, TILFELDIGMATRISE, og TILFELDIGMELLOM -funksjonene. Andre flyktige funksjoner, for eksempel FORSKYVNING, INDIREKTE, and IDAG returnerer ikke forskjellige verdier for hver beregningsoverføring. 

Formelen =FINN.RAD(A:A,A:C,2,USANN) ville for eksempel når den plasseres i celle  E2 som i eksemplet nedenfor, tidligere bare slå opp ID-en i celle A2 . Men i dynamisk Excel-matrise vil formelen føre til en #OVERFLYT! -feil fordi Excel slår opp hele kolonnen, returnerer 1 048 576 resultater og kommer til slutten av Excel-rutenettet.

#OVERFLYT! feil forårsaket med =FINN.RAD(A:A,A:D,2,USANN) i celle E2, fordi resultatene ville flyte utover regnearkets kant. Flytt formelen til celle E1, så vil den fungere som den skal.

Det finnes tre enkle måter å løse dette problemet på:

#

Fremgangsmåte

Formel

1

Referer bare til oppslagsverdiene du er interessert i. Denne formelstilen returnerer en dynamisk matrise, men fungerer ikke med Excel-tabeller

Bruk =FINN.RAD(A2:A7,A:C,2,USANN) til å returnere en dynamisk matrise som ikke resulterer i en #OVERFLYT! -feil.

=FINN.RAD(A2:A7,A:C,2,USANN)

2

Referer bare til verdien på samme rad, og kopier deretter formelen ned. Denne tradisjonelle formelstilen fungerer i tabeller, men vil ikke returnere en dynamisk matrise.

Bruk den tradisjonelle FINN.RAD med én enkelt søkeverdireferanse: =FINN.RAD(A2,A:C,32,USANN). Denne formelen returnerer ikke en dynamisk matrise, men kan brukes med Excel-tabeller.

=FINN.RAD(A2,A:C,2,USANN)

3

Be om at Excel utfører implisitt skjæringspunkt ved hjelp av @-operatoren, og kopier deretter formelen ned. Denne formelstilen fungerer i tabeller, men vil ikke returnere en dynamisk matrise.

Bruk @-operatoren, og kopier ned: =FINN.RAD(@A:A,A:C,2,USANN). Denne referansestilen vil fungere i tabeller, men vil ikke returnere en dynamisk matrise.

=FINN.RAD(@A:A,A:C,2,USANN)

Overflytmatriseformler støttes ikke i Excel-tabeller. Prøv å flytte formelen ut av tabellen, eller konverter tabellen til et område (klikk Tabellutforming > Verktøy > Konverter til område).

#OVERFLYT! feil – tabellformel

Overflytmatriseformelen du prøver å skrive inn, har ført til at Excel ikke har nok minne. Prøv å referere til en mindre matrise eller et mindre område.

Overflytmatriseformler kan ikke flyte over i sammenslåtte celler. Vennligst fjern de aktuelle sammenslåtte cellene, eller flytt formelen til et annet område som ikke lager skjæringspunkt med sammenslåtte celler.

#OVERFLYT! feil – flyter over i sammenslått celle

Når formelen er merket, angir en stiplet kantlinje det tiltenkte overflytområdet.

Du kan velge feilflyten og velge alternativet Velg hindrende celler for umiddelbart å gå til de hindrende cellene. Så snart de sammenslåtte cellene fjernes, flyter matriseformelen over som tiltenkt.

Excel gjenkjenner ikke eller kan ikke avstemme årsaken til denne feilen. Kontroller at formelen inneholder alle de nødvendige argumentene for scenarioet.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excels tekniske fellesskap eller få hjelp i Svar-fellesskapet.

Se også

FILTER-funksjonen

TILFELDIGMATRISE-funksjonen

SEKVENS-funksjonen

SORTER-funksjonen

SORTER ETTER-funksjonen

UNIK-funksjonen

Dynamiske matriser og overflytende matrise

Implisitt skjæringspunktoperator: @

Trenger du mer hjelp?

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Microsoft Insiders

Var denne informasjonen nyttig?

Hvor fornøyd er du med kvaliteten på oversettelsen?
Hva påvirket opplevelsen din?

Takk for tilbakemeldingen!

×