ВВЕДЕНИЕ
В этой статье перечислены ошибки, исправленные в Microsoft SQL Server 2008 R2 с пакетом обновления 1 (SP1).
Заметки
- Другие исправления, которые не описаны в документации, могут быть включены в пакет обновления.
- Этот список будет обновляться по мере выхода новых статей.
Дополнительные сведения о том, как получить пакеты обновления для SQL Server 2008 R2, см. в следующей статье базы знаний Майкрософт:
2527041 Как получить последний пакет обновления для SQL Server 2008 R2
Дополнительные сведения
Помимо исправлений, перечисленных в этой статье, SQL Server 2008 R2 с пакетом обновления 1 (SP1) содержит исправления, которые были включены в пакеты обновления с 1 по 6 для SQL Server 2008 R2. В этот пакет обновления также входят все обновления для системы безопасности, выпущенные до июля 2011 г.
Для получения дополнительной информации о накопительных пакетах обновления, доступных для SQL Server 2008 R2, щелкните статью со следующим номером в базе знаний Майкрософт:
981356 Сборки SQL Server 2008 R2, выпущенные после выпуска SQL Server 2008 R2
Исправления в этом пакете обновления
Для получения дополнительных сведений об ошибках, исправленных в SQL Server 2008 R2 с пакетом обновления 1 (SP1), просмотрите соответствующие статьи в базе знаний Майкрософт.
| Номер ошибки VSTS | Номер статьи базы знаний | Описание |
|---|---|---|
| 657377 | 949775 | Целевой сервер не может загрузить многосерверное задание с сервера master, если целевой сервер работает с немецкой или французской версией SQL Server 2005 |
| 657404 | 2216478 | Сообщение об ошибке при запуске Get-Command в среде PowerShell версии 2 на сервере с SQL Server 2008: "Объектная ссылка не установлена на экземпляр объекта" |
| 649451 | 2216485 | ИСПРАВЛЕНО: монитор ресурсов переходит в состояние "невозврат" на сервере, на котором работает SQL Server 2008 |
| 649479 | 2216489 | Проблема 2008 SP2 [Назначение SQL Server [19]] Ошибка: не удается подготовить массовую вставку SSIS для вставки данных |
| 649504 | 2216497 | FIX: Пространственное хранилище геометрии полигональные типы данных с внутренними кольцами возвращают неверные данные с помощью различных геометрических операций |
| 649529 | 2216501 | ИСПРАВЛЕНИЕ: Многосерверные задания не загружаются из SQL Server 2000 в роли MSX в SQL Server 2008 в роли TSX |
| 649457 | 2448971 | ИСПРАВЛЕНО: блокировки таблицы не эскалируются при вставке большого количества строк в таблицу в SQL Server 2008 |
| 628428 | 2463682 | FIX: База данных, включенная для прозрачного шифрования данных, может стать недоступной, если сертификат, который используется для шифрования ключа шифрования базы данных, отброшен. |
| 625028 | 2494517 | ИСПРАВЛЕНО: Значение скрытого текстового поля, на которое ссылается заголовок табликса, отображается только на первой странице после экспорта отчета в модуль визуализации с жестким разрывом страницы |
| 447613 | 2515006 | Примененные фильтры набора данных SharedDataSet или обработка параметров Использование неправильных параметров сортировки |
| 697406 | 2525273 | ИСПРАВЛЕНИЕ. Модель кластеризации, использующая алгоритм K-средних, генерирует различные результаты, на которые влияют столбцы PredictOnly в службах SQL Server 2008 R2 Analysis Services |
| 649480 | 2216491 | Служебная программа SQL Dumper не может создавать файлы дампа ошибок в отказоустойчивом кластере SQL Server 2008 или SQL Server 2008 R2 в отказоустойчивом кластере Advanced/Enterprise |
| 649339 | 2216460 | Сообщение об ошибке при попытке открыть проект в SQL Server 2008 или SQL Server 2008 R2: "Определение манифеста расположенной сборки не соответствует ссылке на сборку" |
| 405512 | 2105809 | При переключении из режима подключения в локальный> режим возникает ошибка «Невозможно остановить службу сервера отчетов на компьютере<» |
| 405514 | 981588 | Появляется сообщение об ошибке при попытке прямого перехода к серверу отчетов SSRS 2008 R2 после создания сайта утверждений SharePoint |
| 665971 | 2546901 | ИСПРАВЛЕНИЕ. Другие результаты возвращаются при выполнении параллельного запроса, использующего функцию ранжирования в SQL Server 2005, SQL Server 2008 или SQL Server 2008 R2 на компьютере с 8 или более процессорами |
| 650006 | 2563828 | Assert в функции = Microsoft.ReportingServices.ReportProcessing.ParameterBase.Cast file = line = 0 expression = Необработанное управляемое исключение: Type = System.InvalidCastException, Message = Невозможно привести объект типа 'System.Boolean' к типу 'Syste. |
| 689073 | 2531482 | ИСПРАВЛЕНИЕ: функция IntelliSense в SSMS 2008 R2 может перестать работать после установки Visual Studio 2010 SP1 |
| 649856 | 2584903 | ИСПРАВЛЕНИЕ: Задание сборщика данных для удаления данных из базы данных MDW в SQL Server 2008 R2 занимает много времени |
Дополнительные исправления в этом пакете обновления
Решения следующих проблем также включены в SQL Server 2008 R2 с пакетом обновления 1 (SP1).
| ID | Описание |
|---|---|
| 418521 | Отрисовщик HTML больше не создает исключение ArgumentOutOfRangeException, если в отчете свойство ConsumeContainerWhitespace имеет значение TRUE и если есть горизонтальное пустое пространство, доступное для заполнения. |
| 346804 | ИСПРАВЛЕНИЕ: Синтаксис подсказки индекса "FORCESEEK" теперь принимает необязательные параметры. Добавлена новая подсказка запроса FORCESCAN. Дополнительные сведения см. в статье "Подсказки запросов (Transact-SQL)" (http://msdn.microsoft.com/en-us/library/ms181714.aspx). |
| 405562 | Строки подключения, такие как 'server="tcp:"' и 'server="np:"', поддерживаются в SQL Server Native Client 2008 для подключения к локальному экземпляру. Благодаря этому исправлению эти строки подключения теперь работают в SQL Server Native Client 2008 R2 и позволяют подключаться к локальному экземпляру. |
| 447996 | Проблема в логической проверке больше не возникает, если секционированный столбец индексированного представления совпадает с секционированным столбцом базовой секционированной таблицы. Переключение таблиц больше не поддерживается в индексированных представлениях, не связанных с выравниванием разделов. |
| 471571 | Использование SQL 10.5 BIDS для развертывания частей отчета в SQL Server 2008 R2 (и более поздних версиях) Сервер отчетов больше не дает сбой или не создает сообщение об ошибке управления версиями SQL. |
| 512199 | Метки времени теперь отображаются корректно при чтении файлов расширенных событий или аудита SQL на компьютере, отличном от того, на котором был создан файл. Метки времени теперь также корректны после перезапуска сервера. |
| 528501 | Отрисовка отчета в режиме синхронного отображения с помощью веб-частей Reporting Services 2008 R2 теперь можно просматривать, если отчет содержит пробелы в имени отчета. Сообщение об ошибке StreamNotFound больше не создается. |
| 538455 | При отображении в формате HTML с параметром DeviceInfo "StyleStream", установленным в значение ИСТИНА, параметры стиля больше не теряются в текстовых полях или тексте, если определены действия. |
| 540725 | Созданы два новых файла шаблонов трассировки для подсистемы и служб анализа. Это позволяет Profiler отображать все события и столбцы как для подсистемы, так и для служб анализа. |
| 550635 | ИСПРАВЛЕНО: Неправильное сообщение о тексте, когда анализатор работоспособности SP 2010 возвращает сообщение об ошибке о службах Analysis Services, работающих в режиме VertiPaq. |
| 550947 | В элементе отчета табликса, содержащем 20 или более строк, содержащих вложенные элементы отчета контейнера (Прямоугольник и табликс), оболочка BIDS больше не перестает отвечать при вставке новой строки над или под любым элементом табликса. |
| 555701 | Сообщение об отсутствии порядка больше не приводит к ошибке нарушения прав доступа при запуске объекта DBM. |
| 617987 | При установке нового сервера больше не сообщается, что ключ Secure Store master не создается при установке устройства бизнес-аналитики. (Сообщение было создано, хотя установка прошла успешно.) |
| 623819 | Исправлена проблема, из-за которой отображалось сообщение об ошибке, когда оптимизатору запросов не удавалось создать план для некоторых запросов к секционированным представлениям. Это описано в 620614 проблемы Microsoft Connect. Исправление находится под флагом трассировки (см. статью базы знаний 974006). |
| 624909 | Производительность больше не снижается при использовании средства просмотра отчетов или отображения в формате HTML, если на одной странице SharePoint имеется несколько веб-частей. |
| 624951 | Больше не возникает исключение "Ошибка при выгрузке домена приложения" при закрытии приложения WPF, содержащего элемент управления ReportViewer. |
| 626205 | Службы Analysis Services не могут создать локальный куб из куба сервера, имеющего элементы измерения, связанные с неизвестным элементом. |
| 626243 | Теперь PowerPivot успешно установлен в существующей ферме, если общие компоненты SQL Server установлены в расположение, отличное от расположения по умолчанию. |
| 629973 | BIDS и Report Builder 3 больше не аварийно завершают работу при следующих действиях: перетащите ячейку в таблице за границу, перейдите в режим "Переместить элемент отчета", переместите объект за пределы таблицы и нажмите клавишу ESC при щелчке и удерживании кнопки мыши. |
| 636999 | Если помощнику по обновлению не удается выполнить сканирование файла трассировки, теперь помощник по обновлению может отобразить понятное сообщение об ошибке для пользователя. |
| 639182 | Диалоговое окно входа в систему для Report Builder 3.0 Эта функция вызывается, когда для служб SSRS используется проверка подлинности форм, и больше не заслоняется модальным диалоговым окном "Мастер создания отчетов". (Из-за этой проблемы пользователи могут не знать, что запрашивается вход в систему.) |
| 643961 | Все конкретные параметры учетных записей пользователей теперь работают в расписаниях источников данных. |
| 646473 | Приложение, разработанное в среде .NET Framework 4.0, больше не завершается сбоем, если структурная декомпозиция ресурсов (СДРиА) не может найти сведения о его конфигурации. Теперь поиск информации выполняется в файлах конфигурации .NET Framework 4.0 и .NET Framework 3.5. |
| 658405 | Теперь можно создавать настраиваемые отчеты с помощью ODC-файла на информационной панели управления ИТ. |
| 665971 | Оператор параллелизма передает строки в правильном порядке. Теперь оптимизатор может выбрать неоптимальный план. Поэтому для этого исправления требуется флаг трассировки. Чтобы использовать это исправление, необходимо включить traceflag 4134. |
| 674357 | Теперь созданы два новых файла шаблонов трассировки для службы подсистемы и для службы анализа. Это делается для того, чтобы профилировщик мог отобразить все события и столбцы для обеих служб. |
| 679035 | Исправлена небольшая опечатка на странице центрального администратора. |
| 684435 | StringCchPrintf_l ожидаем размер конечного буфера в символах. Размер передавался в байтах. Поэтому была поднята ошибка OACR - BUFFER_OVERFLOW. Исправлен код, передав правильную длину. |
| 649475 | Наборы коллекции работают некорректно при сборе счетчиков производительности в кластере, если имя экземпляра SQL совпадает с именем виртуальной сети. |
| 649357 | В данной базе данных использование указателя сервера, объявленного для оператора select, содержащего любое системное представление, может выдать неправильные результаты после присоединения и повторного подключения этой базы данных. |
| 649391 | Ошибки повреждения DBCC возникают во время сортировки SQL Server 2008 R2, когда используются строки с последовательностями Jamo, следующими за японским пролонгированным знаком. |
| 657399 | Неверный номер версии отображается в SQL Server Management Studio и SQL Server Reporting Services. Это вносит путаницу, так как отображаемое число не отличается от номера версии RTM после выполнения обновления. |
| 649476 | FIX: Улучшена и регистрируется дополнительная информация для InvalidReportParameterException в расширенном выводе, если во время обработки параметров возникают определенные условия. |
| 649557 | ИСПРАВЛЕНО. Проблема специальных возможностей, возникающая из-за того, что имя Microsoft Active Accessibility "Символ" равно нулю. Имена активных специальных возможностей Майкрософт обновлены и теперь доступны для обнаружения. |
| 649447 | ReportBuilder 2.0 ClickOnce отображает пустой отчет при запуске, если пользователь редактирует отчет с помощью ReportBuilder 2.0 с веб-сайта SharePoint 12. |
| 649575 | Имена MSAA для диалогового окна "Свойства радиальной шкалы" неверны и не соответствуют требованиям специальных возможностей. |
| 519534 | Использование возвращающих табличное значение параметров для столбцов бизнес-приложений может привести к нарушению прав доступа на сервере. |
| 645824 | Ошибка нарушения прав доступа может возникать во время выполнения расширенных хранимых процедур в условиях высокого напряжения. |
| 649559 | ИСПРАВЛЕНИЕ: улучшена производительность создания индекса с помощью инструкций DDL для таблиц с большим количеством секций и без данных. Ранее время, необходимое для этого процесса, увеличивалось в геометрической прогрессии по мере увеличения числа секций. Требуемое время теперь увеличивается в линейной прогрессии. |
| 649537, 448009 | В некоторых условиях имя секционированного столбца в сообщении об ошибке 11405 может быть неправильным. Это приводило к выводу на печать неправильного имени столбца. |
| 649530 | Дополнительное исключение может возникать, когда службы Analysis Services создают файл дампа Watson. Это верно независимо от того, создан ли файл дампа Watson из-за фактического исключения или из-за явного запроса на дамп при определенных ошибках. При возникновении вторичного исключения на сервере может возникать бесконечная рекурсия. Это создает множество файлов дампа, а затем выключает сервер. |
| 649524 | Если пользователь создает пользовательский тип и функцию с табличным значением в одной транзакции и если функция имеет возвращаемую таблицу, содержащую столбец пользовательского типа, происходит самовзаимоблокировка. Кроме того, подключение, которое пытается выполнить эти операции, останавливается. |
| 649532 | Невозможно безопасно создать пространственный индекс в таблице, в которой для имен столбцов используются CELL_ID, CELL_ATTRIBUTES или SRID. |
| 657405 | Иногда на сервере SQL Server появляется сообщение об ошибке "Недостаточно системной памяти в пуле ресурсов "внутренний" для выполнения этого запроса". Эту ситуацию часто можно предотвратить. |
| 649434 | Если параметры, связанные функцией SQLBindParameter, указывают длину SQL_DATA_AT_EXEC, драйвер ODC собственного клиента SQL Server 2008 R2 вызывает нарушение прав доступа, если функция SQLPutData указывает длину SQL_NULL_DATA при поставке значения параметра для выполнения. |
| 512170 | Если используется режим MARS, в sys.dm_os_tasks представлении отображается одинаковое значение в request_id столбце для всех задач, а не указывается правильное значение, связанное с каждой задачей. |
| 649425 | В представлении sys.dm_os_wait_stats отображаются повторяющиеся строки для типа ожидания MISCELLANEOUS. Это может вызвать проблемы со средствами мониторинга. |
| 649346 | Целевой объект асинхронного сегментирования отображает неверные пары значение/строка для сопоставленных полей при сравнении со сведениями, доступными в dm_xe_map_values. |
| 649340 | ИСПРАВЛЕНО: В базовой таблице системы syscolpars отображались дубликаты строк. Это исправление отличает их путем добавления номера процедуры в DBCC checkcatalog. |
| 649427 | ИСПРАВЛЕНИЕ: Новый код ошибки (6257) возвращается, когда пользователь пытается зарегистрировать сборку CLR, собранную для более новой среды выполнения, такой как CLR v4. Предыдущее сообщение об ошибке (код 6218) было запутанным и не указывало фактическую проблему. Подробные сведения см. в этой статье. |
| 649433 | В пограничном случае значение идентификатора вставляется за пределами текущего диапазона в режиме "Включить identity_insert TABLE_NAME". Эта проблема также возникает в операциях резервного копирования и восстановления. |
| 649450 | Когда BCP.exe получает сведения о метаданных столбцов, возвращаются неверные параметры сортировки столбцов. |
| 649527 | Использование функции PeriodsToDate с параметром-членом Null может вызвать ошибку "Непредвиденное исключение". |
| 649341 | Если запрос содержит фильтр, который ссылается на столбец в представлении sys.dm_server_audit_status, фильтр игнорируется и возвращаются все строки из sys.dm_server_audit_status. |
| 629570 | Ошибка 955 возникает, когда пользователи пытались настроить Data Warehouse управления, если на их сервере есть базы данных, которые не подключены к сети. |
| 649374 | В буфере кругов отображаются неполные данные о событии (события вывода из dm_xe_session_targets) при достижении предельного размера для выходных данных XML. |
| 677560 | Исправлена проблема, из-за которой удаленный запрос приводил к ошибке с кодом 7359 в SQL Server 2008 R2. Эта проблема возникала, если в пользовательской функции используется синоним связанной таблицы, если на локальном сервере существует план выполнения этой функции, а версия схемы связанной таблицы обновляется на удаленном сервере. |
| 562310 | Исправлена ошибка "Read AV in FullXactImpBase::GetXdes xact.cpp @ 2536", которая возникает, когда создается база данных db1, кэшируется запрос для db1, а затем db1 удаляется, создается вторая база данных, снова создается db1 и кэшированный запрос выполняется повторно. |
| 623804 | Исправлен неверный результат запросов, выполняемых внутри текста триггера. Для сценария требуется уникальный отфильтрованный индекс. Триггер должен содержать запрос, от которого зависит, является ли столбец уникальным для всей таблицы. |
| 636156 | Устраняет проблему, из-за которой резервные копии повреждаются, если в базах данных включено прозрачное шифрование базы данных, включены контрольные суммы страниц, а для резервного копирования используются контрольные суммы. |
| 657511 | ИСПРАВЛЕНИЕ: Это исправление устраняет тайм-ауты и взаимоблокировки, которые могут возникать во время обработки подписок, когда одновременно обрабатывается множество подписок. Исправление применяется, если службы Reporting Services развернуты в интегрированном режиме SharePoint. |
| 676139 | Исправлена проблема, из-за которой пользователю приходилось выполнять сортировку, а страница сортировки разливалась на диск. Кроме того, сканирование TDE происходит одновременно с касанием этой конкретной страницы. Можно перезагрузить компьютер, чтобы устранить проблему. Однако вы не сможете полностью избежать этой проблемы, если не отключите TDE. |
| 676491 | Устраняет потенциальную проблему, возникающую после применения исправления, описанного в VSTS 473052 об ошибках. |
| 679886 | Исправлена проблема, из-за которой собранные расширенные события или файлы журнала аудита SQL могут отображать неправильные сведения о метке времени. |
| 686401 | Исправлена проблема, из-за которой значение C# Null преобразуется в dbNull перед его сохранением. |
| 620861 | ИСПРАВЛЕНИЕ. Поддерживается не более 15 000 разделов в таблицах и индексах в выпусках Microsoft Datacenter, Корпоративная, Для разработчиков и Ознакомительная версия Microsoft SQL Server 2008 R2 SP1. Дополнительные сведения о включении и отключении этой поддержки, ее ограничениях, известных проблемах и обходных путях см. в техническом документе "Поддержка 15 000 разделов" https://go.microsoft.com/fwlink/?linkid=199773 |
| 296354 | ИСПРАВЛЕНИЕ. Значения по умолчанию свойства SqlDumperDumpTimeOut выходят за пределы допустимой области в Microsoft SQL Server 2008 R2 SP1. Допустимая область значений варьируется от 0 (мс) до MAXDWORD. |
| 417616 | ИСПРАВЛЕНО. Логика получения имен субъектов-служб для учетных записей служб теперь настроена на то, чтобы всегда регистрироваться. Перед применением этого исправления логика записывается в журнал только при включенном EP. Эти сведения могут быть использованы для устранения проблем с Kerberos. |
| 517329 | Из-за дефекта программы различные средства диагностики сообщают о том, что запросы выполняются в базе данных master, а не в той базе данных, в которой они были фактически выполнены. |
| 615697 | Отсутствуют баллы SQM для важных функций в Microsoft SQL Server 2008 или более поздней версии SQL Server. Это исправление добавляет несколько важных точек SQM, которые полезны для отслеживания метрик использования клиентами. |
| 645245 | ИСПРАВЛЕНО: логика повторного подключения и повторного выполнения удалена из пути к коду выполнения запроса в редакторе SQL. Эти сведения больше не требуются, так как период ожидания подключения IDLE для Microsoft SQL Azure увеличился до 30 минут. |
| 674580 | Новый файл шаблона трассировки ("Microsoft Analysis Services TraceDefinition 10.50.0.xml") в службах Analysis Services необходимо создать заново, чтобы включить в него вновь добавленные события трассировки, чтобы профилировщик мог отобразить все события и столбцы. |
| 707007 | Импорт не удался в сценариях Далласа. |
| 710263 | Если в качестве браузера используется Internet обозреватель 9, при попытке создания моментальных снимков в коллекции отчетов возвращается ошибка. |
| 710433 | ИСПРАВЛЕНО: Реестр обновляется для передачи имен файлов в качестве параметра ssms.exe при двойном щелчке по файлу .sql. |
| 656177 | ИСПРАВЛЕНО. Нарушение прав доступа происходит при использовании хранимой процедуры или определяемой пользователем функции для создания табличной переменной в SQL Server 2008 или SQL Server 2008 R2 |
Ссылки
Для получения дополнительных сведений об определении текущей версии и выпуска SQL Server щелкните следующий номер статьи в базе знаний Майкрософт:
321185
Определение версии и выпуска SQL Server
Продукты сторонних разработчиков, рассмотренные в этой статье, выпущены компаниями, независимыми от корпорации Майкрософт. Корпорация Майкрософт не гарантирует надлежащую работоспособность и надежность этих продуктов.