ВВЕДЕНИЕ
В этой статье перечислены ошибки, исправленные в Microsoft SQL Server 2008 R2 с пакетом обновления 2 (SP2).
Заметки
- Другие исправления, которые не описаны в документации, также могут быть включены в пакет обновления.
- Этот список будет обновляться по мере выхода новых статей.
Дополнительные сведения о том, как получить пакеты обновления для SQL Server 2008 R2, см. в следующей статье базы знаний Майкрософт:
2527041 Как получить последний пакет обновления для SQL Server 2008 R2
Дополнительные сведения
Помимо исправлений, перечисленных в этой статье, SQL Server 2008 R2 с пакетом обновления 2 (SP2) содержит исправления, которые были включены в пакеты обновления с 1 по 5 для SQL Server 2008 R2 с пакетом обновления 1 (SP1).
Примечание При обновлении с накопительного пакета обновления 6 для SQL Server 2008 R2 R2 с пакетом обновления 1 (SP1) необходимо установить накопительный пакет обновления после SQL Server 2008 R2 с пакетом обновления 2 (SP2) после обновления до SQL Server 2008 R2 с пакетом обновления 2 (SP2), чтобы получить все исправления.
Дополнительные сведения о накопительных пакетах обновлений для SQL Server 2008 R2 с пакетом обновления 1 (SP1) см. в следующей статье базы знаний Майкрософт:
2567616 Сборки SQL Server 2008 R2, выпущенные после выпуска SQL Server 2008 R2 с пакетом обновления 1
Проблемы, исправленные в этом пакете обновления
Для получения дополнительных сведений об ошибках, исправленных в SQL Server 2008 R2 с пакетом обновления 2 (SP2), просмотрите соответствующие статьи в базе знаний Майкрософт.
| Номер ошибки VSTS | Номер статьи базы знаний | Описание |
|---|---|---|
| 820875 | 922578 | ИСПРАВЛЕНИЕ: Многие сообщения с кодом сообщения 19030 и кодом сообщения 19031 регистрируются в SQL Server 2005, SQL Server 2008 или SQL Server 2008 R2 Файл журнала ошибок при использовании профиля SQL Server в SQL Server 2005, в SQL Server 2008 или в SQL Server 2008 Р2 |
| 728527 | 2216456 | Улучшения в SQL Server 2008 с пакетом обновления 2 (SP2) и SQL Server 2008 R2 с пакетом обновления 2 (SP2) для текста сообщения об ошибке "Операция отменена" в службах Analysis Services |
| 820858 | 2550375 | ИСПРАВЛЕНИЕ: в sys.dm_database_encryption_keys DMV в SQL Server 2008 R2 может возникать взаимоблокировка при запуске отправки журналов из нескольких баз данных на один дополнительный сервер. |
| 820878 | 2565683 | ИСПРАВЛЕНО. Вы можете получить неправильные результаты при выполнении сложного запроса, содержащего агрегатные функции, функции объединения и отдельные функции во вложенных запросах в среде SQL Server 2008 или SQL Server 2008 R2 |
| 820756 | 2588050 | ИСПРАВЛЕНИЕ: Сбой установки объединенным потоком пакета обновления для SQL Server 2008 или SQL Server 2008 R2 при добавлении новых компонентов в экземпляр SQL, если установлено ядро СУБД |
| 901689 | 2653857 | ИСПРАВЛЕНИЕ: не удается подключиться к SQL Server с помощью драйвера JDBC для SQL Server после обновления до JRE 6 с обновлением 29 или более поздней версии |
| 873603 | 2682488 | ИСПРАВЛЕНО: сбой операции резервного копирования в SQL Server 2008, SQL Server 2008 R2 или в базе данных SQL Server 2012 после включения отслеживания изменений |
| 958983 | 2719217 | ИСПРАВЛЕНО: ошибка тайм-аута блокировки, если у вас есть таблицы кучи и включено сжатие данных в SQL Server 2008 R2 или SQL Server 2012 |
Дополнительные проблемы, исправленные в этой CTP-версии пакета обновления
Решения следующих проблем также включены в SQL Server 2008 R2 SP2.
| Номер ошибки VSTS | Описание |
|---|---|
| 820845 | в восторге от использования метода BindParameter и ссылки на параметры типа long, которые используются этим методом. |
| 852397 | Обновления UpgradeIncompleteFeatureConfigEventHandler.cs включить сценарий RebuildDatabase при сбросе ConfigurationState. |
| 887672 | Для библиотек документов с параметром "Открытие документов в браузере" со значением "Открыть в клиентском приложении" GetSnapshot.exe игнорирует конфигурацию и всегда отображает книгу, используя службы Excel, как если бы был выбран параметр "Открыть в браузере". |
| 820805 | FIX: В русскоязычной локализованной сборке Reporting Services Configuration Manager информация о Execution Account содержит обрезанные строки. |
| 718430 | Счетчики использования ExpectedCount и ExpectedElapsedMs обновляются для отражения фактического количества. |
| 737914 | Исправлена проблема, из-за которой во время синхронизации базы данных происходит сбой служб SQL Server 2008 R2 Analysis Services. |
| 788389 | Флаг трассировки 1264 удаляется, чтобы имя процесса собиралось по умолчанию в невозвращаемых дампах сценариев. Количество записей потоков в файлах дампа сценариев, не возвращающих урожай, увеличено с 1 КБ до 16 КБ. |
| 820762 | Если событие должно быть зарегистрировано, в SQL Server 2008 R2 изменяется значение параметра FireAgain на значение True. Однако после того, как некоторые коды были удалены по ошибке, некоторые журналы отсутствуют, поскольку параметр FireAgain определяется только внешним прослушивателем событий. После применения этого исправления проблема будет устранена. |
| 820764 | Рассмотрим следующий сценарий. В SQL Server 2008 R2 есть индексированное представление столбцов проектов из базовых и небазовых таблиц. Столбец из небазовой таблицы имеет тот же идентификатор и тип порядка, что и столбец в базовой таблице. В этом сценарии SQL Server 2008 R2 переключает разделы. После применения исправления в SQL Server 2008 R2 вместо переключения разделов возникает ошибка. |
| 820792 | Исправлена проблема, из-за которой объект, выделенный в SOS_Task PMO, мог также использоваться другой задачей с другим сроком жизни. Этот пакет обновления использует правильный PMO для выделения объекта. |
| 820796 | После применения исправления оптимизатор понимает, что CRYPT_GEN_RANDOM могут возвращать разные выходные данные для одного и того же ввода. |
| 820859 | Исправлена проблема, из-за которой при запуске SCOPE_IDENTITY() возвращается неправильное значение. |
| 820864 | Исправлена проблема, из-за которой происходит сбой программы установки SQL Server 2008 R2 при установке SxS с Shiloh OLAP SP3a. Эта проблема возникает из-за того, что Shiloh OLAP SP3a неправильно записывает раздел реестра версии как "Пакет обновления 3.0". |
| 820873 | Исправлена проблема, из-за которой sys.dm_exec_query_stats сообщает о неправильном времени ЦП, если задействованы параллельные планы запросов. |
| 820880 | Исправлена проблема, возникавшая при разделении разделителя столбцов из нескольких символов во внутренних асинхронных буферах чтения файлов на две части. Исправление заключается в правильном сбросе текущего указателя синтаксического анализа после переключения буферов. |
| 847805 | Используется синхронизация только в том случае, если операция SQLWixCompilerExtension выполняется в свече. |
| 890643 | Изменяет операцию HierarchyGet, чтобы избежать определенного пути кода для явного ограничения, которое применяется только к производной части иерархии. Это однострочное обновление с низким риском. |
| 731796 | Исправлена проблема, из-за которой в выписке возникают ошибки при удалении snapshots.notable_query_text. |
| 820829 | Неправильные значения GUID, анализируемые из неструктурированных файлов, могут вызывать ошибки. Исправление заключается в возврате в режим усечения, если размер исходного буфера превышает максимальный размер строки GUID. |
| 677173 | Периодически пересчитывает пороговое значение срабатывания защелки, чтобы избежать изменений из-за ошибки вычислений при запуске. |
| 725819 | Предлагаемое исправление заключается в согласовании звонков между вызывающим и вызываемым пользователем. |
| 769975 | Исправлена ошибка, приводившая к аварийному завершению работы во время запуска, когда на компьютере были пустые слоты процессора или при использовании параметра перезапуска /setgroupsize. |
| 788233 | Сокращает время, в течение которого защелка отступает при блокировке вращения. Это помогает повысить производительность |
| 840461 | Исправлена состояние гонки во время запуска сеанса XE, которое могло приводить к сбоям SQL Server. |
Ссылки
Для получения дополнительных сведений об определении текущей версии и выпуска SQL Server щелкните следующий номер статьи в базе знаний Майкрософт:
321185
Определение версии и выпуска SQL Server
Продукты сторонних разработчиков, рассмотренные в этой статье, выпущены компаниями, независимыми от корпорации Майкрософт. Корпорация Майкрософт не гарантирует надлежащую работоспособность и надежность этих продуктов.