Введение
В этой статье перечислены ошибки, исправленные в Microsoft SQL Server 2012 с пакетом обновления 2 (SP2).
Заметки
- Дополнительные исправления, не описанные здесь, также могут быть включены в пакет обновления.
- Этот список будет обновляться по мере выхода новых статей.
Для получения дополнительных сведений о том, как получить пакеты обновления для SQL Server 2012, щелкните следующий номер статьи в базе знаний Майкрософт:
2755533 Как получить последний пакет обновления для SQL Server 2012 г. Примечание. Дополнительные сведения о том, какой файл следует выбрать из списка доступных загрузок, проверка заметках о выпуске здесь.
Дополнительные сведения
Пакеты обновления для SQL Server 2012 представляют собой накопительные пакеты обновлений, которые обновляют все выпуски и уровни обслуживания SQL Server 2012 до пакета обновления 2 (SP2). Помимо исправлений, перечисленных в этой статье, этот пакет обновления содержит накопительный пакет обновления 9 (CU9) для Microsoft SQL Server 2012 с пакетом обновления 1 (SP1).
Дополнительные сведения о накопительных пакетах обновления, доступных для SQL Server 2012 с пакетом обновления 1 (SP1), см. в следующей статье базы знаний Майкрософт:
2772858 Сборки SQL Server 2012 г., выпущенные после выпуска SQL Server 2012 с пакетом обновления 1 (SP1)
Проблемы, исправленные в этом пакете обновления
Для получения дополнительных сведений об ошибках, исправленных в SQL Server 2012 с пакетом обновления 2 (SP2), просмотрите статьи базы знаний Майкрософт по следующим номерам.
| Номер ошибки VSTS | Номер статьи базы знаний | Описание |
|---|---|---|
| 1374617 | 2028830 | ИСПРАВЛЕНО: общие компоненты устанавливаются в неправильном месте при реализации установки отказоустойчивого кластера SQL Server 2008 или SQL Server 2012 |
| 1703014 | 2963382 | ИСПРАВЛЕНИЕ: Не удается подключиться к серверу при выполнении запроса MDX о создании куба в SSAS 2012 |
| 2011247 | 2927741 | ИСПРАВЛЕНИЕ: Изображение не отображается должным образом на веб-странице при использовании действия детализации в отчете SSRS 2012 |
| 2034994 | 2963383 | ИСПРАВЛЕНО: Текст усекается при использовании отрисовщика HPB для просмотра отчета в SSRS 2012 |
| 1769469 | 2963384 | ИСПРАВЛЕНО. SQL Server аварийно завершает работу, когда файл журнала базы данных tempdb заполнен в SQL Server 2012 |
| 1973168 | 2963386 | FIX: SSRS 2012 fails with IsolatedStorageException, when subscriptions, экспортируемые в листы Excel, превышают 10 МБ |
| 1973196 | 2963388 | ИСПРАВЛЕНО: SSRS 2012 не может экспортировать отчет размером более 10 МБ в формат Excel |
| 787358 | 2963404 | ИСПРАВЛЕНО: откат приводит к переходу базы данных в подозрительный режим в SQL Server 2012 |
| 1043717 | 2806979 | ИСПРАВЛЕНО: низкая производительность при выполнении запроса к таблице в базе данных с поддержкой RCSI в SQL Server 2012 |
| 1178585 | 2963412 | Новые sys.dm_fts_index_keywords_position_by_document DMF в SQL Server 2012 с пакетом обновления 2 (SP2) |
| 1182241 | 2966520 | ИСПРАВЛЕНО: при перезапуске службы Windows Reporting Services в SSRS 2012 1 января не создаются новые файлы журнала |
| 1240848 | 2966519 | ИСПРАВЛЕНО: Нет сообщения об ошибке при сбое резервного копирования журнала в SQL Server 2012 |
| 1253861 | 2936004 | FIX: Visual Studio 2012 аварийно завершает работу из-за нарушения прав доступа при завершении привязки источника данных в пользовательском интерфейсе средства просмотра отчетов 2012 в локальном режиме |
| 1262029 | 2966522 | ИСПРАВЛЕНО: подписка на общий файловый ресурс не заполняет столбец описания в SSRS 2012 |
| 1481773 | 2966523 | FIX: Раскрывающийся список "Имя" пуст, когда указан отчет SSRS 2012 |
| 1419367 | 2964762 | ИСПРАВЛЕНО. Событие с кодом 22 или ошибка 0xC1000016 будут регистрироваться при использовании команды обнаружения в SSAS 2012 |
| 2103903 | 2972285 | ИСПРАВЛЕНО. Проблемы с производительностью при использовании SSISDB в качестве хранилища развертывания в SQL Server 2012 |
| 2021581 | 2965035 | Улучшение функции ведения журнала SSAS 2012 в SQL Server 2012 с пакетом обновления 2 (SP2) |
| 203749 | 2952444 | ИСПРАВЛЕНИЕ: низкая производительность при использовании переменных таблицы в SQL Server 2012 |
| 2095064 | 2936328 | ИСПРАВЛЕНО: нарушение прав доступа возникает при запуске функций CHECKTABLE или CHECKDB для таблицы с сохраненными вычисляемыми столбцами в SQL Server 2008 R2 или SQL Server 2012 |
| 1222472 | 2827857 | ИСПРАВЛЕНО: DTA не работает в экземпляре SQL Server 2012, который использует параметры сортировки для дополнительных символов |
| 2124209 | 2939277 | ИСПРАВЛЕНО. Неправильные результаты при выполнении запросов, содержащих оператор UNION, с помощью параллельного плана запросов в SQL Server |
Решения следующих проблем также включены в SQL Server 2012 с пакетом обновления 2 (SP2).
| Номер ошибки VSTS | Описание |
|---|---|
| 950185 | Улучшены сообщения об ошибках обработки и предупреждениях при работе с большими отчетами в формате HTML. |
| 950189 | Улучшены сообщения об ошибках обработки и предупреждениях при работе с отчетами с большим количеством параметров. |
| 994470 | Некорректные результаты при работе с унарными операторами режима блокировки. |
| 1041277 | Полная резервная копия DPM на сервере с AlwaysOn вторичной будет преобразована в резервную копию copy_only. |
| 1278767 | Значение счетчиков производительности табличного экземпляра: Memory\VertiPaq <TypeName> KB всегда равно 0. |
| 1355346 | Конечный оператор SCOPE не совпадает с открывающим оператором SCOPE. |
| 1374617 | ИСПРАВЛЕНИЕ: общие компоненты устанавливаются в неправильном месте при реализации установки отказоустойчивого кластера SQL Server 2008 |
| 1610447 | Неинициализированный объект приводит к сбоям и потенциально неверным результатам при выполнении выражений DAX с условными вычислениями. |
| 1610492 | Простой запрос DAX возвращает неожиданные результаты при использовании PowerPivot версии 2 11.0.3000.0. |
| 2060218 | "ACTIONABLE_HEAP_CORRUPTION", когда файл конфигурации SSRS анализируется с использованием недопустимого идентификатора экземпляра. |
| 2065570 | Запись NonYieldProcessTable в RING_BUFFER_NONYIELD_PROCESSTABLE кольце не имеет времени процесса пользователя и ядра. |
| 2075161 | Предоставляет сведения о платформе в журнале SSRS 2012 |
| 1347204 | ИСПРАВЛЕНО: Нарушение прав доступа при вставке данных в таблицу, содержащую столбец с последовательностью по умолчанию из транзакции между базами данных в SQL Server 2012 |
| 1184332 | Если резервное копирование журнала последних версий выполняется для базы данных модели, база данных модели зависает в состоянии восстановления во время перезапуска сервера, что препятствует успешному запуску SQL Server. Это вызвано тем, что не удалось создать базу данных Tempdb во время запуска сервера и вы получаете следующее сообщение об ошибке: "База данных "<DatabaseName>" не может быть открыта" |
| 1243853 | Ошибка 3456 возникает при восстановлении резервной копии журнала базы данных с неполным протоколированием, где был добавлен новый файл данных с начальным размером больше 64704 КБ. |
| 1404999 | При удалении snapshot базы данных в сеансе с параметром LOCK_TIMEOUT может возникать ошибка времени ожидания, за которой следует ошибка утверждения. |
| 1190211 | Установка SQL Server с помощью InstallShield приводит к зависанию. Дополнительные сведения см. в этойстатье базы знаний. |
| 1386073 | После установки SQL Server 2012 с пакетом обновления 2 (SP2) при остановке работы SQL Server из диспетчера конфигураций или диспетчера служб сразу после завершения работы на SQL Server отправляется информационное сообщение. В предыдущих версиях мы выводили эти сообщения после остановки внутренних служб, таких как платформа .NET Framework и брокер служб. |
Исправления для элементов связи, отправленных сообществом
| Идентификатор ошибки подключения | Описание |
|---|---|
| 714689 | Результаты оценки многократно записываются в выходной xml-файл при реализации Enterprise Management Framework для нескольких серверов и возникновении ошибки на одном из серверов в списке. |
| 735543 | База данных переходит в режим восстановления, когда ее резервная копия восстанавливается как другая база данных в том же экземпляре. |
| 736509 | Невозможно отладить хранимую процедуру, вызывающую sp_executesql in SQL Server Management Studio (SSMS). При нажатии клавиши F11 появляется сообщение об ошибке "Ссылка на объект не установлена в экземпляр объекта". |
| 740181 | SSMS не полностью управляет Full-Text в SQL Server Express. |
| 745566 | SQL Server SMO игнорирует ограничение по умолчанию в SQL Server 2012 и SQL Server 2014. |
| 764197 | SSMS обрабатывает пронумерованные хранимые процедуры несогласованно. |
| 769121 | "Столбец "<имя> столбца" не относится к сводке таблицы. (System.Data)" при репликации таблиц с одинаковыми именами, но в разных схемах. |
| 773710 | После возврата к snapshot базы данных, содержащей полнотекстовые индексы, невозможно создать ft_catalogs до перезапуска SQL Server, отсоединения и последующего подключения базы данных или переноса базы данных в автономный режим и последующего перевода базы данных в оперативный режим. |
| 774317 | При закрытии SSMS иногда дает сбой, что приводит к автоматическому перезапуску |
| 785064 | Сообщение об ошибке "Значение 'null' недопустимо для 'stream'" при работе с компонентами конвейера клиентов в Business Intelligence Development Studio (BIDS). |
| 785151 | При выполнении запросов с включенным параметром "Показать фактический план запроса" возвращается значение NULL и появляется следующее сообщение об ошибке: Ошибка: MSG 50000, уровень 16, состояние 10, проверка процедуры, строка 34 Строковые или двоичные данные будут усечены. |
| 791929 | Сообщение об ошибке "Сбой проверки системного утверждения" при вставке данных в секционированное представление с триггерами. |
| 797967 | Создание сценария дублирует операторы при создании сценариев разрешений на уровне столбца в SSMS. |
| 799430 | SSMS может аварийно завершить работу при попытке обновить значок окна SSMS на панели задач. |
| 804901 | При развертывании новых версий больших проектов во время развертывания в базе данных каталога служб SSIS (SSISDB) возникает тайм-аут. Кроме того, вы получаете следующие сообщения об ошибке: Не удалось развернуть project. Чтобы получить дополнительные сведения, запросите в operation_messages представлении идентификатор операции "219". (Microsoft SQL Server, ошибка: 27203) Не удалось развернуть проект. Устраните проблемы и повторите попытку позже.:Время ожидания истекло. Время ожидания истекло до завершения операции или сервер не отвечает. Заявление было прекращено. |
| 805659 | "Некоторая часть вашего SQL-оператора вложена слишком глубоко. Перепишите запрос или разбейте его на более мелкие запросы" при анализе или выполнении хранимой процедуры. |
Основные возможности SQL Server 2012 с пакетом обновления 2 (SP2)
Ниже перечислены некоторые изменения, внесенные в SQL Server 2012 с пакетом обновления 2 (SP2):
AlwaysOn
Удобство поддержки:
- Сообщение 35285 отображается как информационное сообщение, как и ожидалось, а не как ошибка.
Функции
- Поддержка модуля записи SQL COPY_ONLY резервного копирования: полное резервное копирование Data Protection Manager (DPM) на сервере с AlwaysOn вторичным образом будет преобразовано в резервное копирование COPY_ONLY.
Analysis Services (SSAS)
Реализация поддержки сценария создания локального куба:
- При использовании служб SQL Server 2012 Analysis Services (SSAS 2012) с пакетом обновления 2 (SP2) можно создать локальный куб, который подключается к SSAS, работающему на статическом порту, отличном от порта по умолчанию, для которого отключен браузер SQL. Эта новая функция управляется новым параметром конфигурации в msmdsrv.ini: "ConfigurationSettings\LocalCubeServerPortInConnectionString". Чтобы включить эту функцию, установите значение 1. Этот параметр не действует, если SSAS 2012 настроен как отказоустойчивый кластер или работает на порте по умолчанию.
Добавить другие журналы:
- Этот пакет обновления добавляет дополнительные сведения в файл журнала SSAS для улучшения устранения неполадок. Сюда входит версия SSAS, имя компьютера, NetBIOS-имя, количество ЦП, размер ОЗУ, IP-адрес, порт, тип протокола, взаимоблокировка, время ожидания блокировки и некоторые другие сведения.
Integration Services (SSIS)
Повышение производительности взаимоблокировки и очистки SSISDB
Введение
Взаимоблокировка в базе данных SSISDB при одновременных вызовах хранимой процедуры SSISDB.catalog.create_execution
- Устранены проблемы совпадений SSISDB и взаимоблокировок. Однако это еще не решает всех проблем. Текущее временное решение — сдвиг заданий на несколько секунд. Но это обходное решение может быть недоступно.
- Низкая производительность задания обслуживания SSISDB
Доступно исправление для заданий обслуживания SSISDB.
Архитектура
Предыдущая модель:
- Каждая транзакция создает сертификат и симметричный ключ, которые также должны храниться и обрабатываться в задачах обслуживания или очистки.
Новая модель:
- Ввести новую строку в таблицу свойств каталога SERVER_OPERATION_ENCRYPTION_LEVEL и по умолчанию использовать PER_EXECUTION для обеспечения обратной совместимости, значение можно изменить на PER_PROJECT создания одной пары ключей или сертификатов для каждого проекта. Перед переходом с PER_EXECUTION на PER_PROJECT требуется выполнить полную очистку. Введены две новые процедуры хранения для полной очистки.
Сводка изменений:
Введение новой строки в таблицу свойств SSISDB SERVER_OPERATION_ENCRYPTION_LEVEL:
- Допустимы только два значения (1 и 2).
- Value "1": значение по умолчанию. Шифруется симметричными ключами и сертификатами в соответствии с уровнем выполнения. Высокий уровень безопасности, но могут возникнуть проблемы с производительностью или взаимоблокировкой.
- Значение "2": Шифруется симметричными ключами и сертификатами в соответствии с уровнем проекта. Снижение уровня безопасности, устранение проблем с производительностью или взаимоблокировкой.
Представляем две новые хранимые процедуры (SP) Cleanup_server_logs и cleanup_server_execution_keys
Пакеты обновления предназначены для использования при изменении уровня шифрования с "1" на "2". Сначала можно запустить Cleanup_server_logs, который можно очень быстро завершить, чтобы привести SSISDB в хорошее состояние. База данных SSISDB готова к переводу на уровень шифрования.
Cleanup_server_keys занимает больше времени, чем Cleanup_server_logs. Однако она запускается после изменения уровня шифрования на "2" и периодически запускается в непиковое время.
Cleanup_server_logs. Очистка только всех журналов операций.
Cleanup_server_execution_keys. Очистка симметричных ключей и сертификатов, которые используются для защиты конфиденциальных параметров выполнения.
@cleanup\_flag int (в (1,2))
- cleanup_flag = 1: отбрасывать симметричные ключи и сертификаты уровня выполнения
- cleanup_flag = 2: удалить симметричные ключи и сертификаты уровня проекта (будут удалены только в том случае, если этот пертикулярный проект был удален, а все журналы операций, связанные с этим проектом, были очищены).
@delete\_batch\_size int = 1000
- Количество ключей или сертификатов сбрасывается при одном вызове данной процедуры хранения.
В internal.cleanup_server_retention_window измените delete_batch_size с 10 на 1000.
Реляционный движок
Необязательная поддержка количества строк переменных таблицы для улучшения планов запросов:
Если переменная таблицы объединена с другими таблицами в SQL Server, это может привести к снижению производительности из-за неэффективного выбора плана запросов, так как SQL Server не поддерживает статистику или отслеживание количества строк в переменной таблицы при составлении плана запроса.
В SQL Server 2012 с пакетом обновления 2 (SP2) добавлен новый флаг трассировки, позволяющий оптимизатору запросов использовать сведения о количестве строк, вставленных в переменную таблицы, для выбора более эффективного плана запроса. Включите флаг трассировки 2453, чтобы активировать это поведение.
Примечания.
- В некоторых сценариях включение флага трассировки 2453 может привести к некоторому снижению производительности из-за дополнительной компиляции, необходимой для учета фактического количества строк, вставленных в табличную переменную во время выполнения. Как правило, этот флаг трассировки будет полезен, если переменная таблицы имеет значительное количество строк, соединенных с другими таблицами, или имеет более одной строки и используется на внешней стороне оператора соединения вложенного цикла с планом на внутренней стороне, который обрабатывает большое количество строк.
- Аналогичное поведение может быть достигнуто в других версиях SQL Server с помощью подсказки запроса OPTION (RECOMPILE). Однако подсказка запроса требует обнаружения и изменения всех запросов, страдающих от плохого выбора плана из-за большого объема работы, обусловленной табличными переменными, в то время как включение флага трассировки 2453 может повлиять на существующие рабочие нагрузки.
Улучшены способы устранения неполадок с производительностью планов выполнения параллельных запросов
- Теперь sys.dm_exec_requests DMV возвращает точное значение для cpu_time для планов выполнения параллельных запросов. СТАТИСТИКА В результате диагностики ввода-вывода теперь отображаются точные логические данные для параллельных планов выполнения запросов.
Улучшена диагностика переноса хэша
- Если оператор хэш-соединения или хэш-агрегата переносит данные в базу данных tempdb во время выполнения запроса, для диагностики ввода-вывода STATISTICS IO теперь регистрируется соответствующий ввод-вывод.
Улучшенная полнотекстовая диагностика индекса
- В некоторых случаях может быть сложно понять, как возвращаются результаты определенных полнотекстовых запросов. Подсистема полнотекстового поиска взаимодействует с внешними средствами разбиения по словам и стоп-листами, и в результате этого взаимодействия позиционная информация по ключевым словам в документе может отличаться от той, которая наблюдается в фактическом тексте. Это очень важно при поиске по фразам или NEAR, так как дельта между словами используется во внутренних вычислениях для поиска совпадающих документов.
- В SQL Server 2012 с пакетом обновления 2 (SP2) добавлена новая функция динамического управления (DMF) для предоставления доступа к сведениям о местоположении ключевых слов, индексированных в документе. Новый DMF аналогичен существующему sys.dm_fts_index_keywords_by_document DMF и имеет следующий синтаксис: sys. dm_fts_index_keywords_position_by_document
(
DB_ID('database_name'), OBJECT_ID('table_name')
) - Вместо подсчета случаев он возвращает сведения о каждом вхождении и его позиции в индексированном документе.
- Эти сведения можно использовать для просмотра сопоставления между текстом и внутренним индексом, которое покажет разницу в дельте (если таковая имеется) для искомой фразы. Это поможет понять результаты поиска по фразам.
Репликация
Поддержка
Репликация транзакций:
Добавлены подробные сообщения в статистику в таблицах истории и более подробные сообщения в журналах агента:
- Добавлено текстовое сообщение в <вывод stats> xml для определения различных состояний как в logreader, так и в дистрибьюторских агентах.
- Добавлена статистика на уровне статьи для команд дистрибьютора и логридера.
- Добавлено количество пропущенных команд для вывода файла в агенте распространителя.
- Добавлено время, затрачиваемое на изменение схемы в агенте распространителя.
LogReader: записи журнала добавляются .TXT файл при записи дампа пользователя.
Одноранговый обмен: процедуры вставки, обновления и удаления обновлены, чтобы предоставить следующие сведения о сообщении о конфликте:
- Имя таблицы
- Имя и значения столбца первичного ключа
- Текущая версия
- Предварительная версия
- Пост-версия
Репликация слиянием:
- Выходные данные флага трассировки 101, добавляемый в файл журнала, когда уровень детализации выходных данных для агента слияния равен 4.
Функциональность
Репликация транзакций:
- Одноранговая репликация теперь поддерживает частичные обновления, внесенные в текстовый столбец с помощью Update или . Пишите семантически.
Репликация слиянием:
- Очистка хранимой процедуры была переработана, чтобы избежать избыточной загрузки данных.
Reporting Services (SSRS)
Регистрация сообщений с ошибками обработки и предупреждениями для предотвращения распространенных вызовов CSS, больших отчетов HTML.
Обзор:
- Обнаружение структуры отчета, чтобы определить, приведет ли структура отчета к созданию большого HTML-отчета и потенциальной проблеме с производительностью. Это легко обнаружить, изучив параметры высоты и ширины интерактивной страницы.
Сценарий пользователя:
Вы создаете отчет в Report Builder. В свойстве InteractiveSize введите значение '0'. Появляется всплывающее окно со следующим сообщением с предупреждением о потенциальном влиянии на производительность:
Примечание
Установка интерактивного размера на 0 матов влияет на производительность.
Подсистема хранилища
Повышение производительности
Несколько улучшений производительности в пакете обновления 2, как описано в следующих статьях:
- Проблемы с производительностью возникают при увеличении активности блокировки базы данных в SQL Server 2012
- Проблемы с производительностью возникают в средах NUMA во время обработки внешних страниц в SQL Server 2012
- Производительность снижается после выполнения операции ALTER INDEX... Операция ONLINE прервана в SQL Server 2012
Улучшения DMV
- sys.dm_db_session_space_usage отражает объем места, занимаемого в базе данных tempdb объектом-пользователем за сеанс. Если количество удаленных строк превышает 1024 страницы, освобождение этих страниц откладывается. В SQL Server 2012 с пакетом обновления 2 (SP2) DMV также будет включать сведения об использовании пространства для единиц распределения, отложенных в новый столбец с именем user_objects_deferred_dealloc_page_count.
- Теперь sys.dm_server_services правильно указывает имя узла в cluster_nodename столбце, если SQL Server установлено в отказоустойчивом кластере.
Улучшения кольцевого буфера
Кольцевой буфер для доменов приложений RING_BUFFER_CLRAPPDOMAIN содержит причину выгрузки домена приложения в <поле DoomReason> :
- 1 = выгружается операциями DDL, такими как сборка перетаскивания.
- 2 = Выгружено в результате операции, связанной с безопасностью, такой как изменение разрешения.
- 3 = Выгружено из-за обработки нехватки памяти.
- 4 = Выгружено из-за сбоя инициализации.
Соответствующий расширенный app_domain_ring_buffer_recorded события содержит причину выгрузки в поле данных doom_reason события.
RING_BUFFER_RESOURCE_MONITOR содержит записи при обнаружении изменений в состоянии, отслеживаемом монитором ресурсов. Кроме того, уведомления о системных и технологических ресурсах также доступны в <узле IndicatorsPool></IndicatorsPool> .
Resource_monitor_ring_buffer_recorded расширенное событие включает в себя уведомления для всего пула в поле данных pool_indicators.
RING_BUFFER_NONYIELD_PROCESSTABLE включает имя процесса, а также другую информацию о 8192 потоках, которые выполняются в системе на момент записи записи записи кольцевого буфера.
Усовершенствования резервного копирования и восстановления
Начиная с пакета обновления 2, невозможно создать резервную копию журнала хвоста модели с параметром norecovery.
Сообщения о завершении резервного копирования и восстановления в журнале ошибок включают сведения о длительности и пропускной способности:
- БАЗА ДАННЫХ BACKUP успешно обработала 298 страниц за 0,026 секунды (89,261 МБ/сек).
- ВОССТАНОВИТЬ БАЗУ данных успешно обработала 298 страниц за 0,016 секунды (145,050 МБ/с).
Расширенные события
В SQL Server 2012 с пакетом обновления 2 (SP2) добавлены или изменены следующие расширенные события:
Выделение памяти:
- Расширенные page_allocated событий и page_freed можно использовать для просмотра основных потребителей SQL Server памяти. Начиная с пакета обновления 2, эти расширенные события также сообщают о зарезервированной памяти, которая выделяется и освобождается во время выполнения запроса.
Призрачная уборка:
При удалении записи из таблицы или индекса такая операция удаления никогда не приводит к физическому удалению записей со страниц, а только пометке их как удаленные или фантомные. Это оптимизация производительности, которая позволяет быстрее выполнять операции удаления. Фоновая задача, называемая задачей фантомной очистки, физически удаляет все удаленные записи. В пакет обновления 2 добавлено несколько расширенных событий, иллюстрирующих различные этапы выполнения этой задачи.
- ghost_cleanup_task_start
- ghost_cleanup_task_suspend
- ghost_cleanup_task_packet_enqueue
- ghost_cleanup_task_process_packet
- ghost_cleanup_task_process_pages_for_db_packet
Ссылки
Для получения дополнительных сведений об определении текущей версии и выпуска SQL Server щелкните следующий номер статьи в базе знаний Майкрософт:
321185 Как определить версию и выпуск SQL Server и его компонентов