ВВЕДЕНИЕ
В этой статье перечислены ошибки, исправленные в Microsoft SQL Server 2008 с пакетом обновления 2 (SP2).
Заметки
- Другие исправления, которые не описаны в документации, могут быть включены в пакет обновления.
- Этот список будет обновляться по мере выхода новых статей.
Для получения дополнительных сведений о том, как получить пакеты обновления для SQL Server 2008, откройте статью со следующим номером в базе знаний Майкрософт:
968382
Получение последней версии пакета обновления для SQL Server 2008
Дополнительные сведения
Помимо исправлений, перечисленных в этой статье, SQL Server 2008 с пакетом обновления 2 (SP2) содержит исправления, которые были включены в пакеты обновления с 1 по 8 для SQL Server 2008 с пакетом обновления 1 (SP1). Дополнительные сведения о накопительных пакетах обновлений для SQL Server 2008 с пакетом обновления 1 (SP1) см. в следующей статье базы знаний Майкрософт:
970365 Сборки SQL Server 2008 г., выпущенные после выпуска SQL Server 2008 с пакетом обновления 1 (SP1)
Ошибки, исправленные в этом пакете обновления
Для получения дополнительных сведений об ошибках, исправленных в SQL Server 2008 SP2, просмотрите соответствующие статьи в базе знаний Майкрософт.
| Номер ошибки VSTS | Номер статьи базы знаний | Описание |
|---|---|---|
| 249682 | 2216454 | ИСПРАВЛЕНО: сообщение об ошибке при выполнении команды ProcessAdd после внесения изменений в раздел на сервере с SQL Server 2008: "Внутренняя ошибка: произошло непредвиденное исключение" |
| 256736 | 2322209 | ИСПРАВЛЕНО. Неверные результаты при использовании скобок вокруг SELECT в инструкции с общим табличным выражением в SQL Server 2008 |
| 258076 | 2216456 | ИСПРАВЛЕНИЕ. В SQL Server 2008 с пакетом обновления 2 (SP2) улучшен текст сообщения об ошибке "Операция отменена" в службах Analysis Services |
| 270561 | 2216460 | Сообщение об ошибке при попытке открыть проект в SQL Server 2008: "Определение манифеста найденной сборки не совпадает со ссылкой на сборку" |
| 274280 | 2216461 | Не удается установить программу установки SQL Server 2008 в точке подключения кластера на основе Windows Server 2008 |
| 284360 | 955850 | Сообщение об ошибке при попытке использовать двоичные файлы из пакета типов SQL Server System CLR (SQLSysClrTypes.msi): "Не удается загрузить библиотеку DLL 'SqlServerSpatial.dll': это приложение не удалось запустить, так как конфигурация приложения неверна" |
| 301603 | 2216465 | Сбой объединенной установки SQL Server 2008, если в пути /PCUSOURCE или /CUSOURCE есть пробел |
| 317800 | 2216472 | Запрос ROLAP SQL Server 2008 или SQL Server 2005 Analysis Services возвращает неправильные результаты |
| 340066 | 2216474 | ИСПРАВЛЕНО. Возможна некоторая потеря данных при использовании инструкции UPDATE с предложением SET, которое использует типы time, datetime2 и datetimeoffset в SQL Server 2008 |
| 347731 | 2216478 | Сообщение об ошибке при запуске Get-Command в среде PowerShell версии 2 на сервере с SQL Server 2008: "Объектная ссылка не установлена на экземпляр объекта" |
| 351286 | 2216480 | ИСПРАВЛЕНИЕ. Поля не сохраняются в отчете при экспорте отчета в Excel на сервере с SQL Server 2008 и последующем предварительном просмотре отчета в Excel |
| 351981 | 2216484 | ИСПРАВЛЕНО: сообщение об ошибке при экспорте отчета в Excel в диспетчере отчетов на сервере с установленным приложением SQL Server 2008: "Необработанное управляемое исключение: тип = System.ArgumentOutOfRangeException" |
| 357416 | 2216485 | ИСПРАВЛЕНИЕ: монитор ресурсов вводит невозвращающееся состояние на сервере SQL Server 2008 |
| 390126 | 2216491 | Служебная программа SQL Dumper не может создать файлы дампа ошибок в отказоустойчивом кластере SQL Server 2008 в отказоустойчивом кластере Advanced/Enterprise |
| 396527 | 980671 | Исправление отсутствия вариаций криптографической соли в хэше входа в SQL Server sa |
| 402453 | 2019402 | Сопоставление между именами учетных записей и идентификаторами безопасности не выполнено" при добавлении узла в отказоустойчивый кластер SQL Server 2008 |
| 426753 | 2216499 | Невозможно зарегистрировать экземпляр базы данных SQL Server 2008 в служебной программе SQL Server |
| 426753 | 2253128 | Невозможно развернуть приложение Data-Tier в экземпляре базы данных SQL Server 2008 |
| 427703 | 2216501 | ИСПРАВЛЕНИЕ: многосерверные задания не загружаются из SQL Server 2000 с ролью MSX на SQL Server 2008 с ролью TSX |
| 524642 | 2283072 | ИСПРАВЛЕНИЕ: доступно исправление, позволяющее службам SQL Server 2008 R2 Reporting Services использовать 2048-разрядный ключ RSA для шифрования ключа Reporting Services на соответствие FIPS |
| 370540 | 2448971 | ИСПРАВЛЕНО: блокировки таблицы не эскалируются при вставке большого количества строк в таблицу в SQL Server 2008 |
Дополнительные проблемы, исправленные в этом пакете обновления
Решения следующих проблем также включены в SQL Server 2008 SP2.
| Номер ошибки VSTS | Описание |
|---|---|
| 270934 | Ошибки повреждения DBCC возникают при сортировке SQL Server 2008, когда используются строки, содержащие последовательности Jamo, следующие за японским пролонгированным знаком. |
| 271554 | ИСПРАВЛЕНО: В базовой таблице системы syscolpars отображались дубликаты строк. Это исправление отличает их путем добавления номера процедуры в DBCC checkcatalog. |
| 271708 | Если запрос содержит фильтр, который ссылается на столбец в представлении sys.dm_server_audit_status, фильтр игнорируется и возвращаются все строки из sys.dm_server_audit_status. |
| 280004 | Цель асинхронного группирования показывает неверные пары значение/строка для сопоставленных полей по сравнению со сведениями, доступными в dm_xe_map_values. |
| 284760 | ИСПРАВЛЕНО: Несовпадающее представление может содержать несколько представлений с разным количеством индексов. Это исправление принудительно применяет детерминированный порядок представлений для сравнения, основанный на сопоставленных функциях и количестве сопоставленных индексов. |
| 285377 | Пользователи получают сообщение об ошибке "Отказано в доступе" при локальном переходе к диспетчеру отчетов, если включен UAC. Добавление обновленного сообщения "Отказано в доступе" для упоминания UAC может позволить пользователям настроить параметр соответствующим образом. |
| 291707 | В данной базе данных использование курсора сервера, объявленного для оператора select, содержащего любое системное представление, может выдать неправильные результаты после присоединения и повторного подключения этой базы данных. |
| 293089 | Пользователи радиального датчика, которые пытаются использовать "RateOfChange" или "Integral" в качестве типа формулы для MaximumValue или MinimumValue в датчике, не видят значения в раскрывающемся списке сетки свойств. |
| 296314 | ИСПРАВЛЕНИЕ: файл FailoverAnalysis.sql устанавливается во время настройки отказоустойчивого кластера SQL Server. Этот сценарий будет вызываться автоматически при возникновении сбоя. Закрытое свойство SqlDMVScriptTimeout определяет, сколько миллисекунд может потребоваться для завершения сценария. |
| 302563 | Пользователи получают сообщение об ошибке проверки при обновлении общих источников данных, в имени которых есть пробел. Ошибка означает, что имя не может содержать пробелы. |
| 302707 | Установка пакета обновления 1 для SQL Server Business Intelligence Development Studio 2008 завершается сбоем из-за отсутствия файла конфигурации. |
| 304390 | В буфере кругов отображаются неполные данные о событии (события вывода из dm_xe_session_targets) при достижении предельного размера для выходных данных XML. |
| 307313 | Пользователи не могут возвращать несколько файлов cookie в своем модуле HTTP. Это влияет на пользователей при попытке реализовать пользовательскую проверку подлинности. |
| 309869 | Для действий "sqlsos.task_address", "sqlsos.worker_address" и "sqlsos.scheduler_address расширенные события" отображается неправильный адрес. |
| 310483 | Reporting Services 2008 Designer преобразует сантиметры в дюймы в табликсе. Это приводит к потере точности макета. |
| 313780 | Удаление первого из двух названных экземпляров AS отключает браузер SQL. В результате второй именованный экземпляр становится недоступным. |
| 319216 | Пользователи не могут использовать сохраненные учетные данные в своих источниках данных, если требуется смарт-карта. |
| 322046 | Запрос с предложением subselect, использующим выражение множества, которое не возвращает вычисляемых элементов, возвращает ошибку с сообщением о том, что выбор subselect с вычисляемыми элементами не разрешен. |
| 327301 | Задание элемента измерения по умолчанию в службах Analysis Services с помощью многомерных выражений с функцией NonEmpty приводит к тому, что сервер возвращает внутреннюю ошибку при попытке открыть куб. |
| 328752 | В представлении sys.dm_os_wait_stats отображаются повторяющиеся строки для типа ожидания MISCELLANEOUS. Это может вызвать проблемы со средствами мониторинга. |
| 331630 | Целочисленное значение неправильно округляется в SQL Server Reporting Services Designer многократно используемого запроса. |
| 333544 | ИСПРАВЛЕНИЕ: Новый код ошибки (6257) возвращается, когда пользователь пытается зарегистрировать сборку CLR, собранную для более новой среды выполнения, такой как CLR v4. Предыдущее сообщение об ошибке (код 6218) было запутанным и не указывало фактическую проблему. |
| 336809 | В пограничном случае значение идентификатора вставляется за пределами текущего диапазона в режиме "Включить identity_insert TABLE_NAME". Эта проблема также возникает в операциях резервного копирования и восстановления. |
| 338247 | Если параметры, связанные функцией SQLBindParameter, указывают длину SQL_DATA_AT_EXEC, драйвер ODBC для Native Client SQL Server 2008 вызывает нарушение доступа, если функция SQLPutData указывает длину SQL_NULL_DATA при предоставлении значения параметра для выполнения. |
| 338999 | Когда пользователь использует интерфейс SOAP для запуска и экспорта отчета, в SQL Server Reporting Services 2008 возникает утечка подключения. |
| 347779 | Иногда на сервере SQL Server появляется сообщение об ошибке "Недостаточно системной памяти в пуле ресурсов "внутренний" для выполнения этого запроса". Эту ситуацию часто можно предотвратить. |
| 350670 | Пользователи получают сообщение об ошибке "Срок действия страницы истек" при попытке сослаться на отрисованный отчет после того, как отчет оставался неиспользованным в течение одного часа. |
| 352788 | Ошибка 955 возникает, когда пользователи пытались настроить Data Warehouse управления, если на их сервере есть базы данных, которые не подключены к сети. |
| 352862 | ReportBuilder 2.0 ClickOnce отображает пустой отчет при запуске, если пользователь редактирует отчет с помощью ReportBuilder 2.0 с веб-сайта SharePoint 12. |
| 355222 | Если используется режим MARS, в sys.dm_os_tasks представлении отображается одинаковое значение в request_id столбце для всех задач, а не указывается правильное значение, связанное с каждой задачей. |
| 355228 | FIX: Новое сообщение об ошибке указывает на причину нарушения прав доступа, которое возникает, если целевые параметры bucketizer установлены неправильно. |
| 356127 | Когда BCP.exe получает сведения о метаданных столбцов, возвращаются неверные параметры сортировки столбцов. |
| 360584 | Подписки завершаются сбоем во время выполнения из-за проблемы структуры данных в памяти при попытке доставки отчета с отображением MHTML по электронной почте. |
| 368388 | Конструктор отчетов BIDS 2008, работающий вместе с SQL Server Reporting Services 2008, аварийно завершает работу, когда пользователи изменяют размер строки таблицы. |
| 376257 | Поля "КОМУ", "СК" и "СК" в диалоговом окне "Параметры доставки отчета" очищаются после отмены или закрытия диалогового окна "Сведения о расписании", чтобы вернуться в раздел "Параметры доставки отчета". |
| 383747 | Наборы коллекции работают некорректно при сборе счетчиков производительности в кластере, если имя экземпляра SQL совпадает с именем виртуальной сети. |
| 384800 | FIX: Улучшена и регистрируется дополнительная информация для InvalidReportParameterException в расширенном выводе, если во время обработки параметров возникают определенные условия. |
| 393410 | Когда пользователи снимают выбор одного или нескольких месяцев в ежемесячном расписании, службы SSRS создают отдельные расписания для каждого выбранного месяца. В некоторых случаях это может вызвать ошибку "@active_end_date не может быть до @active\_start\_date". |
| 393879 | Data-Driven подписка завершается сбоем, если возвращается значение NULL при сопоставлении с параметром отчета, который принимает значение NULL. |
| 394977 | Проблемы с подпиской и доставкой трудно диагностировать в файле трассировки Reporting Services. Требуется более подробное ведение журнала. |
| 415084 | Пользователи получают сообщение "Индекс был вне допустимого диапазона. Должен быть неотрицательным и меньше размера коллекции" при экспорте в PDF. |
| 419740 | Пользователи не могут использовать настраиваемую проверку подлинности в веб-версии SKU SQL Server 2008. |
| 424595 | Если пользователь создает пользовательский тип и функцию с табличным значением в одной транзакции и если функция имеет таблицу return, содержащую столбец пользовательского типа, происходит самовзаимоблокировка. Кроме того, соединение, которое пытается выполнить эти операции, разрывается. |
| 421922 | ИСПРАВЛЕНИЕ. Поддерживается не более 15 000 разделов в таблицах и индексах в выпусках Enterprise (Корпоративная), "Разработчик" и "Ознакомительная" Microsoft SQL Server 2008 SP2. Дополнительные сведения о включении и отключении этой поддержки, ее ограничениях, известных проблемах и обходных путях см. в техническом документе "Поддержка 15 000 разделов" (http://go.microsoft.com/fwlink/?LinkId=199773). |
| 424804 | В службах Analysis Services некоторые клиенты могут столкнуться с нарушением прав доступа при использовании иерархии типа "родитель-потомок" в состоянии функции IIF. |
| 426631 | Использование функции PeriodsToDate с параметром-членом Null может вызвать ошибку "Непредвиденное исключение". |
| 429253 | Неверный номер версии отображается в SQL Server Management Studio и SQL Server Reporting Services. Это вносит путаницу, так как отображаемое число не отличается от номера версии RTM после выполнения обновления. |
| 430703 | Дополнительное исключение может возникнуть, когда службы Analysis Services создают дамп Watson. Это верно независимо от того, создан ли дамп Watson из-за фактического исключения или из-за явного запроса на дамп при определенных ошибках. При возникновении вторичного исключения на сервере может возникать бесконечная рекурсия. Это создает множество дампов, а затем выключает сервер. |
| 431298 | FIX: В SSRS 2008 Service Pack 2 обновлена надстройка RS для SharePoint 2007 для связи с сервером отчетов SSRS 2008 R2. Это позволяет получить доступ к определенным функциям в ReportBuilder 3.0, ReportParts и ATOM Renderer, включая новый предварительный просмотр отчета в ReportBuilder 3.0. |
| 431301 | Импорт данных при обработке объектов в базе данных, содержащих тысячи объектов метаданных, занимает много времени. Это связано с тем, что серверу необходимо создать расписание заданий перед началом импорта данных. Кроме того, алгоритм, используемый для определения зависимостей, снижает производительность, если в базе данных существует множество объектов метаданных. |
| 432094 | Невозможно безопасно создать пространственный индекс в таблице, в которой для имен столбцов используются CELL_ID, CELL_ATTRIBUTES или SRID. |
| 448007 | В некоторых условиях имя секционированного столбца в сообщении об ошибке 11405 может быть неправильным. Это приводило к выводу на печать неправильного имени столбца. |
| 455538 | Использование безопасности ячеек вместе с вычислениями дает неправильные результаты при использовании предложения NON EMPTY. |
| 456534 | Нарушение прав доступа на чтение происходит во время процесса фиксации, если одновременно выполняются две транзакции: одна для изменения или создания раздела, а другая для обработки измерения. |
| 471363 | При интеграции Microsoft Office 12 со службами Reporting Services SQL Server 2008 интеграция с SharePoint не будет по умолчанию написана по URL-адресу clickOnce Report Builder, что не позволит запустить Report Builder. |
| 471421 | FIX: Проблема локализации в турецком SKU: хлебные крошки теперь локализуются на новых страницах библиотеки reportpart. |
| 499162 | ИСПРАВЛЕНО. Проблема специальных возможностей, возникающая из-за того, что имя MSAA "Символ" равно нулю. Имена MSAA обновлены и теперь доступны для обнаружения. |
| 503096 | ИСПРАВЛЕНИЕ: улучшена производительность создания индекса с помощью инструкций DDL для таблиц с большим количеством секций и без данных. Ранее время, необходимое для этого процесса, увеличивалось в геометрической прогрессии по мере увеличения числа секций. Требуемое время теперь увеличивается в линейной прогрессии. |
| 515240 | Использование возвращающих табличное значение параметров для столбцов бизнес-приложений может привести к нарушению прав доступа на сервере. |
| 520700 | Имена MSAA для диалогового окна "Свойства радиальной шкалы" неверны и не соответствуют требованиям специальных возможностей. |
| 525601 | Во время проверки для детального аудита алгоритм, который используется для перечисления любых аудитов, включающих это событие, может испытывать утечки памяти списка аудитов. Так продолжается до тех пор, пока не возникнут ошибки нехватки памяти и не потребуется перезапустить службу для освобождения памяти. |
Примечание При обновлении с накопительного пакета обновления 9 (SP1) для SQL Server 2008 или более поздней версии необходимо установить накопительный пакет обновления после SQL Server 2008 с пакетом обновления 2 (SP2) после обновления до SQL Server 2008 с пакетом обновления 2 (SP2), чтобы получить все исправления.
Дополнительные сведения о пакетном пакете обновления для SQL Server 2008 с пакетом обновления 2 (SP2) см. в следующей статье базы знаний Майкрософт:
2289254 Накопительный пакет обновления 1 для пакета обновления 2 SQL Server 2008
Ссылки
Для получения дополнительных сведений об определении текущей версии и выпуска SQL Server щелкните следующий номер статьи в базе знаний Майкрософт:
321185
Определение версии и выпуска SQL Server
Продукты сторонних разработчиков, рассмотренные в этой статье, выпущены компаниями, независимыми от корпорации Майкрософт. Корпорация Майкрософт не гарантирует надлежащую работоспособность и надежность этих продуктов.