KB3182545 — сведения о выпуске пакета обновления 1 SQL Server 2016 г.

Дата выхода: 16 ноября 2016 г.
Версия: 13.0.4001.0

В этой статье содержатся важные сведения, которые следует прочитать перед установкой Microsoft SQL Server 2016 с пакетом обновления 1 (SP1). В нем описано, как получить пакет обновления, приведен список исправлений, включенных в пакет обновления, известны проблемы и указан список авторских прав для продукта.

Примечание

Эта статья служит единственным источником информации для поиска всей документации, связанной с этим пакетом обновления. Он включает в себя все сведения, которые вы ранее нашли в заметках о выпуске и Readme.txt файлах.

Известные проблемы, связанные с этим пакетом обновления

SQL Server Reporting Services

После установки SQL Server 2016 с пакетом обновления 1 (SP1) могут возникнуть следующие проблемы при использовании служб SQL Server Reporting Services:

  • Если службы Reporting Services настроены на использование безопасного подключения (https/SSL), может отображаться предупреждение о безопасности содержимого.

  • В некоторых случаях кнопка "Печать" перестает работать.

Чтобы устранить эти проблемы, установите исправление в KB 3207512 .

SQL Server Integration Services (SSIS)

После установки SQL Server 2016 с пакетом обновления 1 (SP1) разрешения DCOM на запуск служб интеграции и доступ к ним сбрасываются в значения по умолчанию. Если у вас настроены разрешения DCOM, потребуется повторно применить настройку.

Драйвер ODBC 13.1

При установке SQL Server 2016 по умолчанию драйвер ODBC 13.0 устанавливается на сервере, который используется агентом SQL и SSMS (устанавливается на сервере) для подключения к экземпляру SQL Server. Если по какой-либо причине на сервере установлен драйвер ODBC версии 13.1, установка SQL Server 2016 с пакетом обновления 1 (SP1) переопределяет установку драйвера ODBC версии 13.1, и исправления, внесенные в версии 13.1, такие как KB 3185365, могут быть потеряны. В этом случае после установки SQL Server 2016 с пакетом обновления 1 (SP1) рекомендуется удалить драйвер ODBC, установленный SQL Server 2016 с пакетом обновления 1 (SP1), и установить драйвер ODBC 13.1.

Для проверки наличия драйвера ODBC, установленного на сервере, можно перейти в панель управления сервера -> Программы и компоненты -> Поиск ODBC. Номер версии драйвера ODBC 13.1 — 13.1.811.168, как показано ниже:

Снимок экрана: драйвер Microsoft ODBC 13 для SQL Server.

Список исправлений, включенных в SQL Server 2016 с пакетом обновления 1 (SP1)

Пакеты обновления для Microsoft SQL Server 2016 представляют собой накопительные обновления. SQL Server 2016 SP1 обновляет все выпуски и уровни обслуживания SQL Server 2016 до SQL Server 2016 SP1. Помимо исправлений, перечисленных в этой статье, SQL Server 2016 с пакетом обновления 1 (SP1) включает исправления, которые были включены в накопительный пакет обновления 1 (накопительный) для SQL Server 2016 CU3 для SQL Server 2016 CU3.

Дополнительные сведения о накопительных обновлениях, доступных в SQL Server 2016, см. в статье Версии сборок SQL Server 2016.

Примечание

  • Дополнительные исправления, не описанные здесь, также могут быть включены в пакет обновления.
  • Этот список будет обновляться по мере выхода новых статей.

Дополнительные сведения об ошибках, исправленных в SQL Server 2016 с пакетом обновления 1 (SP1), см. в следующих статьях базы знаний Майкрософт.

Ссылка на ошибку Описание
7778636 Доступно обновление, расширяющее событие Trace Extended сведениями о подтверждении протокола безопасности в SQL Server 2016 (KB3191296)
7898693 Использование DBCC CLONEDATABASE для создания схемы и статистической копии пользовательской базы данных в SQL Server 2014 SP2 и SQL Server 2016 SP1 (KB3177838)
7994008 Поддерживает DROP TABLE DDL для статей, включенных в репликацию транзакций в SQL Server 2014 или в SQL Server 2016 SP1 (KB3170123)
8024963 Обновление для добавления предупреждения о временно предоставленном буфере памяти в XML Showplan в SQL Server 2014 или 2016 (KB3172997)
8024978 Обновление для добавления DMF sys.dm_db_incremental_stats_properties в SQL Server 2014 или 2016 (KB3170114)
8024984 Обновление для предоставления максимального объема памяти, включенного для одного запроса в Showplan XML в SQL Server 2014 или 2016 (KB3170112)
8024985 Сведения о включенных флагах трассировки добавляются в XML-файл showplan в SQL Server 2014 SP2 или 2016 (KB3170115)
8025018 Улучшена диагностика для планов выполнения запросов, включающих отправку остаточного предиката в SQL Server (KB3107397)
8025088 Обновление добавляет расширенные события и счетчики производительности AlwaysOn в SQL Server 2014 или 2016 (KB3173156)
8025128 Добавлена хранимая процедура для ручной очистки боковой таблицы отслеживания изменений в SQL Server 2014 SP2 или 2016 SP1 (KB3173157)
8103248 Доступно обновление, которое вводит новую подсказку запроса USE HINT in SQL Server 2016 (KB3189813)
8103261 Обновление с добавлением новой инструкции Transact-SQL CREATE OR ALTER in SQL Server 2016 (KB3190548)
8103265 Обновление для улучшения диагностика путем предоставления типа данных параметров для параметризованных запросов в выходных данных XML showplan в SQL Server 2016 г. (KB3190761)
8110745 Доступно обновление, которое добавляет поддержку ограничений самоссылки в новом операторе целостности данных в SQL Server 2016 (KB3191273)
8149617 Обновление для улучшения диагностика планов выполнения запросов, включающих отправку остаточного предиката в SQL Server 2016 (KB3190762)
8155425 Новая функция DynamicManagement "sys.dm_exec_query_statistics_xml" доступна в SQL Server 2016 с пакетом обновления 1 (KB3190871)
8349500 Доступно обновление, которое добавляет общую статистику выполнения запросов в результаты XML STATISTICS в SQL Server 2016 (KB3201552)
7062744 ИСПРАВЛЕНИЕ: ошибка "Атрибут "Соль" для пароля отсутствует в манифесте проекта при закрытии и повторном открытии проекта бизнес-аналитики SSIS в SQL Server 2016 (KB3189687)
8024967 ИСПРАВЛЕНО: серьезная ошибка при использовании sys.dm_db_uncontained_entities DMV в SQL Server 2014 или 2016 (KB3172998)
8024976 Ошибка "Поставщик журнала "Microsoft.LogProviderSQLServer" установлен неправильно" при открытии окна настройки журналов служб SSIS (KB3100256)
8025041 ИСПРАВЛЕНИЕ: ошибка "Unable to create restore plan due to break in the LSN chain" при восстановлении разностного резервного копирования в SSMS (KB3065060)
8025045 Ошибка при выполнении пакета SSIS в Windows с поддержкой FIPS (KB2925865)
8025056 ИСПРАВЛЕНО: временно предоставленный буфер памяти, необходимый для выполнения оптимизированного соединения с вложенным циклом, не отражается в Showplan XML в SQL Server 2014 или 2016 (KB3170116)
8025125 ИСПРАВЛЕНО: в журнале ошибок SQL Server неправильно упоминаются логические процессоры при включенном программном NUMA (KB3189663)
8025131 Динамическое административное sys.dm_os_memory_nodes возвращает ненулевое значение pages_kb для узла DAC в SQL Server 2016 (KB3170015)
8025149 ИСПРАВЛЕНО: DBCC CHECKDB или CHECKTABLE возвращает ложные срабатывания при повреждении данных и сбоях утверждений в SQL Server 2014 или 2016 (KB3173766)
8265472 ИСПРАВЛЕНО: При установке накопительного пакета обновления 1 за SQL Server 2016 возникает ошибка именованного экземпляра (KB3189709)
8273495 ИСПРАВЛЕНО: Взаимоблокировка при выполнении плана запроса с вложенным соединением циклов в пакетном режиме в SQL Server 2014 или 2016 (KB3195825)
8274352 ИСПРАВЛЕНО: Долгое время компиляции для запроса, содержащего много разных операторов в SQL Server 2016 (KB3201554)
8338496 ИСПРАВЛЕНО: каталог FileTable перестает отвечать при одновременном создании нескольких файлов в SQL Server 2014 или 2016 (KB3191062)
8343868 ИСПРАВЛЕНИЕ: запросы, использующие CHANGETABLE, используют гораздо больше ресурсов ЦП в SQL Server 2014 SP1 или SQL Server 2016 (KB3180060)
8451202 ИСПРАВЛЕНИЕ: SQL Server 2016 не записывает сообщения об ошибках с уровнем серьезности 21 для несоответствий контрольных сумм, обнаруженных в файлах контрольных точек OLTP (KB4019715 In-Memory)
8528563 ИСПРАВЛЕНИЕ: SQL Server 2016 перестает отвечать на запросы при восстановлении баз данных, содержащих таблицы, оптимизированные для памяти (KB3197605)
8529432 ИСПРАВЛЕНИЕ: SQL Server управляемое резервное копирование в Windows Azure пытается создать резервную копию моментальных снимков базы данных в SQL Server (KB3168708)
Новая функция производительности, которая ускоряет время фиксации (задержку) транзакций до 2–4 раз при использовании памяти класса хранилища (энергонезависимое хранилище NVDIMM-N)
Низкая производительность при запуске INSERT.. Операции SELECT в SQL Server 2016 (KB3180087)
Предупреждение "Требуется драйвер с цифровой подписью" при установке пакетов SQL Server в Windows Server 2016 и Windows 10 (KB3203693)
8024991 ИСПРАВЛЕНО. При импорте данных с помощью мастера импорта и экспорта (KB3112704) в сообщении об ошибке не указываются отсутствующие столбцы

Дополнительные резолюции

Решения следующих проблем также включены в SQL Server 2016 SP1.

Ссылка на ошибку Описание Область исправления

68674998024974
Значения NULL игнорируются при изменении типа данных столбца с текстового на varchar(max). Двигатель
8024962 Sqlcmd завершает работу без ошибок, если текст запроса содержит как внедренные примечания, так и фигурные ("{" скобки или "}"). Двигатель
8024968 Пакетная сортировка и оптимизированный вложенный цикл могут вызвать проблемы со стабильностью и производительностью. Двигатель
8024987 Сканирование таблиц и индексов с предикатом вытеснения, как правило, приводит к завышению временно предоставленного буфера памяти для родительского оператора. Двигатель
8024997 Функция поиска Full-Text работает неправильно для голландского языка. Двигатель
8025069 Инструкция CREATE NONCLUSTERED INDEX может завершиться с ошибкой, если имя базы данных начинается со знака '#'. Двигатель
8025097 Добавлены информационные сообщения для tempdb конфигураций в журнал ошибок SQL Server. Двигатель
8267453 MERGE Операторы, содержащие оба UPDATE оператора And INSERT , завершаются ошибкой "Невозможно вставить повторяющуюся строку ключа", если конечная таблица содержит уникальный индекс. Двигатель
8279683 Происходит сбой SQL Server при неожиданном завершении задачи средства обработки кортежей. Двигатель
8025058 Добавьте в таблицу имя таблицы и значение первичного ключа для ошибки 20598 msdistribution_history (репликация SQL Server). Улучшение
8025059 При сбое агента репликации с превышением времени ожидания запроса текст запроса записывается без включения подробного журнала. Репликация
8025081 Агент чтения журнала репликации может завершиться сбоем, если конечная таблица является пустой строкой. Репликация
4300066 Обновите информацию об авторских правах до «© 2016 Microsoft» в командной строке установки SQL Server. Установка
5610151 Ненужное предупреждающее сообщение возвращается в выходных данных командной строки, когда объединенный поток устанавливает SQL Server с параметром командной строки. Установка
7270486 После удаления одного или нескольких обновлений для SQL Server при восстановлении SQL Server операция восстановления завершается ошибкой. Установка
7350315 Установка SQL Server на компьютере с доменным именем не на английском языке завершится сбоем с ошибкой «Недопустимые символы в пути». Установка
7439317 Строка "Отчет об обнаружении установки" в отчете "Отчет об обнаружении установленных функций SQL Server" не локализована. Установка
7439502 В мастере установки SQL Server 2016 неправильно указан SQL Server 2008 SP3, хотя требуется SQL 2008 R2 SP3. Установка
8024994 На вкладке "Complete" отсутствует ссылка на документацию MSDN "Конфигурация контактной области" в разделе "Документ и ссылки" при установке объединенного потока. Установка
8051010 Настройка SQL Server 2016 может завершиться сбоем, если во время установки установлен драйвер ODBC 11 для SQL Server. Установка
8343905 При установке объединенного потока может произойти сбой с ошибкой "Сбой проверки строгого имени". Установка
8348718 Если UpdateEnabled установлено значение False в объединенной установке, сводный журнал настройки не содержит сведений об обновлениях, установленных во время установки. Установка
8024972 Сбой BCP с ошибкой при анализе формата YYYY/MM/DD даты в DATE столбце. Подключение SQL
5128484 Standard выпуск служб SQL Server 2016 Analysis Services (табличный режим) игнорирует ограничение памяти в 16 ГБ. SSAS
7487320 Запросы, содержащие Row-Level Security (RLS), могут завершиться сбоем, даже если для DataView задано значение Sample. SSAS
8210484 Маска сходства работает неправильно для узлов NUMA в службах SQL Server 2016 Analysis Services. SSAS
8281121 Повышение масштабируемости производительности табличной версии SSAS путем реализации поддержки NUMA в табличном режиме SSAS. SSAS
8430619 Повышение масштабируемости табличной производительности SSAS с помощью стандартных блоков Intel® Threading (Intel® TBB). SSAS
8024998 Ошибка «Поставщик журналов «Microsoft.LogProviderEventLog не установлен» возникает при открытии диалогового окна "Настройка журналов служб SSIS: пакет" в пакете служб SSIS, в котором уже есть журнал. СГИС
8025032 Это обновление изменяет поведение: если задача XML не может получить кодировку из XML-документов, будет использоваться кодировка Юникода. СГИС
7330691 Добавляет дополнительные сведения, указывающие, является ли отчет мобильным, в журналы выполнения сервера отчетов SSRS. SSRS
7807395 Возможно, потребуется повторить попытку повторной авторизации, если не удалось выверить данные в таблице с включенной базой данных растяжки. Stretch DB
8196154 Выполнение запроса в таблице с поддержкой растянутой базы данных с указанным предикатом фильтра может завершиться с ошибкой. Stretch DB
8292093 Создание, изменение или удаление индексов в таблице с включенной растяжкой базы данных может завершиться неудачей. Stretch DB

Дополнительные сведения о том, как обновить установку SQL Server до SQL Server 2016 SP1, см. в разделе Поддерживаемые обновления версий и выпусков.

Как получить SQL Server 2016 SP1

SQL Server 2016 с пакетом обновления 1 (SP1) доступен для загрузки со страницы загрузки SQL Server 2016 SP1.

Примечание

После установки пакета обновления версия службы SQL Server должна отображаться как 13.0.4422.0.

Если по какой-либо причине вы решите удалить SQL Server 2016 с пакетом обновления 1 (SP1), удаление SQL Server 2016 с пакетом обновления 1 (SP1) не будет заблокировано и вы сможете удалить SQL Server 2016 с пакетом обновления 1 (SP1), как и любой другой пакет обновления. Тем не менее, если вы используете выпуск SQL Server Standard, Web и Express и используете некоторые новые функции, которые становятся доступны только начиная с SQL Server 2016 SP1, вы можете увидеть некоторые непредвиденные ошибки или базы данных могут даже остаться в подозрительном состоянии после удаления SQL Server 2016 SP1. Еще хуже то, что если системные базы данных используют новые функции, например секционированную таблицу в базе данных master, это может привести к тому, что экземпляр SQL Server не запустится после удаления SQL Server 2016 SP1. Поэтому рекомендуется проверить, что все новые функции отключены или удалены, прежде чем вы решите удалить SQL Server 2016 SP1 в выпусках, отличных от выпуск Enterprise. Удалить memory_optimized_data файловой группы невозможно. Следовательно, если у вас есть установочная memory_optimized_data файловая группа в базе данных с пакетом обновления 1 (SP1), не следует удалять SQL Server 2016 SP1. В противном случае база данных перейдет в подозрительный режим со следующим сообщением об ошибке, зарегистрированным в журнале ошибок:

<DateTime> spid15s Ошибка: 41381, Серьезность: 21, Состояние: 1.
<DateTime> spid15s База данных не запускается в этом выпуске SQL Server, так как она содержит MEMORY_OPTIMIZED_DATA файловую группу. Дополнительные сведения о поддержке функций в различных выпусках SQL Server см. в веб-книгах.

  • Этот продукт содержит программное обеспечение, основанное на функции Xerox Secure Hash Function.

  • Этот продукт включает программное обеспечение из библиотеки сжатия общего назначения zlib.

  • Некоторые компоненты этого программного обеспечения частично основаны на разработках RSA Data Security, Inc. Так как корпорация Майкрософт включила программное обеспечение RSA Data Security, Inc. в этот продукт, корпорация Майкрософт обязана включить приведенный ниже текст, который прилагается к такому программному обеспечению:

    • Авторские права 1990 г., RSA Data Security, Inc. Все права защищены.
    • Лицензия на копирование и использование этого программного обеспечения предоставляется при условии, что оно обозначено как «RSA Data Security, Inc., MD5 Message-Digest Algorithm» во всех материалах, упоминающих или ссылающихся на это программное обеспечение или эту функцию. Лицензия также предоставляется на создание и использование производных работ при условии, что такие работы идентифицированы как «производные от RSA Data Security, Inc., MD5 Message-Digest Algorithm» во всех материалах, упоминающих или ссылающихся на производную работу.
    • RSA Data Security, Inc. не делает никаких заявлений относительно товарной пригодности данного программного обеспечения или его пригодности для какой-либо конкретной цели. Он предоставляется "как есть" без явных или подразумеваемых гарантий.

    Эти уведомления должны храниться во всех копиях любой части документации или программного обеспечения.

  • Функция сопоставления Reporting Services использует данные из шейп-файлов TIGER/Line, любезно предоставленных Бюро переписи населения США. Шейп-файлы TIGER/Line представляют собой извлечение избранной географической и картографической информации из базы данных Census MAF/TIGER. Шейп-файлы TIGER/Line доступны бесплатно в Бюро переписи населения США. Для получения дополнительной информации о шейп-файлах TIGER/Line перейдите в раздел шейп-файлы TIGER/Line. Информация о границах в шейп-файлах TIGER/Line предназначена только для сбора статистических данных и подсчета таблиц; Его описание и обозначение для статистических целей не представляет собой определение юрисдикционных полномочий, прав собственности или прав, а также не отражает юридических описаний земли. Census TIGER и TIGER/Line являются зарегистрированными товарными знаками Бюро переписи населения США.

Авторское право 2012 Microsoft. Все права защищены.

Ссылки

Для получения дополнительных сведений об определении текущей версии и выпуска SQL Server выберите номер статьи со следующим номером для перехода к статье в базе знаний Майкрософт:

321185 Определение версии и выпуска SQL Server

Продукты сторонних разработчиков, рассмотренные в этой статье, выпущены компаниями, независимыми от корпорации Майкрософт. Корпорация Майкрософт не гарантирует надлежащую работоспособность и надежность этих продуктов.