Triệu chứng
Khi bạn khôi phục một đăng ký trước bằng cách sử dụng lệnh scanreg /restore , bạn có thể nhận được thông báo lỗi sau:
Thao tác khôi phục sổ đăng ký Microsoft CheckerSystem không thành công.
Nguyên nhân
Hiện tượng này xảy ra bởi vì bạn đang cố gắng khôi phục Phiên bản u lưu sổ đăng ký. Số đăng ký tối đa đã được lưu theo quy định trong tập tin Scanreg.ini MaxBackupCopies cài đặt. Khi bạn cố gắng khôi phục sổ đăng ký u, Windows sẽ cố gắng để sao lưu sổ đăng ký hiện tại. Bởi vì Windows sẽ cố gắng ghi đè lên cùng một bản sao lưu sổ đăng ký bạn đang cố gắng khôi phục, khôi phục hoạt động không thành công. Lưu ý: sao lưu sổ đăng ký cổ nhất vẫn được thay thế bằng bản sao lưu sổ đăng ký hiện tại và đăng ký u không còn có sẵn để khôi phục.
Giải pháp
Để giải quyết vấn đề này, thực hiện một trong các thao tác sau trước khi sử dụng lệnh scanreg /restore :
-
Đổi tên một hoặc nhiều bản sao lưu sổ đăng ký khác để làm cho bản sao lưu khác.
-
Tăng thiết lập MaxBackupCopies trong tệp Scanreg.ini để sao lưu sổ đăng ký hiện tại.
Bạn có thể cũng khôi phục thủ công tệp đăng ký ngăn chặn tự động sao lưu sổ đăng ký hiện tại. Để biết thêm thông tin về các tuỳ chọn này, hãy bấm số bài viết sau để xem bài viết trong cơ sở kiến thức Microsoft:
Thông báo lỗi : khôi phục hoạt động không thành công