Bỏ qua để tới nội dung chính
Đăng nhập với Microsoft
Đăng nhập hoặc tạo một tài khoản.
Xin chào,
Chọn một tài khoản khác.
Bạn có nhiều tài khoản
Chọn tài khoản bạn muốn đăng nhập.

Quan trọng Bài viết này chứa thông tin về cách sửa đổi sổ đăng ký. Hãy chắc chắn rằng bạn sao lưu sổ đăng ký trước khi sửa đổi. Hãy chắc chắn rằng bạn biết cách khôi phục sổ đăng ký nếu sự cố xảy ra. Để biết thêm thông tin về cách sao lưu, khôi phục và sửa đổi sổ đăng ký, hãy bấm vào số bài viết sau đây để xem bài viết trong Cơ sở Kiến thức Microsoft:

256986 Mô tả về sổ đăng ký Microsoft Windows

Triệu chứng

Bạn tìm thấy dấu chấm than màu vàng bên cạnh biểu tượng Máy khách Tường lửa. Ngoài ra, khi bạn di chuyển con trỏ chuột trên biểu tượng Máy khách Tường lửa, thông báo mẹo công cụ sẽ được hiển thị giống như sau:

Máy khách Tường lửa không được cài đặt đúng cách

Nguyên nhân

Sự cố này xảy ra nếu bạn đang chạy một chương trình cài đặt Nhà cung cấp Dịch vụ Cơ sở WinSock (BSP), chẳng hạn như trình tối ưu hóa kết nối điện thoại di động. BSP có thể bỏ qua BSP Máy khách Tường lửa và ảnh hưởng đến chức năng chính xác của Máy khách Tường lửa. Để cảnh báo bạn về tình huống này, máy khách tường lửa hiển thị một thông báo cảnh báo.

Tuy nhiên, một số BSP không bỏ qua BSP máy khách tường lửa. Vì vậy, các BSP không ảnh hưởng đến chức năng của máy khách tường lửa. Nếu bạn đã kiểm tra chương trình của bạn, và nếu bạn đã xác minh rằng nó không ảnh hưởng đến hoạt động chính xác của máy khách tường lửa, bạn có thể vô hiệu hóa thông báo cảnh báo mẹo công cụ. Để tắt thông báo cảnh báo mẹo công cụ này, hãy cài đặt hotfix được mô tả trong phần "Độ phân giải".

Sau khi cài đặt hotfix, bạn phải thêm mục đăng ký UiEnableCatalogValidation để bật hotfix. Để biết thêm thông tin về cách thêm mục đăng ký này, hãy xem phần "Thông tin sổ đăng ký Windows".

Giải pháp

Thông tin cập nhật nóng

Hotfix được hỗ trợ có sẵn từ Microsoft. Tuy nhiên, hotfix này là nhằm sửa chữa chỉ vấn đề được mô tả trong bài viết này. Áp dụng hotfix này chỉ cho hệ thống đang gặp vấn đề cụ thể này.

Nếu bản cập nhật nóng có sẵn để tải xuống thì có mục "Tải xuống bản cập nhật nóng sẵn dùng" ở đầu bài viết Cơ sở Kiến thức này. Nếu phần này không xuất hiện, hãy gửi yêu cầu đến Bộ phận Dịch vụ khách hàng và Hỗ trợ Khách hàng của Microsoft để nhận cập nhật nóng.

Lưu ý Nếu có sự cố khác xảy ra hoặc nếu cần khắc phục sự cố bất kỳ, bạn có thể phải tạo một yêu cầu dịch vụ riêng biệt. Chi phí hỗ trợ thông thường sẽ áp dụng cho các câu hỏi và sự cố hỗ trợ bổ sung không đủ điều kiện cho hotfix cụ thể này. Để có danh sách đầy đủ các số điện thoại của Bộ phận Dịch vụ Khách hàng và Hỗ trợ của Microsoft hoặc để tạo yêu cầu dịch vụ riêng biệt, hãy truy cập trang Web Microsoft sau:

http://support.microsoft.com/contactus/?ws=supportLưu ý Biểu mẫu "Tải xuống cập nhật nóng" hiển thị các ngôn ngữ mà hotfix có sẵn. Nếu bạn không thấy ngôn ngữ của mình, đó là vì bản cập nhật nóng không có sẵn cho ngôn ngữ đó.

Thông tin về tệp

Phiên bản tiếng Anh của hotfix này có các thuộc tính tệp (hoặc các thuộc tính tệp mới hơn) được liệt kê trong bảng sau đây. Ngày và giờ của các tệp này được liệt kê theo Giờ chuẩn quốc tế (UTC). Khi bạn xem thông tin về tệp, tệp đó đã được chuyển đổi thành giờ địa phương. Để tìm ra sự khác biệt giữa UTC và giờ địa phương, hãy dùng tab Múi giờ trong mục Ngày Giờ trong Panel điều khiển.

Tên tệp

Phiên bản tệp

Kích thước tệp

Ngày

Giờ

Nền

Fwcmgmt.exe

4.0.3442.700

120,208

Ngày 20 tháng 5 năm 2007

16:39

Not Applicable

Thông tin đăng ký Windows

Cảnh báo Các vấn đề nghiêm trọng có thể xảy ra nếu bạn sửa đổi sổ đăng ký không chính xác bằng cách sử dụng Trình soạn thảo Sổ đăng ký hoặc bằng phương pháp khác. Những sự cố này có thể yêu cầu bạn phải cài đặt lại hệ điều hành. Microsoft không thể đảm bảo rằng những vấn đề này có thể được giải quyết. Bạn phải tự chịu rủi ro khi sửa đổi sổ đăng ký.

Sau khi cài đặt hotfix này, bạn phải thêm mục đăng ký UiEnableCatalogValidation để bật hotfix này. Để thực hiện việc này, hãy làm theo các bước sau:

  1. Bấm vào Bắt đầu, bấm vào Chạy, nhập regedit, rồi bấm ok.

  2. Tìm rồi bấm vào khóa con đăng ký sau:

    Trên máy tính 32 bit:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Firewall Client 2004\Policies

    Trên máy tính 64 bit:HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Firewall Client 2004\Policies

  3. Trên menu Chỉnh sửa, bấm vào Mới, rồi bấm vào Giá trị DWORD.

  4. Nhập UiEnableCatalogValidation, rồi nhấn ENTER.

  5. Bấm chuột phải vào UiEnableCatalogValidation, rồi đảm bảo rằng hộp Dữ liệu giá trị chứa giá trị null (0).

Trạng thái

Microsoft đã xác nhận đây là sự cố trong các sản phẩm của Microsoft được liệt kê trong phần "Áp dụng cho".

Thông tin Bổ sung


Để biết thêm thông tin về thuật ngữ tiêu chuẩn được sử dụng để mô tả các bản cập nhật phần mềm của Microsoft, hãy bấm vào số bài viết sau để xem bài viết trong Cơ sở Kiến thức Microsoft:
 

824684 Mô tả thuật ngữ chuẩn được sử dụng để miêu tả các bản cập nhật phần mềm của Microsoft
 

Bạn cần thêm trợ giúp?

Bạn muốn xem các tùy chọn khác?

Khám phá các lợi ích của gói đăng ký, xem qua các khóa đào tạo, tìm hiểu cách bảo mật thiết bị của bạn và hơn thế nữa.

Cộng đồng giúp bạn đặt và trả lời các câu hỏi, cung cấp phản hồi và lắng nghe ý kiến từ các chuyên gia có kiến thức phong phú.

Thông tin này có hữu ích không?

Bạn hài lòng đến đâu với chất lượng dịch thuật?
Điều gì ảnh hưởng đến trải nghiệm của bạn?
Khi nhấn gửi, phản hồi của bạn sẽ được sử dụng để cải thiện các sản phẩm và dịch vụ của Microsoft. Người quản trị CNTT của bạn sẽ có thể thu thập dữ liệu này. Điều khoản về quyền riêng tư.

Cảm ơn phản hồi của bạn!

×