KB2630458 - 在 SQL Server 2008 R2 Service Pack 2 中修复的 Bug 列表

应用对象
SQL Server 2008 R2 Service Pack 2

简介

本文列出了在 Microsoft SQL Server 2008 R2 Service Pack 2 (SP2) 中修复的 bug。

便笺

  • Service Pack 中可能还会包含未记录的其他修复程序。
  • 当有更多文章发布时,该列表将会更新。

有关如何获取 SQL Server 2008 R2 Service Pack 的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2527041 如何获取 SQL Server 2008 R2 的最新 Service Pack

详细信息

除了本文列出的修补程序之外,SQL Server 2008 R2 SP2 还包含 SQL Server 2008 R2 Service Pack 1 (SP1) 的累积更新 1 到累积更新 5 中包含的修补程序。

注意:如果要从 SQL Server 2008 R2 SP1 累积更新 6 升级,则必须在升级到 SQL Server 2008 R2 SP2 后应用 SQL Server 2008 R2 SP2 之后的累积更新,才能获取所有修补程序。

  有关可用于 SQL Server 2008 R2 SP1 的累积更新包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2567616 在 SQL Server 2008 R2 Service Pack 1 发布之后发布的 SQL Server 2008 R2 内部版本

此 Service Pack 中修复的问题

有关 SQL Server 2008 R2 SP2 中修复的 Bug 的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章。

VSTS 错误号 知识库文章编号 说明
820875 922578 修复:在 SQL Server 2005、SQL Server 2008 或 SQL Server 中使用 SQL Server 配置文件时,SQL Server 2005、SQL Server 2008 或 SQL Server 2008 R2 中记录了大量消息 ID 为 19030 和消息 ID 为 19031 的邮件 错误日志文件2008 R2
728527 2216456 SQL Server 2008 Service Pack 2 和 SQL Server 2008 R2 Service Pack 2 对 Analysis Services 中“操作已取消”错误消息文本的增强
820858 2550375 修复:运行从多个数据库到一个辅助服务器的日志传送时,SQL Server 2008 R2 中的 sys.dm_database_encryption_keys DMV 中可能会发生死锁
820878 2565683 修复:在 SQL Server 2008 或 SQL Server 2008 R2 环境中运行包含聚合函数、联接函数和子查询中的不同函数的复杂查询时,可能会收到错误的结果
820756 2588050 修复:如果安装了数据库引擎,则在向 SQL 实例添加新功能时,SQL Server 2008 或 SQL Server 2008 R2 Service Pack 的滑流安装失败
901689 2653857 修复:升级到 SQL Server 6 更新 29 或更高版本后,无法使用适用于 SQL Server 的 JDBC 驱动程序连接到 SQL Server
873603 2682488 修复:启用更改跟踪后,备份操作在 SQL Server 2008、SQL Server 2008 R2 或 SQL Server 2012 数据库中失败
958983 2719217 修复:当具有堆表并且在 SQL Server 2008 R2 或 SQL Server 2012 中启用数据压缩时,闩锁超时错误

此 CTP 版本的 Service Pack 中修复的其他问题

以下问题的解决方法也包括在 SQL Server 2008 R2 SP2 中。

VSTS 错误号 说明
820845 很高兴使用 BindParameter 方法和此方法使用的长类型参数的引用。
852397 重置 ConfigurationState 时汇报 UpgradeIncompleteFeatureConfigEventHandler.cs包括 RebuildDatabase 方案。
887672 对于将“在浏览器中打开文档”设置设置为“在客户端应用程序中打开”的文档库,GetSnapshot.exe 将忽略配置并始终使用Excel Services显示工作簿,就像设置为“在浏览器中打开”一样。
820805 修复:在俄语本地化版本的 Reporting Services Configuration Manager 中,执行帐户信息包含剪辑的字符串。
718430 ExpectedCount 和 ExpectedElapsedMs 使用计数将更新以反映实际计数。
737914 修复了 SQL Server 2008 R2 Analysis Services 在数据库同步期间崩溃的问题。
788389 删除跟踪标志 1264,以便在非生成方案转储中默认收集进程名称。 非生成方案转储文件中的线程记录数从 1K 增加到 16K。
820762 如果应记录事件,SQL Server 2008 R2 会将 FireAgain 参数更改为 True。 但是,在误删除某些代码后,某些日志丢失,因为 FireAgain 参数仅由外部事件侦听器确定。 应用此修补程序后,问题得到解决。
820764 请考虑以下情形。 你已为 SQL Server 2008 R2 中的基表和非基表中的视图项目列编制了索引。 非基表中的列与基表的列具有相同的订单 ID 和类型。 在此方案中,SQL Server 2008 R2 切换分区。 应用修补程序后,SQL Server 2008 R2 遇到错误而不是切换分区。
820792 修复了在 SOS_Task PMO 上分配的对象也可能被另一个具有不同生存期的任务使用的问题。 此 Service Pack 使用正确的 PMO 分配对象。
820796 应用修补程序后,优化器了解CRYPT_GEN_RANDOM可以针对相同的输入返回不同的输出。
820859 修复了运行 SCOPE_IDENTITY () 时返回错误值的问题。
820864 修复了在使用 Shiloh OLAP SP3a 安装 SxS 时 SQL Server 2008 R2 安装程序崩溃的问题。 出现此问题的原因是 Shiloh OLAP SP3a 错误地将版本注册表项写入为“Service Pack 3.0”。
820873 修复了涉及并行查询计划时 sys.dm_exec_query_stats 报告不正确的 CPU 时间的问题。
820880 修复了内部异步文件读取缓冲区将多字符列分隔符拆分为两部分时发生的问题。 修复方法是在切换缓冲区后正确重置当前分析指针。
847805 仅当 SQLWixCompilerExtension 操作在蜡烛中运行时才使用同步。
890643 更改 HierarchyGet 操作以避免显式上限出现仅适用于层次结构派生部分的特定代码路径。 该更新是低风险的单行更新。
731796 修复了从 snapshots.notable_query_text 清除时在语句中收到错误的问题。
820829 从平面文件分析的错误 GUID 值可能会导致错误。 修复方法是,如果源缓冲区大于 GUID 字符串的最大大小,则回退到截断模式。
677173 定期重新计算闩锁提升阈值,以避免由于启动时的计算错误而产生变化。
725819 建议的修复方法是匹配呼叫方和被呼叫者之间的调用约定。
769975 修复了当计算机的处理器插槽为空或使用重启选项 /setgroupsize 时启动期间的崩溃问题。
788233 减少闩锁在遇到旋转锁时退出的时间。 这有助于提高性能
840461 修复了 XE 会话启动期间可能导致 SQL Server 崩溃的争用条件。

参考资料

有关如何确定当前 SQL Server 版本的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

321185
  如何识别你的 SQL Server 版本
 本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。