发布日期: 2018 年 4 月 24 日
版本: 13.0.5026.0
本文包含在安装 Microsoft SQL Server 2016 Service Pack 2 (SP2) 之前需要阅读的重要信息。 本文介绍如何获取服务包、服务包中包含的修补程序列表、已知问题以及产品的版权属性列表。
注意
本文作为查找与此 Service Pack 相关的所有文档的单一信息来源。 它包括您先前在发行说明和 Readme.txt 文件中找到的所有信息。
SQL Server 2016 SP2 中包含的修补程序列表
Microsoft SQL Server 2016 服务包是累积更新。 SQL Server 2016 SP2 将 SQL Server 2016 的所有版本和服务级别升级到 SQL Server 2016 SP2。 除了本文列出的修补程序之外,SQL Server 2016 SP2 还包括 SQL Server 2016 累积更新 1 (CU1) SQL Server 2016 SP1 CU8 中包含的修补程序。
有关 SQL Server 2016 中提供的累积更新的详细信息,请参阅 SQL Server 2016 内部版本。
注意
- 此处未记录的其他修补程序也可能包含在服务包中。
- 当有更多文章发布时,该列表将会更新。
有关 SQL Server 2016 SP2 中修复的 Bug 的更多信息,请转到以下 Microsoft 知识库文章。
其他解决方案
以下问题的解决方法也包括在 SQL Server 2016 SP2 中。
| Bug 参考 | 说明 | 区域 |
|---|---|---|
| 8523231 | 添加可对非持久内存优化表具有外键引用的持久内存优化表。 | 内存中 OLTP |
| 9146914 | 将属性添加到 SpLevel and ReleaseProductVersion SQL Server 2016 SP1。 |
设置和安装 |
| 10365365 | 通过在自定义群集中的被动节点上安装 SQL Server 安全更新来修复问题。 | 设置和安装 |
| 9480942 | 修复了避免在 中 GetNextAllHoBts出现 null 引用的问题。 |
SQL 引擎 |
| 9737945 | 添加一个 DVM sys.dm_tran_version_store_space_usage ,它可以跟踪 tempdb 每个数据库中的版本存储使用情况。 |
SQL 引擎 |
| 9742982 | 修复了当 . MAXDOP1时计划缓存内存使用率较高的问题 |
SQL 引擎 |
| 10698782 | 添加一个新的 DMV sys.dm_db_log_stats ,它返回摘要级别属性和有关数据库事务日志文件的信息。 |
SQL 引擎 |
| 10698786 | 添加一个新的 DMV sys.dm_db_log_info ,它返回虚拟日志文件 (VLF) 有关事务日志文件的信息。 |
SQL 引擎 |
| 10698823 | 显示数据库中差异更改的百分比,以帮助确定完整数据库备份或差异备份是否有用。 | SQL 引擎 |
| 10698846 | 添加一个新的 DMV,该 DMV sys.dm_tran_version_store_space_usage 返回一个表,以显示每个数据库的版本存储记录使用的 tempdb 中的总空间。 |
SQL 引擎 |
| 10698847 | 修复了以下问题:通过虚拟设备接口 (VDI) 接口还原启用了透明数据加密 (TDE) 数据库的压缩备份可能会失败,并出现操作系统错误 38。 | SQL 引擎 |
| 10755072 | 将文件组支持 SELECT INTO 添加到语句中。 这允许您指定一个已创建了新表的文件组名称。 指定的文件组应存在于数据库中,否则 SQL Server 引擎会引发错误。 |
SQL 引擎 |
| 10756412 | 向管理命令添加WITH VERIFY_CLONEDBCC CLONEDATABASE选项,WITH BACKUP_CLONE允许您验证和备份克隆的数据库。 |
SQL 引擎 |
| 10760480 | 公开 DMV sys.dm_server_services 和 SERVERPROPERTY 函数中的处理器信息,如内核计数、套接字和 NUMA 信息。 |
SQL 引擎 |
| 10823015 | 改进具有大内存计算机的备份性能。 | SQL 引擎 |
| 10914366 | 在进程列表和 executionStack 扩展事件 xml_deadlock_report 中添加数据库名称属性以公开数据库名称。 |
SQL 引擎 |
| 10925573 | 添加一个新的扩展事件,该事件 marked_transaction_latch_trace 显示标记的事务使用的全局闩锁的状态。 |
SQL 引擎 |
| 10973764 | 改进了分布式事务处理协调器 (DTC) 对 AG) 数据库 (AlwaysOn 可用性组的支持。 | SQL 引擎 |
| 11559743 | 修复了在横向扩展部署模式下安装 Polybase 功能时无法运行该 ADDNODE 步骤的问题。 |
SQL 引擎 |
| 11565681 | 公开数据库的上次已知良好 DBCC CHECKDB 日期和时间。 |
SQL 引擎 |
| 11583626 | 通过从已安装 Polybase 的故障转移群集中删除节点来修复问题。 | SQL 引擎 |
| 8837822 | 修复了 DMV sys.dm_exec_query_profiles 显示与估计或实际查询计划不一致的错误结果的问题。 |
SQL 性能 |
| 9437530 | 修复了内存授予使用情况 (InputMemoryGrant, OutputMemoryGrant 以及 UsedMemoryGrant Showplan XML 中用于并行查询的属性) 问题。 |
SQL 性能 |
| 10697461 | 修复了查询提示并非始终得到遵守的问题 MAX_GRANT_PERCENT 。 |
SQL 性能 |
| 10723493 | 修复了以下问题:如果列包含值,TIMESTAMP则查询 DMV sys.dm_db_stats_histogram 时可能会发生断言错误。 |
SQL 性能 |
有关如何将 SQL Server 安装升级到 SQL Server 2016 SP2 的详细信息,请参阅支持的版本和版本升级。
如何获取 SQL Server 2016 SP2
SQL Server 2016 SP2、Microsoft SQL Server 2016 SP2 Express 和 Microsoft SQL Server 2016 SP2 功能包可在以下 Microsoft 下载中心网站手动下载和安装。
注意
安装 Service Pack 后,SQL Server 服务版本应为 13.0.5026.0 Microsoft SQL Server 2016 Service Pack 是累积更新。 SQL Server 2016 SP2 将 SQL Server 2016 的所有版本和服务级别升级到 SQL Server 2016 SP2。
不建议卸载 SQL Server 2016 SP2 ()
如果出于任何原因选择卸载 SQL Server 2016 SP2,我们将不会阻止 SQL Server 2016 SP2 卸载,并且你将能够以与任何其他服务包相同的方式卸载 SQL Server 2016 SP2。 但是,如果运行的是 Standard、Web 或 Express 版本的 SQL Server,并且您正在使用某些仅当启动 SQL Server 2016 SP2 时才解锁的新功能,则卸载 SQL Server 2016 SP2 后您可能会遇到错误或数据库显示可疑状态。 更糟糕的是,如果系统数据库正在使用新功能 (例如,master 数据库中的分区表) ,这可能会阻止卸载 SQL Server 2016 SP2 后启动 SQL Server 实例。
我们建议您选择卸载企业版以外的 SQL Server 2016 SP2 版本之前验证是否已禁用或删除所有新功能。 不能删除 memory_optimized_data 文件组。 因此,如果您已使用 SP2 在数据库上设置memory_optimized_data文件组,则不应卸载 SQL Server 2016 SP2。 否则,数据库将进入可疑状态,以下条目将被记录在错误日志中:
<日期时间> spid15s 错误:41381,严重性:21,状态:1。
<日期时间> spid15s 数据库无法在此版本的 SQL Server 中启动,因为它包含MEMORY_OPTIMIZED_DATA文件组。 有关不同 SQL Server 版本中的功能支持的详细信息,请参阅联机丛书。
版权归属
此产品包含从 Xerox 安全哈希函数派生的软件。
此产品包含 zlib 通用压缩库中的软件。
此软件的部分内容基于 RSA Data Security, Inc. 的工作。因为 Microsoft 已在此产品中包含 RSA Data Security, Inc., 软件,所以 Microsoft 必须包含此类软件附带的下列文本:
- 版权所有 1990,RSA Data Security, Inc. 保留所有权利。
- 只要在提及或引用本软件或此功能的所有材料中标明为“RSA Data Security, Inc., MD5 Message-Digest Algorithm”,则授予复制和使用本软件的许可。 如果这些作品在所有提及或引用衍生作品的材料中被标识为“源自 RSA Data Security, Inc., MD5 消息摘要算法”,则还授予制作和使用衍生作品的许可。
- RSA Data Security, Inc. 对本软件的适销性或本软件对任何特定用途的适用性不作任何声明。 它按“原样”提供,不提供任何形式的明示或默示担保。
这些通知必须保存在本文档或软件的任何部分的任何副本中。
Reporting Services 映射功能使用 TIGER/Line Shapefiles 中提供的数据,这些数据是由美国统计局提供的。 Tiger/Line Shapefiles 是从 Census MAF/TIGER 数据库中提取的选定地理和地图信息。 TIGER/Line Shapefiles 可以从美国统计局免费查询。 若要获取有关 TIGER/Line shapefiles 的更多信息,请转到 TIGER/Line shapefiles。 TIGER/Line Shapefiles 中的边界信息仅用于统计数据收集和制表目的;出于统计目的,其描述和指定不构成对管辖权、所有权或权利的确定,也不反映合法的土地描述。 Census TIGER 和 TIGER/Line 是美国统计局的注册商标。
版权所有 2012 Microsoft。 保留所有权利。
参考资料
有关如何确定当前 SQL Server 版本的更多信息,请选择下面的文章编号,以查看 Microsoft 知识库中相应的文章:
321185 如何识别SQL Server版本
本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。