KB4052908 - SQL Server 2016 Service Pack 2 版本信息

发布日期: 2018 年 4 月 24 日
版本: 13.0.5026.0

本文包含在安装 Microsoft SQL Server 2016 Service Pack 2 (SP2) 之前需要阅读的重要信息。 本文介绍如何获取服务包、服务包中包含的修补程序列表、已知问题以及产品的版权属性列表。

注意

本文作为查找与此 Service Pack 相关的所有文档的单一信息来源。 它包括您先前在发行说明和 Readme.txt 文件中找到的所有信息。

SQL Server 2016 SP2 中包含的修补程序列表

Microsoft SQL Server 2016 服务包是累积更新。 SQL Server 2016 SP2 将 SQL Server 2016 的所有版本和服务级别升级到 SQL Server 2016 SP2。 除了本文列出的修补程序之外,SQL Server 2016 SP2 还包括 SQL Server 2016 累积更新 1 (CU1) SQL Server 2016 SP1 CU8 中包含的修补程序。

有关 SQL Server 2016 中提供的累积更新的详细信息,请参阅 SQL Server 2016 内部版本。

注意

  • 此处未记录的其他修补程序也可能包含在服务包中。
  • 当有更多文章发布时,该列表将会更新。

有关 SQL Server 2016 SP2 中修复的 Bug 的更多信息,请转到以下 Microsoft 知识库文章。

Bug 参考 说明
3507192 SQL Server 2017 CU3 和 SQL Server 2016 SP2 (KB4051361) 中添加的查询执行计划中的优化器行目标信息
5660983 更新将新列添加到 SYS。SQL Server 2016 SP2 中的DM_EXEC_QUERY_STATS DMV (KB4051358)
8742052 改进:对 SQL Server 2016 和 2017 中更改跟踪清理过程的常规改进 (KB4054842)
9443219 更新以在 SQL Server 2016 SP2 中向 DMV sys.dm_sql_referenced_entities添加新列 (KB4038418)
9824203 改进了分发代理清理过程,以提高 SQL Server 2016 中的事务复制性能 (KB4092069)
9956170 更新将“CLR 严格安全性”功能添加到 SQL Server 2016 (KB4018930)
10385772 提高 SQL Server 2017 和 SQL Server 2016 SP2 中 DMV 和扩展事件中的 tempdb 溢出诊断 (KB4041814)
10696815 更新将 CPU 超时设置添加到 SQL Server 2016 和 2017 中的Resource Governor工作组REQUEST_MAX_CPU_TIME_SEC (KB4038419)
10726760 SQL Server 2016 和 2017 中手动更改跟踪清理过程的更新 (KB4052129)
10727775 更新为 SQL Server 2016 和 2017 中的 CREATE STATISTICS 和 UPDATE STATISTICS 语句添加了对 MAXDOP 选项的支持 (KB4041809)
10732726 提高 SQL Server 2016 SP2 中分区表的查询性能 (KB4052137)
10871974 从 SQL Server 2012 SP4 和 SQL Server 2016 SP2 开始的 SQL Server 统一 Showplan 架构 (KB4016949)
11555288 在 SQL Server 2017 和 2016 中改进了查询内并行度死锁故障排除 (KB4089473)
11578523 改进:将 MDS 从 SQL Server 2012 升级到 2016 时出现性能问题 (KB4089718)
6884989 修复:增量统计信息的自动更新在 2016 和 2017 SQL Server 中延迟 (KB4041811)
7990665 SQL Server (KB3162858) 中日志备份过程失败时出现“日志备份链断开”错误
8025121 修复:当表中包含稀疏列集时“复制数据库向导”失败SQL Server (KB3157575)
8846046 修复:在 SQL Server 2016 SP1 Express Edition (KB4046909) 中执行联机事务时,LogPool 缓存MEMORYCLERK_SQLLOGPOOL消耗更多内存
9191595 修复:在 SQL Server 2016 中禁用更改数据捕获功能时,AG 中发生 LSN 截断 (KB4092045)
9912272 修复:标量用户定义函数的执行统计信息被添加到 SQL Server 2016 SP2 中的 Showplan XML 文件 (KB4051360)
10065114 修复:当查询通过 SQL Server 2016 中的同义词引用 SQLCLR 函数时会发生访问冲突 (KB3136496)
10077001 修复:在 SQL Server 2016 中以高 DOP 运行并行查询时,并行查询速度变慢 (KB4052138)
10456101 修复:在 SQL Server 2016 和 2017 的 XML 显示计划中添加 CXPACKET 等待类型 (KB4046914)
10571989 修复:SQL Server 2016 安装页面包含不安全的工具下载链接 (KB4046885)
10697582 修复:从 SQL Server (KB4014756) 中的远程过程调用执行时,SQL Server Profiler 无法对sp_setapprole进行模糊处理
10704351 修复:即使 SQL Server 实例上的所有其他数据库均未加密, (sys.databases) 的 tempdb 系统数据库仍处于加密状态 (KB4042788)
10727149 修复:运行优化嵌套循环连接所需的内存授予未反映在 SQL Server (KB3170116) 的 Showplan XML 中
10817173 修复:在 SQL Server 2016 或 2017 中,tempdb 数据库上的间接检查点导致“非生成计划程序”错误 (KB4040276)
10871961 修复:当 SQLCLR UDT 用作 SQL RPC 调用 (KB4013128) 的存储过程参数时,性能下降和 CLR_AUTO_EVENT 和 CMEMTHREAD 等待时间过长
10871968 修复:在 SQL Server 2012 和 2016 中为可用性数据库创建或配置Always On可用性组时发生访问冲突 (KB4021243)
10871976 修复:在 SQL Server (KB4016361) 中进行可用性组故障转移后,Service Broker 终结点连接不会关闭
10872004 修复:“sp_special_columns”在 SQL Server 2016 中返回错误结果 (KB4056008)
10914360 修复:在 SQL Server 2016 中,当许多连接同时访问单用户模式数据库时,单用户模式数据库上会发生死锁 (KB4042415)
10932023 修复:更改跟踪手动清理失败,并在 SQL Server (KB4043624) 中出现表不存在错误
10937127 修复:当在 SQL Server 2016 的扩展事件会话中捕获表值参数时,即使未启用收集语句或数据流,SQL Server也会耗尽内存 (KB4051359)
10973046 修复:在 SQL Server 2016 和 2017 中,当 SQL CLR 函数通过模拟调用调用 Transact-SQL 语句时执行失败 (KB4046918)
11032173 修复:重新启动后为“停止的 IOCP 侦听器”和“非生成SQL Server IOCP 侦听器”生成的内存转储 (KB4048942)
11086264 修复:SQL Server审核事件无法写入安全日志 (KB4052136)
11454650 修复:在 SQL Server 2016 中启用 TF 7412 后,QRY_PROFILE_LIST_MUTEX被阻止 (KB4089239)
11523867 修复:回滚更新 SQL Server 2016 中大量数据的批次需要很长时间 (KB4090279)
11542281 修复:在 SQL Server 2016 和 2017 中,CXPACKET 和 CXCONSUMER 等待类型显示某些并行查询计划的结果不一致 (KB4057054)
12519464 修复:访问具有筛选索引或统计信息 (KB4475794) 的表的查询优化期间发生访问冲突异常
9653457 更新启用 XML 显示计划以提供 SQL Server 2016 和 2017 中查询优化期间使用的统计信息列表 (KB4041817)
10895916 改进:添加了对 DBCC CLONEDATABASE SQL Server 2016 (KB4092075) 中的 Service Broker 支持
9832539 修复:TRY…CATCH在 SQL Server 2016 中的某些内存中 OLTP 错误处理方案中,块回滚了太多事务 (KB4039846)
10288012 修复:使用 ALTER DATABASE ADD FILE OR ADD LOG 命令添加具有相同逻辑名称的文件后无法重启 SQL Server 2016 (KB4092046)
10761398 修复:尝试将文件的 TempDB 初始大小设置为大于 1024 MB 的值时出现“TempDB 文件大小超过 1024 MB”错误 (KB4046902)
11032146 修复:在 SQL Server 2016 和 2017 (KB4045795) 中使用数据种子设定的 AAG 中出现线程池耗尽和 CMEMTHREAD 争用
11334467 修复:在 SSRS 2016 (SharePoint 模式下的报表参数窗格中,布尔值未正确本地化) (KB4075158)
11543252 修复:当数据库排序规则在 SQL Server 2016 和 2017 中使用 '_SC' 排序扩展时,未启用复制 (KB4092066)
11566335 修复:使用 QDS 并指定查询计划以解决性能回归问题时发生访问冲突 (KB4089509)

其他解决方案

以下问题的解决方法也包括在 SQL Server 2016 SP2 中。

Bug 参考 说明 区域
8523231 添加可对非持久内存优化表具有外键引用的持久内存优化表。 内存中 OLTP
9146914 将属性添加到 SpLevel and ReleaseProductVersion SQL Server 2016 SP1。 设置和安装
10365365 通过在自定义群集中的被动节点上安装 SQL Server 安全更新来修复问题。 设置和安装
9480942 修复了避免在 中 GetNextAllHoBts出现 null 引用的问题。 SQL 引擎
9737945 添加一个 DVM sys.dm_tran_version_store_space_usage ,它可以跟踪 tempdb 每个数据库中的版本存储使用情况。 SQL 引擎
9742982 修复了当 . MAXDOP1时计划缓存内存使用率较高的问题 SQL 引擎
10698782 添加一个新的 DMV sys.dm_db_log_stats ,它返回摘要级别属性和有关数据库事务日志文件的信息。 SQL 引擎
10698786 添加一个新的 DMV sys.dm_db_log_info ,它返回虚拟日志文件 (VLF) 有关事务日志文件的信息。 SQL 引擎
10698823 显示数据库中差异更改的百分比,以帮助确定完整数据库备份或差异备份是否有用。 SQL 引擎
10698846 添加一个新的 DMV,该 DMV sys.dm_tran_version_store_space_usage 返回一个表,以显示每个数据库的版本存储记录使用的 tempdb 中的总空间。 SQL 引擎
10698847 修复了以下问题:通过虚拟设备接口 (VDI) 接口还原启用了透明数据加密 (TDE) 数据库的压缩备份可能会失败,并出现操作系统错误 38。 SQL 引擎
10755072 将文件组支持 SELECT INTO 添加到语句中。 这允许您指定一个已创建了新表的文件组名称。 指定的文件组应存在于数据库中,否则 SQL Server 引擎会引发错误。 SQL 引擎
10756412 向管理命令添加WITH VERIFY_CLONEDBCC CLONEDATABASE选项,WITH BACKUP_CLONE允许您验证和备份克隆的数据库。 SQL 引擎
10760480 公开 DMV sys.dm_server_services 和 SERVERPROPERTY 函数中的处理器信息,如内核计数、套接字和 NUMA 信息。 SQL 引擎
10823015 改进具有大内存计算机的备份性能。 SQL 引擎
10914366 在进程列表和 executionStack 扩展事件 xml_deadlock_report 中添加数据库名称属性以公开数据库名称。 SQL 引擎
10925573 添加一个新的扩展事件,该事件 marked_transaction_latch_trace 显示标记的事务使用的全局闩锁的状态。 SQL 引擎
10973764 改进了分布式事务处理协调器 (DTC) 对 AG) 数据库 (AlwaysOn 可用性组的支持。 SQL 引擎
11559743 修复了在横向扩展部署模式下安装 Polybase 功能时无法运行该 ADDNODE 步骤的问题。 SQL 引擎
11565681 公开数据库的上次已知良好 DBCC CHECKDB 日期和时间。 SQL 引擎
11583626 通过从已安装 Polybase 的故障转移群集中删除节点来修复问题。 SQL 引擎
8837822 修复了 DMV sys.dm_exec_query_profiles 显示与估计或实际查询计划不一致的错误结果的问题。 SQL 性能
9437530 修复了内存授予使用情况 (InputMemoryGrant, OutputMemoryGrant 以及 UsedMemoryGrant Showplan XML 中用于并行查询的属性) 问题。 SQL 性能
10697461 修复了查询提示并非始终得到遵守的问题 MAX_GRANT_PERCENT 。 SQL 性能
10723493 修复了以下问题:如果列包含值,TIMESTAMP则查询 DMV sys.dm_db_stats_histogram 时可能会发生断言错误。 SQL 性能

有关如何将 SQL Server 安装升级到 SQL Server 2016 SP2 的详细信息,请参阅支持的版本和版本升级。

如何获取 SQL Server 2016 SP2

SQL Server 2016 SP2、Microsoft SQL Server 2016 SP2 Express 和 Microsoft SQL Server 2016 SP2 功能包可在以下 Microsoft 下载中心网站手动下载和安装。

注意

安装 Service Pack 后,SQL Server 服务版本应为 13.0.5026.0 Microsoft SQL Server 2016 Service Pack 是累积更新。 SQL Server 2016 SP2 将 SQL Server 2016 的所有版本和服务级别升级到 SQL Server 2016 SP2。

如果出于任何原因选择卸载 SQL Server 2016 SP2,我们将不会阻止 SQL Server 2016 SP2 卸载,并且你将能够以与任何其他服务包相同的方式卸载 SQL Server 2016 SP2。 但是,如果运行的是 Standard、Web 或 Express 版本的 SQL Server,并且您正在使用某些仅当启动 SQL Server 2016 SP2 时才解锁的新功能,则卸载 SQL Server 2016 SP2 后您可能会遇到错误或数据库显示可疑状态。 更糟糕的是,如果系统数据库正在使用新功能 (例如,master 数据库中的分区表) ,这可能会阻止卸载 SQL Server 2016 SP2 后启动 SQL Server 实例。

我们建议您选择卸载企业版以外的 SQL Server 2016 SP2 版本之前验证是否已禁用或删除所有新功能。 不能删除 memory_optimized_data 文件组。 因此,如果您已使用 SP2 在数据库上设置memory_optimized_data文件组,则不应卸载 SQL Server 2016 SP2。 否则,数据库将进入可疑状态,以下条目将被记录在错误日志中:

<日期时间> spid15s 错误:41381,严重性:21,状态:1。
<日期时间> spid15s 数据库无法在此版本的 SQL Server 中启动,因为它包含MEMORY_OPTIMIZED_DATA文件组。 有关不同 SQL Server 版本中的功能支持的详细信息,请参阅联机丛书。

  • 此产品包含从 Xerox 安全哈希函数派生的软件。

  • 此产品包含 zlib 通用压缩库中的软件。

  • 此软件的部分内容基于 RSA Data Security, Inc. 的工作。因为 Microsoft 已在此产品中包含 RSA Data Security, Inc., 软件,所以 Microsoft 必须包含此类软件附带的下列文本:

    • 版权所有 1990,RSA Data Security, Inc. 保留所有权利。
    • 只要在提及或引用本软件或此功能的所有材料中标明为“RSA Data Security, Inc., MD5 Message-Digest Algorithm”,则授予复制和使用本软件的许可。 如果这些作品在所有提及或引用衍生作品的材料中被标识为“源自 RSA Data Security, Inc., MD5 消息摘要算法”,则还授予制作和使用衍生作品的许可。
    • RSA Data Security, Inc. 对本软件的适销性或本软件对任何特定用途的适用性不作任何声明。 它按“原样”提供,不提供任何形式的明示或默示担保。

    这些通知必须保存在本文档或软件的任何部分的任何副本中。

  • Reporting Services 映射功能使用 TIGER/Line Shapefiles 中提供的数据,这些数据是由美国统计局提供的。 Tiger/Line Shapefiles 是从 Census MAF/TIGER 数据库中提取的选定地理和地图信息。 TIGER/Line Shapefiles 可以从美国统计局免费查询。 若要获取有关 TIGER/Line shapefiles 的更多信息,请转到 TIGER/Line shapefiles。 TIGER/Line Shapefiles 中的边界信息仅用于统计数据收集和制表目的;出于统计目的,其描述和指定不构成对管辖权、所有权或权利的确定,也不反映合法的土地描述。 Census TIGER 和 TIGER/Line 是美国统计局的注册商标。

版权所有 2012 Microsoft。 保留所有权利。

参考资料

有关如何确定当前 SQL Server 版本的更多信息,请选择下面的文章编号,以查看 Microsoft 知识库中相应的文章:

321185 如何识别SQL Server版本

本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。