简介
本文列出了可通过 Microsoft SQL Server 2008 Service Pack 3 (SP3) 修复的 SQL Server 2008 问题。
便笺
- Service Pack 可能会修复一些未记录的问题。
- 当问题的文章发布时,问题列表将更新。
若要详细了解如何获取 SQL Server 2008 Service Pack,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
968382
如何获取最新的 SQL Server 2008 Service Pack
注意 Microsoft 将 Microsoft SQL Server 2008 修补程序作为一个可下载的文件分发。 由于修补程序是累积的,因此每个新版本都包含之前 SQL Server 2008 修补程序版本中包含的所有修补程序和安全修补程序。 通常,你应该下载最新的 Service Pack。
立即下载 SQL Server 2008 Service Pack 3
详细信息
SQL Server 2008 SP3 修复了以下问题:
本文列出的问题
以下 Microsoft SQL Server 2008 Service Pack 2 (SP2 累积更新包中修复的问题) :
- SQL Server 2008 SP2 累积更新程序包 1
- SQL Server 2008 SP2 累积更新程序包 2
- SQL Server 2008 SP2 累积更新程序包 3
- SQL Server 2008 SP2 累积更新程序包 4
有关可用于 SQL Server 2008 SP2 的累积更新包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2402659 在 SQL Server 2008 Service Pack 2 发布之后发布的 SQL Server 2008 内部版本 下表提供了有关在 SQL Server 实例和 SQL Server 版本上自动检查此条件的产品或工具的详细信息计算规则所依据的产品。
| 规则软件 | 规则标题 | 规则说明 | 计算规则所依据的产品版本 |
|---|---|---|---|
| System Center Advisor | SQL Server缺少保证启动主体 lazywriter 的更新KB2546951 | System Center Advisor 可确定此 SQL Server 实例是否在逻辑处理器超过 64 个的服务器上运行。 此外,顾问还会检查 sqlservr.exe 的当前版本和版本。 如果 sqlservr.exe 的当前内部版本小于修补程序内部版本,则顾问将生成有关此问题的警报。 查看顾问警报的 “收集的信息” 部分中提供的详细信息,并应用本文中讨论的修补程序。 此顾问警报引用本文中提到的修补程序 ID 337272。 | SQL Server 2008 |
SQL Server 2008 SP3 修复的问题
有关问题的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章。
| VSTS 错误号 | 知识库文章编号 | 说明 |
|---|---|---|
| 721415 | 2550552 | 修复:SQL Server命令在使用非缓冲访问路径访问 SQL Server 2008 R2 或 SQL Server 2008 中的 FILESTREAM 文件时停止响应 |
| 611967 | 922578 | 修复:在 SQL Server 2005 中使用 SQL Server 配置文件时,许多消息 ID 为 19030 和消息 ID 为 19031 的邮件都记录在 SQL Server 2005 错误日志文件中 |
| 628427 | 2463682 | 修复:如果在 SQL Server 2008 R2 中删除了服务器证书,则启用了透明数据加密的数据库可能会被标记为“可疑” |
| 729461 | 2500042 | 应用适用于 SQL Server 2008 的 Service Pack 2 (SP2) 时出现“SQL Server 2008 安装程序需要安装 Microsoft .NET Framework 4.0”错误消息 |
| 757676 | 2565683 | 修复:在 SQL Server 2008 环境中运行包含聚合函数、联接函数和子查询中的不同函数的复杂查询时,可能会收到错误的结果 |
| 746231 | 2569923 | 修复:如果作业将数据上传到 SQL Server 2008 或 SQL Server 2008 R2 中的 MDW 数据库,则上传数据收集器的作业会快速打开和关闭大量 SQL Server 端口 |
| 429231 | 2588050 | 修补程序:SQL Server 2008 Service Pack 的单流安装可能会失败 |
| 717065 | 2588453 | 修复:如果表的空间数据类型列上存在索引,则 DTA 针对 SQL Server 2008 中的表运行查询时发生访问冲突 |
| 644781 | 2589980 | 修复:在 SQL Server 2008 中运行使用 row_number 函数和并行执行计划的 SELECT 语句或 DML 语句时,出现错误结果或违反约束 |
| 420834 | 2590124 | 修复:安装 SQL Server 2008 时出现“ChainerInfrastructureException”错误 |
| 666690 | 969052 | 如何还原丢失的 Windows Installer 缓存文件并解决 SQL Server 更新期间发生的问题 |
| 406407 | 2591753 | 修复:更新可用于将服务帐户的 SPN 信息添加到 Reporting Services 日志文件中 |
SQL Server 2008 SP3 修复的其他问题
SQL Server 2008 SP3 还修复了以下问题。
| VSTS 错误号 | 说明 |
|---|---|
| 295196, 771825 | 如果在 SQL Server 2008 中启用了“收缩数据库”选项,则在创建维护计划时,可能会收到以下警告消息:“收缩数据文件会移动数据,并可能导致这些文件中的索引碎片。” |
| 295750 | 各种诊断工具错误地报告针对 SQL Server 2008 中的其他数据库执行的查询的主数据库。 |
| 337272 | 如果 0 NUMA 节点在 SQL Server 2008 中不包含任何处理器,则主体 Lazy Writer 不会启动。 |
| 444202 | 用户不能使用 SQL Server 2008 的 SSMS) 更改 SQL Server 2005 中的密码SQL Server Management Studio (。 |
| 447990 | 假设索引视图从基表和非基表中投影列,并假定非基表中的列与基表的列具有相同的顺序 ID 和类型。 在这种情况下,如果安装了 SQL Server 2008 SP3,则会发生错误而不是分区切换。 |
| 450529 | 假设你以非管理员身份打开 SSMS,然后尝试附加数据库。 在这种情况下,如果安装了 SQL Server 2008 SP3,你将收到“拒绝访问”错误,而不是异常。 |
| 507222 | 请考虑以下情形:
在这种情况下,你将在 SQL Server 2008 中收到“FullXactImpBase::GetXdes xact.cpp @ 2536 中的读取访问冲突”错误。 |
| 546001 | 修复此 bug 的问题会在为表值参数创建默认值时重置表值参数的名称。 安装 SQL Server 2008 SP3 后,TableVarElem 元素在从临时表缓存中检索默认值时始终具有正确的名称。 |
| 643903 | 执行跨数据库 DDL 操作时,可能不会生成数据库级事件的事件通知。 出现此问题是因为使用了不正确的对话框句柄。 |
| 650111 | 如果并行安装了代号为“Denali”的 SQL Server,则应用程序无法连接到 SQL Server 2008。 出现此问题的原因为 null 指针。 使用 null 指针时,将忽略计算机上安装的上层实例。 安装 SQL Server 2008 SP3 后,使用 SQL Server 2008 Configuration Manager 时不会使用 null 指针。 |
| 703968 | 安装 SQL Server 2008 SP3 后,查询优化器可以处理CRYPT_GEN_RANDOM列中相同输入值的不同输出值。 |
| 704992 | 基于 x64 的操作系统上的整体数据转换问题。 出现这些问题的原因是 BindParameter 方法和此方法使用的 LONG 数据类型参数。 |
| 707059 | 探查器可能不会同时显示 SQL Server 数据库引擎和 SQL Server Analysis Services 的所有事件和列。 安装 SQL Server 2008 SP3 后,将分别为 SQL Server 数据库引擎和 SQL Server Analysis Services 生成新的跟踪模板文件。 |
| 709063 | 运行 mdw_purge_data_[<your MDW database name>] 数据收集器作业以执行 DELETE 操作时,会出现性能缓慢问题。 如果 Microsoft SQL Server 2008 Management Data Warehouse (MDW) 的数据收集器在大规模 MDW 数据库上运行,则会出现此问题。 |
| 741462 | 从 DTExec.exe 运行时实用工具或 SQL 代理作业步骤运行 SSIS 包时,记录的输出中可能缺少某些输出日志记录事件。 输出中可能缺少 OnInformation、OnProgress、Diagnostic、OnPostExecute 和 PackageEnd 事件等事件。 输出中可能缺少常见到的信息性日志事件,例如 OnInformation:“OLE DB Destination” written ###### rows.“。 从 BIDS 环境调试 SSIS 包时的其他运行时实用程序(如 DTExecUI.exe 和 DtsDebugHost.exe ()) 不受此问题的影响。 |
| 755932 | LAG 和 LEAD 分析函数在程序包和部署向导 (PDW) 引擎中不起作用。 出现此问题的原因是 MemoXML 方案中的某些信息被删除。 |
| 771381 | 删除具有 FILESTREAM 文件组的数据库时分配的内存对象指针不正确。 |
| 540323 | 当应用程序尝试引发 9530 错误代码时发生访问冲突。 出现此问题的原因是使用了 NULL 指针。 |
| 778341 | SCOPE_IDENTITY () 函数可能返回不正确的值。 |
| 536835 | 在安装了 SQL Server 2000 Service Pack 3 (SP3) Online Analytical Processing (OLAP) 的计算机上安装 Microsoft SQL Server 2008 时,安装程序崩溃。 出现此问题的原因是 SQL Server 2000 SP3 OLAP 错误地将版本注册表项设置为 Service Pack 3.0。 |
| 544926 | 如果在尝试更改 SMO) 对象SQL Server DatabaseEncryptionKey (管理对象时不修改任何属性,则数据库 SMO 对象不会更新 DatabaseEncryptionKey 值。 |
| 729229 | 安装 SQL Server 2008 SP3 后,不会缓存枚举的结果,也不会将其存储在本地变量中来枚举资源。 此外,磁盘仅验证一次,结果将存储以供后续请求使用。 |
| 425485 | 安装 SQL Server 2008 SP3 后,将禁用运行安装方案的所有登陆页面链接。 |
| 700081 | 当应用程序查找比率计数器的基本计数器的名称时,应用程序必须执行一个在 SQL Server 2008 中不区分大小写的子字符串查找操作。 |
| 281309 | 对 sys.dm_exec_query_stats 表运行并行查询计划时 CPU 时间不正确。 |
| 356915 | 当异步读取操作的内部缓冲区将多字符列分隔符分成两部分时,会发生错误。 安装 SQL Server 2008 SP3 后,当前分析指针将在切换缓冲区后重置。 |
| 645220 | 在命令提示符处键入有效的 SQLAgent.exe 命令时,SQLAgent.exe 不会运行。 出现此问题的原因是共享内存的权限错误。 |
| 747046 | 安装 SQL Server 2008 SP3 后,如果数据库名称与当前数据库用户的名称相同,则不会创建数据库。 |
| 769191 | SQL Server 2008 SP3 在 Ntverp.h 文件中包含更新的VER_PRODUCTLEVEL_STR和VER_PRODUCTLEVEL_WSTR全局变量。 这些变量将更新到 SP3。 |
| 453592 | 如果用户在 Microsoft SQL Server 2008 Reporting Services Configuration Manager中为数据库服务器指定了端口,则该用户无法访问目录数据库。 |
| 773344 | 在俄语本地化版本的 Microsoft SQL Server 2008 Reporting Services Configuration Manager中,执行帐户信息包含截断字符串。 |
参考资料
有关如何确定当前 SQL Server 版本的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
321185
如何识别你的 SQL Server 版本
本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。