简介
本文列出了在 Microsoft SQL Server 2008 Service Pack 2 (SP2) 中修复的 bug。
便笺
- Service Pack 中可能包括未记录的其他修复程序。
- 当有更多文章发布时,该列表将会更新。
若要详细了解如何获取 SQL Server 2008 Service Pack,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
968382
如何获取最新的 SQL Server 2008 Service Pack
详细信息
除了本文列出的修补程序之外,SQL Server 2008 SP2 还包含 SQL Server 2008 Service Pack 1 (SP1) 的累积更新 1 到累积更新 8 中包含的修补程序。 有关可用于 SQL Server 2008 SP1 的累积更新包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
970365 在 SQL Server 2008 SP1 发布之后发布SQL Server 2008 内部版本
此 Service Pack 中修复的 Bug
有关 SQL Server 2008 SP2 中修复的 Bug 的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章。
| VSTS 错误号 | 知识库文章编号 | 说明 |
|---|---|---|
| 249682 | 2216454 | 修复:在运行 SQL Server 2008 的服务器上更改分区后运行 ProcessAdd 命令时出现错误消息:“内部错误:发生意外异常” |
| 256736 | 2322209 | 修复:如果在 SQL Server 2008 中具有公用表表达式的语句中使用括号将 SELECT 括起来,则会出现错误结果 |
| 258076 | 2216456 | 修复:SQL Server 2008 Service Pack 2 对 Analysis Services 中“操作已取消”错误消息文本的增强 |
| 270561 | 2216460 | 尝试在 SQL Server 2008 中打开项目时出现错误消息:“所找到的程序集的清单定义与程序集引用不匹配” |
| 274280 | 2216461 | SQL Server 2008 安装程序无法在基于 Windows Server 2008 的群集装载点上安装 |
| 284360 | 955850 | 尝试使用 SQL Server System CLR 类型包中的二进制文件时出现错误消息 (SQLSysClrTypes.msi) :“无法加载 DLL'SqlServerSpatial.dll':由于应用程序配置不正确,此应用程序无法启动” |
| 301603 | 2216465 | 如果 /PCUSOURCE 或 /CUSOURCE 的路径中有空格,则 SQL Server 2008 的滑流安装将失败 |
| 317800 | 2216472 | SQL Server 2008 或 SQL Server 2005 Analysis Services ROLAP 查询返回不正确的结果 |
| 340066 | 2216474 | 修复:将 UPDATE 语句与 SET 子句配合使用,该子句使用 SQL Server 2008 中的时间、datetime2 和 datetimeoffset 类型的话时,可能会遇到一些数据丢失问题 |
| 347731 | 2216478 | 在运行 SQL Server 2008 的服务器上的 PowerShell 版本 2 环境中运行 Get-Command 时出现错误消息:“对象引用未设置为对象实例” |
| 351286 | 2216480 | 修复:在运行 2008 SQL Server 的服务器上将报表导出到 Excel 时,边距不会保留在报表中,然后在 Excel 中预览报表 |
| 351981 | 2216484 | 修复:在运行 SQL Server 2008 的服务器上将报表导出到 Excel 时,出现错误消息:“未处理的托管异常: 类型 = System.ArgumentOutOfRangeException” |
| 357416 | 2216485 | 修复:资源监视器在 SQL Server 2008 服务器上进入非生成条件 |
| 390126 | 2216491 | SQL 转储工具无法在高级/企业故障转移群集安装的 SQL Server 2008 故障转移群集上生成错误转储文件 |
| 396527 | 980671 | 更正 SQL Server 上缺少加密盐变体的问题 sa 登录哈希 |
| 402453 | 2019402 | 将节点添加到 SQL Server 2008 故障转移群集时出现“未完成帐户名和安全 ID 之间的映射”错误 |
| 426753 | 2216499 | 无法将 SQL Server 2008 数据库实例注册到 SQL Server 实用工具中 |
| 426753 | 2253128 | 无法将 Data-Tier 应用程序部署到 SQL Server 2008 数据库实例 |
| 427703 | 2216501 | 修复:多服务器作业未从具有 MSX 角色的 SQL Server 2000 下载到具有 TSX 角色的 SQL Server 2008 |
| 524642 | 2283072 | 修复:修补程序可用,使 SQL Server 2008 R2 Reporting Services 能够使用 2048 位 RSA 密钥加密 Reporting Services 密钥,实现 FIPS 合规性 |
| 370540 | 2448971 | 修复:在 SQL Server 2008 中的表中插入多行时,表的锁定不会升级 |
此 Service Pack 中修复的其他问题
以下问题的解决方法也包括在 SQL Server 2008 SP2 中。
| VSTS 错误号 | 说明 |
|---|---|
| 270934 | 在 SQL Server 2008 排序规则期间,如果使用了带有日语延号的 Jamo 序列的字符串,则会发生 DBCC 损坏错误。 |
| 271554 | 修复:syscolpars 系统基表显示重复行。 此修补程序通过在 DBCC checkcatalog 中添加过程编号来区分它们。 |
| 271708 | 当查询具有引用 sys.dm_server_audit_status 视图中列的筛选器时,将忽略该筛选器,并且所有行都将从sys.dm_server_audit_status返回。 |
| 280004 | 与 dm_xe_map_values 中可用的信息相比,异步存储桶目标为映射字段显示不正确的值/字符串对。 |
| 284760 | 修复:“不匹配”视图可以包含具有不同索引数的多个视图。 此修复强制根据匹配的函数和匹配的索引数执行视图的确定性顺序进行比较。 |
| 285377 | 如果启用了 UAC,则用户在本地导航到报表管理器时会收到“拒绝访问”错误消息。 添加更新的“拒绝访问”消息以提及 UAC 可能允许用户相应地解决设置问题。 |
| 291707 | 在给定的数据库中,使用为包含任何系统视图的 select 语句声明的服务器光标可能会在连接和重新连接该数据库后给出不正确的结果。 |
| 293089 | 尝试使用“RateOfChange”或“Integral”作为仪表上 MaximumValue 或 MinimumValue 的公式类型的径向仪表用户在属性网格下拉列表中看不到值。 |
| 296314 | 修复:FailoverAnalysis.sql文件是在 SQL Server 故障转移群集设置期间安装的。 发生故障时,将自动调用此脚本。 SqlDMVScriptTimeout 专用属性控制脚本完成所需的毫秒数。 |
| 302563 | 用户在升级名称中有空格的共享数据源时收到验证错误。 该错误指示名称不能包含空格。 |
| 302707 | Service Pack 1 for SQL Server Business Intelligence Development Studio 2008 的安装因为缺少配置文件而失败。 |
| 304390 | 当环缓冲区达到 XML 输出的大小限制时,它会显示不完整的事件数据 (来自 dm_xe_session_targets) 的事件输出。 |
| 307313 | 用户无法在其 HTTP 模块中返回多个 Cookie。 这会影响用户尝试实现自定义身份验证。 |
| 309869 | sqlsos.task_address、sqlsos.worker_address和 sqlsos.scheduler_address 扩展事件操作显示的地址不正确。 |
| 310483 | Reporting Services 2008 Designer 在 Tablix 中将厘米转换为英寸。 这会导致布局精度损失。 |
| 313780 | 卸载两个 AS 命名实例中的第一个会禁用 SQL 浏览器。 这将导致第二个命名实例无法访问。 |
| 319216 | 如果需要智能卡,则用户不能在其数据源中使用存储的凭据。 |
| 322046 | 如果查询具有子选择子句,该子句使用不返回任何计算成员的集合表达式,则返回一个错误,指出不允许具有计算成员的子选择。 |
| 327301 | 在 Analysis Services 中,使用具有 NonEmpty 函数的 MDX 表达式设置维度默认成员会导致服务器在尝试打开多维数据集时返回内部错误。 |
| 328752 | “sys.dm_os_wait_stats”视图显示“杂项等待”类型的重复行。 这可能会导致监视工具出现问题。 |
| 331630 | 整数值在 SQL Server Reporting Services 可重用查询Designer中被错误地舍入。 |
| 333544 | 修复:当用户尝试注册针对较新的运行时(如 CLR v4)构建的 CLR 程序集时,将返回新的错误代码 (6257) 。 之前的错误消息 (代码 6218) 令人困惑,并且没有说明实际问题。 |
| 336809 | 边缘事例在“设置identity_insert TABLE_NAME打开”模式下插入当前范围之外的标识值。 备份/还原操作中也会出现此问题。 |
| 338247 | 如果由 SQLBindParameter 函数绑定的参数指定长度为 SQL_DATA_AT_EXEC,则当提供参数值以供执行时,SQLPutData 函数指定长度为 SQL_NULL_DATA 时,SQL Server 2008 Native Client ODBC 驱动程序将导致访问冲突。 |
| 338999 | 当用户使用 SOAP 接口运行和导出报表时,SQL Server Reporting Services 2008 遇到连接泄漏。 |
| 347779 | SQL Server 有时会生成“资源池'internal'中的系统内存不足,无法运行此查询”错误消息。 这种情况通常是可以预防的。 |
| 350670 | 当用户尝试引用呈现的报表在报表空闲一小时后,他们会收到“页面已过期”错误消息。 |
| 352788 | 如果用户尝试配置 Management Data Warehouse,如果其服务器上的数据库不在线,则会出现错误 955。 |
| 352862 | ReportBuilder 2.0 如果用户使用 SharePoint 12 网站中的 ReportBuilder 2.0 编辑报表,ClickOnce 在启动时显示空白报表。 |
| 355222 | 如果使用 MARS,则sys.dm_os_tasks视图在 request_id 列中显示所有任务的相同值,而不是报告与每个任务关联的正确值。 |
| 355228 | 修复:如果桶化器目标参数设置不正确,将出现新的错误消息,指示导致访问冲突的原因。 |
| 356127 | BCP.exe 检索列元数据信息时,返回的列排序规则信息不正确。 |
| 360584 | 在尝试通过电子邮件传递 MHTML 呈现的报表期间,由于内存中数据结构问题,订阅在执行期间失败。 |
| 368388 | BIDS 2008 报表设计器与 SQL Server Reporting Services 2008 一起运行会在用户调整表行大小时崩溃。 |
| 376257 | 在用户取消或关闭“计划详细信息”对话框以返回到“报表传递选项”后,将清除“报表传递选项”对话框的“收件人”、“抄送”和“密件抄送”字段。 |
| 383747 | 如果 SQL 实例名称与虚拟网络名称相同,则集合集在群集上收集性能计数器时无法正常工作。 |
| 384800 | 修复:改进了在参数处理过程中出现某些情况时,详细输出中 InvalidReportParameterException 记录的其他信息。 |
| 393410 | 当用户清除每月计划中一个或多个月份的选择时,SSRS 将为仍处于选中的每个月创建单独的计划。 在某些情况下,这可能会导致“@active_end_date不能在之前 @active\_start\_date”错误。 |
| 393879 | 如果在映射到接受 NULL 值的报表参数(该参数接受 NULL 值)时返回 NULL 值,则 Data-Driven 订阅失败。 |
| 394977 | 订阅和交付问题很难在 Reporting Services 跟踪文件中诊断。 需要更详细的日志记录。 |
| 415084 | 用户收到“索引超出范围。 必须为非负数且小于集合大小“导出到 PDF 时出现错误消息。 |
| 419740 | 用户无法在 SQL Server 2008 Web SKU 中使用自定义身份验证。 |
| 424595 | 如果用户在同一事务中创建了用户定义的类型和表值函数,并且该函数的返回表包含用户定义类型的列,则会发生自死锁。 此外,尝试执行这些操作的连接将终止。 |
| 421922 | 修复:在 Microsoft SQL Server 2008 SP2 的企业版、开发人员版和评估版中,最多支持 15,000 个表和索引中的分区。 有关如何启用和禁用此支持、其限制以及一些已知问题和解决方法的详细信息,请参阅“支持 15,000 个分区”白皮书 (http://go.microsoft.com/fwlink/?LinkId=199773) 。 |
| 424804 | 在 Analysis Services 中,某些客户在 IIF 函数条件下使用父子层次结构时可能会遇到访问冲突。 |
| 426631 | 使用具有 Null 成员参数的 PeriodsToDate 函数可能会导致“意外异常”错误。 |
| 429253 | SQL Server Management Studio 和 SQL Server Reporting Services 中显示的版本号不正确。 这会导致混淆,因为在执行升级后,显示的编号与 RTM 版本号没有变化。 |
| 430703 | 当 Analysis Services 生成一个 Watson 转储时,可能会出现第二个异常。 无论 Watson 转储是由于实际异常还是由于显式请求在某些错误时转储而生成,都是如此。 如果发生次要异常,服务器可能会经历无限递归。 这将生成许多转储,然后关闭服务器。 |
| 431298 | 修复:在 SSRS 2008 Service Pack 2 中,更新了用于与 SSRS 2008 R2 报表服务器通信的 SharePoint 2007 的 RS 加载项。 这样就可以访问 ReportBuilder 3.0、ReportPart 和 ATOM Renderer 中的某些功能,包括 ReportBuilder 3.0 中新的报表预览。 |
| 431301 | 处理包含数千个元数据对象的数据库中的对象需要很长时间才能开始导入数据。 发生这种情况是因为服务器必须在数据导入开始之前生成作业计划。 此外,当数据库中存在许多元数据对象时,用于确定依赖关系的算法会导致性能下降。 |
| 432094 | 无法在使用 CELL_ID、CELL_ATTRIBUTES 或 SRID 作为列名的表中安全地创建空间索引。 |
| 448007 | 在某些情况下,错误消息 11405 中的分区列名称可能错误。 这会导致打印不正确的列名。 |
| 455538 | 使用 NON EMPTY 子句时,将单元格安全性与计算结合使用会产生错误的结果。 |
| 456534 | 如果两个事务同时运行:一个用于修改或创建分区,另一个用于处理维度,则在提交过程中会发生读取访问冲突。 |
| 471363 | 当 Microsoft Office 12 与 SQL Server 2008 Reporting Services 集成时,SharePoint 集成不会默认为 Report Builder clickonce URL,从而阻止 Report Builder 启动。 |
| 471421 | 修复:土耳其语 SKU 中的本地化问题:面包屑现已在新的 reportpart 库页面上本地化。 |
| 499162 | 修复:由于 MSAA 名称“Symbol”为空而发生的辅助功能问题。 MSAA 名称已更新,现在可发现。 |
| 503096 | 修复: 改进了通过 DDL 语句对具有多个分区且不包含数据的表创建索引的性能。 以前,随着分区数量的增加,此过程所需的时间以几何级数增加。 现在所需的时间将呈线性递进方式增加。 |
| 515240 | 对 LOB 列使用表值参数可能会导致服务器上的访问冲突。 |
| 520700 | 径向刻度属性对话框的 MSAA 名称不正确,不符合辅助功能要求。 |
| 525601 | 在检查粒度审核期间,用于列出包含该事件的任何审核的算法可能会遇到审核列表的内存泄漏。 这种情况一直持续到出现内存不足错误,并且必须重新启动服务才能回收内存。 |
注意 如果要从 SQL Server 2008 SP1累积更新 9 或更高版本升级,则必须在升级到 SQL Server 2008 SP2 后应用 SQL Server 2008 SP2 之后的累积更新,以获取所有修补程序。
有关 SQL Server 2008 SP2 之后的累积更新的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2289254 SQL Server 2008 Service Pack 2 的累积更新程序包 1
参考资料
有关如何确定当前 SQL Server 版本的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
321185
如何识别你的 SQL Server 版本
本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。