KB3058865 - SQL Server 2014 Service Pack 1 版本信息

应用对象
SQL Server 2014 Developer SQL Server 2014 Enterprise SQL Server 2014 Express SQL Server 2014 Standard SQL Server 2014 Web SQL Server 2014 Business Intelligence

本文包含在安装 Microsoft SQL Server 2014 Service Pack 1 (SP1) 之前需要阅读的重要信息。 它介绍如何获取 Service Pack、Service Pack 中包含的修复程序列表、如何根据当前安装的版本选择正确的下载,以及产品的版权归属列表。

注意 本文是查找与此 Service Pack 相关的所有文档的单一信息来源。 它包括您先前在发行说明和 Readme.txt 文件中找到的所有信息。

注意 如果您尝试将实例从 SQL Server 2014 的累积更新 11 更新 (内部版本号 12.0.2560.0) SQL Server Service Pack 1,Service Pack 安装程序会由于 SQLServr.exe 文件和 qds.dll 文件之间的二进制文件不匹配而失败,之后无法启动SQL Server。

要解决此问题,请使用下列方法:

    

详细信息

如何获取 SQL Server 2014 SP1

可从 SQL Server 2014 SP1 下载页下载 SQL Server 2014 SP1。 可在此处下载 SQL Server 2014 SP1 功能包。

注意 安装 Service Pack 后,SQL Server 服务版本应反映为 12.0.4100.1。

SQL Server 2014 SP1 中包含的修补程序列表

Microsoft SQL Server 2014 服务包是累积更新。 SQL Server 2014 SP1 将 SQL Server 2014 的所有版本和服务级别升级到 SQL Server 2014 SP1。

除了本文列出的修补程序之外,SQL Server 2014 SP1 还包括 SQL Server 2014 CU1 到 SQL Server 2014 CU 5 中包含的修补程序。

有关 SQL Server 2014 中提供的累积更新的详细信息,请参阅 SQL Server 2014 内部版本。

便笺

  • 此处未记录的其他修复也可能包含在 Service Pack 中。
  • 当有更多文章发布时,该列表将会更新。

有关 SQL Server 2014 SP1 中修复的 Bug 的更多信息,请单击以下链接,以查看 Microsoft 知识库中相应的文章。

VSTS 错误号 知识库文章编号 说明
2275929 3044954 修复:在 SQL Server 2014 中启用自动关闭时,I/O 完成例程上发生访问冲突
2364636 2969781 修复:在 SSIS 2014 Designer 中添加自定义连接管理器时出错
2580631 2963404 修复:回退导致数据库在 SQL Server 2012 或 SQL Server 2014 中进入可疑模式
2580750 2806979 修复:在 SQL Server 2012 或 2014 中对启用了 RCSI 的数据库中的表运行查询时性能不佳
2580628 2965035 SQL Server 2012 Service Pack 2 中的 SSAS 2012 日志记录功能改进
2581015 2963412 SQL Server 2012 SP2 和 SQL Server 2014 SP1 中的新 DMF sys.dm_fts_index_keywords_position_by_document
2581019 2966520 修复:1 月 1 日在 SSRS 中重新启动 Reporting Services Windows 服务时,不会创建新的日志文件
2581025 3051521 修复:模型数据库的尾部日志备份后重启 SQL Server 时出现“无法打开数据库'模型'”错误
2581225 2964762 修复:在 SSAS 2012 中使用 Discover 命令时,将记录事件 ID 22 或错误 0xC1000016
2581168 2966522 修复:文件共享订阅不填充 SSRS 2012 或 SSRS 2014 中的说明列
2581259 2966523 修复:在 SSRS 2012 或 SSRS 2014 中指定报告时,“名称”下拉列表为空
2581317 2963382 修复:在 SSAS 2012 或 SSAS 2014 中运行多维数据集创建 MDX 查询时无法连接到服务器
2581323 2963384 修复:在 SQL Server 2012 或 SQL Server 2014 中,tempdb 数据库的日志文件已满时SQL Server崩溃
2581360 2927741 修复:对 SSRS 2012 或 2014 报表使用钻取操作时,图像未在网页中正确显示
2581371 2963383 修复:在 SSRS 2012 或 SSRS 2014 中使用 HPB 呈现器查看报表时截断文本
2700155 3044958 修复:运行 DBCC CHECKDB 后 SQL Server 意外关闭时,快照上的回滚恢复失败
3860819 3030619 修复:在 SQL Server 2014 中的查询中使用 DATE 数据类型作为限定符时,返回的数据不正确
3879685 3020112 修复:在 SQL Server 2014 中执行 DML 语句时发生非生成错误
3919713 3027860 SQL Server 启动期间出现错误 17066 或 17310
3933346 3044953 修复:在 SQL Server 2014 中将页面写入缓冲池扩展文件时出现非生成计划程序问题
4011750 3029977 修复:在 SQL Server 2014 中对包含列存储索引的数据库执行 DBCC CHECKDB 命令时出现操作系统错误 665
4033440 3021757 修复:与函数的 NEXT VALUE FOR 并行运行 sp_sequence_get_range 时会生成重复的序列值
4034813 3029825 修复:当 SQL Server 2012 或 SQL Server 2014 中涉及 SQL CLR UDT 时,DBCC CHECKDB 和 SQL Server CHECKTABLE 需要更长的时间才能运行 SQL Server
4050109 3026082 修复:系统表行集缓存上的SOS_CACHESTORE旋转锁争用导致 SQL Server 2012 或 2014 中的 CPU 使用率过高
4075490 3034679 修复:AlwaysOn 可用性组报告为未同步
4093558 3035165 修复:在 SQL Server 2014 中对具有聚集列存储索引的表运行 DML 语句时出现错误 8646
3534419, 3534439, 2512250, 1456033, 2274636 3044952 修复:在 SQL Server 2014 中启用缓冲池扩展功能时出现的问题
3731772, 3731776 3044519 修复:在 SQL Server 2014 中启用新基数估计器时出现查询性能问题
2581312 2904152 修复:在已发布的 SSRS 2014 服务应用程序集成的 SharePoint 中不起作用使用远程场上的报告

其他解决方案

以下问题的解决方法也包括在 SQL Server 2014 SP1 中。

VSTS 错误号 说明
1957464 RESTORE HEADER仅用于数据库的加密备份文件,不显示备份是否加密。
应用 SP1 后,RESTORE HEADONLY 的输出将包括三个附加列:KeyAlgorithm、EncryptorThumbprint 和 EncryptorType,它们可提供有关加密备份的其他详细信息。 有关详细信息,请参阅 SQL Server 联机丛书中的 RESTORE HEADERONLY 主题。
2366022 安装仅在 Windows 8 上安装 2014 Express Edition SQL Server (2014 Express Edition ) 时,SQL Server安装程序需要 .NET Framework 3.5。 现在安装此类媒体时会跳过它。
2535853 安装 SQL Server 2014 RTM 的 Express 程序包时,/qs 选项需要用户输入。
2580641 删除发布在以下位置的文章时,存储过程中的查询语法无效
多个出版物。
2580651 对等 (P2P) 冲突消息需要更多详细信息。

注意 应用 SP2 for 2012 或 SP1 for 2014 后,错误消息 22815 将包含有关表名、主键 () 、当前版本、前版本和后版本的信息。 除了表名和主键 () 之外,Post 版本可用于所有三种类型的冲突, (删除、更新和插入) 。 当前版本不适用于删除冲突类型,PreVersion 不适用于插入冲突类型的存在。
2580686 使用 UPDATE 或 WRITE 对文本列进行更新时,Update-Update P2P 复制中的冲突。
2580693 使用块模式一元运算符时出现错误结果。
2580746 DPM 在服务器上具有 AlwaysOn 辅助数据库的完整备份将转换为 copy_only 备份
2581191 合并复制日志记录改进:
为了帮助解决合并复制性能问题,请在合并代理的输出详细级别设置为 4 时添加 TraceFlag 101 的输出。
2581192 事务复制日志记录改进:
若要帮助解决事务复制性能问题,请向历史记录表中的统计信息添加详细消息,并在代理日志中添加更详细的消息。
2581222 如果维护计划名称和第一个SUB_PLAN名称相同,则 SSMS 在移动维护计划任务期间崩溃。
2581197 结束 SCOPE 语句与开始的 SCOPE 语句不匹配。
2581377 当使用无效的 InstanceId 分析 SSRS 配置文件时,出现“ACTIONABLE_HEAP_CORRUPTION”。
2581382 在 SSRS 2014 的日志中提供平台信息
2733205 在对象资源管理器中从 Report Server 实例的上下文菜单中选择 Facets 选项时出现“找不到操作 <名称> ”消息
2841734 执行 SQL Server 2014 累积更新包时发生异常 (SQLServer2014-KB2967546-x64.exe) 例如,使用命令行开关 /?
3143194 在执行具有聚集列存储索引的查询期间,当“SET STATISTICS IO”处于打开状态时,LOB 读取显示为零。
3506361 当 SSDT BI 版本 12.0.2299.1 和 SQL Server 2014 并行安装时,无法修补某些共享组件以用于以后的服务。
3731350 例如,在具有多个套接字的系统上使用依赖于日志池缓存 (的功能时,Always On) 可能会注意到“日志写入等待”计数器的高值。 在 SP1 之前,必须启用跟踪标志 T9024 才能激活 SQL Server 2014 中此问题的修补程序。 从 SP1 开始,您不必手动添加跟踪标志,因为已经包括修补程序。 有关详细信息,请参阅修复:SQL Server 2012 实例上“日志写入等待”计数器值过高。
3732057 当 SQL Server 实例由于连接池而处理数千次连接重置时,当 SQL Server 中的数据库锁定活动增加时,就会出现性能问题。 此问题已在 SQL Server 2014 的 CU1 中修复,必须添加跟踪标志 T1236 来启动参数才能激活修补程序。 SQL Server 2014 Service Pack 1 默认包含此修补程序,你无需添加任何跟踪标志即可激活该修补程序。 有关详细信息,请参阅修复:当 SQL Server 中的数据库锁定活动增加时出现性能问题。
3909490 启用用于批量加载的快速加载上下文 (TF610) 和 TF4199 时,对于数据库架构和数据的某种组合会出现错误 4819。
3938420 无法将 SQL Server 实例升级到 SQL Server 2014,因为缺少 SQL Server 代理 JOBS 目录,并且系统处于不完整状态。

针对连接物品的修补程序

以下连接项修补程序由社区提交,也包含在 SQL Server 2014 SP1 中。

连接 Bug ID 说明
714689 当您针对多个服务器实施企业管理框架,并且针对列表中的一个服务器发生错误时,评估结果会多次写入输出 xml 文件。
735543 当数据库的备份在同一实例上还原为不同的数据库时,数据库将进入还原模式。
736509 无法调试调用 SSMS) 中sp_executesql SQL Server Management Studio (存储过程。 按 F11 时,会收到“对象引用未设置为对象实例”错误消息。
740181 SSMS 不能完全管理 SQL Server Express 中的 Full-Text。
745566 SQL Server SMO 忽略 SQL Server 2012 和 SQL Server 2014 中的默认约束。
764197 SSMS 处理编号存储过程不一致。
769121 “列'<列名称>'不属于表摘要。 复制具有相同名称但位于不同架构中的表时,出现 (System.Data) “错误消息。
773710 还原到包含全文索引的数据库快照后,除非重新启动SQL Server、分离然后附加数据库,或者使数据库脱机后再使数据库联机,否则无法创建任何ft_catalogs。
774317 SSMS 偶尔会在关闭时崩溃,从而导致其自动重启
785064 在 Business Intelligence Development Studio (BIDS) 中使用客户管道组件时出现“'null' 的值对'stream' 无效”错误消息。
785151 在启用“显示实际查询计划”执行查询时,将返回 Null 的结果,并收到以下错误消息:
错误:消息 50000,级别 16,状态 10,过程测试,第 34 行字符串或二进制数据将被截断。
791929 将数据插入到具有触发器的分区视图时出现“系统断言检查失败”错误消息。
797967 创建脚本在 SSMS 中编写列级权限脚本时会复制语句。
799430 尝试刷新任务栏上的 SSMS 窗口图标时,SSMS 可能会崩溃。
804901 在部署到 SSIS 目录数据库 (SSISDB) 期间,部署新版本的大型项目会遇到超时。 此外,你还会收到以下错误消息:
无法部署项目。 有关详细信息,请查询operation_messages视图以获取操作标识符“219”。 (Microsoft SQL Server,错误:27203) 无法部署项目。 修复问题,稍后重试。:Timeout expired. 操作完成前超时时间已过,或服务器没有响应。 该声明已终止。
805659 “SQL 语句的某些部分嵌套得太深。 解析或执行存储过程时出现重写查询或将其拆分为更小的查询“错误消息。

选择要下载的正确文件并进行安装

SQL Server 2014 SP1 下载页包含安装 SQL Server 2014 SP1 的系统要求和基本安装说明。 有关如何使用 SQL Server 2014 服务更新升级已安装的 SQL Server 2014 SP1 组件的其他文档,请参阅“安装 SQL Server 2014 服务汇报”。

使用下表根据当前安装的版本标识要下载的文件的位置和名称。 下载页提供系统要求和基本安装说明。

您当前安装的版本 要采取的操作 要下载和安装的文件
任何版本的 SQL Server 2014 的 32 位版本 升级到 32 位版本的 SQL Server 2014 SP1 从此处 SQLServer2014SP1-KB3018269-x86-ENU.exe
32 位版本的 SQL Server 2014 RTM Express 升级到 32 位版本的 SQL Server 2014 Express SP1 从此处 SQLServer2014SP1-KB3018269-x86-ENU.exe
仅适用于 SQL Server 2014 ((包括 SQL Server 2014 Management Studio) )的客户端和可管理性工具的 32 位版本 将客户端和可管理性工具升级到 32 位版本的 SQL Server 2014 SP1 SQLManagementStudio_x86_ENU.exe(位于这里)
32 位版本的 SQL Server 2014 Management Studio Express 升级到 32 位版本的 SQL Server 2014 SP1 Management Studio Express SQLManagementStudio_x86_ENU.exe(位于这里)
任何版本的 32 位版本的 SQL Server 2014 以及 32 位版本的客户端和可管理性工具 (包括 SQL Server 2014 RTM Management Studio) 将所有产品升级到 32 位版本的 SQL Server 2014 SP1 从此处 SQLServer2014SP1-KB3018269-x86-ENU.exe
Microsoft SQL Server 2014 RTM 功能包中一个或多个工具的 32 位版本 将工具升级到 32 位版本的 Microsoft SQL Server 2014 SP1 功能包 Microsoft SQL Server 2014 SP1 功能包中的一个或多个文件
没有安装 32 位 SQL Server 2014 Management Studio 安装 32 位 SQL Server 2014 Management Studio(包括 SP1) SQLManagementStudio_x86_ENU.exe(位于这里)
没有 32 位版本的 SQL Server 2014 RTM Express 安装 32 位 SQL Server 2014 Express(包括 SP1) SQLEXPR32_x86_ENU.exe(位于这里)
任何版本的 SQL Server 2014 的 64 位版本 升级到 64 位版本的 SQL Server 2014 SP1 从此处 SQLServer2014SP1-KB3018269-x64-ENU.exe
64 位版本的 SQL Server 2014 RTM Express 升级到 64 位版本的 SQL Server 2014 SP1 从此处 SQLServer2014SP1-KB3018269-x64-ENU.exe
仅 SQL Server 2014 客户端和可管理性工具的 64 位版本(包括 SQL Server 2014 Management Studio) 将客户端和可管理性工具升级到 64 位版本的 SQL Server 2014 SP1 SQLManagementStudio_x64_ENU.exe(位于这里)
64 位版本的 SQL Server 2014 Management Studio Express 升级到 64 位版本的 SQL Server 2014 SP1 Management Studio Express SQLManagementStudio_x64_ENU.exe(位于这里)
任何 SQL Server 2014 版本的 64 位版本以及客户端和可管理性工具的 64 位版本(包括 SQL Server 2014 RTM Management Studio) 将所有产品升级到 64 位版本的 SQL Server 2014 SP1 从此处 SQLServer2014SP1-KB3018269-x64-ENU.exe
Microsoft SQL Server 2014 RTM 功能包中一个或多个工具的 64 位版本 将工具升级到 64 位版本的 Microsoft SQL Server 2014 SP1 功能包 Microsoft SQL Server 2014 SP1 功能包中的一个或多个文件
没有安装 64 位 SQL Server 2014 Management Studio 安装 64 位 SQL Server 2014 Management Studio(包括 SP1) SQLManagementStudio_x64_ENU.exe(位于这里)
64 位版本的 SQL Server 2014 RTM Express 安装 64 位 SQL Server 2014 Express(包括 SP1) SQLEXPR_x64_ENU.exe(位于这里)

有关如何将 SQL Server 安装升级到 SQL Server 2014 SP1 的详细信息,请参阅支持的版本和版本升级。

注意 如果 (KB3018269) 安装了 SQL Server 2014 Service SP1 的版本 12.0.4050.0,则必须在安装此更新之前从所有安装实例中卸载该更新。 为此,请使用控制面板中的“添加或删除程序”。 有关更多信息,请参阅 KB 3018269 。 请注意,您可能由于以下任何原因而安装了 KB3018269:

  • 您已将更新应用于 SQL Server 2014 的现有实例
  • 您使用KB3018269“Slipstream Package” (安装了 SQL Server 2014 SP1 的新实例,例如 SQLServer2014SP1-FullSlipstream-x64-ENU)
  • 已安装任何 SQL Server 2014 SP1 Express Edition 程序包
  • 此产品包含从 Xerox 安全哈希函数派生的软件。

  • 此产品包含 zlib 通用压缩库中的软件。

  • 此软件的部分内容基于 RSA Data Security, Inc. 的工作。因为 Microsoft 已在此产品中包含 RSA Data Security, Inc., 软件,所以 Microsoft 必须包含此类软件附带的下列文本:

    • 版权所有 1990,RSA Data Security, Inc. 保留所有权利。
    • 如果本软件在提及或引用本软件或本功能的所有材料中被标识为“RSA Data Security, Inc., MD5 消息摘要算法”,则授予复制和使用本软件的许可。 如果这些作品在所有提及或引用衍生作品的材料中被标识为“源自 RSA Data Security, Inc., MD5 消息摘要算法”,则还授予制作和使用衍生作品的许可。
    • RSA Data Security, Inc. 对本软件的适销性或本软件对任何特定用途的适用性不作任何声明。 其按原样提供,不包含任何明示或默示保证。

    这些通知必须保存在本文档或软件的任何部分的任何副本中。

  • Reporting Services 映射功能使用 TIGER/Line Shapefiles 中提供的数据,这些数据是由美国统计局提供 (http://www.census.gov/) 。 Tiger/Line Shapefiles 是从 Census MAF/TIGER 数据库中提取的选定地理和地图信息。 TIGER/Line Shapefiles 可从美国统计局免费查询。 要获取有关 TIGER/Line shapefiles 的更多信息,请转到 http://www.census.gov/geo/www/tiger。 TIGER/Line Shapefiles 中的边界信息仅用于统计数据收集和制表目的;其用于统计目的的描述和指定不构成对管辖权、所有权或权利的确定,也不反映合法的土地描述。 Census TIGER 和 TIGER/Line 是美国人口普查局的注册商标。

版权所有 2012 Microsoft。 保留所有权利。

参考资料

有关如何确定当前 SQL Server 版本的更多信息,请单击下面的文章编号,以转到 Microsoft 知识库中相应的文章:

321185
  如何识别你的 SQL Server 版本
 本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。