发布日期: 2016 年 11 月 16 日
版本: 13.0.4001.0
本文包含在安装 Microsoft SQL Server 2016 Service Pack 1 (SP1) 之前需要阅读的重要信息。 本文介绍如何获取服务包、服务包中包含的修补程序列表、已知问题以及产品的版权属性列表。
注意
本文作为查找与此 Service Pack 相关的所有文档的单一信息来源。 它包括您先前在发行说明和 Readme.txt 文件中找到的所有信息。
此 Service Pack 中的已知问题
SQL Server Reporting Services
安装 SQL Server 2016 SP1 后,在使用 SQL Server Reporting Services 时可能会遇到以下问题:
如果Reporting Services设置为使用安全 (https/SSL) 连接,则可能会显示有关安全内容的警告。
在某些情况下,“打印”按钮会停止工作。
安装 KB 3207512 中的修补程序来解决这些问题。
SQL Server Integration Services (SSIS)
安装 SQL Server 2016 SP1 后,启动和访问 Integration Services 服务的 DCOM 权限将重置为默认权限。 如果你具有自定义的 DCOM 权限,则需要重新应用自定义项。
ODBC 驱动程序 13.1
默认安装 SQL Server 2016 时,ODBC 驱动程序 13.0 安装在 SQL 代理使用的服务器上,SSMS (安装在服务器) 连接到 SQL Server 实例。 如果你出于任何原因在服务器上安装了 ODBC 驱动程序 13.1,SQL Server 2016 SP1 安装将覆盖 ODBC 驱动程序 13.1 安装,并且 13.1 中引入的修补程序(如 KB 3185365)可能会丢失。 在这种情况下,在安装 SQL Server 2016 SP1 后,建议卸载 SQL Server 2016 SP1 安装的 ODBC 驱动程序并安装 ODBC 驱动程序 13.1。
要检查服务器上是否安装了 ODBC 驱动程序,您可以转到服务器的控制面板 - 程序和功能 ->> 搜索 ODBC。 ODBC 驱动程序 13.1 的版本号为 13.1.811.168,如下所示:
SQL Server 2016 SP1 中包含的修补程序列表
Microsoft SQL Server 2016 服务包是累积更新。 SQL Server 2016 SP1 将 SQL Server 2016 的所有版本和服务级别升级到 SQL Server 2016 SP1。 除了本文列出的修补程序之外,SQL Server 2016 SP1 还包括 SQL Server 2016 累积更新 1 (CU1) SQL Server 2016 CU3 中包含的修补程序。
有关 SQL Server 2016 中提供的累积更新的详细信息,请参阅 SQL Server 2016 内部版本。
注意
- 此处未记录的其他修补程序也可能包含在服务包中。
- 当有更多文章发布时,该列表将会更新。
有关 SQL Server 2016 SP1 中修复的 Bug 的更多信息,请转到以下 Microsoft 知识库文章。
其他解决方案
以下问题的解决方法也包括在 SQL Server 2016 SP1 中。
| Bug 参考 | 说明 | 修复区域 |
|---|---|---|
| 68674998024974 | 将列的数据类型从 text 更改为 varchar (max) 时,将忽略 NULL 值。 | 引擎 |
| 8024962 | 如果查询文本同时包含嵌入注释和大括号("{"或 ."}") |
引擎 |
| 8024968 | 批处理排序和优化嵌套循环可能会导致稳定性和性能问题。 | 引擎 |
| 8024987 | 使用下推谓词的表扫描和索引扫描往往会高估父运算符的内存授予。 | 引擎 |
| 8024997 | 对于荷兰语,Full-Text 搜索功能无法按预期工作。 | 引擎 |
| 8025069 |
CREATE NONCLUSTERED INDEX如果数据库名称以 '#' 字符开头,则语句可能会失败。 |
引擎 |
| 8025097 | 在 SQL Server 错误日志中添加配置信息tempdb消息。 |
引擎 |
| 8267453 |
MERGE 如果目标表包含唯一索引,则同时 UPDATE 包含 AND INSERT 语句的语句将失败,并显示“无法插入重复键行”。 |
引擎 |
| 8279683 | 当元组移动器任务意外终止时,SQL Server 崩溃。 | 引擎 |
| 8025058 | 在表 (SQL Server 复制) 中msdistribution_history添加错误 20598 的表名和主键值信息。 |
改进 |
| 8025059 | 当复制代理因查询超时而失败时,将记录查询文本,但不启用详细日志记录。 | 复制 |
| 8025081 | 当目标表为空字符串时,复制日志读取器代理可能会失败。 | 复制 |
| 4300066 | 在 SQL Server 命令提示符安装中将版权信息更新为“© 2016 Microsoft”。 | 设置 |
| 5610151 | 当 slipstream 使用命令行选项安装 SQL Server 时,命令行输出中会返回不必要的警告消息。 | 设置 |
| 7270486 | 删除 SQL Server 的一个或多个更新后,修复 SQL Server 时,修复操作失败并出现错误。 | 设置 |
| 7350315 | 在具有非英语域名的计算机上安装 SQL Server 将失败,并出现错误“路径中的非法字符”。 | 设置 |
| 7439317 | “已安装的 SQL Server 功能发现报告”中的字符串“安装程序发现报告”未本地化。 | 设置 |
| 7439502 | SQL Server 2016 安装向导错误地提及了 SQL Server 2008 SP3,而 SQL 2008 R2 SP3 是必需的。 | 设置 |
| 8024994 | 在“完成”选项卡上,在支流安装中的“文档和链接”部分中缺少指向“外围区域配置”MSDN 文档的链接。 | 设置 |
| 8051010 | 如果在安装过程中安装了适用于 SQL Server 的 ODBC 驱动程序 11,则 SQL Server 2016 的安装可能会失败。 | 设置 |
| 8343905 | 支流安装可能会失败,并出现“强名称验证失败”错误。 | 设置 |
| 8348718 | 如果设置为False在支流安装中,则UpdateEnabled安装摘要日志不包含安装期间安装的更新的信息。 |
设置 |
| 8024972 | 将日期格式 YYYY/MM/DD 解析为 DATE 列时,BCP 失败并显示错误。 |
SQL 连接 |
| 5128484 | Standard版本的 SQL Server 2016 Analysis Services (表格模式) 忽略 16 GB 内存限制。 | SSAS |
| 7487320 | 即使 DataView 设置为 Sample,包含 Row-Level 安全性 (RLS) 的查询也可能会失败。 | SSAS |
| 8210484 | 关联掩码无法为 SQL Server 2016 Analysis Services 中的 NUMA 节点正常工作。 | SSAS |
| 8281121 | 通过在 SSAS 表格格式模式下实现 NUMA 感知,提高 SSAS 表格性能的可伸缩性。 | SSAS |
| 8430619 | 通过使用 Intel® 线程构建基块 (Intel® TBB) ,提高 SSAS 表格性能的可伸缩性。 | SSAS |
| 8024998 | 在已有日志的 SSIS 包中打开“配置 SSIS 日志:包”对话框时,出现错误“未安装日志提供程序 'Microsoft.LogProviderEventLog'”。 | SSIS |
| 8025032 | 此更新更改了以下行为:当 XML 任务无法从 XML 文档中获取编码时,将使用 Unicode 编码。 | SSIS |
| 7330691 | 向 SSRS 报表服务器执行日志添加其他信息以指示报表是否为移动报表。 | SSRS |
| 7807395 | 如果在启用了 Stretch Database 的表上进行数据核对失败,您可能需要重试重新授权。 | 弹性 DB |
| 8196154 | 在指定了筛选谓词的已启用 Stretch Database 的表上执行查询可能会失败。 | 弹性 DB |
| 8292093 | 在启用了 Stretch Database 的表上创建、更改或删除索引可能会失败。 | 弹性 DB |
有关如何将 SQL Server 安装升级到 SQL Server 2016 SP1 的详细信息,请参阅支持的版本和版本升级。
如何获取 SQL Server 2016 SP1
可从 SQL Server 2016 SP1 下载页下载 SQL Server 2016 SP1。
注意
安装 Service Pack 后,SQL Server 服务版本应反映为 13.0.4422.0。
不建议卸载 SQL Server 2016 SP1 ()
如果出于任何原因选择卸载 SQL Server 2016 SP1,则不会阻止卸载 SQL Server 2016 SP1,并且你可以像卸载任何其他 Service Pack 一样卸载 SQL Server 2016 SP1。 但是,如果运行的是 Standard、Web、Express 版的 SQL Server,并利用某些仅从 SQL Server 2016 SP1 开始解锁的新功能,则卸载 SQL Server 2016 SP1 后可能会看到一些不可预见的错误,或者数据库甚至可能处于可疑状态。 更糟糕的是,如果系统数据库使用新功能(例如,master 数据库中的分区表),可能会导致卸载 SQL Server 2016 SP1 后无法启动 SQL Server 实例。 因此,建议在选择卸载 Enterprise Edition 以外的版本上的 SQL Server 2016 SP1 之前验证是否已禁用或删除所有新功能。 不能删除 memory_optimized_data 文件组。 因此,如果您在使用 SP1 的数据库上设置memory_optimized_data了文件组,则不应卸载 SQL Server 2016 SP1,否则数据库将进入可疑模式,错误日志中记录以下错误消息:
<日期时间> spid15s 错误:41381,严重性:21,状态:1。
<日期时间> spid15s 数据库无法在此版本的 SQL Server 中启动,因为它包含MEMORY_OPTIMIZED_DATA文件组。 有关不同 SQL Server 版本中的功能支持的详细信息,请参阅联机丛书。
版权归属
此产品包含从 Xerox 安全哈希函数派生的软件。
此产品包含 zlib 通用压缩库中的软件。
此软件的部分内容基于 RSA Data Security, Inc. 的工作。因为 Microsoft 已在此产品中包含 RSA Data Security, Inc., 软件,所以 Microsoft 必须包含此类软件附带的下列文本:
- 版权所有 1990,RSA Data Security, Inc. 保留所有权利。
- 只要在提及或引用本软件或此功能的所有材料中标明为“RSA Data Security, Inc., MD5 Message-Digest Algorithm”,则授予复制和使用本软件的许可。 如果这些作品在所有提及或引用衍生作品的材料中被标识为“源自 RSA Data Security, Inc., MD5 消息摘要算法”,则还授予制作和使用衍生作品的许可。
- RSA Data Security, Inc. 对本软件的适销性或本软件对任何特定用途的适用性不作任何声明。 它按“原样”提供,不提供任何形式的明示或默示担保。
这些通知必须保存在本文档或软件的任何部分的任何副本中。
Reporting Services 映射功能使用 TIGER/Line Shapefiles 中提供的数据,这些数据是由美国统计局提供的。 Tiger/Line Shapefiles 是从 Census MAF/TIGER 数据库中提取的选定地理和地图信息。 TIGER/Line Shapefiles 可以从美国统计局免费查询。 若要获取有关 TIGER/Line shapefiles 的更多信息,请转到 TIGER/Line shapefiles。 TIGER/Line Shapefiles 中的边界信息仅用于统计数据收集和制表目的;出于统计目的,其描述和指定不构成对管辖权、所有权或权利的确定,也不反映合法的土地描述。 Census TIGER 和 TIGER/Line 是美国统计局的注册商标。
版权所有 2012 Microsoft。 保留所有权利。
参考资料
有关如何确定当前 SQL Server 版本的更多信息,请选择下面的文章编号,以查看 Microsoft 知识库中相应的文章:
321185 如何识别SQL Server版本
本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。