Zobrazení a otevření sharepointových souborů pomocí Průzkumníka souborů

V současnosti se nedoporučuje používání příkazu Otevřít v Průzkumníkovi (v klasickém prostředí SharePointu) a Zobrazit v Průzkumníkovi souborů (v moderním prostředí). 

Doporučujeme použít příkaz  Synchronizovat místo Otevřít v Průzkumníkovi

Příkaz Synchronizovat představuje rychlejší a spolehlivější metodu vkládání Sharepointových souborů do složek, které můžete vidět v průzkumníkovi souborů, a to bez ohledu na to, jestli používáte Chrome, Microsoft Edge nebo jiný prohlížeč. 

Příkaz Synchronizovat je k nalezení přímo nad vaší knihovnou dokumentů:

Snímek obrazovky zobrazující tlačítko Synchronizovat v knihovně služby SharePoint

Synchronizace Sharepointových souborů a složek

Podívejte se na 90vteřinové video o základech používání příkazu Synchronizovat u vašich Sharepointových souborů a složek.

Podrobnější instrukce najdete v článku Synchronizace souborů aplikací SharePoint a Teams s vaším počítačem.

Co když používáte prohlížeč Internet Explorer

Technologie ActiveX, na které je založený příkaz Otevřít v Průzkumníkovi, je poměrně stará a postupem času se stala méně spolehlivou. Proto se možnost Otevřít v Průzkumníkovi občas zobrazuje šedě i v aplikaci Internet Explorer 11. Pokud používáte prohlížeč Internet Explorer, získáte spolehlivější výsledky použitím příkazu Synchronizovat. V článku Synchronizace souborů aplikací SharePoint a Teams s vaším počítačem najdete podrobnější pokyny.

Pokud byste radši dále používali příkaz Otevřít v Průzkumníkovi, přečtěte si následující části tohoto článku. První část vám pomůže řešit problémy, když není příkaz Otevřít v Průzkumníkovi k dispozici. 

Poznámka:  Microsoft 365 Aplikace a služby nebudou od 17. srpna 2021 podporovat Internet Explorer 11. Další informace Poznámka: Internet Explorer 11 bude i nadále podporovaný prohlížeč. Internet Explorer 11 je součástí operačního systému Windows a dodržuje Zásady životního cyklu pro produkt, na kterém je nainstalovaný. 

 Níže vyberte nadpis, abyste otevřeli příslušný oddíl a podívali se na podrobné informace.

Tady jsou uvedeny 4 možné důvody a pokyny, jak jednotlivé problémy vyřešit.

  • Používáte prohlížeč, který nepodporuje ovládací prvky technologie ActiveX.    Otevřít v aplikaci Explorer funguje jenom v aplikaci Internet Explorer 10 nebo 11. V systému Windows 10 je výchozím prohlížeč Edge, ale nainstalovaný je i Internet Explorer 11. Příkaz Otevřít v aplikaci Explorer nefunguje v prohlížečích Edge, Chrome ani Firefox. K převedení souborů můžete použít Internet Explorer a pak můžete dále používat preferovaný prohlížeč (pokud nejde o IE).

  • Internet Explorer využívá ovládací prvky Technologie ActiveX nebo jsou zablokované doplňky.    V prohlížeči Internet Explorer 11 stiskněte ALT+T na klávesnici. Pokud je v nabídce Nástroje zaškrtnutá možnost Filtrování technologie ActiveX, stiskněte X abyste ji vypnuli. Můžete taky kliknout na Nástroje, pak na Bezpečnost, a pak na Filtrování technologie ActiveX.

  • Používáte 64bitovou verzi aplikace Internet Explorer    Ovládací prvky technologie ActiveX používají technologii, která má jenom 32 bitů. Nespustí se v 64bitové verzi prohlížeče Internet Explorer. V aplikaci Internet Explorer 11 je pouze jeden prohlížeč, který se automaticky přepne do režimu 32 bitů kvůli ovládacím prvkům technologie ActiveX. Pokud však používáte 64bitovovou aplikaci Internet Explorer 10, musíte se přepnout do 32bitové verze. Pokud chcete zjistit, kterou máte verzi, stiskněte ALT+Ha potom stiskněte A abyste se dostali do části O aplikaci Internet Explorer.

  • Tyto SharePoint doplňky nejsou nainstalované.    V aplikaci Internet Explorer klikněte v nabídce Nástroje na příkaz Spravovat doplňky. Ujistěte se, že máte nainstalované a povolené tyto doplňky:

    Jméno

    Publisher

    Stav

    SharePoint Exportovat spouštěč databází

    Microsoft Corporation

    Povoleno

    SharePoint Třída OpenDocuments

    Microsoft Corporation

    Povoleno

    SharePoint Stssync Handler

    Microsoft Corporation

    Povoleno

  • Windows WebClient není spuštěný    Windows WebClient zajišťuje podporu pro to, aby mohly Windows a ovládací prvek ActiveX komunikovat s SharePoint knihovnami. Ve výchozím nastavení je zapnutý a spuštěný v rámci systému Windows. Pokud není spuštěný, můžete mít při používání příkazu Otevřít v aplikaci Explorer problémy. WebClient je součástí aplikace Internet Explorer. Postupujte podle těchto pokynů, abyste se ujistili, že je WebClient spuštěný.

    1. Stiskněte klávesu Windows + R, napište service.msc, a pak stiskněte Enter.

    2. V dialogovém okně najděte WebClient. Pokud ho nedokážete najít, výběrem nabídky Název seřadíte seznam podle abecedy.

    3. Přesvědčte se, že je v poli Stav uvedeno Spuštěno. Pokud to tak není, klikněte pravým tlačítkem myši na WebClient a vyberte Spustit.

    Dialogové okno Služeb pro Windows se zvýrazněnou položkou Webový klient

Poznámka: Pokud použijete příkaz Synchronizovat nebo Otevřít v aplikaci Explorer, vaše historie verzí se nezkopíruje. Dojde k přesunu nebo zkopírování výhradně nejnovějších nebo publikovaných verzí dokumentů. Další informace najdete v článku Proč příkaz Synchronizovat nebo Otevřít v Průzkumníkovi nekopíruje nebo nepřesune moje informace o verzi?

Průzkumník souborů je systém pro správu souborů, který se používá na počítačích se systémem Windows. V průzkumníkovi souborů můžete otevřít SharePoint knihovny a přesouvat nebo kopírovat soubory a složky z vašich složek na stolním počítači do SharePoint. V průzkumníkovi souborů můžete taky otevřít více SharePointových knihoven a kopírovat nebo přesouvat složky mezi nimi.

Poznámka: Pokud máte povolenou možnost Vyžadovat rezervaci, asi ji budete muset dočasně zakázat, abyste mohli stáhnout několik souborů. Další informace najdete v článku Nastavení knihovny tak, aby byla vyžadována rezervace souborů.

  1. V SharePoint otevřete knihovnu dokumentů, která obsahuje soubor nebo složky, které chcete přesunout nebo kopírovat.

  2. Udělejte jednu z těchto věcí:

    • V SharePoint v Microsoftu 365 (když používáte Internet Explorer) vyberte nabídku Zobrazení a pak vyberte Zobrazit v průzkumníkovi souborů.

      Nabídka Všechny dokumenty se zvýrazněnou možností Otevřít v Průzkumníkovi souborů
    • V In SharePoint Server 2019, SharePoint Server 2016, SharePoint Server 2013, nebo SharePoint Server 2010 (když používáte Internet Explorer) vyberte kartu knihovna a pak vyberte Otevřít v Průzkumníkovi.

      Otevřít v Průzkumníkovi souborů v SharePointu 2016 v IE11
    • V SharePoint Server 2007 vyberte Akce Obrázek nabídky a pak vyberte Otevřít v Průzkumníkovi Windows.

      Možnost nabídky Otevřít v Průzkumníkovi Windows v části Akce

    Poznámka:  Příkazy Zobrazit v průzkumníkovi souborů, Otevřít v Průzkumníkovi, a Otevřít v Průzkumníkovi Windows fungují jenom v prohlížeči Internet Explorer 10 nebo 11.

  3. Kromě otevíraní v průzkumníkovi souborů může SharePoint otevřít knihovnu v další kartě v rámci klasického režimu SharePoint. Toto okno knihovny můžete ignorovat nebo zavřít.

    Může se vám zobrazit automaticky otevírané okno s dotazem, jestli byste radši knihovnu synchronizovali. Je to na vás. Když v průzkumníkovi souborů otevřete knihovnu, je složka na vašem stolním počítači dočasná. Pokud použijete synchronizaci, získáte trvalou složku, která se bude nadále synchronizovat s knihovnou dokumentů. Další informace najdete v článku Synchronizace Sharepointových souborů pomocí synchronizační aplikace Microsoft OneDrivu.

  4. Pokud se vám zobrazí dialogové okno Zabezpečení prohlížeče Internet Explorer, vyberte Povolit. Můžete taky vybrat zaškrtnutí u pole Pro tento program mi už nezobrazujte varování.

  5. Otevřete složku pro cílový dokument a opakujte krok 2.

  6. Teď když máte v průzkumníkovi souborů otevřené obě knihovny dokumentů (zdroj i cíl), můžete mezi nimi kopírovat a přesouvat soubory.

    Připravte si obě okna tak, abyste mezi nimi mohli kopírovat nebo přesouvat. Na obrazovce si můžete zobrazit obě pomocí těchto kroků:

    • Vyberte okno zdroje a stiskněte klávesu Windows Tlačítko Start ve Windows 10 + Šipku vlevo. Okno by se mělo ukotvit na levé straně obrazovky.

    • Toto opakujte i s oknem cíle ale stiskněte klávesu Windows Tlačítko Start ve Windows 10 + Šipku vpravo abyste ho ukotvili na pravé straně obrazovky. Měly by být vidět obě okna.

      Umístění složek Průzkumníka vedle sebe

    U oken můžete taky změnit velikost tak, aby se překrývala.

    Překrývající se složky ve Windows
  7. Udělejte jednu z těchto věcí:

    • Abyste mohli kopírovat, vyberte složky a soubory ve zdroji, klikněte pravým tlačítkem myši, a vyberte možnost Kopírovat, anebo stiskněte klávesy Ctrl+C.

      Klikněte pravým tlačítkem, vyberte Kopírovat.
    • Abyste mohli přesouvat, vyberte složky a soubory ve zdroji, klikněte pravým tlačítkem myši, a vyberte možnost Vyjmout, anebo stiskněte klávesy Ctrl+X.

      Kliknutím pravým tlačítkem myši a výběrem možnosti Vyjmout přesunete soubor.

      Pokud soubory přesouváte, můžete namísto používání funkcí vyjmout a vložit dané soubory vybrat a přetáhnout mezi jednotlivými okny průzkumníka souborů.

    Poznámka: Pokud vaše knihovna používá správu verzí, dostanete pouze publikované nebo nejnovější dokumenty. Dřívější verze nemůžete přesunout ani kopírovat. Další informace najdete v článku Proč příkaz Synchronizovat nebo Otevřít v Průzkumníkovi nekopíruje nebo nepřesune moje informace o verzi?

  8. V cílové složce klikněte pravým tlačítkem myši a vyberte možnost Vložit, nebo stiskněte klávesy Ctrl+V.

    Klikněte pravým tlačítkem a vyberte Vložit.

    Poznámka: Pokud možnost Vložit nevidíte, vraťte se do zdrojové složky, zvýrazněte požadované soubory a složky, klikněte pravým tlačítkem myši a vyberte možnost Vyjmout anebo Kopírovat.

    kopírování souborů mezi dvěma okny Průzkumníka souborů
  9. Až dokončíte kopírování nebo přesun všech požadovaných souborů. zavřete obě okna průzkumníka souborů. Všechny vámi provedené změny souborů nebo složek se automaticky nahrají do SharePoint.

  10. Vraťte se do cílové knihovny v SharePoint. Pokud se nové soubory, složky nebo změny neprojevily, aktualizujte stránku.

    Prázdná knihovna

    Než začnete kopírovat soubory

    Knihovna se soubory zkopírovanými z Průzkumníka souborů

    Po zkopírování souborů

Kromě používání příkazu Otevřít v Průzkumníkovi můžete knihovnu taky synchronizovat s vašim stolním počítačem. Když synchronizujete, zůstane vám na ploše trvalá kopie knihovny SharePoint. Soubory můžete uložit přímo do této synchronizované složky a dojde k jejich automatickému nahrání do knihovny SharePoint, se kterou je synchronizovaná.

Můžete synchronizovat buď zdrojovou nebo cílovou knihovnu nebo obě. Zároveň můžete pracovat s oběma z nich. Další informace najdete v článku Synchronizace Sharepointových souborů pomocí synchronizační aplikace Microsoft OneDrivu.

Návod k nahrávání souborů najdete v článku Nahrání složky nebo souborů do knihovny dokumentů

Pokud potřebujete, aby se při přesouvání souboru mezi jednotlivými knihovnami služby SharePoint zachovaly informace o verzi, použijte příkaz Přesunout do. Čtěte dál a získáte další informace.

Správa verzí je součástí knihovny SharePoint. Verze a sledování se ukládá v samotných datech SharePoint, ne v souborech. SharePoint ukládá starší i novější soubory a rozlišuje mezi nimi pomocí čísel verzí, místo aby došlo k přepsání starších souborů když vrátíte novou verzi se změnami. Soubory jsou pořád oddělené, a jsou sledovány v rámci knihovny, ale verze jsou jenom v knihovně SharePoint.

Diagram úložiště správy verzí

Synchronizace a příkaz Otevřít v Průzkumníkovi fungují se soubory, které obsahují metadata potřebná pro daný soubor, jako například pozměněné datum nebo autor. Když kopírujete pomocí příkazuOtevřít v Průzkumníkovi, může kopírovat nebo přesunout jenom soubory a jejich bezprostřední informace. Dodatečné informace a další soubory SharePoint nejsou zahrnuty.

Když používáte SharePoint, přesune příkaz Přesunout do historii verzí, protože pracuje v rámci dané knihovny. Příkaz Přesunout do zachovává historii verzí, protože existuje jenom jedna kopie souboru a struktury. Když SharePoint přesune soubor mezi složkami nebo knihovnami pomocí příkazu Přesunout do, zahrnuje informace o verzi a sledování.

Příkaz SharePoint Kopírovat do naopak zkopíruje jenom nejnovější soubor. Toto zabraňuje rozštěpení historie mezi dvěma umístěními. Můžete aktualizovat kterýkoli ze souborů, ale změny se projeví jenom v pozměněném souboru.

Pokud kopírujete soubory pro zálohování a chcete zachovat historii verzí, zvažte využití zálohy na serveru SharePoint místo manuálního kopírování. Pokud se něco stane s vašimi současnými soubory, můžete je obnovit ze zálohy SharePoint. Podívejte se na článek Doporučené postupy pro zálohování a obnovu pomocí SharePointového serveru.

Jaký je rozdíl mezi příkazy Synchronizovat a Otevřít v Průzkumníkovi?

Příkazy Synchronizovat a Otevřít v Průzkumníkovi propojují SharePoint knihovnu se složkou na vašem stolním počítači, ale je mezi nimi rozdíl:

  • Otevřít v Průzkumníkovi používá dočasnou složku, která se otevírá v Průzkumníkovi souborů. Tato složka vydrží do doby, než ji zavřete a její obsah se uloží do SharePoint. Příkaz Otevřít v Průzkumníkovi vám poskytuje jednorázový přístup do SharePointové knihovny prostřednictvím složek ve vašem stolním počítači.

  • Příkaz Synchronizovat používá Synchronizační aplikace OneDrivu k vytvoření trvalejší složky, kterou můžete používat každý den. Veškerý obsah, který přidáte, upravíte nebo odstraníte z online SharePointové knihovny nebo ze složky na stolním počítači se automaticky synchronizuje s odpovídajícím místem. Například, jakmile synchronizujete knihovnu, můžete ukládat do složky na stolním počítači přímo z Word nebo Excel, a všechno se automaticky nahraje do knihovny SharePoint. Pokud něco při práci v režimu offline uložíte do složky na stolním počítači, Synchronizace aktualizuje knihovnu SharePoint hned, jakmile budete opět online.

    V článku Synchronizace souborů aplikací SharePoint a Teams s vaším počítačem najdete další informace o příkazu Synchronizace.

Další informace

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou překladu?

Co ovlivnilo váš názor?

Máte další zpětnou vazbu? (Nepovinné)

Děkujeme za váš názor!

×