Диаграммы позволяют наглядно представить данные, чтобы произвести наибольшее впечатление на аудиторию. Узнайте, как создать диаграмму и добавить линию тренда. Вы можете начать работу с рекомендуемой диаграммы или выбрать диаграмму из нашей коллекции готовых шаблонов.
Создание диаграммы
Выберите данные для диаграммы.
Выберите "Вставить>рекомендуемые диаграммы".
На вкладке Рекомендуемые диаграммы выберите диаграмму для предварительного просмотра.
Примечание
Можно выделить нужные данные для диаграммы и нажать клавиши ALT+F1, чтобы сразу создать диаграмму, однако результат может оказаться не самым лучшим. Если вы не видите диаграмму, которая вам нравится, выберите вкладку "Все диаграммы ", чтобы просмотреть все типы диаграмм.
Выберите диаграмму.
Нажмите кнопку ОК.
Добавление линии тренда
- Выберите диаграмму.
- Выберите Chart Design,>Добавить элемент диаграммы.
- Выберите элемент "Линия тренда" и выберите нужный тип линии тренда, например линейную, экспоненциальную, линейную прогнозную или скользящую среднюю.
Примечание
Часть содержимого этого раздела может быть неприменима к некоторым языкам.
Диаграммы отображают данные в графическом формате, который помогает вам и вашей аудитории визуализировать отношения между данными. При создании диаграммы доступно множество типов диаграмм (например, гистограмма с накоплением или трехмерная разрезанная круговая диаграмма). После создания диаграммы ее можно настроить, применив экспресс-макеты или стили.
Элементы диаграммы
Диаграмма содержит несколько элементов, таких как заголовок, подписи осей, условные обозначения и линии сетки. Вы можете скрыть или показать эти элементы, а также изменить их расположение и форматирование.
Название диаграммы
Область построения
Легенда
Названия осей
Метки осей
Деления
Линии сетки
Создание диаграммы
Диаграмму можно создать в Excel, Word и PowerPoint. Однако данные диаграммы вводятся и сохраняются на листе Excel. При вставке диаграммы в Word или PowerPoint открывается новый лист в Excel. При сохранении документа Word или презентации PowerPoint с диаграммой данные Excel для этой диаграммы автоматически сохраняются в документе Word или презентации PowerPoint.
Примечание
Коллекция книг Excel заменяет прежний мастер диаграмм. По умолчанию коллекция книг Excel открывается при запуске Excel. В коллекции можно просматривать шаблоны и создавать на их основе новые книги. Если коллекция книг Excel не отображается, в меню Файл выберите пункт Создать на основе шаблона.
В меню Вид выберите пункт Разметка страницы.
Откройте вкладку "Вставка ", выберите тип диаграммы и дважды щелкните диаграмму, которую нужно добавить.
При вставке диаграммы в приложение Word или PowerPoint открывается лист Excel с таблицей образцов данных.
В приложении Excel замените образец данных данными, которые нужно отобразить на диаграмме. Если эти данные уже содержатся в другой таблице, их можно скопировать оттуда и вставить вместо образца данных. Рекомендации по упорядочиванию данных в соответствии с типом диаграммы см. в таблице ниже.
Тип диаграммы Расположение данных Диаграмма с областями, линейчатая диаграмма, гистограмма, кольцевая диаграмма, график, лепестковая диаграмма или поверхностная диаграмма Данные расположены в столбцах или строках, как в следующих примерах:
Серия 1Серия 2Категория A1012Категория B1114Категория C915илиКатегория Категория BSeries 11011Серия 21214Пузырьковая диаграмма В столбцах поместите значения x в первый столбец, а соответствующие значения y и значения размера пузырька — в соседние столбцы, как в следующих примерах:X-ValuesY-Value 1Size 10.72.741.83.252.60.086 Круговая диаграмма Один столбец или строка данных и один столбец или строка меток данных, как в следующих примерах:
Продажи1-й квартал252-й квартал303-й квартал45или 1-й квартал2-й квартал2-й квартал2-й квартал253045Биржевая диаграмма Данные расположены по столбцам или строкам в указанном ниже порядке с использованием названий или дат в качестве подписей, как в следующих примерах:
OpenHighLowClose1/5/02445511251/6/0225571238or1/5/021/6/02Open4425High5557Low1112Close2538X Y (точечная) диаграмма Данные расположены по столбцам, причем значения x — в первом столбце, а соответствующие значения y — в смежных столбцах, как в следующих примерах:
X-значенияЗначение Y 10.72.71.83.22.60.08или X-значения0.71.82.6Значение Y 12.73.20.08Чтобы изменить число строк и столбцов, включенных в диаграмму, наведите указатель мыши на нижний правый угол выбранных данных, а затем перетащите угол, чтобы выбрать дополнительные данные. В приведенном ниже примере таблица расширяется, чтобы включить дополнительные категории и последовательности данных.
Чтобы увидеть результаты изменений, вернитесь в приложение Word или PowerPoint.
Примечание
При закрытии документа Word или презентации PowerPoint с диаграммой таблица данных Excel для этой диаграммы закроется автоматически.
Изменение акцентированной оси диаграммы
После создания диаграммы можно изменить способ отображения строк и столбцов таблицы в диаграмме. Например, в первой версии диаграммы строки данных таблицы могут отображаться по вертикальной оси (значение), а столбцы — по горизонтальной оси (категория). В следующем примере диаграмма акцентирует продажи по инструментам.
Однако если требуется, чтобы диаграмма акцентировала продажи по месяцам, можно изменить способ отображения диаграммы на обратный.
- В меню Вид выберите пункт Разметка страницы.
- Щелкните диаграмму.
- Откройте вкладку Конструктор и нажмите кнопку Строка/столбец.
Если команда "Строка/столбец" недоступна
Элемент Строка/столбец доступен только при открытой таблице данных диаграммы Excel и только для определенных типов диаграмм. Вы также можете изменить данные, щелкнув диаграмму и отредактировав лист в Excel.
Применение готового макета диаграммы
- В меню Вид выберите пункт Разметка страницы.
- Щелкните диаграмму.
- Откройте вкладку Конструктор и нажмите кнопку Экспресс-макет.
- Выберите нужную разметку.
Чтобы быстро отменить примененный макет, нажмите
+ Z .
Применение готового стиля диаграммы
Стили диаграмм — это набор дополняющих цветов и эффектов, которые можно применить к диаграмме. При выборе стиля диаграммы изменения влияют на всю диаграмму.
- В меню Вид выберите пункт Разметка страницы.
- Щелкните диаграмму.
- Откройте вкладку Конструктор и выберите нужный стиль.
Чтобы просмотреть другие стили, наведите указатель мыши на стиль и щелкните
параметры".
Чтобы немедленно отменить примененный стиль, нажмите
+ Z .
Добавление названия диаграммы
- В меню Вид выберите пункт Разметка страницы.
- Щелкните диаграмму и откройте вкладку Конструктор.
- Нажмите кнопку Добавить элемент диаграммы.
- Выберите пункт Название диаграммы, чтобы задать параметры форматирования названия, а затем вернитесь к диаграмме, чтобы ввести название в поле Название диаграммы.
См. также
1. Создание диаграммы
Чтобы приступить к созданию диаграммы в Excel, убедитесь, что данные в книге уже готовы. Начните работу с новой книгой или откройте текущую книгу в Excel для Интернета. Чтобы создать диаграмму, можно использовать рекомендуемые диаграммы, выбрать диаграмму из нашей коллекции в разделе "Создание" или выбрать наиболее подходящий тип диаграммы для ваших данных. После подготовки данных выполните следующие действия:
Выделите диапазон ячеек, содержащих данные, которые нужно визуализировать.
Перейдите на вкладку " Вставка" на ленте.
Перейдите в раздел "Диаграммы" и выберите тип диаграммы, который лучше всего соответствует вашим потребностям.
Дополнительные сведения о типах диаграммПримечание
Попробуйте использовать функцию "Рекомендуемые диаграммы", чтобы увидеть рекомендации на основе ваших данных. Просто перейдите в раздел "Диаграммы" на ленте и выберите нужный элемент. Рекомендуемые диаграммы доступны подписчикам Microsoft 365 на английском, французском, испанском, немецком, упрощенном китайском и японском языках. Если вы являетесь подписчиком Microsoft 365, убедитесь, что у вас установлена последняя версия Office. Дополнительные сведения о различных каналах обновления для Office см. в статье: Обзор каналов обновления для Приложения Microsoft 365.
2. Измените данные
Если нужно изменить параметры выделения данных или добавить в диаграмму дополнительные данные, щелкните диаграмму правой кнопкой мыши и выберите команду "Выбор данных", чтобы открыть область задач.
Изменить выбор данных
- Изисточника>данных> Выберите новый диапазон ячеек или введите диапазон вручную в поле "Источник" и примените его.
Добавление, удаление и изменение ряда данных
- Чтобы добавить новый ряд данных, в разделе "Настройка данных>""Добавить поле>" выделите диапазон ячеек на листе и примените его.>
- Чтобы изменить существующий ряд, щелкните ряд, который требуется изменить, в разделе "Настройка".
- Чтобы изменить имя ряда, нажмите кнопку✏️ . Вы можете ввести новое имя или выбрать ячейку, чтобы связать ее с сообщением. Имя также можно изменить в разделе "Формат>имени ряда>".
- Чтобы изменить тип диаграммы для одного набора данных, используйте команду "Построить как".
- Чтобы изменить порядок отображения рядов на диаграмме, используйте ⬆️ стрелки and ⬇️.
Переключение вертикальной и горизонтальной оси
Соберите нужные данные на диаграмме, если потребуется поменять местами оси, отражающие те или иные данные:
- Перейдите в разделНастройка>данных>Горизонтальная ось>Горизонтальное поле.
- Введите диапазон ячеек на вертикальной оси или диапазон ячеек.
- Удаление исходного выделенного диапазона с горизонтальной оси.
- В поле"Добавить полепо вертикальной оси>" введите исходный диапазон относительно горизонтальной оси.
- Чтобы завершить переключение, удалите исходный ряд с вертикальной оси.
3. Настройте диаграмму
Чтобы внести изменения в диаграмму, дважды щелкните диаграмму, чтобы открыть область задач и перейти на вкладку "Формат ".
Добавление, удаление или изменение заголовка
- В разделе "Формат> названия >диаграммы" установите переключатель ВКЛ/ВЫКЛ.
- Разверните "Название диаграммы", чтобы изменить заголовок, положение и шрифт.
Добавление, удаление и изменение названий осей
- Выберите вертикальную или горизонтальную ось, чтобы просмотреть соответствующие параметры в области задач.
- Под соответствующей осью прокрутите вниз до раздела "Название оси".
- Включите или выключите функцию добавления/удаления.
- Измените название и шрифт заголовка оси, развернув раздел "Название оси".
Изменение цвета ряда или точки данных
- Чтобы изменить цвет ряда, выберите ряд, который требуется изменить, и просмотрите соответствующие параметры в области задач. Выберите нужный цвет для ряда в области задач.
- Чтобы изменить цвет отдельной точки данных, выберите точку данных и щелкните правой кнопкой мыши точку данных на диаграмме. Выберите нужный цвет точки данных в плавающем меню.
Добавление, удаление и изменение меток данных
Выберите ряд, который требуется изменить, и просмотрите соответствующие параметры в области задач.
- Используйте переключатель ВКЛ/ВЫКЛ, чтобы добавить или удалить метки данных.
Чтобы отобразить или скрыть имя ряда, категорию, значение, ключ легенды и изменить разделитель, выполните следующие действия.
- Перейдите к области > задач диаграммы "Форматирование>>подписей рядов данных".
Добавление, удаление и изменение легенды
- Дважды щелкните диаграмму, пока в правой части экрана не откроется область задач диаграммы.
- Выберите "Формат>легенды".
- Включите или выключите легенду, чтобы добавить или удалить легенду.
- Измените положение и шрифт диаграммы, развернув элемент "Легенда".
Добавление, удаление и изменение линий тренда
Дважды щелкните диаграмму, пока в правой части экрана не откроется область задач диаграммы.
Выберите "Формат>линии тренда".
Используйте переключатель ВКЛ/ВЫКЛ, чтобы добавить или удалить линию тренда.
- Измените имя, тип тренда, стиль или пересечение, развернув "Легенда".
Другие способы настройки диаграмм в Excel в Интернете
Внесите изменения в диаграмму с помощью контекстного меню
Чтобы просмотреть все параметры форматирования, доступные для диаграммы, перейдите к разделу «Формат области > задач диаграммы».
Вы также можете внести в диаграмму некоторые изменения, щелкнув правой кнопкой мыши часть диаграммы, которую нужно изменить.
Типы диаграмм
Рекомендуется просмотреть свои данные и решить, какой тип диаграммы лучше всего подходит. Ниже перечислены доступные типы.
Гистограммы
Данные в столбцах или строках листа можно представить в виде гистограммы. В гистограмме категории обычно отображаются по горизонтальной оси, а значения — по вертикальной оси, как показано на этой диаграмме:
Типы гистограмм
Столбец с группировкой На гистограмме с группировкой значения выводятся в виде плоских столбцов. Используйте этот тип диаграммы при наличии категорий, представляющих:
- диапазоны значений (например, количество элементов);
- специфические шкалы (например, шкала Ликерта с масками, такими как "Полностью согласен", "Согласен", "Не знаю", "Не согласен", "Полностью не согласен");
- неупорядоченные имена (например, названия элементов, географические названия или имена людей).
Столбец с накоплением Гистограмма с накоплением представляет значения в виде плоских столбцов с накоплением. Используйте этот тип диаграммы, когда есть несколько рядов данных и нужно подчеркнуть итоговое значение.
100% столбец с накоплением Нормированная гистограмма с накоплением представляет значения в виде плоских нормированных столбцов с накоплением для представления 100 % значений. Используйте этот тип диаграммы, когда есть несколько рядов данных и нужно подчеркнуть их вклад в итоговое значение, особенно если итоговое значение одинаково для всех категорий.
Графики
Данные, расположенные в столбцах или строках листа, можно представить в виде графика. На графиках данные категорий равномерно распределяются вдоль горизонтальной оси, а все значения равномерно распределяются вдоль вертикальной оси. Графики позволяют отображать непрерывное изменение данных с течением времени на оси с равномерным распределением и идеально подходят для представления тенденций изменения данных с равными интервалами, такими как месяцы, кварталы или финансовые годы.
Типы графиков
Линия и линия с маркерами Графики, отображаемые как с маркерами для конкретных значений данных, так и без них, могут отображать тенденции с течением времени или по категориям данных, разделенным равными интервалами, особенно если имеется много точек данных и важен порядок, в котором они представлены. Если имеется много категорий или значения являются приблизительными, используйте график без маркеров.
График с накоплением и график с накоплением с маркерами. Графики с накоплением, отображаемые как с маркерами для конкретных значений данных, так и без них, могут отображать динамику изменения вклада каждого значения с течением времени или по категориям данных, разделенным равными интервалами.
100% линия с накоплением и 100% линия с маркерами Нормированные графики с накоплением с маркерами, отмечающими отдельные значения данных, или без маркеров могут отображать динамику вклада каждой величины в процентах с течением времени или по категориям данных, разделенным равными интервалами. Если имеется много категорий или значения являются приблизительными, используйте нормированный график с накоплением без маркеров.
Примечание
- Графики лучше всего подходят для вывода нескольких рядов данных— если нужно отобразить только один ряд данных, вместо графика рекомендуется использовать точечную диаграмму.
- На графиках с накоплением данные суммируются, что может быть нежелательно. Увидеть накопление на графике бывает непросто, поэтому иногда вместо него стоит воспользоваться графиком другого вида либо диаграммой с областями с накоплением.
Круговые диаграммы
Данные в одном столбце или строке листа можно представить в виде круговой диаграммы. Круговые диаграммы отражают размер элементов одного ряда данных относительно суммы элементов. Точки данных на круговой диаграмме отображаются в виде процентных долей целого круга.
Круговую диаграмму рекомендуется использовать, если:
- нужно отобразить только один ряд данных;
- все значения ваших данных неотрицательны;
- почти все значения данных больше нуля;
- имеется не более семи категорий, каждой из которых соответствуют части общего круга.
Кольцевые диаграммы
Данные, расположенные только в столбцах или строках листа, можно представить в виде кольцевой диаграммы. Как и круговая диаграмма, кольцевая диаграмма отображает отношение частей к целому, но может содержать более одного ряда данных.
Совет
Восприятие кольцевых диаграмм затруднено. Вместо них можно использовать линейчатые диаграммы с накоплением или гистограммы с накоплением.
Линейчатые диаграммы
Данные в столбцах или строках листа можно представить в виде линейчатой диаграммы. Линейчатые диаграммы используют для сравнения отдельных элементов. В диаграммах этого типа категории обычно располагаются по вертикальной оси, а величины — по горизонтальной.
Линейчатые диаграммы рекомендуется использовать, если:
- метки осей имеют большую длину;
- выводимые значения представляют собой длительности.
Типы линейчатых диаграмм
- С группировкой На линейчатой диаграмме с группировкой значения выводятся в виде плоских столбцов.
- С накоплением Линейчатая диаграмма с накоплением показывает вклад отдельных величин в общую сумму в виде плоских столбцов.
- 100% сложение Этот тип диаграмм позволяет сравнить по категориям процентный вклад каждой величины в общую сумму.
Диаграммы с областями
Данные в столбцах или строках листа можно представить в виде диаграммы с областями. Диаграммы с областями могут использоваться для отображения изменений величин с течением времени и привлечения внимания к итоговому значению в соответствии с тенденцией. Отображая сумму значений рядов, такая диаграмма также наглядно показывает вклад каждого ряда.
Типы диаграмм с областями
- Площадь Двумерные диаграммы с областями отображают изменение значений с течением времени или по категориям. Обычно вместо диаграмм с областями без накопления рекомендуется использовать графики, так как данные одного ряда могут быть скрыты за данными другого ряда.
- С областями с накоплением Диаграммы с областями с накоплением показывают изменения вклада каждой величины с течением времени или по категориям в двухмерном виде.
- Нормированная Нормированные диаграммы с областями с накоплением отображают изменения вклада каждой величины в процентах с течением времени или по категориям.
Точечные диаграммы
Данные в столбцах и строках листа можно представить в виде точечной диаграммы. Поместите данные по оси X в одну строку или столбец, а соответствующие данные по оси Y — в соседние строки или столбцы.
Точечная диаграмма имеет две оси значений: горизонтальную (X) и вертикальную (Y). На точечной диаграмме значения "x" и "y" объединяются в одну точку данных и выводятся через неравные интервалы или кластеры. Точечные диаграммы обычно используются для отображения и сравнения числовых значений, например научных, статистических или технических данных.
Точечные диаграммы рекомендуется использовать, если:
- требуется изменять масштаб горизонтальной оси;
- требуется использовать для горизонтальной оси логарифмическую шкалу;
- значения расположены на горизонтальной оси неравномерно;
- на горизонтальной оси имеется множество точек данных;
- требуется настраивать независимые шкалы точечной диаграммы для отображения дополнительных сведений о данных, содержащих пары сгруппированных полей со значениями;
- требуется отображать не различия между точками данных, а аналогии в больших наборах данных;
- требуется сравнивать множество точек данных без учета времени; чем больше данных будет использовано для построения точечной диаграммы, тем точнее будет сравнение.
Типы точечных диаграмм
- Точечная диаграмма. Диаграмма этого типа позволяет отображать точки данных без соединительных линий для сравнения пар значений.
- Точечная диаграмма с плавными линиями и маркерами и точечная диаграмма с плавными линиями На этой диаграмме точки данных соединены сглаживающими линиями. Такие линии могут отображаться с маркерами или без них. Сглаживающую кривую без маркеров следует использовать, если точек данных достаточно много.
- Точечная диаграмма с прямыми линиями и маркерами и точечная диаграмма с прямыми линиями На этой диаграмме отображаются прямые соединительные линии между точками данных. Линии могут отображаться с маркерами или без них.
Лепестковые диаграммы
Данные в столбцах или строках листа можно представить в виде лепестковой диаграммы. Лепестковые диаграммы позволяют сравнить агрегированные значения нескольких рядов данных.
Типы лепестковых диаграмм
- Лепестковые диаграммы и лепестковые диаграммы с маркерами для отдельных точек данных отображают изменения значений относительно центральной точки.
- Лепестковая диаграмма с областями. На лепестковой диаграмме с областями области, заполненные рядами данных, выделены цветом.
Внесение дополнительных изменений в диаграмму
Разделение полей по строкам или столбцам
Переключение параметра "строки по столбцам" меняет структуру данных: то, что когда-то было строками, теперь находится в столбцах, и наоборот.
- Изисточника>данных>Поля данных с разбивкой.
Переключение направления оси сверху вниз или слева направо
- От вертикальной оси или горизонтальной оси>«Значения в обратном порядке».
Изменение имени ряда
- Выберите ряд, который требуется изменить, и просмотрите соответствующие параметры в области задач.
- Введите новое имя серии в поле "Имя серии".
Изменение ширины столбцов и полос
- От горизонтальной оси > отрегулируйте ползунок ширины зазора по своему усмотрению.
Изменение верхней и нижней границ оси
Выберите ряд, который требуется изменить, чтобы просмотреть соответствующие параметры в области задач.
- Выберите "Границы".
- Введите "Минимальное" и "Максимальное" значения.
Изменение единиц
Единицы измерения на диаграмме определяют масштаб, используемый для представления данных вдоль осей.
- Выберите ряд, который требуется изменить, и просмотрите соответствующие параметры в области задач.
- Выберите "Единицы"
- Введите «основные подразделения» и «второстепенные подразделения».
Изменение деек
- Выберите ряд, который требуется изменить, и просмотрите соответствующие параметры в области задач.
- Выберите "Деления ".
- Выберите "Основной тип" и "Дополнительный тип".
Настройка типа, размера и цвета маркеров для определенных диаграмм
- Выберите ряд, который требуется изменить, и просмотрите соответствующие параметры в области задач.
- Выберите параметры> маркера Настройте размер, тип ицветмаркера по своему усмотрению.
Добавление, удаление и изменение пределов погрешностей
- Дважды щелкните диаграмму, пока в правой части экрана не откроется область задач диаграммы.
- Выберите> формат:предельные значения погрешностей >Вкл/Выкл
- Разверните "Пределы погрешностей", чтобы настроить стиль, направление и количество ошибок.
Примечание
В настоящее время настраиваемые планки погрешностей не поддерживаются в веб-версии Excel и доступны только на компьютере.
Добавление и удаление линий сетки
- Дважды щелкните диаграмму, пока в правой части экрана не откроется область задач диаграммы.
- Выберите "Формат>ряда".
- Выберите "Основные" или "Дополнительные" линии сетки.
Добавление, удаление или изменение таблицы данных
- Дважды щелкните диаграмму, пока в правой части экрана не откроется область задач диаграммы.
- Выберите переключатель " Формат>таблицы> данных " ВКЛ/ВЫКЛ.
- Разверните "Таблица данных", чтобы изменить границы, легенду и шрифт таблицы.
Дополнительные сведения
Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.