Bỏ qua để tới nội dung chính
Đăng nhập với Microsoft
Đăng nhập hoặc tạo một tài khoản.
Xin chào,
Chọn một tài khoản khác.
Bạn có nhiều tài khoản
Chọn tài khoản bạn muốn đăng nhập.

NHANH CHÓNG XÂY DỰNG CÁC BÀI VIẾT CUNG CẤP THÔNG TIN TRỰC TIẾP TỪ TRUNG TÂM HỖ TRỢ CỦA MICROSOFT. THÔNG TIN CÓ TRONG TÀI LIỆU NÀY ĐƯỢC TẠO RA TRONG PHẢN ỨNG MỚI XUẤT HIỆN HOẶC DUY NHẤT CHỦ ĐỀ, HOẶC NHẰM MỤC ĐÍCH BỔ SUNG THÔNG TIN CƠ SỞ KIẾN THỨC KHÁC.

Bài viết này áp dụng cho Microsoft Dynamics NAV cho tất cả các nước và tất cả ngôn ngữ.

Triệu chứng

Khi bạn in báo cáo cổ điển từ máy khách RoleTailored (RTC) trong Microsoft Dynamics NAV 2009 Service Pack 1 liên tiếp, bạn nhận được thông báo lỗi sau:

Bạn không thể sử dụng tệp zup vì nó đã được sử dụng.


Lưu ý Báo cáo vẫn được in.

Nguyên nhân

Vấn đề này xảy ra do các báo cáo cổ điển có một bố cục Visual Studio. Microsoft Dynamics NAV sử dụng công cụ báo cáo từ khách hàng truyền thống để in các báo cáo. Vấn đề này xảy ra khi Microsoft Dynamics NAV mở và sau đó đóng trình báo cáo cổ điển liên tiếp. Khi Microsoft Dynamics NAV đóng khách hàng truyền thống, tệp .zup được Cập Nhật. Do đó, nếu một công cụ báo cáo cổ điển cố gắng đóng trước khi trình báo cáo trước đó hoàn tất, vấn đề này xảy ra.

Giải pháp

Thông tin về cập nhật nóng

Cập nhật nóng được hỗ trợ do Microsoft cung cấp. Đó là một phần "Tải xuống Hotfix sẵn có" ở đầu bài viết cơ sở kiến thức này. Nếu bạn đang gặp sự cố tải xuống, cài đặt hotfix này, hoặc có câu hỏi hỗ trợ kỹ thuật khác, liên hệ với đối tác của bạn hoặc, nếu đăng ký kế hoạch hỗ trợ trực tiếp với Microsoft, bạn có thể liên hệ với hỗ trợ kỹ thuật cho Microsoft Dynamics và tạo ra một yêu cầu hỗ trợ mới. Để thực hiện việc này, hãy truy cập trang web sau của Microsoft:

https://mbs.microsoft.com/support/newstart.aspxBạn cũng có thể liên hệ hỗ trợ kỹ thuật cho Microsoft Dynamics qua điện thoại bằng cách sử dụng các liên kết cho quốc gia số điện thoại cụ thể. Để thực hiện việc này, ghé thăm một trong số các Microsoft Web site sau:

Đối tác

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global+Support+ContactsKhách hàng

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htmTrong trường hợp đặc biệt, chi phí thường phát sinh để hỗ trợ cuộc gọi có thể bị hủy bỏ nếu chuyên viên hỗ trợ kỹ thuật cho Microsoft Dynamics và sản phẩm liên quan xác định rằng một Cập Nhật cụ thể sẽ giải quyết vấn đề của bạn. Chi phí hỗ trợ thông thường sẽ áp dụng bất kỳ vấn đề không Cập Nhật cụ thể trong câu hỏi và câu hỏi hỗ trợ bổ sung.



Làm thế nào để có được hotfix Microsoft Dynamics NAV hoặc cập nhật tệp

Sau khi bạn yêu cầu một hotfix Microsoft Dynamics NAV, siêu liên kết sẽ được gửi cho bạn trong e-mail.


E-mail sẽ chứa một liên kết và mật khẩu. Bạn có thể sử dụng các siêu liên kết để tải xuống hotfix Microsoft Dynamics NAV hoặc các tập tin Cập Nhật. Khi bạn bấm vào siêu liên kết, hộp thoại Tệp tải xuống – cảnh báo bảo mật mở. Sau đó, bạn được nhắc để chạy, lưu hoặc hủy bỏ tải xuống.


Nếu bạn bấm chạy, các tệp bắt đầu tải xuống và trình giải nén. Bạn phải chỉ định thư mục cho tệp mới và sau đó cung cấp mật khẩu.


Nếu bạn bấm lưu, bạn phải chỉ định đường dẫn lưu tệp nén. Khi bạn mở tệp mà bạn đã lưu, bạn được nhắc chỉ định đường dẫn tệp. Sau đó, bạn phải cung cấp mật khẩu được cung cấp trong email.


Nếu bạn bấm huỷ, dừng quá trình tải xuống.


Làm thế nào để cài đặt bản cập nhật tệp hoặc một hotfix Microsoft Dynamics NAV

Microsoft Dynamics NAV nền tảng hotfix và bản Cập Nhật được thực hiện có sẵn như là một tệp. Để cài đặt một hotfix Microsoft Dynamics NAV hoặc bản Cập Nhật, bạn phải thay thế tệp cài đặt Microsoft Dynamics NAV sẵn có với hotfix hay cập nhật tệp. Để thực hiện việc này, hãy làm theo các bước sau.

Bước 1: Thay thế các tệp cài đặt Microsoft Dynamics NAV khách hàng truyền thống

Trong cài đặt Microsoft Dynamics NAV khách hàng truyền thống, thay thế các tệp sau bằng cách sử dụng các hotfix hoặc tệp Cập Nhật.

Tên tệp

Phiên bản tệp

Kích thước tệp

Ngày

Giờ

Nền tảng

Dbm.dll

6.0.30677.0

427,848

24-Feb-2010

15:16

x86

Fin.exe

6.0.30677.0

12,597,064

24-Feb-2010

15:17

x86

Finhlink.exe

6.0.30677.0

452,432

24-Feb-2010

15:17

x86

Finsql.exe

6.0.30677.0

12,718,928

24-Feb-2010

15:17

x86

Nc_netb.dll

6.0.30677.0

96,592

24-Feb-2010

15:16

x86

Nc_tcp.dll

6.0.30677.0

98,640

24-Feb-2010

15:16

x86

Nc_tcps.dll

6.0.30677.0

141,136

24-Feb-2010

15:16

x86

Ndbcs.dll

6.0.30677.0

1,348,944

24-Feb-2010

15:16

x86

Slave.exe

6.0.30677.0

152,400

24-Feb-2010

15:16

x86

Để thay thế các tệp Microsoft Dynamics NAV hiện tại, hãy làm theo các bước sau:

  1. Đóng ứng dụng khách Microsoft Dynamics NAV cổ điển.

  2. Xác định thư mục cài đặt Microsoft Dynamics NAV khách hàng truyền thống. Microsoft Dynamics NAV khách truyền thống thường được cài đặt trong thư mục sau:

    C:\Program Files\Microsoft Dynamics NAV\60\Classic

  3. Sao chép các tệp bạn đã tải xuống.

  4. Dán các tệp mà bạn truy cập vào thư mục cài đặt Microsoft Dynamics NAV khách hàng truyền thống.

  5. Bấm để ghi đè lên các tệp trong thư mục.

Bước 2: Thay thế các tệp cài đặt máy khách Microsoft Dynamics NAV RoleTailored

Trong quá trình cài đặt máy khách Microsoft Dynamics NAV RoleTailored, thay thế các tệp sau bằng cách sử dụng các hotfix hoặc tệp Cập Nhật.

Tên tệp

Phiên bản tệp

Kích thước tệp

Ngày

Giờ

Nền tảng

Microsoft.dynamics.framework.patterns.dll

1.3.10803.137

71,656

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.dll

1.3.10803.137

698,328

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.mapping.dll

1.3.10803.137

104,424

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.navigation.dll

1.3.10803.137

34,800

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.ux2006.dll

1.3.10803.137

88,040

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.ux2006.winforms.dll

1.3.10803.137

63,480

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.windows.dll

1.3.10803.137

83,944

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.winforms.controls.dll

1.3.10803.137

2,111,488

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.winforms.dll

1.3.10803.137

690,152

24-Feb-2010

06:30

x86

Microsoft.dynamics.nav.client.builder.dll

6.0.30677.0

198,544

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.client.exe

6.0.30677.0

149,376

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.client.interop.communicator.dll

1.0.559.183

75,688

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.client.serviceconnection.dll

6.0.30677.0

104,352

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.client.ui.dll

6.0.30677.0

505,728

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.client.winforms.dll

6.0.30677.0

337,808

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.client.winforms.tlb

Không áp dụng

2,644

24-Feb-2010

12:05

Không áp dụng

Microsoft.dynamics.nav.language.dll

6.0.30677.0

1,992,576

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.types.dll

6.0.30677.0

567,160

24-Feb-2010

15:06

x86

Microsoft.office.interop.outlook.dll

10.0.4504.0

395,136

24-Feb-2010

15:17

x86

Để thay thế các tệp này, hãy làm theo các bước sau:

  1. Đóng các khách hàng Microsoft Dynamics NAV RoleTailored.

  2. Xác định thư mục cài đặt khách hàng của Microsoft Dynamics NAV RoleTailored. Khách hàng Microsoft Dynamics NAV RoleTailored thường được cài đặt trong thư mục sau:

    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored khách hàng

  3. Sao chép các tệp bạn đã tải xuống.

  4. Dán tệp mà bạn tải xuống thư mục cài đặt khách hàng của Microsoft Dynamics NAV RoleTailored.

  5. Bấm để ghi đè lên các tệp trong thư mục.

Bước 3: Thay thế các tệp trong quá trình cài đặt máy chủ Microsoft Dynamics NAV

Trong cài đặt máy chủ Microsoft Dynamics NAV, thay thế các tệp sau bằng cách sử dụng các hotfix hoặc tệp Cập Nhật.

Tên tệp

Phiên bản tệp

Kích thước tệp

Ngày

Giờ

Nền tảng

Httpcfg.exe

5.2.3790.0

22,352

24-Feb-2010

15:17

x86

Microsoft.dynamics.nav.language.dll

6.0.30677.0

1,992,576

24-Feb-2010

15:06

x86

Microsoft.dynamics.nav.ncl.dll

6.0.30677.0

608,120

24-Feb-2010

15:06

x86

Microsoft.dynamics.nav.server.exe

6.0.30677.0

141,184

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.service.dll

6.0.30677.0

145,280

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.service.runtime.dll

6.0.30677.0

75,664

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.service.webservices.dll

6.0.30677.0

145,304

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.types.dll

6.0.30677.0

567,160

24-Feb-2010

15:06

x86

Microsoft.dynamics.nav.watson.dll

6.0.30677.0

42,880

24-Feb-2010

15:05

x86

Nclcsrt.etx

Không áp dụng

89,525

24-Feb-2010

08:28

Không áp dụng

Nclcsrt.stx

Không áp dụng

91,724

24-Feb-2010

08:28

Không áp dụng

Nclcsrts.dll

6.0.30677.0

1,473,872

24-Feb-2010

15:17

x86

Ndbcs.dll

6.0.30677.0

1,348,944

24-Feb-2010

15:17

x86

Để thay thế các tệp này, hãy làm theo các bước sau:

  1. Ngăn chặn máy chủ Microsoft Dynamics NAV.

  2. Xác định thư mục cài đặt Microsoft Dynamics NAV Server. Máy chủ Microsoft Dynamics NAV thường được cài đặt trong thư mục sau:

    C:\Program Files\Microsoft Dynamics NAV\60\Service

  3. Sao chép các tệp mà bạn tải xuống.

  4. Dán các tệp mà bạn truy cập vào thư mục cài đặt Microsoft Dynamics NAV Server.

  5. Bấm để ghi đè lên các tệp trong thư mục.

  6. Khởi động máy chủ Microsoft Dynamics NAV.

Bước 4: Thay thế các tệp trong quá trình cài đặt máy chủ ứng dụng Microsoft Dynamics NAV

Nếu bạn có Microsoft Dynamics NAV máy chủ ứng dụng được cài đặt, thay thế các tệp sau đây trong quá trình cài đặt máy chủ ứng dụng Microsoft Dynamics NAV bằng cách sử dụng các hotfix hay cập nhật tệp.

Tên tệp

Phiên bản tệp

Kích thước tệp

Ngày

Giờ

Nền tảng

Dbm.dll

6.0.30677.0

427,848

24-Feb-2010

15:16

x86

Nas.exe

6.0.30677.0

2,259,784

24-Feb-2010

15:17

x86

Nassql.exe

6.0.30677.0

2,358,096

24-Feb-2010

15:17

x86

Ndbcs.dll

6.0.30677.0

1,348,944

24-Feb-2010

15:16

x86

Slave.exe

6.0.30677.0

152,400

24-Feb-2010

15:16

x86

Để thay thế các tệp, hãy làm theo các bước sau.

  1. Ngăn chặn máy chủ ứng dụng Microsoft Dynamics NAV.

  2. Xác định thư mục cài đặt Microsoft Dynamics NAV máy chủ ứng dụng. Máy chủ ứng dụng Microsoft Dynamics NAV thường được cài đặt trong thư mục sau:

    C:\Program Files\Microsoft Dynamics NAV\60\Application Server

  3. Sao chép các tệp mà bạn tải xuống.

  4. Dán các tệp mà bạn truy cập vào thư mục cài đặt Microsoft Dynamics NAV máy chủ ứng dụng.

  5. Bấm để ghi đè lên các tệp trong thư mục.

  6. Khởi động máy chủ Microsoft Dynamics NAV ứng dụng.

Sau khi bạn áp dụng hotfix này, máy RTC trước tiên sẽ cố gắng đóng trình báo cáo. Nếu không thể đóng trình báo cáo, RTC sẽ chờ một chút và thử lại đến 30 lần.

Điều kiện tiên quyết

Bạn phải có Microsoft Dynamics NAV 2009 Service Pack 1 cài đặt để áp dụng hotfix này.

Trạng thái

Microsoft đã xác nhận rằng đây là một lỗi trong sản phẩm của Microsoft được liệt kê trong phần "Áp dụng cho".

Thông tin

Để biết thêm thông tin, hãy bấm vào số bài viết sau để xem bài viết trong Cơ sở Kiến thức Microsoft:

824684 mô tả thuật ngữ chuẩn được sử dụng để miêu tả các bản cập nhật phần mềm Microsoft

MICROSOFT VÀ/HOẶC CÁC NHÀ CUNG CẤP THỰC HIỆN KHÔNG TUYÊN BỐ HOẶC BẢO ĐẢM VỀ TÍNH PHÙ HỢP, ĐỘ TIN CẬY HOẶC TÍNH CHÍNH XÁC CỦA THÔNG TIN CÓ TRONG TÀI LIỆU VÀ ĐỒ HOẠ LIÊN QUAN ĐƯỢC ĐĂNG TRÊN TRANG WEB NÀY ("TÀI LIỆU") CHO MỤC ĐÍCH NÀO.

CÁC TÀI LIỆU CÓ THỂ BAO GỒM KỸ THUẬT KHÔNG CHÍNH XÁC HOẶC LỖI VÀ CÓ THỂ ĐƯỢC SỬA ĐỔI BẤT KỲ LÚC NÀO MÀ KHÔNG CẦN THÔNG BÁO. MỨC TỐI ĐA CHO PHÉP THEO LUẬT, MICROSOFT VÀ/HOẶC CÁC NHÀ CUNG CẤP TỪ CHỐI VÀ LOẠI TRỪ TẤT CẢ CÁC TUYÊN BỐ, BẢO ĐẢM VÀ ĐIỀU KIỆN CHO DÙ EXPRESS, NGỤ Ý HAY THEO LUẬT ĐỊNH, BAO GỒM NHƯNG KHÔNG GIỚI HẠN ĐỐI VỚI TUYÊN BỐ, BẢO ĐẢM HOẶC ĐIỀU KIỆN CỦA TIÊU ĐỀ, KHÔNG VI PHẠM, THOẢ MÃN ĐIỀU KIỆN HOẶC CHẤT LƯỢNG, BÁN VÀ CHO MỘT MỤC ĐÍCH CỤ THỂ, ĐỐI VỚI CÁC TÀI LIỆU.

Bạn cần thêm trợ giúp?

Bạn muốn xem các tùy chọn khác?

Khám phá các lợi ích của gói đăng ký, xem qua các khóa đào tạo, tìm hiểu cách bảo mật thiết bị của bạn và hơn thế nữa.

Cộng đồng giúp bạn đặt và trả lời các câu hỏi, cung cấp phản hồi và lắng nghe ý kiến từ các chuyên gia có kiến thức phong phú.

Thông tin này có hữu ích không?

Bạn hài lòng đến đâu với chất lượng dịch thuật?
Điều gì ảnh hưởng đến trải nghiệm của bạn?
Khi nhấn gửi, phản hồi của bạn sẽ được sử dụng để cải thiện các sản phẩm và dịch vụ của Microsoft. Người quản trị CNTT của bạn sẽ có thể thu thập dữ liệu này. Điều khoản về quyền riêng tư.

Cảm ơn phản hồi của bạn!

×