Triệu chứng
Khi bạn cố gắng cài đặt một ứng dụng bằng cách sử dụng một chuỗi tác vụ phương tiện độc lập trong Microsoft System Center 2012 Configuration Manager Gói Dịch vụ 1, việc cài đặt không thành công.
Ngoài ra, các mục tương tự như sau đây được ghi vào tệp Smsts.log:
Tạo tài liệu tạm thời: C:\Windows\TEMP\\b90-0\0000000a.xml
Tài liệu tạm thời đã tạo: C:\Windows\TEMP\\b90-0\0000000b.xml
Tài liệu tạm thời được tạo: C:\Windows\TEMP\\b90-0\0000000c.xml
Tài liệu tạm thời được tạo: C:\Windows\TEMP\\b90-0\0000000d.xml
spCIStore->StoreCIFromDisk(pInfo), HRESULT=80004005
Nguyên nhân
Sự cố này xảy ra vì các tệp XML được tạo trên máy khách khi bạn chạy chuỗi tác vụ được định dạng không chính xác. Đây là sự cố UTF-8 với ký tự mở rộng gây ra lỗi phân tích XML.
Giải pháp
Để giải quyết vấn đề này, áp dụng hotfix được mô tả trong phần sau đây. Phương tiện độc lập mà trưng bày vấn đề này đã được tái tạo ra sau khi bạn áp dụng hotfix này.
Thông tin cập nhật nóng
Hotfix được hỗ trợ có sẵn từ Microsoft. Tuy nhiên, hotfix này là nhằm sửa chữa chỉ vấn đề được mô tả trong bài viết này. Áp dụng hotfix này chỉ cho hệ thống đang gặp vấn đề mô tả trong bài viết này. Hotfix này có thể nhận được kiểm tra bổ sung. Do đó, nếu bạn không bị ảnh hưởng nghiêm trọng bởi sự cố này, chúng tôi khuyên bạn nên đợi bản cập nhật phần mềm tiếp theo có chứa cập nhật nóng này.
Nếu bản cập nhật nóng có sẵn để tải xuống thì có mục "Tải xuống bản cập nhật nóng sẵn dùng" ở đầu bài viết Cơ sở Kiến thức này. Nếu phần này không xuất hiện, hãy liên hệ với bộ phận Dịch vụ và Hỗ trợ Khách hàng của Microsoft để nhận hotfix.
Lưu ý Nếu có sự cố khác xảy ra hoặc nếu cần khắc phục sự cố bất kỳ, bạn có thể phải tạo một yêu cầu dịch vụ riêng biệt. Chi phí hỗ trợ thông thường sẽ áp dụng cho các câu hỏi và sự cố hỗ trợ bổ sung không đủ điều kiện cho hotfix cụ thể này. Để có danh sách đầy đủ các số điện thoại của Bộ phận Dịch vụ Khách hàng và Hỗ trợ của Microsoft hoặc để tạo yêu cầu dịch vụ riêng, hãy truy cập trang web sau của Microsoft:
http://support.microsoft.com/contactus/?ws=supportLưu ý Biểu mẫu "Tải xuống cập nhật nóng" hiển thị các ngôn ngữ mà hotfix có sẵn. Nếu bạn không thấy ngôn ngữ của mình, đó là vì bản cập nhật nóng không có sẵn cho ngôn ngữ đó.
Điều kiện tiên quyết
Để áp dụng bản cập nhật nóng này, bạn phải cài đặt Bản cập nhật Tích lũy 4 cho System Center 2012 Configuration Manager Gói Dịch vụ 1.
Thông tin về khởi động lại
Bạn không phải khởi động lại máy tính sau khi áp dụng hotfix này.
Lưu ý Chúng tôi khuyên bạn nên đóng Bảng điều Configuration Manager quản trị trước khi bạn cài đặt gói cập nhật nóng này.
Thông tin thay thế hotfix
Hotfix này không thay thế bất kỳ hotfix đã phát hành trước đó.
Phiên bản tiếng Anh của hotfix này có các thuộc tính tệp (hoặc các thuộc tính tệp mới hơn) được liệt kê trong bảng sau đây. Ngày và giờ của các tệp này được liệt kê theo Giờ chuẩn quốc tế (UTC). Khi bạn xem thông tin về tệp, tệp đó đã được chuyển đổi thành giờ địa phương. Để tìm ra sự khác biệt giữa UTC và giờ địa phương, hãy dùng tab Múi giờ trong mục Ngày và Giờ trong Panel điều khiển.
Tên tệp |
Phiên bản tệp |
Kích thước tệp |
Ngày |
Giờ |
Nền |
---|---|---|---|---|---|
Createtsmediaadm.dll |
5.0.7804.1509 |
2,304,688 |
Ngày 1 tháng 1 năm 2014 |
01:45 |
x64 |
Adminconsole.msi |
Not Applicable |
133,361,664 |
Ngày 1 tháng 1 năm 2014 |
01:45 |
Không áp dụng |
Configmgr2012adminui-sp1-kb2952686-i386.msp |
Not Applicable |
76,705,792 |
Ngày 1 tháng 1 năm 2014 |
01:45 |
Không áp dụng |
Createtsmediaadm.dll |
5.0.7804.1509 |
1,439,408 |
Ngày 1 tháng 1 năm 2014 |
01:45 |
x86 |
Trạng thái
Microsoft đã xác nhận đây là sự cố trong các sản phẩm của Microsoft được liệt kê trong phần "Áp dụng cho".
Tham khảo
Tìm hiểu về thuật ngữ mà Microsoft sử dụng để mô tả các bản cập nhật phần mềm.