Triệu chứng
Nếu quá trình cài đặt ứng dụng đang diễn ra khi ccmsetup nâng cấp Trung tâm Hệ thống Microsoft Configuration Manager khách, quá trình cài đặt ứng dụng có thể không thành công sau khi nâng cấp.
Chú ý Triển khai ứng dụng mới không bị ảnh hưởng.
Đối với các ứng dụng có dữ liệu yêu cầu nội dung bị xóa, không cài đặt được ứng dụng và thông báo lỗi sau đây được ghi nhật ký trong tệp AppEnforce.log:
+++++ Không thể thực thi ứng dụng. Lỗi 0x87d01106.
++++++ AppEnforce ngày 8128 (0x1FC0)
Nguyên nhân
Sự cố này xảy ra vì dữ liệu yêu cầu nội dung bị xóa trong quá trình nâng cấp do thay đổi sơ đồ.
Lớp sau đây theo dõi các yêu cầu nội dung được thực hiện trong quá trình cài đặt ứng dụng. Lớp này sẽ bị xóa trong quá trình nâng cấp máy khách:
root\ccm\softmgmtagent:DownloadContentRequestEx2
Môi trường của tôi có bị ảnh hưởng không?
Để xác định xem sự cố này có tồn tại trong môi trường của bạn hay không, hãy chạy truy vấn sau đây trên cơ sở dữ liệu máy chủ site của bạn:
select cia.AssignmentName, col.CollectionName from CI_CurrentErrorDetails ced
join CI_ConfigurationItems ci on ci.CI_ID = ced.CI_ID
join CI_AssignmentTargetedCIs cat on cat.CI_ID = ci.CI_ID
join CI_CIAssignments cia on cia.AssignmentID = cat.AssignmentID
join Collections_G col on col.CollectionID = cia.TargetCollectionID
where ced.ErrorCode in ( -2016407290)
group by cia.AssignmentName, col.CollectionName
Nếu truy vấn trả về kết quả giống như sau, môi trường của bạn sẽ bị ảnh hưởng.
Tên Nhiệm vụ |
CollectionName |
Adobe thông qua CMD_All Systems_Install |
Tất cả Hệ thống |
Giải pháp
Sự cố này đã được khắc phục trong phiên bản khả dụng trên toàn cầu của 1702 và trong bản cập nhật cho đợt đầu tiên 1702 sau đây:
4018732 Bản cập nhật cho System Center Configuration Manager phiên bản 1702, đợt đầu tiên
Chú ý Bản cập nhật này sẽ ngăn chặn sự cố được đề cập trong phần "Triệu chứng" xảy ra khi ccmsetup nâng cấp máy Configuration Manager khách. Tuy nhiên, nếu sự cố đã xảy ra, bản cập nhật này sẽ không khắc phục được sự cố. Để khắc phục sự cố sau khi sự cố xảy ra, hãy làm theo các bước được liệt kê trong phần "Giải pháp thay thế".
Cách giải quyết
Để khắc phục sự cố này, hãy sử dụng một trong các phương pháp sau:
-
Hủy nhắm mục tiêu và tái định hướng mục tiêu cho các ứng dụng bị ảnh hưởng.
-
Sử dụng tác vụ dọn dẹp RunOnce ngay sau khi quá trình nâng cấp hoàn tất. Để thực hiện điều này, hãy làm theo các bước sau:
-
Tạo gói phân phối phần mềm và chương trình bằng cách sử dụng lệnh sau: powershell -executionpolicy bypass -noprofile -command "& {$query=gwmi -class CCM_CITask -namespace root\ccm\citasks; $query| rwmi}"
-
Đặt cài đặt để chạy một lần (tốt nhất là khi không có người dùng nào đăng nhập).
-
Triển khai cho tất cả các hệ thống bị ảnh hưởng.
-
Trạng thái
Microsoft đã xác nhận đây là sự cố trong các sản phẩm của Microsoft được liệt kê trong phần "Áp dụng cho".
Sản phẩm bị ảnh hưởng
Bài viết này cũng áp dụng cho:
-
Microsoft System Center Configuration Manager (nhánh hiện tại - phiên bản 1702)