Dấu hiệu
Sau khi bạn cài đặt bản cập nhật tích lũy 13 (CU13) của Microsoft Exchange Server 2019, các tìm kiếm phía máy khách trong Microsoft Outlook sử dụng Dịch vụ Web Exchange (EWS) sẽ trả về kết quả tìm kiếm không đầy đủ và mã lỗi "HTTP 503". Bạn cũng có thể nhận được thông báo lỗi sau:
Chúng tôi đang gặp sự cố khi tải kết quả từ máy chủ.
Nguyên nhân
Sự cố này thường xảy ra sau khi bạn gửi thư email bao gồm các tùy chọn bỏ phiếu và theo dõi được bật hoặc nếu bạn có các mục thư thoại trong hộp thư của mình.
Giải pháp
Để khắc phục sự cố này, hãy thực hiện tìm kiếm bằng cách sử dụng Outlook ở chế độ Trực Outlook trên web (OWA). Để xác minh rằng bạn đang gặp phải sự cố này, hãy tìm kiếm phản hồi "HTTP 503" cho yêu cầu EWS cho hộp thư đang được tìm kiếm. Sau đó, làm theo các bước phía máy chủ trong phần tiếp theo.
Thông tin thêm
Để xác minh rằng người dùng gặp phải sự cố này, người quản trị có thể sử dụng Exchange Management Shell (EMS) trên máy chủ có gắn cơ sở dữ liệu của người dùng. Để trước tiên xác minh máy chủ, hãy chạy lệnh sau đây:
Get-MailboxDatabaseCopyStatus (Get-Mailbox "AffectedUserAlias").Database.Name | ? {$_. Trạng thái -eq "Đã gắn"}
Máy chủ sẽ được xác định theo <DatabaseName\ServerName> dạng. Sau đó, trên cùng một máy chủ đó, chạy các lệnh sau:
Bộ ghi CD $ExScripts
. .\ManagedStoreDiagnosticFunctions.ps1
$MBX = Get-Mailbox "MailboxNameHere"
$DB = $MBX.Database.Name
$Display = $MBX. Displayname
$MailboxNumber = Get-StoreQuery -Database $DB -Query "SELECT MailboxNumber, DisplayName FROM Mailbox" -Unlimited | ? {$_. DisplayName -like $Display}
$Result = Get-StoreQuery -Database $DB -Query "SELECT MessageClass,FolderID,p10800003 FROM Message WHERE MailboxNumber=$($MailboxNumber.MailboxNumber) AND
(p10800003=258 OR p10800003=259 OR p10800003=260 OR p10800003=263 OR p10800003=264 OR p10800003=266 OR p10800003=270 OR p10800003=283 OR p10800003=284 OR p10800003=304)" -Không giới hạn
Nếu biến $Result trả về kết quả bất kỳ, bạn (hoặc người dùng) gặp phải sự cố này. Trong trường hợp này, hãy mở phiếu với Bộ phận Hỗ trợ của Microsoft và đưa vào "danh sách PR_ICON_INDEX" trong tiêu đề trường hợp để được hỗ trợ về sự cố đã biết này.