KB4530499 - CORRECTIF : erreur du planificateur non productif lors de l’appel de fonction Polybase à la mémoire partagée prend beaucoup de temps en SQL Server 2019

S’applique à
SQL Server 2019 on Linux SQL Server 2019 on Windows

Symptômes

Supposons que vous utilisez la fonctionnalité Polybase sur une instance de SQL Server 2019. Sous des charges de travail lourdes, un appel de fonction à la mémoire partagée peut prendre une durée indéfinie et vous pouvez recevoir une erreur de planificateur non yielding.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Résolution

Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.