Symptômes
Lorsque vous exécutez la sp_xml_preparedocument de procédure stockée dans SQL Server 2016, 2017 ou 2019, vous pouvez recevoir un message d’erreur, car le composant MSXMLSQL tente d’accéder à un espace d’adressage virtuel au-delà de la limite de 8 To.
« Impossible de créer le document XML, car la mémoire du serveur est faible. »
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Résolution
Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :
À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.